Forgot your password?
typodupeerror
Programming Google

Google's Dart Becomes ECMA's Dart 190

Posted by timothy
from the trying-for-traction dept.
mikejuk writes "Google's Dart just reached version 1.0, but now it seems that it has aspirations to being an international standard. The question is will this make any difference to the language's future? Given that Google effectively owns Dart, what advantage does standardization bring? The answer to what Google thinks it brings is indicated in the Chromium blog: 'The new standardization process is an important step towards a future where Dart runs natively in web browsers.' and this seems reasonable. A standard is something that would be required before other browser makers decided to fall in line and support native Dart. It is probably a necessary but far from sufficient condition, however, with Microsoft, Apple and Mozilla having other interests to further. Last but not least, having the backing of a standard might just encourage possible users to believe that the language won't sink if Google gets distracted with other projects and decides that Dart is dispensable. However, a strong open source development community capable of supporting Dart without Google's input would be a better reassurance. If you want to help, Google would like you to join the committee. After all, it still doesn't have a Vice Chair. So can we expect to see ECMA CoffeeScript or TypeScript in the near future? Probably not."
This discussion has been archived. No new comments can be posted.

Google's Dart Becomes ECMA's Dart

Comments Filter:
  • Re:OK, I'll bite (Score:3, Informative)

    by Anonymous Coward on Saturday December 14, 2013 @05:40PM (#45691157)

    Dart is Google's attempt to replace Javascript. They're doing this because Javascript is a shitty language.

  • by Anonymous Coward on Saturday December 14, 2013 @06:59PM (#45691551)

    We currently have one of the largest Dart code bases and six full-time Dart devs, and when we asked about being allowed to run Dart on a server OS, their evangelist insulted us. He recommended we run Ubuntu on our servers since they decided Dart should require gcc 4.6+ and glibc 2.14 or newer. He said using Debian, SUSE, CentOS, or Red Hat is "what old people do." The kids running that company just don't damn get it.

    Of course, don't take my word on it. Look at how they just don't get it in the bug comments:

    http://code.google.com/p/dart/issues/detail?id=11920

    Dart will never succeed if you have to run a bleeding edge desktop OS on your server in order to be allowed to use it.

"Card readers? We don't need no stinking card readers." -- Peter da Silva (at the National Academy of Sciencies, 1965, in a particularly vivid fantasy)

Working...