<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	


	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '65493117746915970',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>America's Most Affordable Cities For Tech Workers: Seattle, Austin, and Pittsburgh - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	
		<meta name="description" content="&#34;Seattle tech workers who own their homes can expect to have about $2,000 more in disposable income each month than tech workers in the Bay Area,&#34; according to a new study from LinkedIn and Zillow. An anonymous reader writes:
&#34;For technology workers who rent, Seattle, Austin and Pittsburgh, Pennsylv...">
		<meta itemprop="name" content="America's Most Affordable Cities For Tech Workers: Seattle, Austin, and Pittsburgh - Slashdot">
		<meta itemprop="description" content="&#34;Seattle tech workers who own their homes can expect to have about $2,000 more in disposable income each month than tech workers in the Bay Area,&#34; according to a new study from LinkedIn and Zillow. An anonymous reader writes:
&#34;For technology workers who rent, Seattle, Austin and Pittsburgh, Pennsylv...">
	
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/stats_64.png">
	
	
		<link rel="canonical" href="https://developers.slashdot.org/story/17/03/19/2143230/americas-most-affordable-cities-for-tech-workers-seattle-austin-and-pittsburgh">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/323861" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?release_20170306.2" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?release_20170306.2" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?release_20170306.2" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?release_20170306.2">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- Magnetic -->
<script type="text/javascript">
  // FHItem-toptags: it usa developers programming stats
  
  var backend_tpc = [[ "programming", "it", "stats", "usa", "developers" ]] || ['information technology','tech'];
  var mag_keywords = backend_tpc.join(",");
  mag_keywords = ( mag_keywords.length > 0 ? mag_keywords : 'information technology,tech' );
  //console.log("mag.keywords: " + mag_keywords );
  /* Version: 0.7 */
  /* <![CDATA[ */
  try {
  var _mag = _mag || {};
  _mag.kw = mag_keywords;
  _mag.kw_encoded = 0;
  _mag.shortName = 'sourceforgemedia-computing';
  _mag.default_protocol = ('https:' == document.location.protocol ? 'https:' : 'http:');
  _mag.startTime = (new Date()).getTime();
  (function(d,t) {
  var mag = d.createElement('script'); mag.type = 'text/javascript'; mag.async = true; mag.src = t;
  var head = d.getElementsByTagName('head')[0] || d.documentElement; head.insertBefore(mag, head.firstChild);
  })(document,  _mag.default_protocol + '//d3ezl4ajpp2zy8.cloudfront.net/sourceforgemedia-computing_tag.js');
  } catch (e) {}
  /* ]]> */
</script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?release_20170306.2"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?release_20170306.2" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//developers.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotDevelopers" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //developers.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Become a fan of Slashdot on <a href="http://www.facebook.com/pages/Slashdotorg/267995220856">Facebook</a>
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="adwrap adwrap-unviewed">
				
				<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
				<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 <strong>DEAL:</strong> For $25 - <strong><a href="http://hshd.io/nuLx" rel="nofollow" target="_blank">Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a></strong> Also, <strong>Slashdot's <a href="https://facebook.com/slashdot/" rel="nofollow">Facebook page</a></strong> has a chat bot now. Message it for stories and more. Check out the new <a href="https://sourceforge.net/speedtest/?source=slashdotannouncement" rel="nofollow"><strong>SourceForge HTML5 internet speed test!</a></strong>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-89904953" data-fhid="89904953" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">89904953</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-89904953">
			<a href="//developers.slashdot.org/index2.pl?fhfilter=stats" onclick="return addfhfilter('stats');">
			
				<img src="//a.fsdn.com/sd/topics/stats_64.png" width="64" height="64" alt="Stats" title="Stats">
			
		</a>
		
	
		
		
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=programming" onclick="return addfhfilter('programming');">
			
				<img src="//a.fsdn.com/sd/topics/programming_64.png" width="64" height="64" alt="Programming" title="Programming">
			
		</a>
		
	
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=usa" onclick="return addfhfilter('usa');">
			
				<img src="//a.fsdn.com/sd/topics/usa_64.png" width="64" height="64" alt="United States" title="United States">
			
		</a>
		
	
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=it" onclick="return addfhfilter('it');">
			
				<img src="//a.fsdn.com/sd/topics/it_64.png" width="64" height="64" alt="IT" title="IT">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-89904953" class="story-title"> <a   href="//developers.slashdot.org/story/17/03/19/2143230/americas-most-affordable-cities-for-tech-workers-seattle-austin-and-pittsburgh">America's Most Affordable Cities For Tech Workers: Seattle, Austin, and Pittsburgh</a> <span class=" no extlnk"><a class="story-sourcelnk" href="http://www.prnewswire.com/news-releases/linkedin-zillow-research-finds-places-where-jobs-and-affordable-housing-intersect-300424531.html"  title="External link - http://www.prnewswire.com/news-releases/linkedin-zillow-research-finds-places-where-jobs-and-affordable-housing-intersect-300424531.html" target="_blank"> (prnewswire.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-89904953" >41</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//developers.slashdot.org/story/17/03/19/2143230/americas-most-affordable-cities-for-tech-workers-seattle-austin-and-pittsburgh#comments" title="">41</a></span>
		
	</h2>
	<div class="details" id="details-89904953">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  EditorDavid
			
		
		

		
		
		<time id="fhtime-89904953" datetime="on Sunday March 19, 2017 @05:46PM">on Sunday March 19, 2017 @05:46PM</time>
		
		
			 from the <span class="dept-text">perks-of-Pennsylvania</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-89904953">
	
		
	

	
		
		<div id="text-89904953" class="p">
			
		 	
				"Seattle tech workers who own their homes can expect to have about $2,000 more in disposable income each month than tech workers in the Bay Area," according to a new study from LinkedIn and Zillow. An anonymous reader writes:
<i>"For technology workers who rent, <a href="http://www.prnewswire.com/news-releases/linkedin-zillow-research-finds-places-where-jobs-and-affordable-housing-intersect-300424531.html">Seattle, Austin and Pittsburgh, Pennsylvania came out on top</a> among the housing markets analyzed, with the Bay Area at #4..." the two companies reported.  "Salaries for other industries don't hold up as well in the San Francisco area, though. Even highly-paid finance workers keep only about 32 percent of their incomes after paying for housing and taxes. In Charlotte or Chicago, they can pocket a median of 61 percent."
<br> <br>
The Bay Area's high housing prices are apparently offset by the high salaries paid there to tech workers, according to the study. Even so, both home owners and renters pay roughly half the median income for housing on the west coast, "while a rental in the middle of the country costs more like 25 percent of the median income."</i> <br>
The report also identified the best cities for health workers --  Phoenix, Indianapolis, and Boston -- as well as for finance workers, who do best in Charlotte, Chicago and Dallas.   The top 15 cities for tech workers also included those same cities <em>except</em> Chicago and Phoenix, while also including known tech hotspots like Denver, Atlanta, and Washington, D.C.  But surprisingly the top 15 best cities for tech workers also included Detroit, Nashville, St. Paul (Minnesota) and Tampa, Florida.<br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-89904953" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://developers.slashdot.org/story/17/03/19/2143230/americas-most-affordable-cities-for-tech-workers-seattle-austin-and-pittsburgh"
								  data-janrain-title="America's Most Affordable Cities For Tech Workers: Seattle, Austin, and Pittsburgh"
								  data-janrain-message="America's Most Affordable Cities For Tech Workers: Seattle, Austin, and Pittsburgh @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-89904953" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/it" target="_blank">it</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/usa" target="_blank">usa</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/developers" target="_blank">developers</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//it.slashdot.org/story/17/03/19/2029201/wikileaks-wont-tell-tech-companies-how-to-patch-cia-zero-days-until-demands-are-met?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//yro.slashdot.org/story/17/03/19/2224200/maryland-legislator-wants-to-keep-state-university-patents-away-from-trolls?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//it.slashdot.org/story/17/03/19/2029201/wikileaks-wont-tell-tech-companies-how-to-patch-cia-zero-days-until-demands-are-met?sdsrc=prev">WikiLeaks Won't Tell Tech Companies How To Patch CIA Zero-Days Until Demands Are Met </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//developers.slashdot.org/story/15/11/14/195221/ask-slashdot-undervalued-livable-american-tech-towns?sdsrc=rel">Ask Slashdot: Undervalued, Livable American Tech Towns? </a></h3><h3><a href="//developers.slashdot.org/story/16/05/29/0058206/is-denver-the-next-high-tech-center?sdsrc=rel">Is Denver The Next High-Tech Center?</a></h3><h3><a href="//news.slashdot.org/story/16/07/04/010225/new-york-falls-and-seattle-rises-on-americas-top-tech-cities-list?sdsrc=rel">New York Falls and Seattle Rises on 'America's Top Tech Cities' List</a></h3><h3><a href="//news.slashdot.org/story/17/01/22/0617224/is-the-tech-industry-driving-families-out-of-san-francisco?sdsrc=rel">Is The Tech Industry Driving Families Out of San Francisco?</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//yro.slashdot.org/story/17/03/19/2224200/maryland-legislator-wants-to-keep-state-university-patents-away-from-trolls?sdsrc=next">Maryland Legislator Wants To Keep State University Patents Away From Trolls</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		(function () {
		    var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
		    stackCommerceDiv.style = '';
            var stackCommerce = document.createElement('script');
            stackCommerce.async = true;
            stackCommerce.type = 'text/javascript';
            stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
            var node = document.getElementsByTagName('script')[0];
            node.parentNode.insertBefore(stackCommerce, node);
        })();
	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//developers.slashdot.org/story/17/03/19/2143230/americas-most-affordable-cities-for-tech-workers-seattle-austin-and-pittsburgh" title="Back to Article - America's Most Affordable Cities For Tech Workers: Seattle, Austin, and Pittsburgh">America's Most Affordable Cities For Tech Workers: Seattle, Austin, and Pittsburgh</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - America's Most Affordable Cities For Tech Workers: Seattle, Austin, and Pittsburgh" href="//developers.slashdot.org/story/17/03/19/2143230/americas-most-affordable-cities-for-tech-workers-seattle-austin-and-pittsburgh">America's Most Affordable Cities For Tech Workers: Seattle, Austin, and Pittsburgh</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=10381427" class="btn">Search <span class="totalcommentcnt">41</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//developers.slashdot.org/comments.pl?sid=10381427">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=10381427" class="ui-icon search_comments">Search <span class="totalcommentcnt">41</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//developers.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//developers.slashdot.org/story/17/03/19/2143230/americas-most-affordable-cities-for-tech-workers-seattle-austin-and-pittsburgh#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/03/19/2143230/americas-most-affordable-cities-for-tech-workers-seattle-austin-and-pittsburgh/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/03/19/2143230/americas-most-affordable-cities-for-tech-workers-seattle-austin-and-pittsburgh/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/03/19/2143230/americas-most-affordable-cities-for-tech-workers-seattle-austin-and-pittsburgh/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/03/19/2143230/americas-most-affordable-cities-for-tech-workers-seattle-austin-and-pittsburgh/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?release_20170306.2" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_54070237" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070237" class="commentstatus"></div>
<div id="comment_54070237" class="cw">
	<div id="comment_top_54070237" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070237" name="comment_link_54070237" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070237" onclick="return D2.setFocusComment(54070237)" >Silicon Valley sucks</a>


		 	<span id="comment_score_54070237" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070237); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070237"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070237"><p>Silicon Valley is pretty much a wasteland now. A lot of the real innovation is taking place elsewhere in the country. Silicon Valley is full of companies built on advertising, which is a bubble that's bound to collapse. I can't see why anyone would want to move to Silicon Valley when there are far better options available now, including all of the cities listed in the summary and many others.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070237">

</div>
</div>

<div id="replyto_54070237"></div>

<ul id="group_54070237">
	<li id="hiddens_54070237" class="hide"></li>
</ul>

<ul id="commtree_54070237"><li id="tree_54070299" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070299" class="commentstatus"></div>
<div id="comment_54070299" class="cw">
	<div id="comment_top_54070299" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070299" name="comment_link_54070299" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070299" onclick="return D2.setFocusComment(54070299)" >Re:</a>


		 	<span id="comment_score_54070299" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070299); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070299"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070299"><p><div class="quote"><p> real innovation is taking place</p> </div><p>Real innovation isn't taking place anywhere.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070299">

</div>
</div>

<div id="replyto_54070299"></div>

<ul id="group_54070299">
	<li id="hiddens_54070299" class="hide"></li>
</ul>

<ul id="commtree_54070299"><li id="tree_54070523" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54070523" class="commentstatus"></div>
<div id="comment_54070523" class="cw">
</div>

<div id="replyto_54070523"></div>

<ul id="group_54070523">
	<li id="hiddens_54070523" class="hide"></li>
</ul>

</li><li id="hidestring_54070299"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54070299">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_54070249" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54070249" class="commentstatus"></div>
<div id="comment_54070249" class="cw">
	<div id="comment_top_54070249" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070249" name="comment_link_54070249" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070249" onclick="return D2.setFocusComment(54070249)" >Wrong about Austin</a>


		 	<span id="comment_score_54070249" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070249); return false"><span class=opt>Score:</span>5</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mattwarden">mattwarden</a>  <span class="uid"><a href="//slashdot.org/~mattwarden">( 699984 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070249">		
		on Sunday March 19, 2017 @05:57PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070249">#54070249</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070249"><p>Article is wrong about Austin. It's very expensive. And there are no jobs for tech workers. And it's dirty. With marauding gangs of looters. Many reports of paranormal activity. High risk of pandemic or terrorist attack. No housing supply.</p><p>And no Uber!</p><p>No, no. You don't want to move to Austin. Don't even bother checking it out.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070249">
<span class="ind"></span><a id="reply_link_54070249" class="btn link" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54070249" onclick="D2.replyTo(54070249); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Wrong about Austin by mattwarden @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070249" data-title="Wrong about Austin">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Wrong about Austin by mattwarden" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070249" data-title="Wrong about Austin">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Wrong about Austin by mattwarden" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070249" data-title="Wrong about Austin">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=10381427%26cid=54070249" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54070249" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54070249" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54070249"></div>

<ul id="group_54070249">
	<li id="hiddens_54070249" class="hide"></li>
</ul>

<ul id="commtree_54070249"><li id="tree_54070261" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54070261" class="commentstatus"></div>
<div id="comment_54070261" class="cw">
</div>

<div id="replyto_54070261"></div>

<ul id="group_54070261">
	<li id="hiddens_54070261" class="hide"></li>
</ul>

<ul id="commtree_54070261"><li id="tree_54070283" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54070283" class="commentstatus"></div>
<div id="comment_54070283" class="cw">
</div>

<div id="replyto_54070283"></div>

<ul id="group_54070283">
	<li id="hiddens_54070283" class="hide"></li>
</ul>

</li><li id="hidestring_54070261"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54070261">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54070271" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070271" class="commentstatus"></div>
<div id="comment_54070271" class="cw">
	<div id="comment_top_54070271" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070271" name="comment_link_54070271" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070271" onclick="return D2.setFocusComment(54070271)" >Re: Wrong about Austin</a>


		 	<span id="comment_score_54070271" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070271); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070271"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070271"><p>It's not quite right about Seattle. That was true a few years ago, but the housing market has blown up. I blame  the cost of home ownership on a combination of large hiring sprees with vestments and housing speculation.</p><p>I have a nice home not too close to the city, but the commute can be a terror without the motorcycle.</p><p>I was considering some other tech cities, but everyone seems to suffering the same issues. I miss the sun<nobr> <wbr></nobr>;)</p><p>Also it's hard to find a place that will pay me gobs of cash. The up and downside to<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070271">

</div>
</div>

<div id="replyto_54070271"></div>

<ul id="group_54070271">
	<li id="hiddens_54070271" class="hide"></li>
</ul>

<ul id="commtree_54070271"><li id="tree_54070507" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070507" class="commentstatus"></div>
<div id="comment_54070507" class="cw">
	<div id="comment_top_54070507" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070507" name="comment_link_54070507" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070507" onclick="return D2.setFocusComment(54070507)" >Re:</a>


		 	<span id="comment_score_54070507" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070507); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~NatasRevol">NatasRevol</a>  <span class="uid"><a href="//slashdot.org/~NatasRevol">( 731260 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070507"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070507"><p>Friend moved there. Has 4 kids, so 5 br house.  He's looking at about $1.2M for a nice house.  Yikes.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070507">

</div>
</div>

<div id="replyto_54070507"></div>

<ul id="group_54070507">
	<li id="hiddens_54070507" class="hide"></li>
</ul>

<ul id="commtree_54070507"><li id="tree_54070595" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54070595" class="commentstatus"></div>
<div id="comment_54070595" class="cw">
</div>

<div id="replyto_54070595"></div>

<ul id="group_54070595">
	<li id="hiddens_54070595" class="hide"></li>
</ul>

</li><li id="hidestring_54070507"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54070507">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_54070293" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070293" class="commentstatus"></div>
<div id="comment_54070293" class="cw">
	<div id="comment_top_54070293" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070293" name="comment_link_54070293" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070293" onclick="return D2.setFocusComment(54070293)" >Re:</a>


		 	<span id="comment_score_54070293" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070293); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Carewolf">Carewolf</a>  <span class="uid"><a href="//slashdot.org/~Carewolf">( 581105 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070293"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070293"><p>Haha, what did Austin do to you?<nobr> <wbr></nobr>:D</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070293">

</div>
</div>

<div id="replyto_54070293"></div>

<ul id="group_54070293">
	<li id="hiddens_54070293" class="hide"></li>
</ul>

<ul id="commtree_54070293"><li id="tree_54070351" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070351" class="commentstatus"></div>
<div id="comment_54070351" class="cw">
	<div id="comment_top_54070351" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070351" name="comment_link_54070351" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070351" onclick="return D2.setFocusComment(54070351)" >Re:</a>


		 	<span id="comment_score_54070351" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070351); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070351"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070351"><p>My bet is - it gave him a good house, and a nice place to live, and he doesn't want it invaded by hipsters and techies.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070351">

</div>
</div>

<div id="replyto_54070351"></div>

<ul id="group_54070351">
	<li id="hiddens_54070351" class="hide"></li>
</ul>

<ul id="commtree_54070351"><li id="tree_54070567" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070567" class="commentstatus"></div>
<div id="comment_54070567" class="cw">
	<div id="comment_top_54070567" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070567" name="comment_link_54070567" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070567" onclick="return D2.setFocusComment(54070567)" >Re:</a>


		 	<span id="comment_score_54070567" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070567); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dane23">dane23</a>  <span class="uid"><a href="//slashdot.org/~dane23">( 135106 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070567"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070567">Too late</div>
	</div>

	<div class="commentSub" id="comment_sub_54070567">

</div>
</div>

<div id="replyto_54070567"></div>

<ul id="group_54070567">
	<li id="hiddens_54070567" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_54070307" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070307" class="commentstatus"></div>
<div id="comment_54070307" class="cw">
	<div id="comment_top_54070307" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070307" name="comment_link_54070307" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070307" onclick="return D2.setFocusComment(54070307)" >Q: How many Austinites...</a>


		 	<span id="comment_score_54070307" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070307); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Nova+Express">Nova Express</a>  <span class="uid"><a href="//slashdot.org/~Nova+Express">( 100383 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070307"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070307"><p>...does it take to change a light bulb?</p><p>A: Eight. One to change the bulb, and seven to talk about how much better the light bulbs were at the Armadillo World Headquarters...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070307">

</div>
</div>

<div id="replyto_54070307"></div>

<ul id="group_54070307">
	<li id="hiddens_54070307" class="hide"></li>
</ul>

<ul id="commtree_54070307"><li id="tree_54070315" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070315" class="commentstatus"></div>
<div id="comment_54070315" class="cw">
	<div id="comment_top_54070315" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070315" name="comment_link_54070315" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070315" onclick="return D2.setFocusComment(54070315)" >Re:</a>


		 	<span id="comment_score_54070315" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070315); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mattwarden">mattwarden</a>  <span class="uid"><a href="//slashdot.org/~mattwarden">( 699984 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070315"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070315"><p>I don't get it. Everyone here was born in Cali or the Midwest, and they couldn't pick an armadillo out of a lineup.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070315">

</div>
</div>

<div id="replyto_54070315"></div>

<ul id="group_54070315">
	<li id="hiddens_54070315" class="hide"></li>
</ul>

<ul id="commtree_54070315"><li id="tree_54070357" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070357" class="commentstatus"></div>
<div id="comment_54070357" class="cw">
	<div id="comment_top_54070357" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070357" name="comment_link_54070357" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070357" onclick="return D2.setFocusComment(54070357)" >Re:</a>


		 	<span id="comment_score_54070357" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070357); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070357"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070357"><p>Armadillo is that city in the North Texas Panhandle, it's where they serve 48 oz steaks.</p><p>I saw it on Man vs. Common Sense.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070357">

</div>
</div>

<div id="replyto_54070357"></div>

<ul id="group_54070357">
	<li id="hiddens_54070357" class="hide"></li>
</ul>

<ul id="commtree_54070357"><li id="tree_54070381" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070381" class="commentstatus"></div>
<div id="comment_54070381" class="cw">
	<div id="comment_top_54070381" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070381" name="comment_link_54070381" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070381" onclick="return D2.setFocusComment(54070381)" >Re:</a>


		 	<span id="comment_score_54070381" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070381); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mattwarden">mattwarden</a>  <span class="uid"><a href="//slashdot.org/~mattwarden">( 699984 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070381"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070381"><p>That's Amarillo. I've been to that steakhouse. Quite a spectacle</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070381">

</div>
</div>

<div id="replyto_54070381"></div>

<ul id="group_54070381">
	<li id="hiddens_54070381" class="hide"></li>
</ul>

<ul id="commtree_54070381"><li id="tree_54070427" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54070427" class="commentstatus"></div>
<div id="comment_54070427" class="cw">
</div>

<div id="replyto_54070427"></div>

<ul id="group_54070427">
	<li id="hiddens_54070427" class="hide"></li>
</ul>

</li><li id="hidestring_54070381"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54070381">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li></ul></li></ul></li><li id="tree_54070343" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070343" class="commentstatus"></div>
<div id="comment_54070343" class="cw">
	<div id="comment_top_54070343" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070343" name="comment_link_54070343" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070343" onclick="return D2.setFocusComment(54070343)" >Re:</a>


		 	<span id="comment_score_54070343" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070343); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070343"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070343"><p>Nice try, but you won't keep people away like that.</p><p>You should have said - Austin is in Texas, and you will be forced to watch football and go hunting.</p><p>Watch the techies scream and run away.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070343">

</div>
</div>

<div id="replyto_54070343"></div>

<ul id="group_54070343">
	<li id="hiddens_54070343" class="hide"></li>
</ul>

</li><li id="tree_54070423" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070423" class="commentstatus"></div>
<div id="comment_54070423" class="cw">
	<div id="comment_top_54070423" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070423" name="comment_link_54070423" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070423" onclick="return D2.setFocusComment(54070423)" >Re:</a>


		 	<span id="comment_score_54070423" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070423); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~creimer">creimer</a>  <span class="uid"><a href="//slashdot.org/~creimer">( 824291 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070423"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070423"><p><div class="quote"><p>Article is wrong about Austin. It's very expensive. And there are no jobs for tech workers. And it's dirty. With marauding gangs of looters. Many reports of paranormal activity. High risk of pandemic or terrorist attack. No housing supply.</p></div><p>I thought South by Southwest was over already.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070423">

</div>
</div>

<div id="replyto_54070423"></div>

<ul id="group_54070423">
	<li id="hiddens_54070423" class="hide"></li>
</ul>

</li><li id="tree_54070571" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070571" class="commentstatus"></div>
<div id="comment_54070571" class="cw">
	<div id="comment_top_54070571" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070571" name="comment_link_54070571" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070571" onclick="return D2.setFocusComment(54070571)" >Re:</a>


		 	<span id="comment_score_54070571" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070571); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~plopez">plopez</a>  <span class="uid"><a href="//slashdot.org/~plopez">( 54068 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070571"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070571"><p>Why would I want to move to TX? Any state that slaughters its own citizens is a horrible place to live.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070571">

</div>
</div>

<div id="replyto_54070571"></div>

<ul id="group_54070571">
	<li id="hiddens_54070571" class="hide"></li>
</ul>

<ul id="commtree_54070571"><li id="tree_54070585" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070585" class="commentstatus"></div>
<div id="comment_54070585" class="cw">
	<div id="comment_top_54070585" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070585" name="comment_link_54070585" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070585" onclick="return D2.setFocusComment(54070585)" >Re:</a>


		 	<span id="comment_score_54070585" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070585); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mattwarden">mattwarden</a>  <span class="uid"><a href="//slashdot.org/~mattwarden">( 699984 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070585"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070585"><p>Thank you. I forgot to mention that one. Don't move here unless you want to be slaughtered by the state government.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070585">

</div>
</div>

<div id="replyto_54070585"></div>

<ul id="group_54070585">
	<li id="hiddens_54070585" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54070599" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070599" class="commentstatus"></div>
<div id="comment_54070599" class="cw">
	<div id="comment_top_54070599" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070599" name="comment_link_54070599" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070599" onclick="return D2.setFocusComment(54070599)" >Re:</a>


		 	<span id="comment_score_54070599" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070599); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nbritton">nbritton</a>  <span class="uid"><a href="//slashdot.org/~nbritton">( 823086 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070599"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070599"><p>I concur, traffic is worse then Chicago, also the summers can reach 120 and North Korea is targeting Austin...</p><p><a href="http://www.dailymail.co.uk/news/article-2301425/Why-does-North-Korea-want-bomb-Austin-Twitter-mocks-Kim-Jong-Uns-plan-targets-Lone-Star-state.html" title="dailymail.co.uk">http://www.dailymail.co.uk/new...</a> [dailymail.co.uk]</p><p>Don't move here, don't even come to visit... traffic is already a bitch.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070599">

</div>
</div>

<div id="replyto_54070599"></div>

<ul id="group_54070599">
	<li id="hiddens_54070599" class="hide"></li>
</ul>

</li><li id="hidestring_54070249"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54070249">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54070273" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070273" class="commentstatus"></div>
<div id="comment_54070273" class="cw">
	<div id="comment_top_54070273" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070273" name="comment_link_54070273" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070273" onclick="return D2.setFocusComment(54070273)" >Seattle?</a>


		 	<span id="comment_score_54070273" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070273); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070273"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070273"><p>Seattle is expensive as hell, the internet is garbage, and the weather is cloudy every day.  Your two major companies, Amazon and Microsoft, are constantly looking for ways to outsource you or get you to work extra hours for free.</p><p>Fuck Seattle.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070273">

</div>
</div>

<div id="replyto_54070273"></div>

<ul id="group_54070273">
	<li id="hiddens_54070273" class="hide"></li>
</ul>

<ul id="commtree_54070273"><li id="tree_54070473" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070473" class="commentstatus"></div>
<div id="comment_54070473" class="cw">
	<div id="comment_top_54070473" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070473" name="comment_link_54070473" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070473" onclick="return D2.setFocusComment(54070473)" >Re:</a>


		 	<span id="comment_score_54070473" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070473); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~cheesybagel">cheesybagel</a>  <span class="uid"><a href="//slashdot.org/~cheesybagel">( 670288 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070473"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070473"><p>Yeah but a lot of companies are there or moving there as well like Occulus or even SpaceX who started their satellite division there.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070473">

</div>
</div>

<div id="replyto_54070473"></div>

<ul id="group_54070473">
	<li id="hiddens_54070473" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54070285" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54070285" class="commentstatus"></div>
<div id="comment_54070285" class="cw">
	<div id="comment_top_54070285" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070285" name="comment_link_54070285" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070285" onclick="return D2.setFocusComment(54070285)" >It's one of the things that bother's me</a>


		 	<span id="comment_score_54070285" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070285); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rsilvergun">rsilvergun</a>  <span class="uid"><a href="//slashdot.org/~rsilvergun">( 571051 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070285">		
		on Sunday March 19, 2017 @06:06PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070285">#54070285</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070285">about the H1-Bs (and I know I'm being petty, but hey, I'm getting my ass kicked here financially). They're a captive audience for the renters. There's no way they're gonna buy a home while they're here on work visas. So they drive up my rent substantially. Maybe if I made enough to afford a down payment on a home but, well, with my wages depressed like this that ain't happening...</div>
	</div>

	<div class="commentSub" id="comment_sub_54070285">
<span class="ind"></span><a id="reply_link_54070285" class="btn link" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54070285" onclick="D2.replyTo(54070285); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="It's one of the things that bother's me by rsilvergun @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070285" data-title="It's one of the things that bother's me">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="It's one of the things that bother's me by rsilvergun" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070285" data-title="It's one of the things that bother's me">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="It's one of the things that bother's me by rsilvergun" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070285" data-title="It's one of the things that bother's me">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=10381427%26cid=54070285" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54070285" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54070285" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54070285"></div>

<ul id="group_54070285">
	<li id="hiddens_54070285" class="hide"></li>
</ul>

<ul id="commtree_54070285"><li id="tree_54070341" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54070341" class="commentstatus"></div>
<div id="comment_54070341" class="cw">
	<div id="comment_top_54070341" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070341" name="comment_link_54070341" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070341" onclick="return D2.setFocusComment(54070341)" >Re:It's one of the things that bother's me</a>


		 	<span id="comment_score_54070341" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070341); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Mashiki">Mashiki</a>  <span class="uid"><a href="//slashdot.org/~Mashiki">( 184564 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070341">		 &lt;<a href="mailto:mashiki+AT+gmail+DOT+com">mashiki AT gmail DOT com</a>&gt;
		on Sunday March 19, 2017 @06:24PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070341">#54070341</a>)
		<small><a href="http://slashdot.org/" title="http://slashdot.org/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070341"><p>Come to Canada, guess what happens when they can buy houses(or family who can do it for them)?  The price of housing goes through the roof, and now you can't afford a house or rent.  It gets compounded because of the outside real estate investment that goes on too.  Vancouver is one of the worst places for this double-whammy, and then there's the whole "empty house" problem(8.8% in Vancouver).  Watch Seattle(and Toronto, Ontario), since Vancouver put in a foreign buyers tax they've started buying up there as well.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070341">
<span class="ind"></span><a id="reply_link_54070341" class="btn link" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54070341" onclick="D2.replyTo(54070341); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=54070285" onclick="return D2.selectParent(54070285)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:It's one of the things that bother's me by Mashiki @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070341" data-title="Re:It's one of the things that bother's me">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:It's one of the things that bother's me by Mashiki" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070341" data-title="Re:It's one of the things that bother's me">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:It's one of the things that bother's me by Mashiki" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070341" data-title="Re:It's one of the things that bother's me">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=10381427%26cid=54070341" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54070341" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54070341" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54070341"></div>

<ul id="group_54070341">
	<li id="hiddens_54070341" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54070297" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070297" class="commentstatus"></div>
<div id="comment_54070297" class="cw">
	<div id="comment_top_54070297" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070297" name="comment_link_54070297" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070297" onclick="return D2.setFocusComment(54070297)" >Funny, that's not what I've heard about Seattle</a>


		 	<span id="comment_score_54070297" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070297); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~darthsilun">darthsilun</a>  <span class="uid"><a href="//slashdot.org/~darthsilun">( 3993753 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070297"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070297">I've been told it's quite expensive, although it's not San Francisco and Silicon Valley expensive.</div>
	</div>

	<div class="commentSub" id="comment_sub_54070297">

</div>
</div>

<div id="replyto_54070297"></div>

<ul id="group_54070297">
	<li id="hiddens_54070297" class="hide"></li>
</ul>

<ul id="commtree_54070297"><li id="tree_54070365" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070365" class="commentstatus"></div>
<div id="comment_54070365" class="cw">
	<div id="comment_top_54070365" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070365" name="comment_link_54070365" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070365" onclick="return D2.setFocusComment(54070365)" >Re:</a>


		 	<span id="comment_score_54070365" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070365); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Osgeld">Osgeld</a>  <span class="uid"><a href="//slashdot.org/~Osgeld">( 1900440 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070365"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070365"><p>depends, if you want to live in a modest older house without a bunch of updates, and live more than a bike ride from your work, its not that bad... if you want to live in a fresh HGTV mcmansion then yes its very expensive (but again not like the bay area CA expensive)</p><p>now I will tell you the traffic is horrible, I had to go to kirkland for a IPC training class last summer, which is the first time I set foot in the area in 10 years, so in 2006 that 20 min drive would have taken about 45min maybe an hour, it t<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070365">

</div>
</div>

<div id="replyto_54070365"></div>

<ul id="group_54070365">
	<li id="hiddens_54070365" class="hide"></li>
</ul>

<ul id="commtree_54070365"><li id="tree_54070527" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070527" class="commentstatus"></div>
<div id="comment_54070527" class="cw">
	<div id="comment_top_54070527" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070527" name="comment_link_54070527" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070527" onclick="return D2.setFocusComment(54070527)" >Re:</a>


		 	<span id="comment_score_54070527" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070527); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~93+Escort+Wagon">93 Escort Wagon</a>  <span class="uid"><a href="//slashdot.org/~93+Escort+Wagon">( 326346 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070527"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070527"><p><div class="quote"><p>depends, if you want to live in a modest older house without a bunch of updates, and live more than a bike ride from your work, its not that bad... if you want to live in a fresh HGTV mcmansion then yes its very expensive (but again not like the bay area CA expensive)</p></div><p>Please define "not that bad".</p><p>I work at UW, but live an hour away (by train + light rail). A friend who lives in Seattle was recently telling me about her $1600/month rent for what is basically a studio, within walking distance of UW. Is that considered inexpensive nowadays?</p><p>We bought our house (where I am commuting from now) in the 1990s, so it's been that long since I rented in Seattle - so my question is actually intended to be serious. But my house payment is less than half that.<nobr> <wbr></nobr>:-D</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070527">

</div>
</div>

<div id="replyto_54070527"></div>

<ul id="group_54070527">
	<li id="hiddens_54070527" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_54070301" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54070301" class="commentstatus"></div>
<div id="comment_54070301" class="cw">
	<div id="comment_top_54070301" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070301" name="comment_link_54070301" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070301" onclick="return D2.setFocusComment(54070301)" >Personal opinion: Pittsburgh is the best</a>


		 	<span id="comment_score_54070301" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070301); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~140Mandak262Jamuna">140Mandak262Jamuna</a>  <span class="uid"><a href="//slashdot.org/~140Mandak262Jamuna">( 970587 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070301">		
		on Sunday March 19, 2017 @06:17PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070301">#54070301</a>)
		<small><a href="//slashdot.org/~140Mandak262Jamuna/journal/" title="Thursday December 03, 2009 @02:36PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070301">Low cost housing, many distinct old ethnic neighborhoods and restaurants, good school districts. Rails-to-trails have created many wonderful biking walking trails. Will feel all the four seasons. Only negatives are the narrow single laned roads. Very pictureque and beautiful, as long as you don't have to go anywhere in a hurry, it is great.</div>
	</div>

	<div class="commentSub" id="comment_sub_54070301">
<span class="ind"></span><a id="reply_link_54070301" class="btn link" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54070301" onclick="D2.replyTo(54070301); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Personal opinion: Pittsburgh is the best by 140Mandak262Jamuna @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070301" data-title="Personal opinion: Pittsburgh is the best">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Personal opinion: Pittsburgh is the best by 140Mandak262Jamuna" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070301" data-title="Personal opinion: Pittsburgh is the best">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Personal opinion: Pittsburgh is the best by 140Mandak262Jamuna" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070301" data-title="Personal opinion: Pittsburgh is the best">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=10381427%26cid=54070301" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54070301" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54070301" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54070301"></div>

<ul id="group_54070301">
	<li id="hiddens_54070301" class="hide"></li>
</ul>

</li><li id="tree_54070311" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070311" class="commentstatus"></div>
<div id="comment_54070311" class="cw">
	<div id="comment_top_54070311" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070311" name="comment_link_54070311" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070311" onclick="return D2.setFocusComment(54070311)" >Pittsburgh is fine ...</a>


		 	<span id="comment_score_54070311" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070311); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~OzPeter">OzPeter</a>  <span class="uid"><a href="//slashdot.org/~OzPeter">( 195038 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070311"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070311"><p>Pittsburgh is a great place unless you want to see the horizon.  With all those rolling hills the most you can really see in any direction is about a 1/2 mile.  After growing up in a place where I could see the horizon I actually felt a bit claustrophobic in Pittsburgh.</p><p>And it ranks just behind Seattle for cloudy days, so don;t plan on seeing much in the way of sunlight.</p><p><span class="substr"> </span> <a href="https://www.currentresults.com/Weather-Extremes/US/cloudiest-cities.php" title="currentresults.com">https://www.currentresults.com...</a> [currentresults.com] </p><p>At the opposite end of the spectrum I loved living and working in Salt Lake City for the vistas and the sun</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070311">

</div>
</div>

<div id="replyto_54070311"></div>

<ul id="group_54070311">
	<li id="hiddens_54070311" class="hide"></li>
</ul>

</li><li id="tree_54070319" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070319" class="commentstatus"></div>
<div id="comment_54070319" class="cw">
	<div id="comment_top_54070319" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070319" name="comment_link_54070319" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070319" onclick="return D2.setFocusComment(54070319)" >Austin's rents keep rising...</a>


		 	<span id="comment_score_54070319" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070319); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Nova+Express">Nova Express</a>  <span class="uid"><a href="//slashdot.org/~Nova+Express">( 100383 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070319"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070319"><p>...but yeah, even with that, $250,000 will still buy you a nice house in the Austin area. Good look finding anything like that anywhere near Silicon Valley...</p><p>Just one of the many, many advantages <a href="http://www.battleswarmblog.com/?p=30206" title="battleswarmblog.com">Texas has over California</a> [battleswarmblog.com].</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070319">

</div>
</div>

<div id="replyto_54070319"></div>

<ul id="group_54070319">
	<li id="hiddens_54070319" class="hide"></li>
</ul>

<ul id="commtree_54070319"><li id="tree_54070443" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070443" class="commentstatus"></div>
<div id="comment_54070443" class="cw">
	<div id="comment_top_54070443" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070443" name="comment_link_54070443" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070443" onclick="return D2.setFocusComment(54070443)" >Re:</a>


		 	<span id="comment_score_54070443" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070443); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~creimer">creimer</a>  <span class="uid"><a href="//slashdot.org/~creimer">( 824291 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070443"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070443"><p><div class="quote"><p>Just one of the many, many advantages Texas has over California [battleswarmblog.com].</p></div><p>That blog post is a load of bullshit. But, hey, what do you expect from a low reg, low tax state.</p><p>
<a href="http://www.theblaze.com/wp-content/uploads/2013/04/RTSHf.Xl_.4.jpeg" title="theblaze.com">http://www.theblaze.com/wp-content/uploads/2013/04/RTSHf.Xl_.4.jpeg</a> [theblaze.com]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070443">

</div>
</div>

<div id="replyto_54070443"></div>

<ul id="group_54070443">
	<li id="hiddens_54070443" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54070329" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54070329" class="commentstatus"></div>
<div id="comment_54070329" class="cw">
</div>

<div id="replyto_54070329"></div>

<ul id="group_54070329">
	<li id="hiddens_54070329" class="hide"></li>
</ul>

</li><li id="tree_54070331" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54070331" class="commentstatus"></div>
<div id="comment_54070331" class="cw">
	<div id="comment_top_54070331" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070331" name="comment_link_54070331" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070331" onclick="return D2.setFocusComment(54070331)" >But How Much is That in...</a>


		 	<span id="comment_score_54070331" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070331); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~pipingguy">pipingguy</a>  <span class="uid"><a href="//slashdot.org/~pipingguy">( 566974 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070331">		
		on Sunday March 19, 2017 @06:22PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070331">#54070331</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070331">"<i>about $2,000 more in disposable income each month</i>"<br> <br>

That's, like, almost 5 new MacBook Pros every year! If you don't count all the adaptors you'd need.</div>
	</div>

	<div class="commentSub" id="comment_sub_54070331">
<span class="ind"></span><a id="reply_link_54070331" class="btn link" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54070331" onclick="D2.replyTo(54070331); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="But How Much is That in... by pipingguy @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070331" data-title="But How Much is That in...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="But How Much is That in... by pipingguy" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070331" data-title="But How Much is That in...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="But How Much is That in... by pipingguy" data-url="https://developers.slashdot.org/comments.pl?sid=10381427&cid=54070331" data-title="But How Much is That in...">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=10381427%26cid=54070331" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54070331" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54070331" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54070331"></div>

<ul id="group_54070331">
	<li id="hiddens_54070331" class="hide"></li>
</ul>

</li><li id="tree_54070373" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54070373" class="commentstatus"></div>
<div id="comment_54070373" class="cw">
</div>

<div id="replyto_54070373"></div>

<ul id="group_54070373">
	<li id="hiddens_54070373" class="hide"></li>
</ul>

</li><li id="tree_54070425" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54070425" class="commentstatus"></div>
<div id="comment_54070425" class="cw">
</div>

<div id="replyto_54070425"></div>

<ul id="group_54070425">
	<li id="hiddens_54070425" class="hide"></li>
</ul>

</li><li id="tree_54070449" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54070449" class="commentstatus"></div>
<div id="comment_54070449" class="cw">
</div>

<div id="replyto_54070449"></div>

<ul id="group_54070449">
	<li id="hiddens_54070449" class="hide"></li>
</ul>

</li><li id="tree_54070453" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070453" class="commentstatus"></div>
<div id="comment_54070453" class="cw">
	<div id="comment_top_54070453" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070453" name="comment_link_54070453" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070453" onclick="return D2.setFocusComment(54070453)" >Seattle..</a>


		 	<span id="comment_score_54070453" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070453); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~HockeyPuck">HockeyPuck</a>  <span class="uid"><a href="//slashdot.org/~HockeyPuck">( 141947 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070453"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070453"><p>Seattle may be affordable for Amazon/MSFT employees, but that's only because Seattle is about 5 years behind SF.  Housing prices, traffic are skyrocketing and if you have a job where you don't get options (teacher/fire fighter for example)... it's time to leave.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54070453">

</div>
</div>

<div id="replyto_54070453"></div>

<ul id="group_54070453">
	<li id="hiddens_54070453" class="hide"></li>
</ul>

</li><li id="tree_54070487" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54070487" class="commentstatus"></div>
<div id="comment_54070487" class="cw">
	<div id="comment_top_54070487" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54070487" name="comment_link_54070487" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;cid=54070487" onclick="return D2.setFocusComment(54070487)" >Cleveland!</a>


		 	<span id="comment_score_54070487" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54070487); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dg41">dg41</a>  <span class="uid"><a href="//slashdot.org/~dg41">( 743918 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54070487"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54070487">Cleveland has a growing technology sector. It's highly affordable, we have awesome restaurants and breweries and fantastic cultural sights (art museum, PlayhouseSquare, etc.).</div>
	</div>

	<div class="commentSub" id="comment_sub_54070487">

</div>
</div>

<div id="replyto_54070487"></div>

<ul id="group_54070487">
	<li id="hiddens_54070487" class="hide"></li>
</ul>

<ul id="commtree_54070487"><li id="tree_54070597" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54070597" class="commentstatus"></div>
<div id="comment_54070597" class="cw">
</div>

<div id="replyto_54070597"></div>

<ul id="group_54070597">
	<li id="hiddens_54070597" class="hide"></li>
</ul>

</li><li id="hidestring_54070487"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54070487">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10381427&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">4 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//developers.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 10;
		D2.currents()['full']     = 5;
		D2.currents()['oneline']  = 26;
		// D2.currents_total(41);

		D2.abbrev_comments({54070365:522,54070311:389,54070271:554});
		D2.noshow_comments([54070523,54070261,54070283,54070595,54070427,54070329,54070373,54070425,54070449,54070597]);
		D2.pieces_comments([54070237,54070299,54070271,54070507,54070293,54070351,54070567,54070307,54070315,54070357,54070381,54070343,54070423,54070571,54070585,54070599,54070273,54070473,54070297,54070365,54070527,54070311,54070319,54070443,54070453,54070487]);
		D2.init_hiddens([54070299,54070261,54070507,54070381,54070249,54070487,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(323861);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1001<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/03/01/1643251/programmers-are-confessing-their-coding-sins-to-protest-a-broken-job-interview-process?sdsrc=popbyskidbtmprev">Programmers Are Confessing Their Coding Sins To Protest a Broken Job Interview Process</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>674<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/16/08/15/236236/ask-slashdot-what-are-some-bad-programming-ideas-that-work?sdsrc=popbyskidbtmprev">Ask Slashdot: What Are Some Bad Programming Ideas That Work?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>600<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/02/04/1751211/developer-argues-for-forgotten-code-constructs-like-goto-and-eval?sdsrc=popbyskidbtmprev">Developer Argues For 'Forgotten Code Constructs' Like GOTO and Eval</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>531<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/16/10/01/2249256/are-flawed-languages-creating-bad-software?sdsrc=popbyskidbtmprev">Are Flawed Languages Creating Bad Software?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>523<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/16/07/12/2036201/linus-torvalds-in-sweary-rant-about-punctuation-in-kernel-comments?sdsrc=popbyskidbtmprev">Linus Torvalds In Sweary Rant About Punctuation In Kernel Comments</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//yro.slashdot.org/story/17/03/19/2224200/maryland-legislator-wants-to-keep-state-university-patents-away-from-trolls?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/patents_64.png" width="64" height="64" alt="Patents"></span>
	    
					<p class="grid_12"><a href="//yro.slashdot.org/story/17/03/19/2224200/maryland-legislator-wants-to-keep-state-university-patents-away-from-trolls?sdsrc=nextbtmprev">Maryland Legislator Wants To Keep State University Patents Away From Trolls</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>5<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//it.slashdot.org/story/17/03/19/2029201/wikileaks-wont-tell-tech-companies-how-to-patch-cia-zero-days-until-demands-are-met?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/microsoft_64100.png" width="100" height="64" alt="Microsoft"></span>
	    
					<p class="grid_12"><a href="//it.slashdot.org/story/17/03/19/2029201/wikileaks-wont-tell-tech-companies-how-to-patch-cia-zero-days-until-demands-are-met?sdsrc=prevbtmprev">WikiLeaks Won't Tell Tech Companies How To Patch CIA Zero-Days Until Demands Are Met</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>65<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=10381427&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">41</span> of <span class="totalcommentcnt">41</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>The first rule of intelligent tinkering is to save all the parts.
		-- Paul Erlich</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2017 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1270){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
            if($(this).hasClass('railad')) {
                cls = 'adwrap-railad-sticky';
                toggleCls = '';
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
            }
        });
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                $('#firehoselist article').eq(2).after(html);
            }
        });
        
        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?730">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?362">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->