<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	


	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '109936074470221328',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Only 36 Percent of Indian Engineers Can Write Compilable Code, Says Study - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	
		<meta name="description" content="New submitter troublemaker_23 quotes a report from ITWire:  Only 36% of software engineers in India can write compilable code based on measurements by an automated tool that is used across the world, the Indian skills assessment company Aspiring Minds says in a report. The report is based on a sampl...">
		<meta itemprop="name" content="Only 36 Percent of Indian Engineers Can Write Compilable Code, Says Study - Slashdot">
		<meta itemprop="description" content="New submitter troublemaker_23 quotes a report from ITWire:  Only 36% of software engineers in India can write compilable code based on measurements by an automated tool that is used across the world, the Indian skills assessment company Aspiring Minds says in a report. The report is based on a sampl...">
	
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/programming_64.png">
	
	
		<link rel="canonical" href="https://developers.slashdot.org/story/17/05/09/2019222/only-36-percent-of-indian-engineers-can-write-compilable-code-says-study">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/326011" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?6957c59a8a3c9013" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?6957c59a8a3c9013" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?6957c59a8a3c9013" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?6957c59a8a3c9013">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- Magnetic -->
<script type="text/javascript">
  // FHItem-toptags: bug it software technology programming
  
  var backend_tpc = [[ "bug", "programming", "it", "technology", "software", "developers" ]] || ['information technology','tech'];
  var mag_keywords = backend_tpc.join(",");
  mag_keywords = ( mag_keywords.length > 0 ? mag_keywords : 'information technology,tech' );
  //console.log("mag.keywords: " + mag_keywords );
  /* Version: 0.7 */
  /* <![CDATA[ */
  try {
  var _mag = _mag || {};
  _mag.kw = mag_keywords;
  _mag.kw_encoded = 0;
  _mag.shortName = 'sourceforgemedia-computing';
  _mag.default_protocol = ('https:' == document.location.protocol ? 'https:' : 'http:');
  _mag.startTime = (new Date()).getTime();
  (function(d,t) {
  var mag = d.createElement('script'); mag.type = 'text/javascript'; mag.async = true; mag.src = t;
  var head = d.getElementsByTagName('head')[0] || d.documentElement; head.insertBefore(mag, head.firstChild);
  })(document,  _mag.default_protocol + '//d3ezl4ajpp2zy8.cloudfront.net/sourceforgemedia-computing_tag.js');
  } catch (e) {}
  /* ]]> */
</script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?6957c59a8a3c9013"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?6957c59a8a3c9013" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//developers.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotDevelopers" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //developers.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Slashdot is powered by <strong><a href="//developers.slashdot.org/submission">your submissions</a></strong>, so send in your scoop
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 <strong>DEAL:</strong> For $25 - <strong><a href="http://hshd.io/nuLx" rel="nofollow" target="_blank">Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a></strong> Also, <strong>Slashdot's <a href="https://ifttt.com/slashdot" rel="nofollow">now on IFTTT.</a></strong> Check it out! Check out the new <a href="https://sourceforge.net/speedtest/?source=slashdotannouncement" rel="nofollow"><strong>SourceForge HTML5 Internet speed test!</a></strong>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-90965229" data-fhid="90965229" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">90965229</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-90965229">
			<a href="//developers.slashdot.org/index2.pl?fhfilter=programming" onclick="return addfhfilter('programming');">
			
				<img src="//a.fsdn.com/sd/topics/programming_64.png" width="64" height="64" alt="Programming" title="Programming">
			
		</a>
		
	
		
		
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=bug" onclick="return addfhfilter('bug');">
			
				<img src="//a.fsdn.com/sd/topics/bug_64.png" width="64" height="64" alt="Bug" title="Bug">
			
		</a>
		
	
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=software" onclick="return addfhfilter('software');">
			
				<img src="//a.fsdn.com/sd/topics/software_64.png" width="64" height="64" alt="Software" title="Software">
			
		</a>
		
	
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=it" onclick="return addfhfilter('it');">
			
				<img src="//a.fsdn.com/sd/topics/it_64.png" width="64" height="64" alt="IT" title="IT">
			
		</a>
		
	
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=technology" onclick="return addfhfilter('technology');">
			
				<img src="//a.fsdn.com/sd/topics/technology_64.png" width="64" height="64" alt="Technology" title="Technology">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-90965229" class="story-title"> <a   href="//developers.slashdot.org/story/17/05/09/2019222/only-36-percent-of-indian-engineers-can-write-compilable-code-says-study">Only 36 Percent of Indian Engineers Can Write Compilable Code, Says Study</a> <span class=" no extlnk"><a class="story-sourcelnk" href="http://www.itwire.com/outsourcing/78004-only-36-of-indian-engineers-can-write-compilable-code-study.html"  title="External link - http://www.itwire.com/outsourcing/78004-only-36-of-indian-engineers-can-write-compilable-code-study.html" target="_blank"> (itwire.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-90965229" >54</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//developers.slashdot.org/story/17/05/09/2019222/only-36-percent-of-indian-engineers-can-write-compilable-code-says-study#comments" title="">54</a></span>
		
	</h2>
	<div class="details" id="details-90965229">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  <a href="https://twitter.com/BeauHD" rel="nofollow">BeauHD</a>
			
		
		

		
		
		<time id="fhtime-90965229" datetime="on Tuesday May 09, 2017 @08:05PM">on Tuesday May 09, 2017 @08:05PM</time>
		
		
			 from the <span class="dept-text">programming-abilities</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-90965229">
	
		
	

	
		
		<div id="text-90965229" class="p">
			
		 	
				New submitter <a href="/~troublemaker_23">troublemaker_23</a> quotes a report from ITWire: <i> <a href="http://www.itwire.com/outsourcing/78004-only-36-of-indian-engineers-can-write-compilable-code-study.html">Only 36% of software engineers in India can write compilable code</a> based on measurements by an automated tool that is used across the world, the Indian skills assessment company Aspiring Minds says in a report. The <a href="http://www.aspiringminds.com/modal_forms/nojs/webform/1409?url=http://www.aspiringminds.com/sites/default/files/National%20Programming%20Skills%20Report%20-%20Engineers%202017%20-%20Report%20Brief.pdf">report</a> is based on a sample of 36,800 from more than 500 colleges across India. <a href="http://www.aspiringminds.com/">Aspiring Minds</a> said it used the automated tool Automata which is a 60-minute test taken in a compiler integrated environment and rates candidates on programming ability, programming practices, run-time complexity and test case coverage. It uses advanced artificial intelligence technology to automatically grade programming skills. "We find that out of the two problems given per candidate, only 14% engineers are able to write compilable codes for both and only 22% write compilable code for exactly one problem," the study said. It further found that of the test subjects only 14.67% were employable by an IT services company. When it came to writing fully functional code using the best practices for efficiency and writing, only 2.21% of the engineers studied made the grade.</i><br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-90965229" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://developers.slashdot.org/story/17/05/09/2019222/only-36-percent-of-indian-engineers-can-write-compilable-code-says-study"
								  data-janrain-title="Only 36 Percent of Indian Engineers Can Write Compilable Code, Says Study"
								  data-janrain-message="Only 36 Percent of Indian Engineers Can Write Compilable Code, Says Study @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-90965229" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/bug" target="_blank">bug</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/it" target="_blank">it</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/software" target="_blank">software</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//hardware.slashdot.org/story/17/05/09/1948222/microsoft-wants-you-to-care-for-your-surface-like-a-luxury-handbag?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>You may like to read:</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//apple.slashdot.org/story/17/05/09/2332204/apple-becomes-first-us-company-to-top-800-billion-value?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//hardware.slashdot.org/story/17/05/09/1948222/microsoft-wants-you-to-care-for-your-surface-like-a-luxury-handbag?sdsrc=prev">Microsoft Wants You To Care For Your Surface Like a 'Luxury' Handbag </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
									
									
									
									

																				<h2><a href="//developers.slashdot.org/story/17/03/01/1643251/programmers-are-confessing-their-coding-sins-to-protest-a-broken-job-interview-process?sdsrc=popbyskid">Programmers Are Confessing Their Coding Sins To Protest a Broken Job Interview Process</a><br></h2>
																				<h2><a href="//developers.slashdot.org/story/16/08/15/236236/ask-slashdot-what-are-some-bad-programming-ideas-that-work?sdsrc=popbyskid">Ask Slashdot: What Are Some Bad Programming Ideas That Work?</a><br></h2>
																				<h2><a href="//developers.slashdot.org/story/17/03/27/2115233/prominent-drupal-php-developer-kicked-from-the-drupal-project-over-unconventional-sex-life?sdsrc=popbyskid">Prominent Drupal, PHP Developer Kicked From the Drupal Project Over Unconventional Sex Life</a><br></h2>
																				<h2><a href="//developers.slashdot.org/story/17/02/04/1751211/developer-argues-for-forgotten-code-constructs-like-goto-and-eval?sdsrc=popbyskid">Developer Argues For 'Forgotten Code Constructs' Like GOTO and Eval</a><br></h2>
																				<h2><a href="//developers.slashdot.org/story/16/10/01/2249256/are-flawed-languages-creating-bad-software?sdsrc=popbyskid">Are Flawed Languages Creating Bad Software?</a><br></h2>
									
								
								
									<h3 class="js_disp_only hide"><a class="jshandle_related" data-goto-url="//developers.slashdot.org/submission/7012421/only-36-of-indian-engineers-can-write-compilable-code-study?sdsrc=rel" href="#">Submission: Only 36% of Indian engineers can write compilable code: study</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//apple.slashdot.org/story/17/05/09/2332204/apple-becomes-first-us-company-to-top-800-billion-value?sdsrc=next">Apple Becomes First US Company To Top $800 Billion Value</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//developers.slashdot.org/story/17/05/09/2019222/only-36-percent-of-indian-engineers-can-write-compilable-code-says-study" title="Back to Article - Only 36 Percent of Indian Engineers Can Write Compilable Code, Says Study">Only 36 Percent of Indian Engineers Can Write Compilable Code, Says Study</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Only 36 Percent of Indian Engineers Can Write Compilable Code, Says Study" href="//developers.slashdot.org/story/17/05/09/2019222/only-36-percent-of-indian-engineers-can-write-compilable-code-says-study">Only 36 Percent of Indian Engineers Can Write Compilable Code, Says Study</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=10590957" class="btn">Search <span class="totalcommentcnt">54</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//developers.slashdot.org/comments.pl?sid=10590957">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-20 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=10590957" class="ui-icon search_comments">Search <span class="totalcommentcnt">54</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//developers.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//developers.slashdot.org/story/17/05/09/2019222/only-36-percent-of-indian-engineers-can-write-compilable-code-says-study#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/05/09/2019222/only-36-percent-of-indian-engineers-can-write-compilable-code-says-study/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/05/09/2019222/only-36-percent-of-indian-engineers-can-write-compilable-code-says-study/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/05/09/2019222/only-36-percent-of-indian-engineers-can-write-compilable-code-says-study/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/05/09/2019222/only-36-percent-of-indian-engineers-can-write-compilable-code-says-study/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?6957c59a8a3c9013" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_54388635" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388635" class="commentstatus"></div>
<div id="comment_54388635" class="cw">
</div>

<div id="replyto_54388635"></div>

<ul id="group_54388635">
	<li id="hiddens_54388635" class="hide"></li>
</ul>

<ul id="commtree_54388635"><li id="tree_54388681" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388681" class="commentstatus"></div>
<div id="comment_54388681" class="cw">
</div>

<div id="replyto_54388681"></div>

<ul id="group_54388681">
	<li id="hiddens_54388681" class="hide"></li>
</ul>

<ul id="commtree_54388681"><li id="tree_54388799" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388799" class="commentstatus"></div>
<div id="comment_54388799" class="cw">
</div>

<div id="replyto_54388799"></div>

<ul id="group_54388799">
	<li id="hiddens_54388799" class="hide"></li>
</ul>

</li><li id="hidestring_54388681"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388681">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388717" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388717" class="commentstatus"></div>
<div id="comment_54388717" class="cw">
</div>

<div id="replyto_54388717"></div>

<ul id="group_54388717">
	<li id="hiddens_54388717" class="hide"></li>
</ul>

<ul id="commtree_54388717"><li id="tree_54389013" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54389013" class="commentstatus"></div>
<div id="comment_54389013" class="cw">
</div>

<div id="replyto_54389013"></div>

<ul id="group_54389013">
	<li id="hiddens_54389013" class="hide"></li>
</ul>

</li><li id="hidestring_54388717"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388717">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388961" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388961" class="commentstatus"></div>
<div id="comment_54388961" class="cw">
	<div id="comment_top_54388961" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388961" name="comment_link_54388961" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388961" onclick="return D2.setFocusComment(54388961)" >Re: Sounds about right</a>


		 	<span id="comment_score_54388961" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388961); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388961"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388961"><p>It's still cheaper to hire 3 Indian devs than one American. Far fewer arguments too, they just do what they are told without argument, even if they are incompetent.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54388961">

</div>
</div>

<div id="replyto_54388961"></div>

<ul id="group_54388961">
	<li id="hiddens_54388961" class="hide"></li>
</ul>

<ul id="commtree_54388961"><li id="tree_54389059" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54389059" class="commentstatus"></div>
<div id="comment_54389059" class="cw">
	<div id="comment_top_54389059" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54389059" name="comment_link_54389059" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54389059" onclick="return D2.setFocusComment(54389059)" >Re:</a>


		 	<span id="comment_score_54389059" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54389059); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JustNiz">JustNiz</a>  <span class="uid"><a href="//slashdot.org/~JustNiz">( 692889 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54389059"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54389059"><p>&gt; they just do what they are told without argument, even if they are incompetent.</p><p>a) Generalising here, but they're mostly one (or zero) trick ponies, so no they really don't. If their single ability doesn't happen to fit what you're asking them to do today, you might as well be talking to a brick wall.</p><p>b) Your implication that non-indians argue when told what to do is frankly ridiculous, but even if it was true, its clearly better to have the work product of someone competent than polite but incompetent.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54389059">

</div>
</div>

<div id="replyto_54389059"></div>

<ul id="group_54389059">
	<li id="hiddens_54389059" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_54388635"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388635">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388661" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388661" class="commentstatus"></div>
<div id="comment_54388661" class="cw">
	<div id="comment_top_54388661" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388661" name="comment_link_54388661" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388661" onclick="return D2.setFocusComment(54388661)" >What percent of slashdot editors</a>


		 	<span id="comment_score_54388661" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388661); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388661"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388661"><p>What percent of Slashdot Editors can spot a dupe?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54388661">

</div>
</div>

<div id="replyto_54388661"></div>

<ul id="group_54388661">
	<li id="hiddens_54388661" class="hide"></li>
</ul>

</li><li id="tree_54388673" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388673" class="commentstatus"></div>
<div id="comment_54388673" class="cw">
</div>

<div id="replyto_54388673"></div>

<ul id="group_54388673">
	<li id="hiddens_54388673" class="hide"></li>
</ul>

</li><li id="tree_54388687" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388687" class="commentstatus"></div>
<div id="comment_54388687" class="cw">
	<div id="comment_top_54388687" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388687" name="comment_link_54388687" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388687" onclick="return D2.setFocusComment(54388687)" >Shite</a>


		 	<span id="comment_score_54388687" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388687); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rmdingler">rmdingler</a>  <span class="uid"><a href="//slashdot.org/~rmdingler">( 1955220 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388687"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388687">Does this mean I should be concerned with Dr Gupta's diploma from Cornercutt-, er, Calcutta Medical?</div>
	</div>

	<div class="commentSub" id="comment_sub_54388687">

</div>
</div>

<div id="replyto_54388687"></div>

<ul id="group_54388687">
	<li id="hiddens_54388687" class="hide"></li>
</ul>

</li><li id="tree_54388691" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388691" class="commentstatus"></div>
<div id="comment_54388691" class="cw">
</div>

<div id="replyto_54388691"></div>

<ul id="group_54388691">
	<li id="hiddens_54388691" class="hide"></li>
</ul>

<ul id="commtree_54388691"><li id="tree_54389005" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54389005" class="commentstatus"></div>
<div id="comment_54389005" class="cw">
</div>

<div id="replyto_54389005"></div>

<ul id="group_54389005">
	<li id="hiddens_54389005" class="hide"></li>
</ul>

<ul id="commtree_54389005"><li id="tree_54389089" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54389089" class="commentstatus"></div>
<div id="comment_54389089" class="cw">
</div>

<div id="replyto_54389089"></div>

<ul id="group_54389089">
	<li id="hiddens_54389089" class="hide"></li>
</ul>

</li><li id="hidestring_54389005"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54389005">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_54388691"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388691">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388695" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388695" class="commentstatus"></div>
<div id="comment_54388695" class="cw">
	<div id="comment_top_54388695" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388695" name="comment_link_54388695" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388695" onclick="return D2.setFocusComment(54388695)" >And the rest write PHP and JavaScript</a>


		 	<span id="comment_score_54388695" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388695); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~scrib">scrib</a>  <span class="uid"><a href="//slashdot.org/~scrib">( 1277042 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388695"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388695"><p>I haven't written a single line of compilable code at my latest job.<nobr> <wbr></nobr>:)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54388695">

</div>
</div>

<div id="replyto_54388695"></div>

<ul id="group_54388695">
	<li id="hiddens_54388695" class="hide"></li>
</ul>

<ul id="commtree_54388695"><li id="tree_54388777" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388777" class="commentstatus"></div>
<div id="comment_54388777" class="cw">
	<div id="comment_top_54388777" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388777" name="comment_link_54388777" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388777" onclick="return D2.setFocusComment(54388777)" >Re:</a>


		 	<span id="comment_score_54388777" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388777); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~whoever57">whoever57</a>  <span class="uid"><a href="//slashdot.org/~whoever57">( 658626 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388777"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388777"><p>Did these people have access to a compiler when writing this code? If not, then of course most code has trivial syntax errors.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54388777">

</div>
</div>

<div id="replyto_54388777"></div>

<ul id="group_54388777">
	<li id="hiddens_54388777" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54388699" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388699" class="commentstatus"></div>
<div id="comment_54388699" class="cw">
</div>

<div id="replyto_54388699"></div>

<ul id="group_54388699">
	<li id="hiddens_54388699" class="hide"></li>
</ul>

<ul id="commtree_54388699"><li id="tree_54389123" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54389123" class="commentstatus"></div>
<div id="comment_54389123" class="cw">
</div>

<div id="replyto_54389123"></div>

<ul id="group_54389123">
	<li id="hiddens_54389123" class="hide"></li>
</ul>

</li><li id="hidestring_54388699"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388699">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388705" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388705" class="commentstatus"></div>
<div id="comment_54388705" class="cw">
	<div id="comment_top_54388705" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388705" name="comment_link_54388705" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388705" onclick="return D2.setFocusComment(54388705)" >On the first pass?</a>


		 	<span id="comment_score_54388705" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388705); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~davidwr">davidwr</a>  <span class="uid"><a href="//slashdot.org/~davidwr">( 791652 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388705"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388705"><p>My code rately compiles correctly on the first attempt.</p><p>Sure, I could carefully inspect it before clicking "build," but it's faster to go through the build-fix-build cycle a few times than to scrutinize it for compile-time errors beforehand.</p><p>As for the rest of the test, I would fail too, especially since it is a one-hour timed test.</p><p>Now, show me a problem where the obvious/naive solution is something any decent programmer can get right in half a day but finding an ideal- or nearly-ideal solution will take a gr<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54388705">

</div>
</div>

<div id="replyto_54388705"></div>

<ul id="group_54388705">
	<li id="hiddens_54388705" class="hide"></li>
</ul>

<ul id="commtree_54388705"><li id="tree_54388757" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388757" class="commentstatus"></div>
<div id="comment_54388757" class="cw">
</div>

<div id="replyto_54388757"></div>

<ul id="group_54388757">
	<li id="hiddens_54388757" class="hide"></li>
</ul>

<ul id="commtree_54388757"><li id="tree_54388795" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388795" class="commentstatus"></div>
<div id="comment_54388795" class="cw">
</div>

<div id="replyto_54388795"></div>

<ul id="group_54388795">
	<li id="hiddens_54388795" class="hide"></li>
</ul>

</li><li id="hidestring_54388757"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388757">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_54388705"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388705">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388707" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388707" class="commentstatus"></div>
<div id="comment_54388707" class="cw">
	<div id="comment_top_54388707" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388707" name="comment_link_54388707" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388707" onclick="return D2.setFocusComment(54388707)" >copy-and-paste workforce</a>


		 	<span id="comment_score_54388707" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388707); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Fly+Swatter">Fly Swatter</a>  <span class="uid"><a href="//slashdot.org/~Fly+Swatter">( 30498 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388707"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388707">It's good enough for the bottom line. Bad for everyone else.</div>
	</div>

	<div class="commentSub" id="comment_sub_54388707">

</div>
</div>

<div id="replyto_54388707"></div>

<ul id="group_54388707">
	<li id="hiddens_54388707" class="hide"></li>
</ul>

<ul id="commtree_54388707"><li id="tree_54388753" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388753" class="commentstatus"></div>
<div id="comment_54388753" class="cw">
</div>

<div id="replyto_54388753"></div>

<ul id="group_54388753">
	<li id="hiddens_54388753" class="hide"></li>
</ul>

</li><li id="hidestring_54388707"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388707">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388729" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388729" class="commentstatus"></div>
<div id="comment_54388729" class="cw">
</div>

<div id="replyto_54388729"></div>

<ul id="group_54388729">
	<li id="hiddens_54388729" class="hide"></li>
</ul>

</li><li id="tree_54388731" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54388731" class="commentstatus"></div>
<div id="comment_54388731" class="cw">
	<div id="comment_top_54388731" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388731" name="comment_link_54388731" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388731" onclick="return D2.setFocusComment(54388731)" >A little unclear</a>


		 	<span id="comment_score_54388731" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388731); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mhkohne">mhkohne</a>  <span class="uid"><a href="//slashdot.org/~mhkohne">( 3854 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388731">		
		on Tuesday May 09, 2017 @08:24PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388731">#54388731</a>)
		<small><a href="http://www.kohne.org/" title="http://www.kohne.org/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388731"><p>Am I to infer that these are newly minted software people fresh out of college?</p><p>What's the comparison - how would a set of grads from US universities, or British, or Ukranian fare? Frankly, lots of people make it through educational systems without being able to do whatever their degree says - I'm not clear that the percentages here are any different than anywhere else in the world.</p><p>I'm pretty clear that without more context this is useless. And there's no mention of the report containing that context.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54388731">
<span class="ind"></span><a id="reply_link_54388731" class="btn link" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54388731" onclick="D2.replyTo(54388731); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="A little unclear by mhkohne @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=10590957&cid=54388731" data-title="A little unclear">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="A little unclear by mhkohne" data-url="https://developers.slashdot.org/comments.pl?sid=10590957&cid=54388731" data-title="A little unclear">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="A little unclear by mhkohne" data-url="https://developers.slashdot.org/comments.pl?sid=10590957&cid=54388731" data-title="A little unclear">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=10590957%26cid=54388731" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54388731" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54388731" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54388731"></div>

<ul id="group_54388731">
	<li id="hiddens_54388731" class="hide"></li>
</ul>

<ul id="commtree_54388731"><li id="tree_54388827" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388827" class="commentstatus"></div>
<div id="comment_54388827" class="cw">
	<div id="comment_top_54388827" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388827" name="comment_link_54388827" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388827" onclick="return D2.setFocusComment(54388827)" >Re:</a>


		 	<span id="comment_score_54388827" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388827); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388827"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388827"><p>I couldn't go much past "Hello World!" when I graduated college in the US.  It took years to get where I am now.  So I don't see how the study means anything. <br>
&nbsp; <br>If outsourcing companies have been trying to replace productive senior developers with fresh college graduates they were in for trouble, no matter what country the graduates are from.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54388827">

</div>
</div>

<div id="replyto_54388827"></div>

<ul id="group_54388827">
	<li id="hiddens_54388827" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54388743" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388743" class="commentstatus"></div>
<div id="comment_54388743" class="cw">
</div>

<div id="replyto_54388743"></div>

<ul id="group_54388743">
	<li id="hiddens_54388743" class="hide"></li>
</ul>

</li><li id="tree_54388747" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388747" class="commentstatus"></div>
<div id="comment_54388747" class="cw">
</div>

<div id="replyto_54388747"></div>

<ul id="group_54388747">
	<li id="hiddens_54388747" class="hide"></li>
</ul>

<ul id="commtree_54388747"><li id="tree_54388773" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388773" class="commentstatus"></div>
<div id="comment_54388773" class="cw">
</div>

<div id="replyto_54388773"></div>

<ul id="group_54388773">
	<li id="hiddens_54388773" class="hide"></li>
</ul>

<ul id="commtree_54388773"><li id="tree_54389145" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54389145" class="commentstatus"></div>
<div id="comment_54389145" class="cw">
	<div id="comment_top_54389145" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54389145" name="comment_link_54389145" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54389145" onclick="return D2.setFocusComment(54389145)" >Re:</a>


		 	<span id="comment_score_54389145" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54389145); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54389145"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54389145">Ah, the elusive bash CGI programmer.<nobr> <wbr></nobr>;)</div>
	</div>

	<div class="commentSub" id="comment_sub_54389145">

</div>
</div>

<div id="replyto_54389145"></div>

<ul id="group_54389145">
	<li id="hiddens_54389145" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54388925" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388925" class="commentstatus"></div>
<div id="comment_54388925" class="cw">
</div>

<div id="replyto_54388925"></div>

<ul id="group_54388925">
	<li id="hiddens_54388925" class="hide"></li>
</ul>

</li><li id="hidestring_54388747"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388747">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388781" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388781" class="commentstatus"></div>
<div id="comment_54388781" class="cw">
</div>

<div id="replyto_54388781"></div>

<ul id="group_54388781">
	<li id="hiddens_54388781" class="hide"></li>
</ul>

</li><li id="tree_54388783" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388783" class="commentstatus"></div>
<div id="comment_54388783" class="cw">
</div>

<div id="replyto_54388783"></div>

<ul id="group_54388783">
	<li id="hiddens_54388783" class="hide"></li>
</ul>

<ul id="commtree_54388783"><li id="tree_54388953" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388953" class="commentstatus"></div>
<div id="comment_54388953" class="cw">
</div>

<div id="replyto_54388953"></div>

<ul id="group_54388953">
	<li id="hiddens_54388953" class="hide"></li>
</ul>

</li><li id="hidestring_54388783"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388783">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388787" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388787" class="commentstatus"></div>
<div id="comment_54388787" class="cw">
	<div id="comment_top_54388787" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388787" name="comment_link_54388787" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388787" onclick="return D2.setFocusComment(54388787)" >Dang...</a>


		 	<span id="comment_score_54388787" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388787); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~creimer">creimer</a>  <span class="uid"><a href="//slashdot.org/~creimer">( 824291 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388787"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388787">I could probably write better code &mdash; I don't even work professionally as a programmer.</div>
	</div>

	<div class="commentSub" id="comment_sub_54388787">

</div>
</div>

<div id="replyto_54388787"></div>

<ul id="group_54388787">
	<li id="hiddens_54388787" class="hide"></li>
</ul>

<ul id="commtree_54388787"><li id="tree_54388849" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388849" class="commentstatus"></div>
<div id="comment_54388849" class="cw">
</div>

<div id="replyto_54388849"></div>

<ul id="group_54388849">
	<li id="hiddens_54388849" class="hide"></li>
</ul>

<ul id="commtree_54388849"><li id="tree_54388987" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388987" class="commentstatus"></div>
<div id="comment_54388987" class="cw">
</div>

<div id="replyto_54388987"></div>

<ul id="group_54388987">
	<li id="hiddens_54388987" class="hide"></li>
</ul>

<ul id="commtree_54388987"><li id="tree_54389069" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54389069" class="commentstatus"></div>
<div id="comment_54389069" class="cw">
	<div id="comment_top_54389069" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54389069" name="comment_link_54389069" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54389069" onclick="return D2.setFocusComment(54389069)" >Re:</a>


		 	<span id="comment_score_54389069" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54389069); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CaptainDork">CaptainDork</a>  <span class="uid"><a href="//slashdot.org/~CaptainDork">( 3678879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54389069"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54389069"><p>Fuck you.</p><p>I studied special relativity in 1965 and had to extract square roots by hand.</p><p>What's your goddam point?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54389069">

</div>
</div>

<div id="replyto_54389069"></div>

<ul id="group_54389069">
	<li id="hiddens_54389069" class="hide"></li>
</ul>

<ul id="commtree_54389069"><li id="tree_54389155" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54389155" class="commentstatus"></div>
<div id="comment_54389155" class="cw">
</div>

<div id="replyto_54389155"></div>

<ul id="group_54389155">
	<li id="hiddens_54389155" class="hide"></li>
</ul>

</li><li id="hidestring_54389069"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54389069">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54389153" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54389153" class="commentstatus"></div>
<div id="comment_54389153" class="cw">
	<div id="comment_top_54389153" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54389153" name="comment_link_54389153" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54389153" onclick="return D2.setFocusComment(54389153)" >Re:</a>


		 	<span id="comment_score_54389153" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54389153); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54389153"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54389153">You had no problem writing Delphi and C++ down but you couldn't write the <em>simpler</em> language on paper? Kind of weird, if you ask me...</div>
	</div>

	<div class="commentSub" id="comment_sub_54389153">

</div>
</div>

<div id="replyto_54389153"></div>

<ul id="group_54389153">
	<li id="hiddens_54389153" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54389099" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54389099" class="commentstatus"></div>
<div id="comment_54389099" class="cw">
	<div id="comment_top_54389099" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54389099" name="comment_link_54389099" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54389099" onclick="return D2.setFocusComment(54389099)" >Re:</a>


		 	<span id="comment_score_54389099" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54389099); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~creimer">creimer</a>  <span class="uid"><a href="//slashdot.org/~creimer">( 824291 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54389099"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54389099"><p><div class="quote"><p>Type a code sample with your big fat dick.</p></div><p>You want that in big endian?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54389099">

</div>
</div>

<div id="replyto_54389099"></div>

<ul id="group_54389099">
	<li id="hiddens_54389099" class="hide"></li>
</ul>

</li><li id="hidestring_54388849"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388849">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_54388787"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388787">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388843" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388843" class="commentstatus"></div>
<div id="comment_54388843" class="cw">
	<div id="comment_top_54388843" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388843" name="comment_link_54388843" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388843" onclick="return D2.setFocusComment(54388843)" >Indian Coders and Executives are Trash</a>


		 	<span id="comment_score_54388843" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388843); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388843"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388843"><p>Posting anonymously for obvious reasons. </p><p>Indian software engineers and their "executives" are all terrible. Anytime you have an Indian who finds himself in some sort of executive role, you will have a front row seat to watching half or more of your native country men become unemployed and the amount of "needfulls" working on your project grow exponentially. </p><p> You can then look forward to sloppy, poorly written code coupled with craptastic documentation and more newly appointed Indian managers that think thei<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54388843">

</div>
</div>

<div id="replyto_54388843"></div>

<ul id="group_54388843">
	<li id="hiddens_54388843" class="hide"></li>
</ul>

<ul id="commtree_54388843"><li id="tree_54389073" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54389073" class="commentstatus"></div>
<div id="comment_54389073" class="cw">
	<div id="comment_top_54389073" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54389073" name="comment_link_54389073" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54389073" onclick="return D2.setFocusComment(54389073)" >Re:</a>


		 	<span id="comment_score_54389073" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54389073); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CaptainDork">CaptainDork</a>  <span class="uid"><a href="//slashdot.org/~CaptainDork">( 3678879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54389073"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54389073"><p>I missed the obvious reason.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54389073">

</div>
</div>

<div id="replyto_54389073"></div>

<ul id="group_54389073">
	<li id="hiddens_54389073" class="hide"></li>
</ul>

</li></ul></li><li id="tree_54388845" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388845" class="commentstatus"></div>
<div id="comment_54388845" class="cw">
</div>

<div id="replyto_54388845"></div>

<ul id="group_54388845">
	<li id="hiddens_54388845" class="hide"></li>
</ul>

<ul id="commtree_54388845"><li id="tree_54388883" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54388883" class="commentstatus"></div>
<div id="comment_54388883" class="cw">
</div>

<div id="replyto_54388883"></div>

<ul id="group_54388883">
	<li id="hiddens_54388883" class="hide"></li>
</ul>

</li><li id="hidestring_54388845"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388845">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388855" class="comment full contain"><span class="ind"></span>
<div id="comment_status_54388855" class="commentstatus"></div>
<div id="comment_54388855" class="cw">
	<div id="comment_top_54388855" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388855" name="comment_link_54388855" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388855" onclick="return D2.setFocusComment(54388855)" >It's a timed test</a>


		 	<span id="comment_score_54388855" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388855); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CanadianMacFan">CanadianMacFan</a>  <span class="uid"><a href="//slashdot.org/~CanadianMacFan">( 1900244 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388855">		
		on Tuesday May 09, 2017 @08:41PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388855">#54388855</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388855"><p>At the end of the 60 minutes if your program doesn't compile then you aren't part of the 36%.  You could be finishing a statement or part way through a function or have just forgotten a semi-colon and you are part of the 64%.</p><p>The title is very misleading by saying such a low number can write compilable code.  Through any other group of students at it and I'm sure that you would get similar results.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54388855">
<span class="ind"></span><a id="reply_link_54388855" class="btn link" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54388855" onclick="D2.replyTo(54388855); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="It's a timed test by CanadianMacFan @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=10590957&cid=54388855" data-title="It's a timed test">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="It's a timed test by CanadianMacFan" data-url="https://developers.slashdot.org/comments.pl?sid=10590957&cid=54388855" data-title="It's a timed test">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="It's a timed test by CanadianMacFan" data-url="https://developers.slashdot.org/comments.pl?sid=10590957&cid=54388855" data-title="It's a timed test">linkedin</a>
		<a class="g" href="http://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=10590957%26cid=54388855" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_54388855" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=54388855" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_54388855"></div>

<ul id="group_54388855">
	<li id="hiddens_54388855" class="hide"></li>
</ul>

<ul id="commtree_54388855"><li id="tree_54389061" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54389061" class="commentstatus"></div>
<div id="comment_54389061" class="cw">
</div>

<div id="replyto_54389061"></div>

<ul id="group_54389061">
	<li id="hiddens_54389061" class="hide"></li>
</ul>

</li><li id="tree_54389075" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54389075" class="commentstatus"></div>
<div id="comment_54389075" class="cw">
	<div id="comment_top_54389075" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54389075" name="comment_link_54389075" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54389075" onclick="return D2.setFocusComment(54389075)" >Re:</a>


		 	<span id="comment_score_54389075" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54389075); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AndrewFlagg">AndrewFlagg</a>  <span class="uid"><a href="//slashdot.org/~AndrewFlagg">( 753349 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54389075"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54389075">true.</div>
	</div>

	<div class="commentSub" id="comment_sub_54389075">

</div>
</div>

<div id="replyto_54389075"></div>

<ul id="group_54389075">
	<li id="hiddens_54389075" class="hide"></li>
</ul>

</li><li id="hidestring_54388855"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=54388855">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_54388915" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388915" class="commentstatus"></div>
<div id="comment_54388915" class="cw">
	<div id="comment_top_54388915" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388915" name="comment_link_54388915" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388915" onclick="return D2.setFocusComment(54388915)" >Straight from the mouth of an Indian student</a>


		 	<span id="comment_score_54388915" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388915); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bjdevil66">bjdevil66</a>  <span class="uid"><a href="//slashdot.org/~bjdevil66">( 583941 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388915"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388915">Anecdotal, but still: "A significant percentage (20%+) are dead wood that literally do NOTHING for the firm. They will never type a line of code - and are there solely for marketing brochures and sales pitches. When you combine, 'We have 50 devs ready to work for your project,' with the lower prices for their services, that pitch sounds pretty good to naive managers looking for reasons to pick one company over another."
<br> <br>
When you have practices like that going on, you're going to have a LOT of rotten apple</div>
	</div>

	<div class="commentSub" id="comment_sub_54388915">

</div>
</div>

<div id="replyto_54388915"></div>

<ul id="group_54388915">
	<li id="hiddens_54388915" class="hide"></li>
</ul>

</li><li id="tree_54388929" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54388929" class="commentstatus"></div>
<div id="comment_54388929" class="cw">
	<div id="comment_top_54388929" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54388929" name="comment_link_54388929" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54388929" onclick="return D2.setFocusComment(54388929)" >Better that it doesn't compile</a>


		 	<span id="comment_score_54388929" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54388929); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JoeyRox">JoeyRox</a>  <span class="uid"><a href="//slashdot.org/~JoeyRox">( 2711699 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54388929"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54388929">Because the outcome would be worse if it did.</div>
	</div>

	<div class="commentSub" id="comment_sub_54388929">

</div>
</div>

<div id="replyto_54388929"></div>

<ul id="group_54388929">
	<li id="hiddens_54388929" class="hide"></li>
</ul>

</li><li id="tree_54389031" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54389031" class="commentstatus"></div>
<div id="comment_54389031" class="cw">
	<div id="comment_top_54389031" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54389031" name="comment_link_54389031" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54389031" onclick="return D2.setFocusComment(54389031)" >Here it is ...</a>


		 	<span id="comment_score_54389031" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54389031); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CaptainDork">CaptainDork</a>  <span class="uid"><a href="//slashdot.org/~CaptainDork">( 3678879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54389031"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54389031"><p><div class="quote"><p><nobr> <wbr></nobr>... based on measurements by an automated tool that is used across the world<nobr> <wbr></nobr>...</p> </div><p> <b>coded by Indian engineers!</b></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54389031">

</div>
</div>

<div id="replyto_54389031"></div>

<ul id="group_54389031">
	<li id="hiddens_54389031" class="hide"></li>
</ul>

</li><li id="tree_54389067" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54389067" class="commentstatus"></div>
<div id="comment_54389067" class="cw">
</div>

<div id="replyto_54389067"></div>

<ul id="group_54389067">
	<li id="hiddens_54389067" class="hide"></li>
</ul>

</li><li id="tree_54389101" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54389101" class="commentstatus"></div>
<div id="comment_54389101" class="cw">
	<div id="comment_top_54389101" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54389101" name="comment_link_54389101" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54389101" onclick="return D2.setFocusComment(54389101)" >Neither can I</a>


		 	<span id="comment_score_54389101" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54389101); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Tablizer">Tablizer</a>  <span class="uid"><a href="//slashdot.org/~Tablizer">( 95088 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54389101"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54389101"><p>Neither can I with all the <b>crazy layers our new stack</b> has. I either have to ask for help or spend hours googling and fiddling.</p><p>I suspect all these layers will byte the org in the ass 5 or 10 years down the road. Some layers will be outdated and stop working with others and/or new browsers, have newly-discovered security holes, and/or nobody will remember how they work and/or how to fix them.</p><p>I'm sure in 5 to 10 years some newfangled stack/tool will be "the in thing" and everybody will have forgotten about thi<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_54389101">

</div>
</div>

<div id="replyto_54389101"></div>

<ul id="group_54389101">
	<li id="hiddens_54389101" class="hide"></li>
</ul>

</li><li id="tree_54389125" class="comment oneline"><span class="ind"></span>
<div id="comment_status_54389125" class="commentstatus"></div>
<div id="comment_54389125" class="cw">
	<div id="comment_top_54389125" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_54389125" name="comment_link_54389125" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;cid=54389125" onclick="return D2.setFocusComment(54389125)" >What a stupid metric.</a>


		 	<span id="comment_score_54389125" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 54389125); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JustNiz">JustNiz</a>  <span class="uid"><a href="//slashdot.org/~JustNiz">( 692889 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_54389125"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_54389125"><p>Screw just compiling. Far more realistic criteria are that it has to actually work, be reasonably bug-free, well-designed and easily supportable by others.</p><p>I've worked many years as a software developer, frequently alongside Indians, and after 35 years I've still never met one that is capable of producing code to even that basic minimum standard.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_54389125">

</div>
</div>

<div id="replyto_54389125"></div>

<ul id="group_54389125">
	<li id="hiddens_54389125" class="hide"></li>
</ul>

</li><li id="tree_54389129" class="comment hidden"><span class="ind"></span>
<div id="comment_status_54389129" class="commentstatus"></div>
<div id="comment_54389129" class="cw">
</div>

<div id="replyto_54389129"></div>

<ul id="group_54389129">
	<li id="hiddens_54389129" class="hide"></li>
</ul>

</li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=10590957&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">12 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//developers.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 30;
		D2.currents()['full']     = 2;
		D2.currents()['oneline']  = 22;
		// D2.currents_total(54);

		D2.abbrev_comments({54388915:520,54388705:536,54389101:536,54388843:529});
		D2.noshow_comments([54388635,54388681,54388799,54388717,54389013,54388673,54388691,54389005,54389089,54388699,54389123,54388757,54388795,54388753,54388729,54388743,54388747,54388773,54388925,54388781,54388783,54388953,54388849,54388987,54389155,54388845,54388883,54389061,54389067,54389129]);
		D2.pieces_comments([54388961,54389059,54388661,54388687,54388695,54388777,54388705,54388707,54388827,54389145,54388787,54389069,54389153,54389099,54388843,54389073,54389075,54388915,54388929,54389031,54389101,54389125]);
		D2.init_hiddens([54388681,54388717,54388635,54389005,54388691,54388699,54388757,54388705,54388707,54388747,54388783,54389069,54388849,54388787,54388845,54388855,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(326011);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1001<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/03/01/1643251/programmers-are-confessing-their-coding-sins-to-protest-a-broken-job-interview-process?sdsrc=popbyskidbtmprev">Programmers Are Confessing Their Coding Sins To Protest a Broken Job Interview Process</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>674<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/16/08/15/236236/ask-slashdot-what-are-some-bad-programming-ideas-that-work?sdsrc=popbyskidbtmprev">Ask Slashdot: What Are Some Bad Programming Ideas That Work?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>656<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/03/27/2115233/prominent-drupal-php-developer-kicked-from-the-drupal-project-over-unconventional-sex-life?sdsrc=popbyskidbtmprev">Prominent Drupal, PHP Developer Kicked From the Drupal Project Over Unconventional Sex Life</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>600<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/02/04/1751211/developer-argues-for-forgotten-code-constructs-like-goto-and-eval?sdsrc=popbyskidbtmprev">Developer Argues For 'Forgotten Code Constructs' Like GOTO and Eval</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>531<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/16/10/01/2249256/are-flawed-languages-creating-bad-software?sdsrc=popbyskidbtmprev">Are Flawed Languages Creating Bad Software?</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//apple.slashdot.org/story/17/05/09/2332204/apple-becomes-first-us-company-to-top-800-billion-value?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/business_64.png" width="64" height="64" alt="Businesses"></span>
	    
					<p class="grid_12"><a href="//apple.slashdot.org/story/17/05/09/2332204/apple-becomes-first-us-company-to-top-800-billion-value?sdsrc=nextbtmprev">Apple Becomes First US Company To Top $800 Billion Value</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>11<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//hardware.slashdot.org/story/17/05/09/1948222/microsoft-wants-you-to-care-for-your-surface-like-a-luxury-handbag?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/microsoft_64100.png" width="100" height="64" alt="Microsoft"></span>
	    
					<p class="grid_12"><a href="//hardware.slashdot.org/story/17/05/09/1948222/microsoft-wants-you-to-care-for-your-surface-like-a-luxury-handbag?sdsrc=prevbtmprev">Microsoft Wants You To Care For Your Surface Like a 'Luxury' Handbag</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>29<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=10590957&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">54</span> of <span class="totalcommentcnt">54</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>You can not win the game, and you are not allowed to stop playing.
		-- The Third Law Of Thermodynamics</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2017 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?847">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?131">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->