<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	

<script>
(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '66');
</script>

	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '593067662335325832',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Why Do Web Developers Keep Making The Same Mistakes? - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	  
		<meta name="description" content="An anonymous reader quotes HPE Insights:
Software developers and testers must be sick of hearing security nuts rant, &#34;Beware SQL injection! Monitor for cross-site scripting! Watch for hijacked session credentials!&#34; I suspect the developers tune us out... The industry has generated newer tools, bette...">
	    
		<meta name="twitter:card" content="summary">
		<meta name="twitter:site" content="@slashdot">
		<meta name="twitter:domain" content="developers.slashdot.org">
		<meta property="og:url" content="https://developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes">
	    
		<meta property="og:title" content="Why Do Web Developers Keep Making The Same Mistakes? - Slashdot">
		<meta property="og:description" content="An anonymous reader quotes HPE Insights:
Software developers and testers must be sick of hearing security nuts rant, &#34;Beware SQL injection! Monitor for cross-site scripting! Watch for hijacked session credentials!&#34; I suspect the developers tune us out... The industry has generated newer tools, bette...">
	  
	
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/programming_64.png">
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<link rel="canonical" href="https://developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/332989" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?f5a4d237842139e5" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?f5a4d237842139e5" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?f5a4d237842139e5" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?f5a4d237842139e5">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?f5a4d237842139e5"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?f5a4d237842139e5" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//developers.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotDevelopers" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //developers.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Follow Slashdot stories on <a href="http://twitter.com/slashdot">Twitter</a>
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 Attend or create a Slashdot <strong><a href="https://slashdot.org/anniversary.pl">20th anniversary party!</a></strong> <strong>DEAL:</strong> For $25 - <strong><a href="http://hshd.io/nuLx" rel="nofollow" target="_blank">Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a></strong> Check out the new <a href="https://sourceforge.net/speedtest/?source=slashdotannouncement" rel="nofollow"><strong>SourceForge HTML5 Internet speed test.</a></strong>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-94818541" data-fhid="94818541" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">94818541</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-94818541">
			<a href="//developers.slashdot.org/index2.pl?fhfilter=programming" onclick="return addfhfilter('programming');">
			
				<img src="//a.fsdn.com/sd/topics/programming_64.png" width="64" height="64" alt="Programming" title="Programming">
			
		</a>
		
	
		
		
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=security" onclick="return addfhfilter('security');">
			
				<img src="//a.fsdn.com/sd/topics/security_64.png" width="64" height="64" alt="Security" title="Security">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-94818541" class="story-title"> <a   href="//developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes">Why Do Web Developers Keep Making The Same Mistakes?</a> <span class=" no extlnk"><a class="story-sourcelnk" href="https://insights.hpe.com/content/hpe-nxt/en/articles/2017/10/the-owasp-top-10-is-killing-me-and-killing-you.html"  title="External link - https://insights.hpe.com/content/hpe-nxt/en/articles/2017/10/the-owasp-top-10-is-killing-me-and-killing-you.html" target="_blank"> (hpe.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-94818541" >84</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes#comments" title="">84</a></span>
		
	</h2>
	<div class="details" id="details-94818541">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  EditorDavid
			
		
		

		
		
		<time id="fhtime-94818541" datetime="on Sunday October 29, 2017 @03:30AM">on Sunday October 29, 2017 @03:30AM</time>
		
		
			 from the <span class="dept-text">still-talking-about-injections</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-94818541">
	
		
	

	
		
		<div id="text-94818541" class="p">
			
		 	
				An anonymous reader quotes HPE Insights:
<i>Software developers and testers must be sick of hearing security nuts rant, "Beware SQL injection! Monitor for cross-site scripting! Watch for hijacked session credentials!" I suspect the developers tune us out... The industry has generated newer tools, better testing suites, Agile methodologies, and other advances in writing and testing software. Despite all that, <a href="https://insights.hpe.com/content/hpe-nxt/en/articles/2017/10/the-owasp-top-10-is-killing-me-and-killing-you.html">coders keep making the same dumb mistakes, peer reviews keep missing those mistakes</a>, test tools fail to catch those mistakes, and hackers keep finding ways to exploit those mistakes. One way to see the repeat offenders is to look at the <a href="https://www.owasp.org/index.php/Category:OWASP_Top_Ten_Project">Open Web Application Security Project Top 10</a>, a sometimes controversial ranking of the 10 primary vulnerabilities, published every three or four years by the Open Web Application Security Project... It boggles the mind that a majority of top 10 issues appear across the 2007, 2010, 2013, and draft 2017 OWASP lists...  <br> <br>
It's sad that eight out of 10 of the issues from 2013 are still top security issues in 2017. In fact, if you consider that the draft 2017 list combined two of the 2013 items, it's actually nine out of 10. Ouch...
What can you do? Train everyone better, for starters. Look at coding and test tools that can help detect or prevent security vulnerabilities, but don't consider them silver bullets. Do dynamic application security testing, including penetration testing and fuzz testing. Ensure admins do their part to protect applications. And finally, make sure you establish a culture of security-aware programming and deployment.</i><br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-94818541" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes"
								  data-janrain-title="Why Do Web Developers Keep Making The Same Mistakes?"
								  data-janrain-message="Why Do Web Developers Keep Making The Same Mistakes? @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-94818541" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/security" target="_blank">security</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/programming" target="_blank">programming</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/theyaremorons" target="_blank">theyaremorons</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//apple.slashdot.org/story/17/10/28/1938224/captain-crunch-and-steve-wozniak-write-new-book-beyond-the-little-blue-box?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//apple.slashdot.org/story/17/10/29/0548207/apple-fires-engineer-after-his-daughters-iphone-x-video-goes-viral?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//apple.slashdot.org/story/17/10/28/1938224/captain-crunch-and-steve-wozniak-write-new-book-beyond-the-little-blue-box?sdsrc=prev">Captain Crunch (and Steve Wozniak) Write New Book: 'Beyond the Little Blue Box' </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//it.slashdot.org/story/13/06/13/175209/owasp-top-10-2013-released?sdsrc=rel">OWASP Top 10 2013 Released</a></h3><h3><a href="//it.slashdot.org/story/15/11/22/1437203/the-history-of-sql-injection-the-hack-that-will-never-go-away?sdsrc=rel">The History of SQL Injection, the Hack That Will Never Go Away</a></h3><h3><a href="//news.slashdot.org/story/16/11/12/1918229/owasp-modsecurity-core-rule-set-version-30-released?sdsrc=rel">OWASP ModSecurity Core Rule Set Version 3.0 Released</a></h3><h3><a href="//tech.slashdot.org/story/17/07/22/1911237/debian-gnome-patched-bad-taste-vbscript-injection-vulnerabilities?sdsrc=rel">Debian, Gnome Patched 'Bad Taste' VBScript-Injection Vulnerabilities</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//apple.slashdot.org/story/17/10/29/0548207/apple-fires-engineer-after-his-daughters-iphone-x-video-goes-viral?sdsrc=next">Apple Fires Engineer After His Daughter's iPhone X Video Goes Viral</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes" title="Back to Article - Why Do Web Developers Keep Making The Same Mistakes?">Why Do Web Developers Keep Making The Same Mistakes?</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Why Do Web Developers Keep Making The Same Mistakes?" href="//developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes">Why Do Web Developers Keep Making The Same Mistakes?</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=11287681" class="btn">Search <span class="totalcommentcnt">84</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//developers.slashdot.org/comments.pl?sid=11287681">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=11287681" class="ui-icon search_comments">Search <span class="totalcommentcnt">84</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//developers.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/17/10/29/0441205/why-do-web-developers-keep-making-the-same-mistakes/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?f5a4d237842139e5" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_55451977" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55451977" class="commentstatus"></div>
<div id="comment_55451977" class="cw">
	<div id="comment_top_55451977" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55451977" name="comment_link_55451977" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55451977" onclick="return D2.setFocusComment(55451977)" >Wrong</a>


		 	<span id="comment_score_55451977" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55451977); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~hcs_%24reboot">hcs_$reboot</a>  <span class="uid"><a href="//slashdot.org/~hcs_%24reboot">( 1536101 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55451977">		
		on Sunday October 29, 2017 @03:34AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55451977">#55451977</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55451977">That's not the <i>same</i> web devs making those same mistakes. Developers with some experience do not write code that fails against easy sql-injection. But companies prefer to hire younger inexperienced devs for the reasons that have been discussed here on<nobr> <wbr></nobr>/. many times.</div>
	</div>

	<div class="commentSub" id="comment_sub_55451977">
<span class="ind"></span><a id="reply_link_55451977" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55451977" onclick="D2.replyTo(55451977); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Wrong by hcs_$reboot @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55451977" data-title="Wrong">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Wrong by hcs_$reboot" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55451977" data-title="Wrong">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Wrong by hcs_$reboot" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55451977" data-title="Wrong">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11287681%26cid=55451977" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55451977" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55451977" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55451977"></div>

<ul id="group_55451977">
	<li id="hiddens_55451977" class="hide"></li>
</ul>

<ul id="commtree_55451977"><li id="tree_55451999" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55451999" class="commentstatus"></div>
<div id="comment_55451999" class="cw">
	<div id="comment_top_55451999" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55451999" name="comment_link_55451999" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55451999" onclick="return D2.setFocusComment(55451999)" >Re:</a>


		 	<span id="comment_score_55451999" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55451999); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ovanklot">ovanklot</a>  <span class="uid"><a href="//slashdot.org/~ovanklot">( 715633 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55451999"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55451999"><p><div class="quote"><p>That's not the <i>same</i> web devs making those same mistakes. Developers with some experience do not write code that fails against easy sql-injection. But companies prefer to hire younger inexperienced devs for the reasons that have been discussed here on<nobr> <wbr></nobr>/. many times.</p></div><p>I'll add to that that this isn't limited to web developers.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55451999">

</div>
</div>

<div id="replyto_55451999"></div>

<ul id="group_55451999">
	<li id="hiddens_55451999" class="hide"></li>
</ul>

<ul id="commtree_55451999"><li id="tree_55452035" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452035" class="commentstatus"></div>
<div id="comment_55452035" class="cw">
	<div id="comment_top_55452035" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452035" name="comment_link_55452035" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452035" onclick="return D2.setFocusComment(55452035)" >Re:</a>


		 	<span id="comment_score_55452035" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452035); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~KiloByte">KiloByte</a>  <span class="uid"><a href="//slashdot.org/~KiloByte">( 825081 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452035"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452035"><p><div class="quote"><p>I'll add to that that this isn't limited to web developers.</p></div><p>Hell yeah this.  In most fields, there's decades of prior wisdom that one should at least try to get a grasp of before making "brilliant" inventions.  Like, you shouldn't write an init system before reading "Unix for Dummies".</p><p>Things like SIGHUP/nohup are basic knowledge, if you don't know <b>this</b> you shouldn't write your snowflake way of killing processes on logout.  If you don't know ways to authenticate users and what user names are <b>explicitly allowed</b> by POSIX (the 0day issue), you shouldn't create a gaping<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452035">

</div>
</div>

<div id="replyto_55452035"></div>

<ul id="group_55452035">
	<li id="hiddens_55452035" class="hide"></li>
</ul>

</li><li id="tree_55452175" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452175" class="commentstatus"></div>
<div id="comment_55452175" class="cw">
</div>

<div id="replyto_55452175"></div>

<ul id="group_55452175">
	<li id="hiddens_55452175" class="hide"></li>
</ul>

</li><li id="hidestring_55451999"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55451999">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55452005" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55452005" class="commentstatus"></div>
<div id="comment_55452005" class="cw">
	<div id="comment_top_55452005" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452005" name="comment_link_55452005" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452005" onclick="return D2.setFocusComment(55452005)" >Re:Wrong</a>


		 	<span id="comment_score_55452005" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452005); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452005">		
		on Sunday October 29, 2017 @03:52AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452005">#55452005</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452005"><p>Does not match my experience. Some (few, say 10%) of these people do indeed acquire insight and experience with more time in the field, but most do not seem to. They make the same basic mistakes and have the same defective and incomplete understanding of how thing work, 5 years in, 10 years in and then they move to another field because they have become unemployable in their "specialty".</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452005">
<span class="ind"></span><a id="reply_link_55452005" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55452005" onclick="D2.replyTo(55452005); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=55451977" onclick="return D2.selectParent(55451977)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Wrong by gweihir @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55452005" data-title="Re:Wrong">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Wrong by gweihir" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55452005" data-title="Re:Wrong">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Wrong by gweihir" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55452005" data-title="Re:Wrong">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11287681%26cid=55452005" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55452005" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55452005" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55452005"></div>

<ul id="group_55452005">
	<li id="hiddens_55452005" class="hide"></li>
</ul>

<ul id="commtree_55452005"><li id="tree_55452053" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452053" class="commentstatus"></div>
<div id="comment_55452053" class="cw">
	<div id="comment_top_55452053" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452053" name="comment_link_55452053" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452053" onclick="return D2.setFocusComment(55452053)" >Re:</a>


		 	<span id="comment_score_55452053" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452053); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~scsirob">scsirob</a>  <span class="uid"><a href="//slashdot.org/~scsirob">( 246572 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452053"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452053"><p>We have a special name for those people who do not learn from their mistakes. We call them "Managers"..</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452053">

</div>
</div>

<div id="replyto_55452053"></div>

<ul id="group_55452053">
	<li id="hiddens_55452053" class="hide"></li>
</ul>

</li><li id="tree_55452117" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452117" class="commentstatus"></div>
<div id="comment_55452117" class="cw">
	<div id="comment_top_55452117" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452117" name="comment_link_55452117" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452117" onclick="return D2.setFocusComment(55452117)" >Re:</a>


		 	<span id="comment_score_55452117" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452117); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~swilver">swilver</a>  <span class="uid"><a href="//slashdot.org/~swilver">( 617741 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452117"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452117"><p>Those few are the ones you want to keep.  However, you won't be able to keep them if you don't pay them well, or make their lives difficult/annoying with stupid management decisions.  They'll be the first to leave as they have many options and don't have to deal with stupidity -- leaving your company with those that seem unable to learn from their mistakes, or just don't give a shit.</p><p>I'm considered a decent developer, and if you want to keep me you better be prepared to pay me significantly more than that fr<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452117">

</div>
</div>

<div id="replyto_55452117"></div>

<ul id="group_55452117">
	<li id="hiddens_55452117" class="hide"></li>
</ul>

<ul id="commtree_55452117"><li id="tree_55452297" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452297" class="commentstatus"></div>
<div id="comment_55452297" class="cw">
	<div id="comment_top_55452297" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452297" name="comment_link_55452297" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452297" onclick="return D2.setFocusComment(55452297)" >Re:</a>


		 	<span id="comment_score_55452297" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452297); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452297"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452297"><p>Yes, very much so. I see that all the time, especially with large customers.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452297">

</div>
</div>

<div id="replyto_55452297"></div>

<ul id="group_55452297">
	<li id="hiddens_55452297" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_55452007" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452007" class="commentstatus"></div>
<div id="comment_55452007" class="cw">
</div>

<div id="replyto_55452007"></div>

<ul id="group_55452007">
	<li id="hiddens_55452007" class="hide"></li>
</ul>

</li><li id="tree_55452055" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452055" class="commentstatus"></div>
<div id="comment_55452055" class="cw">
</div>

<div id="replyto_55452055"></div>

<ul id="group_55452055">
	<li id="hiddens_55452055" class="hide"></li>
</ul>

</li><li id="tree_55452059" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452059" class="commentstatus"></div>
<div id="comment_55452059" class="cw">
</div>

<div id="replyto_55452059"></div>

<ul id="group_55452059">
	<li id="hiddens_55452059" class="hide"></li>
</ul>

</li><li id="tree_55452099" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452099" class="commentstatus"></div>
<div id="comment_55452099" class="cw">
	<div id="comment_top_55452099" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452099" name="comment_link_55452099" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452099" onclick="return D2.setFocusComment(55452099)" >Re:</a>


		 	<span id="comment_score_55452099" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452099); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jrumney">jrumney</a>  <span class="uid"><a href="//slashdot.org/~jrumney">( 197329 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452099"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452099"><p><div class="quote"><p>That's not the same web devs making those same mistakes.</p></div><p>True, the web developers from 2013 have all retired and taken up jobs in the fast food industry by now.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452099">

</div>
</div>

<div id="replyto_55452099"></div>

<ul id="group_55452099">
	<li id="hiddens_55452099" class="hide"></li>
</ul>

</li><li id="tree_55452161" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452161" class="commentstatus"></div>
<div id="comment_55452161" class="cw">
</div>

<div id="replyto_55452161"></div>

<ul id="group_55452161">
	<li id="hiddens_55452161" class="hide"></li>
</ul>

</li><li id="tree_55452185" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452185" class="commentstatus"></div>
<div id="comment_55452185" class="cw">
	<div id="comment_top_55452185" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452185" name="comment_link_55452185" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452185" onclick="return D2.setFocusComment(55452185)" >Re:</a>


		 	<span id="comment_score_55452185" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452185); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tlhIngan">tlhIngan</a>  <span class="uid"><a href="//slashdot.org/~tlhIngan">( 30335 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452185"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452185"><blockquote><div><p>That's not the same web devs making those same mistakes. Developers with some experience do not write code that fails against easy sql-injection. But companies prefer to hire younger inexperienced devs for the reasons that have been discussed here on<nobr> <wbr></nobr>/. many times.</p></div></blockquote><p>Well that pretty much applies to practically every job these days. The companies pursue money above all else, to the detriment of themselves - assuming everyone (and everything) is a swappable interchangeable part.</p><p>Nothing can be further from the t<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452185">

</div>
</div>

<div id="replyto_55452185"></div>

<ul id="group_55452185">
	<li id="hiddens_55452185" class="hide"></li>
</ul>

</li><li id="tree_55452225" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452225" class="commentstatus"></div>
<div id="comment_55452225" class="cw">
	<div id="comment_top_55452225" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452225" name="comment_link_55452225" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452225" onclick="return D2.setFocusComment(55452225)" >Re:</a>


		 	<span id="comment_score_55452225" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452225); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~cardpuncher">cardpuncher</a>  <span class="uid"><a href="//slashdot.org/~cardpuncher">( 713057 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452225"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452225">More to the point, why should these serious "mistakes" be possible at all.
<p>
If these errors keep occurring, you have to stop blaming the web developers and start blaming the technology. There is no good reason that cross-site scripting or session hacking should even be possible. It's a mad idea to turn user input into a human-readable SQL command string when no human needs to read it.
</p><p>
The problem is that we stared off with insecure shoddy hacks and there has been a whole slew of incremental mitigations, no<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452225">

</div>
</div>

<div id="replyto_55452225"></div>

<ul id="group_55452225">
	<li id="hiddens_55452225" class="hide"></li>
</ul>

</li><li id="hidestring_55451977"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55451977">4 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55451979" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55451979" class="commentstatus"></div>
<div id="comment_55451979" class="cw">
	<div id="comment_top_55451979" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55451979" name="comment_link_55451979" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55451979" onclick="return D2.setFocusComment(55451979)" >Security is always last</a>


		 	<span id="comment_score_55451979" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55451979); return false"><span class=opt>Score:</span>3</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55451979">		
		on Sunday October 29, 2017 @03:35AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55451979">#55451979</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55451979"><p>Security is always last when implementing a new piece of software. Until management gets that security is vital to their well being, this will continue to happen. But since they have cybersecurity insurance and since everyone has the memory of a goldfish, the company will be fine, and therefore they don't need to spend the money on it.  After all it would just be an added expense and possibly delay the introduction of the software in the first place which could ultimately be worse than having a buggy program.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55451979">
<span class="ind"></span><a id="reply_link_55451979" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55451979" onclick="D2.replyTo(55451979); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Security is always last by Anonymous Coward @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55451979" data-title="Security is always last">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Security is always last by Anonymous Coward" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55451979" data-title="Security is always last">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Security is always last by Anonymous Coward" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55451979" data-title="Security is always last">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11287681%26cid=55451979" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55451979" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55451979" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55451979"></div>

<ul id="group_55451979">
	<li id="hiddens_55451979" class="hide"></li>
</ul>

<ul id="commtree_55451979"><li id="tree_55452183" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452183" class="commentstatus"></div>
<div id="comment_55452183" class="cw">
</div>

<div id="replyto_55452183"></div>

<ul id="group_55452183">
	<li id="hiddens_55452183" class="hide"></li>
</ul>

</li><li id="hidestring_55451979"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55451979">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55451995" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55451995" class="commentstatus"></div>
<div id="comment_55451995" class="cw">
	<div id="comment_top_55451995" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55451995" name="comment_link_55451995" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55451995" onclick="return D2.setFocusComment(55451995)" >Because you keep replacing them with kids.</a>


		 	<span id="comment_score_55451995" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55451995); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Narcocide">Narcocide</a>  <span class="uid"><a href="//slashdot.org/~Narcocide">( 102829 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55451995"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55451995"><p>Next question.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55451995">

</div>
</div>

<div id="replyto_55451995"></div>

<ul id="group_55451995">
	<li id="hiddens_55451995" class="hide"></li>
</ul>

</li><li id="tree_55452001" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55452001" class="commentstatus"></div>
<div id="comment_55452001" class="cw">
	<div id="comment_top_55452001" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452001" name="comment_link_55452001" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452001" onclick="return D2.setFocusComment(55452001)" >Simple: Cheaper than possible personnel </a>


		 	<span id="comment_score_55452001" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452001); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452001">		
		on Sunday October 29, 2017 @03:49AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452001">#55452001</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452001"><p>Web application developers are the lowest-skilled, least educated and least talented people in the IT space. I recently had to explain to some people with supposedly 5 years experience in that space what an HTTP header looks like, because they had no clue. Same for basically every other aspect, like cookie naming, how to make you application able to work behind a proxy (in an enterprise-environment, no less), etc. It is staggering how clueless these people are. All they seem to see is a framework, which they barely understand and then put an application on top that makes all the basic mistakes you can think of. Of course, they eventually remove the mistakes that break the application in the specific target environment for a specific browser, but that is it. Forget about any understanding of the mechanisms they are using or of IT security. Some do not even know what an IP address is or how an URL is composed from components.</p><p>So in essence: Developers that are grossly incompetent and management that is grossly incompetent for hiring these people. As we have a lot of "bean-copunter" types in management these days (MBAs and even less competent ones), things will not change anytime soon.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452001">
<span class="ind"></span><a id="reply_link_55452001" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55452001" onclick="D2.replyTo(55452001); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Simple: Cheaper than possible personnel  by gweihir @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55452001" data-title="Simple: Cheaper than possible personnel ">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Simple: Cheaper than possible personnel  by gweihir" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55452001" data-title="Simple: Cheaper than possible personnel ">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Simple: Cheaper than possible personnel  by gweihir" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55452001" data-title="Simple: Cheaper than possible personnel ">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11287681%26cid=55452001" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55452001" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55452001" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55452001"></div>

<ul id="group_55452001">
	<li id="hiddens_55452001" class="hide"></li>
</ul>

<ul id="commtree_55452001"><li id="tree_55452021" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452021" class="commentstatus"></div>
<div id="comment_55452021" class="cw">
</div>

<div id="replyto_55452021"></div>

<ul id="group_55452021">
	<li id="hiddens_55452021" class="hide"></li>
</ul>

</li><li id="tree_55452129" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452129" class="commentstatus"></div>
<div id="comment_55452129" class="cw">
	<div id="comment_top_55452129" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452129" name="comment_link_55452129" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452129" onclick="return D2.setFocusComment(55452129)" >Re:</a>


		 	<span id="comment_score_55452129" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452129); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gtall">gtall</a>  <span class="uid"><a href="//slashdot.org/~gtall">( 79522 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452129"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452129"><p>Yes, there is plenty of blame to go around. Part of that blame is on CS depts. I was once associated with a CS dept. of a major midwest uni. They said they had an "honors" group of students. I got saddled with three of them for a project in Java. When I asked if they could whack together something that did X, they grumbled, moaned, whined, and produced nothing. They didn't know how to get started. Yet they all went on to "promising" careers in industry...and they were seniors.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452129">

</div>
</div>

<div id="replyto_55452129"></div>

<ul id="group_55452129">
	<li id="hiddens_55452129" class="hide"></li>
</ul>

</li><li id="hidestring_55452001"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55452001">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55452009" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452009" class="commentstatus"></div>
<div id="comment_55452009" class="cw">
	<div id="comment_top_55452009" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452009" name="comment_link_55452009" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452009" onclick="return D2.setFocusComment(55452009)" >Because it isn't a priority</a>


		 	<span id="comment_score_55452009" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452009); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452009"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452009"><p>Companies (especially startups) are too focused on getting the next feature released before the next deadline. Security is one of their lowest priorities. Once they are acquired, it's then the acquiring company's problem to deal with.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452009">

</div>
</div>

<div id="replyto_55452009"></div>

<ul id="group_55452009">
	<li id="hiddens_55452009" class="hide"></li>
</ul>

</li><li id="tree_55452013" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452013" class="commentstatus"></div>
<div id="comment_55452013" class="cw">
	<div id="comment_top_55452013" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452013" name="comment_link_55452013" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452013" onclick="return D2.setFocusComment(55452013)" >culture not technology</a>


		 	<span id="comment_score_55452013" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452013); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452013"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452013"><p>is it not clear yet that this is a cultural issue in the way buisnesses are run and setup and not a technological impossibility?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452013">

</div>
</div>

<div id="replyto_55452013"></div>

<ul id="group_55452013">
	<li id="hiddens_55452013" class="hide"></li>
</ul>

<ul id="commtree_55452013"><li id="tree_55452039" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452039" class="commentstatus"></div>
<div id="comment_55452039" class="cw">
	<div id="comment_top_55452039" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452039" name="comment_link_55452039" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452039" onclick="return D2.setFocusComment(55452039)" >Re:</a>


		 	<span id="comment_score_55452039" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452039); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452039"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452039"><p>Apparently to some, it is not. These may be the people at the core of the problem, though.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452039">

</div>
</div>

<div id="replyto_55452039"></div>

<ul id="group_55452039">
	<li id="hiddens_55452039" class="hide"></li>
</ul>

</li><li id="tree_55452107" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452107" class="commentstatus"></div>
<div id="comment_55452107" class="cw">
	<div id="comment_top_55452107" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452107" name="comment_link_55452107" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452107" onclick="return D2.setFocusComment(55452107)" >Re:</a>


		 	<span id="comment_score_55452107" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452107); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dougTheRug">dougTheRug</a>  <span class="uid"><a href="//slashdot.org/~dougTheRug">( 649069 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452107"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452107">That's a very good point. The system designers have to have their design and implementation* correct, 100% of the time to be safe. And they generally only the the chance to design, once. (refactoring can give you multiple chances at implementation<p>
The attackers on the other hand, only have to be right, once.
</p><p>
The model of this in the natural world is virus infections and other parasitic relationships. If the parasite kills its host or host ecosystem, the parasite also fails. So I think in the worst case, th<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452107">

</div>
</div>

<div id="replyto_55452107"></div>

<ul id="group_55452107">
	<li id="hiddens_55452107" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55452017" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55452017" class="commentstatus"></div>
<div id="comment_55452017" class="cw">
	<div id="comment_top_55452017" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452017" name="comment_link_55452017" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452017" onclick="return D2.setFocusComment(55452017)" >The real problems are...</a>


		 	<span id="comment_score_55452017" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452017); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bradley13">bradley13</a>  <span class="uid"><a href="//slashdot.org/~bradley13">( 1118935 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452017">		
		on Sunday October 29, 2017 @04:01AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452017">#55452017</a>)
		<small><a href="http://richards.kri.ch/" title="http://richards.kri.ch/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452017"><p>IMHO, these problems stem from the following source problems:</p><p>- Incompetent developers. Look at the number one problem, number one for years now: injection. I teach students how to avoid this the first time they touch a database, which is typically in year two of their degree program. It doesn't matter: half of them still write injectable queries, even though using "prepared statements" isn't any more complex. The thing is: there is so much code to be written, that even these students - who evidently don't understand, don't care, and can't be bothered - even these students will find jobs, and some of them will be working on <i> <b>your</b> </i> web projects.</p><p>- Internet speed. TFA talks about "agile methodologies" as if they were a good thing. While "iterative development" absolutely does make sense, in too many companies "agile", and "Scrum" and their brethren are an excuse for pushing half-tested code out the door, because everything has to be fast, <i>fast</i>, <i> <b>fast</b> </i>. I have news for the marketing department: No, your latest brainstorm does not have to be live next week. In fact, given that the brainstorm-after-next will basically reverse this one, it would really be better for everyone if you just fell off a bridge and drowned.</p><p>- Too many frameworks. Real example: I used to use Guice, a small dependency-injection framework from Google, for a small demo-project. A few months ago I decided to update Guice to the latest version. But the latest version depends on another framework, Guava. Guava requires JavaX. JavaX requires Spring. Spring requires...good god, at this point I deleted Guice. I mean, seriously, binding in that much foreign code? First, you are now <i>dependent</i> on all that code, and whatever changes are made to it. Second, you are bringing in <i>all of the vulnerabilties</i> present in that code. And you have absolutely no idea what those may be, because you certainly aren't going to validate all of that code yourself. Thank you very much, I'll just implement that small bit of functionality I need, all by myself.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452017">
<span class="ind"></span><a id="reply_link_55452017" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55452017" onclick="D2.replyTo(55452017); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="The real problems are... by bradley13 @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55452017" data-title="The real problems are...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="The real problems are... by bradley13" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55452017" data-title="The real problems are...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="The real problems are... by bradley13" data-url="https://developers.slashdot.org/comments.pl?sid=11287681&cid=55452017" data-title="The real problems are...">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11287681%26cid=55452017" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55452017" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55452017" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55452017"></div>

<ul id="group_55452017">
	<li id="hiddens_55452017" class="hide"></li>
</ul>

<ul id="commtree_55452017"><li id="tree_55452043" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452043" class="commentstatus"></div>
<div id="comment_55452043" class="cw">
	<div id="comment_top_55452043" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452043" name="comment_link_55452043" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452043" onclick="return D2.setFocusComment(55452043)" >Re:</a>


		 	<span id="comment_score_55452043" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452043); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Hognoxious">Hognoxious</a>  <span class="uid"><a href="//slashdot.org/~Hognoxious">( 631665 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452043"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452043"><blockquote><div><p>But the latest version depends on another framework, Guava. Guava requires JavaX. JavaX requires Spring. Spring requires...good god, at this point I deleted Guice.</p></div>    </blockquote><p>Look on the bright side, it didn't need systemd or gnome.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452043">

</div>
</div>

<div id="replyto_55452043"></div>

<ul id="group_55452043">
	<li id="hiddens_55452043" class="hide"></li>
</ul>

<ul id="commtree_55452043"><li id="tree_55452101" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452101" class="commentstatus"></div>
<div id="comment_55452101" class="cw">
</div>

<div id="replyto_55452101"></div>

<ul id="group_55452101">
	<li id="hiddens_55452101" class="hide"></li>
</ul>

</li><li id="hidestring_55452043"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55452043">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55452047" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452047" class="commentstatus"></div>
<div id="comment_55452047" class="cw">
	<div id="comment_top_55452047" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452047" name="comment_link_55452047" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452047" onclick="return D2.setFocusComment(55452047)" >Re:</a>


		 	<span id="comment_score_55452047" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452047); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452047"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452047"><p>I fully agree on all of these. I also teach a software security lecture, and last year one student summarized the purpose as "warn everybody to get an expert and not to do it themselves". Well, at least that one learned something.</p><p>As to the last point: This is a real catastrophe in the making. Nobody still understand what they do and their dependencies seem to grow all the time. I now push "does not depend on frameworks" as a sign of quality to customers, wherever possible.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452047">

</div>
</div>

<div id="replyto_55452047"></div>

<ul id="group_55452047">
	<li id="hiddens_55452047" class="hide"></li>
</ul>

<ul id="commtree_55452047"><li id="tree_55452075" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452075" class="commentstatus"></div>
<div id="comment_55452075" class="cw">
	<div id="comment_top_55452075" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452075" name="comment_link_55452075" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452075" onclick="return D2.setFocusComment(55452075)" >Re:</a>


		 	<span id="comment_score_55452075" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452075); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~swilver">swilver</a>  <span class="uid"><a href="//slashdot.org/~swilver">( 617741 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452075"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452075"><p>Quality?  That's not quality.  *OUR* software comes with its own Kernel, or are you gonna deny that Kernels aren't full of security issues?  Some kernels consists of over 15 million lines of code!  Did you check all those?</p><p>Sure, customers are surprised at first when none of their other software runs anymore on machines with ours installed, but it is guaranteed secure.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452075">

</div>
</div>

<div id="replyto_55452075"></div>

<ul id="group_55452075">
	<li id="hiddens_55452075" class="hide"></li>
</ul>

<ul id="commtree_55452075"><li id="tree_55452085" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452085" class="commentstatus"></div>
<div id="comment_55452085" class="cw">
	<div id="comment_top_55452085" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452085" name="comment_link_55452085" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452085" onclick="return D2.setFocusComment(55452085)" >Re:</a>


		 	<span id="comment_score_55452085" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452085); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452085"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452085"><p>Who let the clown in?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452085">

</div>
</div>

<div id="replyto_55452085"></div>

<ul id="group_55452085">
	<li id="hiddens_55452085" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55452121" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452121" class="commentstatus"></div>
<div id="comment_55452121" class="cw">
	<div id="comment_top_55452121" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452121" name="comment_link_55452121" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452121" onclick="return D2.setFocusComment(55452121)" >Re:</a>


		 	<span id="comment_score_55452121" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452121); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dougTheRug">dougTheRug</a>  <span class="uid"><a href="//slashdot.org/~dougTheRug">( 649069 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452121"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452121">If you were teaching civil engineering, the first day you would be showing them a film about the bridge that blew down because of its design failing to accommodate for its stress inputs. And the fact that people's lives were on the line.
<p>
I would very much like to know what the first day in your course is like.
</p><p>
I think you have to honestly look at yourself and if you are not educating developers on how and why injection flaws work, and how they must be stopped at every handoff of data between interpretatio<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452121">

</div>
</div>

<div id="replyto_55452121"></div>

<ul id="group_55452121">
	<li id="hiddens_55452121" class="hide"></li>
</ul>

<ul id="commtree_55452121"><li id="tree_55452347" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452347" class="commentstatus"></div>
<div id="comment_55452347" class="cw">
</div>

<div id="replyto_55452347"></div>

<ul id="group_55452347">
	<li id="hiddens_55452347" class="hide"></li>
</ul>

</li><li id="hidestring_55452121"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55452121">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55452065" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452065" class="commentstatus"></div>
<div id="comment_55452065" class="cw">
	<div id="comment_top_55452065" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452065" name="comment_link_55452065" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452065" onclick="return D2.setFocusComment(55452065)" >Re:</a>


		 	<span id="comment_score_55452065" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452065); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~swilver">swilver</a>  <span class="uid"><a href="//slashdot.org/~swilver">( 617741 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452065"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452065"><p>Too many frameworks... that's a good one.  You're worried about the vulnerabilities in some of the most stable, highly scrutinized, fully unit tested and secure frameworks Java has on offer and because of that... you roll your own.</p><p>I guess I know what is really wrong with the industry: developers that think they can create their own framework, replacing several dozen man years of coding, debugging and testing in just a few days -- and then having the arrogance to think it will contain less vulnerabilities ri<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452065">

</div>
</div>

<div id="replyto_55452065"></div>

<ul id="group_55452065">
	<li id="hiddens_55452065" class="hide"></li>
</ul>

<ul id="commtree_55452065"><li id="tree_55452127" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452127" class="commentstatus"></div>
<div id="comment_55452127" class="cw">
	<div id="comment_top_55452127" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452127" name="comment_link_55452127" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452127" onclick="return D2.setFocusComment(55452127)" >Re:</a>


		 	<span id="comment_score_55452127" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452127); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DNS-and-BIND">DNS-and-BIND</a>  <span class="uid"><a href="//slashdot.org/~DNS-and-BIND">( 461968 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452127"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452127">You are assuming without any justification that the entire suite of functionality these frameworks provide is required.  It is not.  We just need one thing, but to implement that one thing, we need to massively expand our attack surface by bringing in huge amounts of foreign code.  Your argument is that by reimplementing this entire framework vulnerabilities will be introduced, which is correct but it does not address the problem at hand.  We aren't reimplementing the entire framework.</div>
	</div>

	<div class="commentSub" id="comment_sub_55452127">

</div>
</div>

<div id="replyto_55452127"></div>

<ul id="group_55452127">
	<li id="hiddens_55452127" class="hide"></li>
</ul>

<ul id="commtree_55452127"><li id="tree_55452167" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452167" class="commentstatus"></div>
<div id="comment_55452167" class="cw">
	<div id="comment_top_55452167" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452167" name="comment_link_55452167" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452167" onclick="return D2.setFocusComment(55452167)" >Re:</a>


		 	<span id="comment_score_55452167" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452167); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~swilver">swilver</a>  <span class="uid"><a href="//slashdot.org/~swilver">( 617741 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452167"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452167"><p>The example given was Guice, which is a DI framework.  To implement DI you need to write at least a couple of thousand lines of code, using not every day concepts like annotation scanning, reflection, thread safety, etc.  That's a non-trivial amount of work requiring a solid test suite to boot.</p><p>Other than that I totally agree with you.  I cringe every time I see some huge framework imported just to use one of its utility functions...  Sure, a framework is great if over half the code needs it and it saves a l<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452167">

</div>
</div>

<div id="replyto_55452167"></div>

<ul id="group_55452167">
	<li id="hiddens_55452167" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55452191" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452191" class="commentstatus"></div>
<div id="comment_55452191" class="cw">
	<div id="comment_top_55452191" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452191" name="comment_link_55452191" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452191" onclick="return D2.setFocusComment(55452191)" >Re:</a>


		 	<span id="comment_score_55452191" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452191); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bongo">Bongo</a>  <span class="uid"><a href="//slashdot.org/~Bongo">( 13261 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452191"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452191"><p>I think there&rsquo;s a side issue: only by trying to write one&rsquo;s own, does one start to understand the problem. So as a learning excercise, trying to write one&rsquo;s own is really useful. And then, use a proper framework. Otherwise there&rsquo;s the opposite problem of people relying on frameworks which they don&rsquo;t understand.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452191">

</div>
</div>

<div id="replyto_55452191"></div>

<ul id="group_55452191">
	<li id="hiddens_55452191" class="hide"></li>
</ul>

</li><li id="tree_55452233" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452233" class="commentstatus"></div>
<div id="comment_55452233" class="cw">
	<div id="comment_top_55452233" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452233" name="comment_link_55452233" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452233" onclick="return D2.setFocusComment(55452233)" >Re:</a>


		 	<span id="comment_score_55452233" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452233); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheRaven64">TheRaven64</a>  <span class="uid"><a href="//slashdot.org/~TheRaven64">( 641858 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452233"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452233"><p>Depend on the amount of code from the framework you actually need.  If you're bringing in half a million lines of code to do something that could be done in a couple of thousand, then you're probably better off rolling your own: it's going to have far more tightly coupled logic and be more amenable to static analysis, as well as being an easier target to fuzz test.  </p><p>
If, on the other hand, you end up implementing most of the logic in a dependency, then you're probably better off using the one that's widely<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452233">

</div>
</div>

<div id="replyto_55452233"></div>

<ul id="group_55452233">
	<li id="hiddens_55452233" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55452073" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452073" class="commentstatus"></div>
<div id="comment_55452073" class="cw">
	<div id="comment_top_55452073" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452073" name="comment_link_55452073" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452073" onclick="return D2.setFocusComment(55452073)" >Re:</a>


		 	<span id="comment_score_55452073" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452073); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jarle.aase">jarle.aase</a>  <span class="uid"><a href="//slashdot.org/~jarle.aase">( 1440081 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452073"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452073">Sir you are wrong!
<p>
Every tattooed d*head in my coffee shop agree that you need to include at least a million lines of javascript, backed a hew hundred gems, including a few dozens C libraries and some Rust apps to render HTML output.
</p><p>
And bad-talking scrum??? What's wrong with scrum, dude? It makes the graybeards quit, and then we get to do everything our own way, without anyone<nobr> <wbr></nobr>/senior/ babbling around about security, response time or energy consumption. Scrum is great. Without scrum we may actually had t<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452073">

</div>
</div>

<div id="replyto_55452073"></div>

<ul id="group_55452073">
	<li id="hiddens_55452073" class="hide"></li>
</ul>

</li><li id="tree_55452111" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452111" class="commentstatus"></div>
<div id="comment_55452111" class="cw">
</div>

<div id="replyto_55452111"></div>

<ul id="group_55452111">
	<li id="hiddens_55452111" class="hide"></li>
</ul>

</li><li id="tree_55452113" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452113" class="commentstatus"></div>
<div id="comment_55452113" class="cw">
	<div id="comment_top_55452113" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452113" name="comment_link_55452113" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452113" onclick="return D2.setFocusComment(55452113)" >Re:</a>


		 	<span id="comment_score_55452113" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452113); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dougTheRug">dougTheRug</a>  <span class="uid"><a href="//slashdot.org/~dougTheRug">( 649069 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452113"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452113">I think you have to honestly look at yourself and if you are not educating or failing these incompetents, you are a bad professor and a part of the problem. Insufficient education is, in my observation, the largest contributor to the problem.</div>
	</div>

	<div class="commentSub" id="comment_sub_55452113">

</div>
</div>

<div id="replyto_55452113"></div>

<ul id="group_55452113">
	<li id="hiddens_55452113" class="hide"></li>
</ul>

</li><li id="tree_55452201" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452201" class="commentstatus"></div>
<div id="comment_55452201" class="cw">
</div>

<div id="replyto_55452201"></div>

<ul id="group_55452201">
	<li id="hiddens_55452201" class="hide"></li>
</ul>

</li><li id="tree_55452223" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452223" class="commentstatus"></div>
<div id="comment_55452223" class="cw">
	<div id="comment_top_55452223" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452223" name="comment_link_55452223" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452223" onclick="return D2.setFocusComment(55452223)" >Re:</a>


		 	<span id="comment_score_55452223" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452223); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Kjella">Kjella</a>  <span class="uid"><a href="//slashdot.org/~Kjella">( 173770 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452223"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452223"><p><div class="quote"><p>The thing is: there is so much code to be written, that even these students - who evidently don't understand, don't care, and can't be bothered - even these students will find jobs, and some of them will be working on your web projects.</p></div><p>And some of them will be working for PHBs that don't understand, don't care and can't be bothered. Far too often the only metric people are measured by is whether the code does the right thing with the right input under normal execution. Error handling? Security? It's working, ship it. That's what you get measured on. That's what your boss gets measured on. If you say it "isn't any more complex" and they do it anyway it's clearly because they don't get corrected or rejected. Those errors conditions are for<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452223">

</div>
</div>

<div id="replyto_55452223"></div>

<ul id="group_55452223">
	<li id="hiddens_55452223" class="hide"></li>
</ul>

</li><li id="hidestring_55452017"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55452017">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55452023" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452023" class="commentstatus"></div>
<div id="comment_55452023" class="cw">
</div>

<div id="replyto_55452023"></div>

<ul id="group_55452023">
	<li id="hiddens_55452023" class="hide"></li>
</ul>

</li><li id="tree_55452029" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452029" class="commentstatus"></div>
<div id="comment_55452029" class="cw">
	<div id="comment_top_55452029" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452029" name="comment_link_55452029" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452029" onclick="return D2.setFocusComment(55452029)" >Because the market doesn't value security.</a>


		 	<span id="comment_score_55452029" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452029); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~aussersterne">aussersterne</a>  <span class="uid"><a href="//slashdot.org/~aussersterne">( 212916 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452029"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452029"><p>The pressure to release early and often is extreme. "MVP" rules the day, and no one in most senior roles has the granular perspective necessary to be aware of "security" as a concept. Is it checked into the testing repo and does it run? PUSH IT OUT. We'll fix any bugs as we "iterate."</p><p>Oh wait, we won't actually iterate. Because existing features don't get us as much as releases of new ones. We'll just keep pushing out new ones as fast as we can.</p><p>Security? Hell, often even basic functionality doesn't work. Rel<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452029">

</div>
</div>

<div id="replyto_55452029"></div>

<ul id="group_55452029">
	<li id="hiddens_55452029" class="hide"></li>
</ul>

</li><li id="tree_55452031" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452031" class="commentstatus"></div>
<div id="comment_55452031" class="cw">
	<div id="comment_top_55452031" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452031" name="comment_link_55452031" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452031" onclick="return D2.setFocusComment(55452031)" >Frameworks and CMS's</a>


		 	<span id="comment_score_55452031" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452031); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Aethedor">Aethedor</a>  <span class="uid"><a href="//slashdot.org/~Aethedor">( 973725 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452031"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452031"><p>I think that most frameworks and CMS's don't provide the right security that is needed to create a secure website. They offer protection against SQL injection, XSS and other common attacks, but don't provide a means for developers to make sure they used it correctly. Look at all the Wordpress plugins that keep on being vulnerable. How do you know a plugin is secure or not? In my opinion, there is a big difference between secure code and provable secure code. So, it's not only web developers making the same<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452031">

</div>
</div>

<div id="replyto_55452031"></div>

<ul id="group_55452031">
	<li id="hiddens_55452031" class="hide"></li>
</ul>

</li><li id="tree_55452037" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452037" class="commentstatus"></div>
<div id="comment_55452037" class="cw">
</div>

<div id="replyto_55452037"></div>

<ul id="group_55452037">
	<li id="hiddens_55452037" class="hide"></li>
</ul>

</li><li id="tree_55452041" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452041" class="commentstatus"></div>
<div id="comment_55452041" class="cw">
</div>

<div id="replyto_55452041"></div>

<ul id="group_55452041">
	<li id="hiddens_55452041" class="hide"></li>
</ul>

</li><li id="tree_55452045" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452045" class="commentstatus"></div>
<div id="comment_55452045" class="cw">
	<div id="comment_top_55452045" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452045" name="comment_link_55452045" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452045" onclick="return D2.setFocusComment(55452045)" >Budgets</a>


		 	<span id="comment_score_55452045" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452045); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Rob+Kaper">Rob Kaper</a>  <span class="uid"><a href="//slashdot.org/~Rob+Kaper">( 5960 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452045"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452045"><p>There is room in budgets to pay attention to <em>some</em> good practices or enforcement thereof by peer review. But often - especially with custom-made sites - it is simply not enough. I've seen plenty of projects where the design company was granted bigger fees for more hours than implementation, stereotypically also making everyone overly complicated. Even during scrum sessions where developer input is more present, doing it quickly is a much larger focus than doing it right. In the end, that simply leads to slop<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452045">

</div>
</div>

<div id="replyto_55452045"></div>

<ul id="group_55452045">
	<li id="hiddens_55452045" class="hide"></li>
</ul>

<ul id="commtree_55452045"><li id="tree_55452135" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452135" class="commentstatus"></div>
<div id="comment_55452135" class="cw">
	<div id="comment_top_55452135" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452135" name="comment_link_55452135" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452135" onclick="return D2.setFocusComment(55452135)" >Re:</a>


		 	<span id="comment_score_55452135" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452135); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gtall">gtall</a>  <span class="uid"><a href="//slashdot.org/~gtall">( 79522 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452135"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452135"><p>"scrum sessions" There's your problem right there. Agile does not encourage good overall design. It is a micromanagering dream and causes coders to only work for the next sprint goals. As long as their little piece of the pie works, they get rewarded. The entire dirty snowball that gets produced is merely a by-product.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452135">

</div>
</div>

<div id="replyto_55452135"></div>

<ul id="group_55452135">
	<li id="hiddens_55452135" class="hide"></li>
</ul>

<ul id="commtree_55452135"><li id="tree_55452203" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452203" class="commentstatus"></div>
<div id="comment_55452203" class="cw">
</div>

<div id="replyto_55452203"></div>

<ul id="group_55452203">
	<li id="hiddens_55452203" class="hide"></li>
</ul>

</li><li id="hidestring_55452135"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55452135">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55452049" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452049" class="commentstatus"></div>
<div id="comment_55452049" class="cw">
	<div id="comment_top_55452049" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452049" name="comment_link_55452049" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452049" onclick="return D2.setFocusComment(55452049)" >In a word: time.</a>


		 	<span id="comment_score_55452049" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452049); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452049"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452049"><p>You're sitting at the computer. The project deadline has just been published. Those fifty feature requests that you've been telling management will take a week each to implement properly? You have two months, total, for <i>all</i> of them. Management is screaming at you to get it done. You don't have time to do more than basic testing. It seems to work? Great! Move on to the next thing.</p><p>Meanwhile, figuring out all the ways in which the code will break - you haven't got time for that. Just pray that the security hol<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452049">

</div>
</div>

<div id="replyto_55452049"></div>

<ul id="group_55452049">
	<li id="hiddens_55452049" class="hide"></li>
</ul>

<ul id="commtree_55452049"><li id="tree_55452193" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452193" class="commentstatus"></div>
<div id="comment_55452193" class="cw">
</div>

<div id="replyto_55452193"></div>

<ul id="group_55452193">
	<li id="hiddens_55452193" class="hide"></li>
</ul>

</li><li id="hidestring_55452049"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55452049">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55452051" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452051" class="commentstatus"></div>
<div id="comment_55452051" class="cw">
	<div id="comment_top_55452051" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452051" name="comment_link_55452051" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452051" onclick="return D2.setFocusComment(55452051)" >Ob</a>


		 	<span id="comment_score_55452051" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452051); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Hognoxious">Hognoxious</a>  <span class="uid"><a href="//slashdot.org/~Hognoxious">( 631665 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452051"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452051"><p>27 people have already pointed out that web devs are fucktards, so I won't.  Remember that they took something designed for displaying static pages and shoehorned interaction &amp; dynamic shit onto it.  The whole thing is built on sand.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452051">

</div>
</div>

<div id="replyto_55452051"></div>

<ul id="group_55452051">
	<li id="hiddens_55452051" class="hide"></li>
</ul>

<ul id="commtree_55452051"><li id="tree_55452123" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452123" class="commentstatus"></div>
<div id="comment_55452123" class="cw">
	<div id="comment_top_55452123" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452123" name="comment_link_55452123" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452123" onclick="return D2.setFocusComment(55452123)" >Re:</a>


		 	<span id="comment_score_55452123" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452123); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dougTheRug">dougTheRug</a>  <span class="uid"><a href="//slashdot.org/~dougTheRug">( 649069 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452123"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452123">Why are C developers still writing buffer overflows?</div>
	</div>

	<div class="commentSub" id="comment_sub_55452123">

</div>
</div>

<div id="replyto_55452123"></div>

<ul id="group_55452123">
	<li id="hiddens_55452123" class="hide"></li>
</ul>

<ul id="commtree_55452123"><li id="tree_55452205" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452205" class="commentstatus"></div>
<div id="comment_55452205" class="cw">
</div>

<div id="replyto_55452205"></div>

<ul id="group_55452205">
	<li id="hiddens_55452205" class="hide"></li>
</ul>

<ul id="commtree_55452205"><li id="tree_55452241" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452241" class="commentstatus"></div>
<div id="comment_55452241" class="cw">
	<div id="comment_top_55452241" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452241" name="comment_link_55452241" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452241" onclick="return D2.setFocusComment(55452241)" >Re:</a>


		 	<span id="comment_score_55452241" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452241); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheRaven64">TheRaven64</a>  <span class="uid"><a href="//slashdot.org/~TheRaven64">( 641858 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452241"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452241">The performance difference between C and a modern safer language is well under a factor of two.  The performance difference between C and C++ using bounds-checked types and smart pointers everywhere is a few tens of percent.  Unless you're targeting a system with 32KB of RAM or less, or you have very strict realtime guarantees (and so aren't even using malloc) there's rarely a good reason to use C these days.</div>
	</div>

	<div class="commentSub" id="comment_sub_55452241">

</div>
</div>

<div id="replyto_55452241"></div>

<ul id="group_55452241">
	<li id="hiddens_55452241" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_55452123"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55452123">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55452057" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452057" class="commentstatus"></div>
<div id="comment_55452057" class="cw">
	<div id="comment_top_55452057" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452057" name="comment_link_55452057" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452057" onclick="return D2.setFocusComment(55452057)" >Email addresses!</a>


		 	<span id="comment_score_55452057" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452057); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Tomahawk">Tomahawk</a>  <span class="uid"><a href="//slashdot.org/~Tomahawk">( 1343 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452057"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452057"><p>Learn how to properly parse an email address!!!</p><p>It's upsetting how many web sites tell me a valid email address is invalid because the developers don't use a library that parses it correctly and don't bother looking up what is actually valid.  Apostrophes and pluses are the main characters they get wrong, among others.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452057">

</div>
</div>

<div id="replyto_55452057"></div>

<ul id="group_55452057">
	<li id="hiddens_55452057" class="hide"></li>
</ul>

<ul id="commtree_55452057"><li id="tree_55452067" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452067" class="commentstatus"></div>
<div id="comment_55452067" class="cw">
	<div id="comment_top_55452067" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452067" name="comment_link_55452067" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452067" onclick="return D2.setFocusComment(55452067)" >Re:</a>


		 	<span id="comment_score_55452067" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452067); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~KiloByte">KiloByte</a>  <span class="uid"><a href="//slashdot.org/~KiloByte">( 825081 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452067"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452067"><p>Actually, most libraries are wrong, too.  If you look at nodejs, it's astonishing how 90% of packages that ship a single line of code (plus tons of boilerplate) get even that single line wrong.</p><p>It doesn't take a genius to look up the relevant RFC and write a regexp.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452067">

</div>
</div>

<div id="replyto_55452067"></div>

<ul id="group_55452067">
	<li id="hiddens_55452067" class="hide"></li>
</ul>

<ul id="commtree_55452067"><li id="tree_55452077" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452077" class="commentstatus"></div>
<div id="comment_55452077" class="cw">
	<div id="comment_top_55452077" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452077" name="comment_link_55452077" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452077" onclick="return D2.setFocusComment(55452077)" >Re:</a>


		 	<span id="comment_score_55452077" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452077); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DamonHD">DamonHD</a>  <span class="uid"><a href="//slashdot.org/~DamonHD">( 794830 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452077"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452077"><p>Getting such a regex right is MUCH harder than it looks:</p><p><a href="https://stackoverflow.com/questions/201323/using-a-regular-expression-to-validate-an-email-address" title="stackoverflow.com">https://stackoverflow.com/ques...</a> [stackoverflow.com]</p><p>Rgds</p><p>Damon</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452077">

</div>
</div>

<div id="replyto_55452077"></div>

<ul id="group_55452077">
	<li id="hiddens_55452077" class="hide"></li>
</ul>

<ul id="commtree_55452077"><li id="tree_55452181" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452181" class="commentstatus"></div>
<div id="comment_55452181" class="cw">
	<div id="comment_top_55452181" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452181" name="comment_link_55452181" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452181" onclick="return D2.setFocusComment(55452181)" >Re:</a>


		 	<span id="comment_score_55452181" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452181); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~KiloByte">KiloByte</a>  <span class="uid"><a href="//slashdot.org/~KiloByte">( 825081 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452181"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452181"><p>Depends on whether you want to support pre-Internet addresses, as that's a good part of the spec.  If you drop stuff like routed addresses or comments/whitespace inside a domain, the rest is quite simple.  Your MTA likely won't accept "@node.test:mary@ (this is a comment) example (whitespace around<nobr> <wbr></nobr>.)<nobr> <wbr></nobr>.net" thus it should be dropped at validation time.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452181">

</div>
</div>

<div id="replyto_55452181"></div>

<ul id="group_55452181">
	<li id="hiddens_55452181" class="hide"></li>
</ul>

<ul id="commtree_55452181"><li id="tree_55452213" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452213" class="commentstatus"></div>
<div id="comment_55452213" class="cw">
	<div id="comment_top_55452213" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452213" name="comment_link_55452213" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452213" onclick="return D2.setFocusComment(55452213)" >Re:</a>


		 	<span id="comment_score_55452213" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452213); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DamonHD">DamonHD</a>  <span class="uid"><a href="//slashdot.org/~DamonHD">( 794830 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452213"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452213"><p>I hear you.  (I used to run a significant UUCP mail node, BTW!)</p><p>But then we have to agree on a definition of 'right' for the application, which is nuanced.</p><p>I still have a perfectly valid address rejected sometimes because it's 'too short'!  (It's of the form X@YY.ZZZ)</p><p>Rgds</p><p>Damon</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452213">

</div>
</div>

<div id="replyto_55452213"></div>

<ul id="group_55452213">
	<li id="hiddens_55452213" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55452199" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452199" class="commentstatus"></div>
<div id="comment_55452199" class="cw">
</div>

<div id="replyto_55452199"></div>

<ul id="group_55452199">
	<li id="hiddens_55452199" class="hide"></li>
</ul>

</li><li id="hidestring_55452077"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55452077">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55452217" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452217" class="commentstatus"></div>
<div id="comment_55452217" class="cw">
</div>

<div id="replyto_55452217"></div>

<ul id="group_55452217">
	<li id="hiddens_55452217" class="hide"></li>
</ul>

<ul id="commtree_55452217"><li id="tree_55452245" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452245" class="commentstatus"></div>
<div id="comment_55452245" class="cw">
	<div id="comment_top_55452245" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452245" name="comment_link_55452245" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452245" onclick="return D2.setFocusComment(55452245)" >Re:</a>


		 	<span id="comment_score_55452245" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452245); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheRaven64">TheRaven64</a>  <span class="uid"><a href="//slashdot.org/~TheRaven64">( 641858 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452245"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452245">It's perhaps worth noting that a number of 'regex' libraries aren't actually regular expressions, they are often provide some state that makes them equivalent to push-down automata, and therefore are able to parse all context-free languages.  That doesn't necessarily make them the right tool for the job, of course.</div>
	</div>

	<div class="commentSub" id="comment_sub_55452245">

</div>
</div>

<div id="replyto_55452245"></div>

<ul id="group_55452245">
	<li id="hiddens_55452245" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_55452067"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55452067">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55452081" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452081" class="commentstatus"></div>
<div id="comment_55452081" class="cw">
</div>

<div id="replyto_55452081"></div>

<ul id="group_55452081">
	<li id="hiddens_55452081" class="hide"></li>
</ul>

<ul id="commtree_55452081"><li id="tree_55452277" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452277" class="commentstatus"></div>
<div id="comment_55452277" class="cw">
	<div id="comment_top_55452277" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452277" name="comment_link_55452277" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452277" onclick="return D2.setFocusComment(55452277)" >Re:</a>


		 	<span id="comment_score_55452277" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452277); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CustomSolvers2">CustomSolvers2</a>  <span class="uid"><a href="//slashdot.org/~CustomSolvers2">( 4118921 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452277"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452277"><p><div class="quote"><p>Absolutely not caused by newbies.</p></div><p>It seems quite sensible to assume that more experienced developers are way more likely to deliver better code than less experienced ones, so your general statement is certainly wrong. If you want to make generalisations (I don't like that too much though), note that most of the problems in programming and virtually everywhere else are likely to be caused by ignorance, short-sightedness and lack of experience. In programming, all these "features" are very common among newbies, non-technical staff making deci<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452277">

</div>
</div>

<div id="replyto_55452277"></div>

<ul id="group_55452277">
	<li id="hiddens_55452277" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55452091" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452091" class="commentstatus"></div>
<div id="comment_55452091" class="cw">
	<div id="comment_top_55452091" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452091" name="comment_link_55452091" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452091" onclick="return D2.setFocusComment(55452091)" >Economics and education standards</a>


		 	<span id="comment_score_55452091" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452091); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dougTheRug">dougTheRug</a>  <span class="uid"><a href="//slashdot.org/~dougTheRug">( 649069 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452091"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452091">I have been working in software security for twelve years, telling developers not to write SQL Injections, or designing processes to detect and fix them. I think there are some chief problems: <p>Any business goes through an initial development phase of creating a <b>minimum viable product</b>. During this time, the company needs to decide if it is going to survive or not, and it must make this decision absolutely as soon as possible. </p><p>The SOONER the business idea can FAIL, the faster the resources can be put into the<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452091">

</div>
</div>

<div id="replyto_55452091"></div>

<ul id="group_55452091">
	<li id="hiddens_55452091" class="hide"></li>
</ul>

<ul id="commtree_55452091"><li id="tree_55452151" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452151" class="commentstatus"></div>
<div id="comment_55452151" class="cw">
	<div id="comment_top_55452151" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452151" name="comment_link_55452151" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452151" onclick="return D2.setFocusComment(55452151)" >Re:</a>


		 	<span id="comment_score_55452151" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452151); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~swilver">swilver</a>  <span class="uid"><a href="//slashdot.org/~swilver">( 617741 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452151"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452151"><p>The real mistake is that people think you can teach people how to write proper software with a couple of hundred contact hours as a small part of a 4 year university program.  Many of these people didn't have enough prior interest in building software to even have tried writing some software before attending these classes.</p><p>It is about as delusional as thinking that you can become a star athlete having done nothing but sitting on a couch for years eating chips and then doing 4 years of aerobics and spinning c<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452151">

</div>
</div>

<div id="replyto_55452151"></div>

<ul id="group_55452151">
	<li id="hiddens_55452151" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55452103" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452103" class="commentstatus"></div>
<div id="comment_55452103" class="cw">
</div>

<div id="replyto_55452103"></div>

<ul id="group_55452103">
	<li id="hiddens_55452103" class="hide"></li>
</ul>

</li><li id="tree_55452105" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452105" class="commentstatus"></div>
<div id="comment_55452105" class="cw">
	<div id="comment_top_55452105" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452105" name="comment_link_55452105" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452105" onclick="return D2.setFocusComment(55452105)" >Why?</a>


		 	<span id="comment_score_55452105" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452105); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nicolaiplum">nicolaiplum</a>  <span class="uid"><a href="//slashdot.org/~nicolaiplum">( 169077 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452105"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452105"><p>"Why Do Web Developers Keep Making The Same Mistakes?"</p><p>StackOverflow.com</p><p>(they read the same wrong answers as other people, because every "I found this useful" or "Lots of people read this" ranking system does not detect factual errors, only opinions)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452105">

</div>
</div>

<div id="replyto_55452105"></div>

<ul id="group_55452105">
	<li id="hiddens_55452105" class="hide"></li>
</ul>

</li><li id="tree_55452137" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452137" class="commentstatus"></div>
<div id="comment_55452137" class="cw">
	<div id="comment_top_55452137" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452137" name="comment_link_55452137" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452137" onclick="return D2.setFocusComment(55452137)" >Why does anyone do half-assed work?</a>


		 	<span id="comment_score_55452137" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452137); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jcr">jcr</a>  <span class="uid"><a href="//slashdot.org/~jcr">( 53032 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452137"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452137"><p>It's because they themselves don't suffer the economic loss of fucking it up.</p><p>-jcr</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452137">

</div>
</div>

<div id="replyto_55452137"></div>

<ul id="group_55452137">
	<li id="hiddens_55452137" class="hide"></li>
</ul>

<ul id="commtree_55452137"><li id="tree_55452249" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452249" class="commentstatus"></div>
<div id="comment_55452249" class="cw">
	<div id="comment_top_55452249" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452249" name="comment_link_55452249" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452249" onclick="return D2.setFocusComment(55452249)" >Re:</a>


		 	<span id="comment_score_55452249" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452249); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TheRaven64">TheRaven64</a>  <span class="uid"><a href="//slashdot.org/~TheRaven64">( 641858 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452249"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452249">This deserves to be moderated up, perhaps with the corollary that often they <i>will</i> suffer economic loss as a result of taking the time to do it right.</div>
	</div>

	<div class="commentSub" id="comment_sub_55452249">

</div>
</div>

<div id="replyto_55452249"></div>

<ul id="group_55452249">
	<li id="hiddens_55452249" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55452141" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452141" class="commentstatus"></div>
<div id="comment_55452141" class="cw">
	<div id="comment_top_55452141" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452141" name="comment_link_55452141" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452141" onclick="return D2.setFocusComment(55452141)" >Software is difficult</a>


		 	<span id="comment_score_55452141" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452141); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Njovich">Njovich</a>  <span class="uid"><a href="//slashdot.org/~Njovich">( 553857 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452141"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452141"><p>Even the simplests of software consists of thousands of lines of code where a simple mistake can compromise the system.  People make mistakes. Online documentation gives flawed examples. It will take an infinite amount of time to write software to perfection. The poor guy in India working 80 hours per week coding the system has no way to know every system he is writing code for. Nobody has ever told the entry level developer that the secure_rng() or mysql_escape_string() library function is in fact not secu<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452141">

</div>
</div>

<div id="replyto_55452141"></div>

<ul id="group_55452141">
	<li id="hiddens_55452141" class="hide"></li>
</ul>

</li><li id="tree_55452155" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452155" class="commentstatus"></div>
<div id="comment_55452155" class="cw">
	<div id="comment_top_55452155" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452155" name="comment_link_55452155" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452155" onclick="return D2.setFocusComment(55452155)" >Every year</a>


		 	<span id="comment_score_55452155" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452155); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thsths">thsths</a>  <span class="uid"><a href="//slashdot.org/~thsths">( 31372 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452155"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452155"><p>my students make the same mistakes. It is as if they learn nothing...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452155">

</div>
</div>

<div id="replyto_55452155"></div>

<ul id="group_55452155">
	<li id="hiddens_55452155" class="hide"></li>
</ul>

</li><li id="tree_55452159" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452159" class="commentstatus"></div>
<div id="comment_55452159" class="cw">
	<div id="comment_top_55452159" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452159" name="comment_link_55452159" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452159" onclick="return D2.setFocusComment(55452159)" >quick and dirty</a>


		 	<span id="comment_score_55452159" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452159); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Begemot">Begemot</a>  <span class="uid"><a href="//slashdot.org/~Begemot">( 38841 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452159"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452159"><p>can it be that often times "Beware SQL injection!<nobr> <wbr></nobr>..." is followed by "and I need it yesterday"?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452159">

</div>
</div>

<div id="replyto_55452159"></div>

<ul id="group_55452159">
	<li id="hiddens_55452159" class="hide"></li>
</ul>

<ul id="commtree_55452159"><li id="tree_55452163" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452163" class="commentstatus"></div>
<div id="comment_55452163" class="cw">
</div>

<div id="replyto_55452163"></div>

<ul id="group_55452163">
	<li id="hiddens_55452163" class="hide"></li>
</ul>

</li><li id="hidestring_55452159"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55452159">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55452169" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452169" class="commentstatus"></div>
<div id="comment_55452169" class="cw">
</div>

<div id="replyto_55452169"></div>

<ul id="group_55452169">
	<li id="hiddens_55452169" class="hide"></li>
</ul>

</li><li id="tree_55452173" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452173" class="commentstatus"></div>
<div id="comment_55452173" class="cw">
</div>

<div id="replyto_55452173"></div>

<ul id="group_55452173">
	<li id="hiddens_55452173" class="hide"></li>
</ul>

</li><li id="tree_55452189" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452189" class="commentstatus"></div>
<div id="comment_55452189" class="cw">
</div>

<div id="replyto_55452189"></div>

<ul id="group_55452189">
	<li id="hiddens_55452189" class="hide"></li>
</ul>

</li><li id="tree_55452207" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452207" class="commentstatus"></div>
<div id="comment_55452207" class="cw">
</div>

<div id="replyto_55452207"></div>

<ul id="group_55452207">
	<li id="hiddens_55452207" class="hide"></li>
</ul>

</li><li id="tree_55452211" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452211" class="commentstatus"></div>
<div id="comment_55452211" class="cw">
</div>

<div id="replyto_55452211"></div>

<ul id="group_55452211">
	<li id="hiddens_55452211" class="hide"></li>
</ul>

</li><li id="tree_55452313" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55452313" class="commentstatus"></div>
<div id="comment_55452313" class="cw">
	<div id="comment_top_55452313" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55452313" name="comment_link_55452313" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;cid=55452313" onclick="return D2.setFocusComment(55452313)" >Simple.  Shiny</a>


		 	<span id="comment_score_55452313" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55452313); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~quonset">quonset</a>  <span class="uid"><a href="//slashdot.org/~quonset">( 4839537 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55452313"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55452313"><p>Web developers are more interested in showing off the latest and greatest procedures, bouncing ads and every unnecessary script they can lay their hands on than they are producing a usable web page.</p><p>Within the last week I am suddenly unable to access the comments section on a web page I have gone to for years.  Most likely because the developers changed twenty scripts and since I never run the latest and greatest browser, comments are now inaccessible.</p><p>There is absolutely no reason not to have a link work in<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55452313">

</div>
</div>

<div id="replyto_55452313"></div>

<ul id="group_55452313">
	<li id="hiddens_55452313" class="hide"></li>
</ul>

</li><li id="tree_55452353" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55452353" class="commentstatus"></div>
<div id="comment_55452353" class="cw">
</div>

<div id="replyto_55452353"></div>

<ul id="group_55452353">
	<li id="hiddens_55452353" class="hide"></li>
</ul>

</li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11287681&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">11 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//developers.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 28;
		D2.currents()['full']     = 5;
		D2.currents()['oneline']  = 51;
		// D2.currents_total(84);

		D2.abbrev_comments({55452313:528,55452031:514,55452167:522,55452225:522,55452141:515,55452185:583,55452117:522,55452233:521,55452073:540,55452277:583,55452151:522,55452029:529,55452091:529,55452065:522,55452107:522,55452223:785,55452045:524,55452121:522,55452049:529,55452035:629});
		D2.noshow_comments([55452175,55452007,55452055,55452059,55452161,55452183,55452021,55452101,55452347,55452111,55452201,55452023,55452037,55452041,55452203,55452193,55452205,55452199,55452217,55452081,55452103,55452163,55452169,55452173,55452189,55452207,55452211,55452353]);
		D2.pieces_comments([55451999,55452035,55452053,55452117,55452297,55452099,55452185,55452225,55451995,55452129,55452009,55452013,55452039,55452107,55452043,55452047,55452075,55452085,55452121,55452065,55452127,55452167,55452191,55452233,55452073,55452113,55452223,55452029,55452031,55452045,55452135,55452049,55452051,55452123,55452241,55452057,55452067,55452077,55452181,55452213,55452245,55452277,55452091,55452151,55452105,55452137,55452249,55452141,55452155,55452159,55452313]);
		D2.init_hiddens([55451999,55451977,55451979,55452001,55452043,55452121,55452017,55452135,55452049,55452123,55452077,55452067,55452159,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(332989);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1001<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/03/01/1643251/programmers-are-confessing-their-coding-sins-to-protest-a-broken-job-interview-process?sdsrc=popbyskidbtmprev">Programmers Are Confessing Their Coding Sins To Protest a Broken Job Interview Process</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>656<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/03/27/2115233/prominent-drupal-php-developer-kicked-from-the-drupal-project-over-unconventional-sex-life?sdsrc=popbyskidbtmprev">Prominent Drupal, PHP Developer Kicked From the Drupal Project Over Unconventional Sex Life</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>600<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/02/04/1751211/developer-argues-for-forgotten-code-constructs-like-goto-and-eval?sdsrc=popbyskidbtmprev">Developer Argues For 'Forgotten Code Constructs' Like GOTO and Eval</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>515<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/06/15/1431253/developers-who-use-spaces-make-more-money-than-those-who-use-tabs?sdsrc=popbyskidbtmprev">Developers Who Use Spaces Make More Money Than Those Who Use Tabs</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>505<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/07/16/1715256/techcrunch-urges-developers-replace-c-code-with-rust?sdsrc=popbyskidbtmprev">TechCrunch Urges Developers: Replace C Code With Rust</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//apple.slashdot.org/story/17/10/29/0548207/apple-fires-engineer-after-his-daughters-iphone-x-video-goes-viral?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/business_64.png" width="64" height="64" alt="Businesses"></span>
	    
					<p class="grid_12"><a href="//apple.slashdot.org/story/17/10/29/0548207/apple-fires-engineer-after-his-daughters-iphone-x-video-goes-viral?sdsrc=nextbtmprev">Apple Fires Engineer After His Daughter's iPhone X Video Goes Viral</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>31<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//apple.slashdot.org/story/17/10/28/1938224/captain-crunch-and-steve-wozniak-write-new-book-beyond-the-little-blue-box?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/books_64.png" width="64" height="64" alt="Books"></span>
	    
					<p class="grid_12"><a href="//apple.slashdot.org/story/17/10/28/1938224/captain-crunch-and-steve-wozniak-write-new-book-beyond-the-little-blue-box?sdsrc=prevbtmprev">Captain Crunch (and Steve Wozniak) Write New Book: 'Beyond the Little Blue Box'</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>27<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=11287681&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">84</span> of <span class="totalcommentcnt">84</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>Your program is sick!  Shoot it and put it out of its memory.</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2017 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?882">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?97">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->