<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	

<script>
(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '66');
</script>

	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '6374968423872724',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>C Programming Language 'Has Completed a Comeback' - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	  
		<meta name="description" content="InfoWorld reports that &#34;the once-declining C language&#34; has &#34;completed a comeback&#34; -- citing its rise to second place in the Tiobe Index of language popularity, the biggest rise of any language in 2017. An anonymous reader quotes their report:
Although the language only grew 1.69 percentage points in...">
	    
		<meta name="twitter:card" content="summary">
		<meta name="twitter:site" content="@slashdot">
		<meta name="twitter:domain" content="developers.slashdot.org">
		<meta property="og:url" content="https://developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+Slashdot%2FslashdotDevelopers+%28Slashdot%3A+Developers%29">
	    
		<meta property="og:title" content="C Programming Language 'Has Completed a Comeback' - Slashdot">
		<meta property="og:description" content="InfoWorld reports that &#34;the once-declining C language&#34; has &#34;completed a comeback&#34; -- citing its rise to second place in the Tiobe Index of language popularity, the biggest rise of any language in 2017. An anonymous reader quotes their report:
Although the language only grew 1.69 percentage points in...">
	  
	
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/programming_64.png">
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<link rel="canonical" href="https://developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/335799" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?38debda35a274e8c" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?38debda35a274e8c" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?38debda35a274e8c" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?38debda35a274e8c">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?38debda35a274e8c"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?38debda35a274e8c" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//developers.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotDevelopers" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //developers.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Become a fan of Slashdot on <a href="http://www.facebook.com/pages/Slashdotorg/267995220856">Facebook</a>
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 <a href="https://slashdot.org/newsletter">Sign up for the Slashdot Daily Newsletter!</a> <strong>DEAL:</strong> For $25 - <a href="http://hshd.io/nuLx" rel="nofollow" target="_blank">Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-96476437" data-fhid="96476437" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">96476437</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-96476437">
			<a href="//developers.slashdot.org/index2.pl?fhfilter=programming" onclick="return addfhfilter('programming');">
			
				<img src="//a.fsdn.com/sd/topics/programming_64.png" width="64" height="64" alt="Programming" title="Programming">
			
		</a>
		
	
		
		
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=java" onclick="return addfhfilter('java');">
			
				<img src="//a.fsdn.com/sd/topics/java_64.png" width="64" height="64" alt="Java" title="Java">
			
		</a>
		
	
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=stats" onclick="return addfhfilter('stats');">
			
				<img src="//a.fsdn.com/sd/topics/stats_64.png" width="64" height="64" alt="Stats" title="Stats">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-96476437" class="story-title"> <a   href="//developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback">C Programming Language 'Has Completed a Comeback'</a> <span class=" no extlnk"><a class="story-sourcelnk" href="https://www.infoworld.com/article/3245786/application-development/c-language-completes-comeback-in-programming-popularity.html"  title="External link - https://www.infoworld.com/article/3245786/application-development/c-language-completes-comeback-in-programming-popularity.html" target="_blank"> (infoworld.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-96476437" >84</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback#comments" title="">84</a></span>
		
	</h2>
	<div class="details" id="details-96476437">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  EditorDavid
			
		
		

		
		
		<time id="fhtime-96476437" datetime="on Sunday January 07, 2018 @06:34PM">on Sunday January 07, 2018 @06:34PM</time>
		
		
			 from the <span class="dept-text">C-you-later</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-96476437">
	
		
	

	
		
		<div id="text-96476437" class="p">
			
		 	
				InfoWorld reports that "the once-declining C language" has "completed a comeback" -- citing its rise to second place in the Tiobe Index of language popularity, the biggest rise of any language in 2017. An anonymous reader quotes their report:
<i>Although the language only grew 1.69 percentage points in its rating year over year in the January index, that was enough beat out runners-up Python (1.21 percent gain) and Erlang (0.98 percent gain). <a href="https://www.infoworld.com/article/3245786/application-development/c-language-completes-comeback-in-programming-popularity.html">Just five months ago, C was at its lowest-ever rating, at 6.477 percent</a>; this month, its rating is 11.07 percent, once again putting it in second place behind Java (14.215 percent) -- although Java dropped 3.05 percent compared to January 2017. C's revival is possibly being fueled by its popularity in manufacturing and industry, including the automotive market, Tiobe believes...<br> <br>
But promising languages such as Julia, Hack, Rust, and Kotlin were not able to reach the top 20 or even the top 30, Tiobe pointed out. "Becoming part of the top 10 or even the top 20 requires a large ecosystem of communities and evangelists including conferences," said Paul Jansen, Tiobe managing director and compiler of <a href="https://www.tiobe.com/tiobe-index/">the index</a>. "This is not something that can be developed in one year's time."</i> <br>
For 2017 Tiobe also reports that after Java and C, the most popular programming languages were C++, Python, C#, JavaScript, Visual Basic .Net, R, PHP, and Perl.
<br> <br>
The rival <a href="http://pypl.github.io/PYPL.html">Pypl Popularity of Programming Language index</a> calculates that the most popular languages are Java, Python, PHP, JavaScript, C#, C++, C, R, Objective-C, and Swift.<br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-96476437" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback"
								  data-janrain-title="C Programming Language 'Has Completed a Comeback'"
								  data-janrain-message="C Programming Language 'Has Completed a Comeback' @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-96476437" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/java" target="_blank">java</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/programming" target="_blank">programming</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/stats" target="_blank">stats</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//linux.slashdot.org/story/18/01/07/228222/can-you-install-linux-on-a-1993-pc?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//apple.slashdot.org/story/18/01/07/2354218/some-smartphone-salesmen-arent-sold-on-the-iphone-x?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//linux.slashdot.org/story/18/01/07/228222/can-you-install-linux-on-a-1993-pc?sdsrc=prev">Can You Install Linux On a 1993 PC? </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//developers.slashdot.org/story/16/07/09/2112255/tiobes-language-popularity-index-sees-a-new-top-10-language-assembly?sdsrc=rel">TIOBE's Language-Popularity Index Sees A New Top 10 Language: Assembly</a></h3><h3><a href="//developers.slashdot.org/story/16/07/27/1943217/c-top-programming-language-for-2016-finds-ieees-study?sdsrc=rel">C Top Programming Language For 2016, Finds IEEE's Study</a></h3><h3><a href="//apple.slashdot.org/story/16/08/29/2235250/c-programming-language-hits-a-15-year-low-on-the-tiobe-index?sdsrc=rel">C Programming Language Hits a 15-Year Low On The TIOBE Index</a></h3><h3><a href="//developers.slashdot.org/story/17/03/18/2038239/redmonk-identifies-2017s-most-popular-languages-javascript-java-and-python?sdsrc=rel">RedMonk Identifies 2017's Most Popular Languages: JavaScript, Java, And Python</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//apple.slashdot.org/story/18/01/07/2354218/some-smartphone-salesmen-arent-sold-on-the-iphone-x?sdsrc=next">Some Smartphone Salesmen Aren't Sold on the iPhone X</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback" title="Back to Article - C Programming Language 'Has Completed a Comeback'">C Programming Language 'Has Completed a Comeback'</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - C Programming Language 'Has Completed a Comeback'" href="//developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback">C Programming Language 'Has Completed a Comeback'</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=11578625" class="btn">Search <span class="totalcommentcnt">84</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//developers.slashdot.org/comments.pl?sid=11578625">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=11578625" class="ui-icon search_comments">Search <span class="totalcommentcnt">84</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//developers.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/01/07/1941209/c-programming-language-has-completed-a-comeback/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?38debda35a274e8c" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_55882157" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882157" class="commentstatus"></div>
<div id="comment_55882157" class="cw">
</div>

<div id="replyto_55882157"></div>

<ul id="group_55882157">
	<li id="hiddens_55882157" class="hide"></li>
</ul>

<ul id="commtree_55882157"><li id="tree_55882197" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882197" class="commentstatus"></div>
<div id="comment_55882197" class="cw">
</div>

<div id="replyto_55882197"></div>

<ul id="group_55882197">
	<li id="hiddens_55882197" class="hide"></li>
</ul>

<ul id="commtree_55882197"><li id="tree_55882275" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882275" class="commentstatus"></div>
<div id="comment_55882275" class="cw">
</div>

<div id="replyto_55882275"></div>

<ul id="group_55882275">
	<li id="hiddens_55882275" class="hide"></li>
</ul>

</li><li id="hidestring_55882197"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882197">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882239" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882239" class="commentstatus"></div>
<div id="comment_55882239" class="cw">
</div>

<div id="replyto_55882239"></div>

<ul id="group_55882239">
	<li id="hiddens_55882239" class="hide"></li>
</ul>

</li><li id="tree_55882633" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882633" class="commentstatus"></div>
<div id="comment_55882633" class="cw">
</div>

<div id="replyto_55882633"></div>

<ul id="group_55882633">
	<li id="hiddens_55882633" class="hide"></li>
</ul>

</li><li id="hidestring_55882157"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882157">3 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882171" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882171" class="commentstatus"></div>
<div id="comment_55882171" class="cw">
</div>

<div id="replyto_55882171"></div>

<ul id="group_55882171">
	<li id="hiddens_55882171" class="hide"></li>
</ul>

</li><li id="tree_55882177" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55882177" class="commentstatus"></div>
<div id="comment_55882177" class="cw">
	<div id="comment_top_55882177" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882177" name="comment_link_55882177" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882177" onclick="return D2.setFocusComment(55882177)" >Don't call it a comeback, it's been here for years</a>


		 	<span id="comment_score_55882177" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882177); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JoeyRox">JoeyRox</a>  <span class="uid"><a href="//slashdot.org/~JoeyRox">( 2711699 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882177">		
		on Sunday January 07, 2018 @06:41PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882177">#55882177</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882177">C never went anywhere. Its mindshare was just continually eclipsed by whatever bullshit venture-captial-seeking-paradigm-of-the-month was en vogue for that month.</div>
	</div>

	<div class="commentSub" id="comment_sub_55882177">
<span class="ind"></span><a id="reply_link_55882177" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882177" onclick="D2.replyTo(55882177); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Don't call it a comeback, it's been here for years by JoeyRox @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882177" data-title="Don't call it a comeback, it's been here for years">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Don't call it a comeback, it's been here for years by JoeyRox" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882177" data-title="Don't call it a comeback, it's been here for years">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Don't call it a comeback, it's been here for years by JoeyRox" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882177" data-title="Don't call it a comeback, it's been here for years">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11578625%26cid=55882177" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55882177" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882177" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55882177"></div>

<ul id="group_55882177">
	<li id="hiddens_55882177" class="hide"></li>
</ul>

<ul id="commtree_55882177"><li id="tree_55882193" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55882193" class="commentstatus"></div>
<div id="comment_55882193" class="cw">
	<div id="comment_top_55882193" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882193" name="comment_link_55882193" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882193" onclick="return D2.setFocusComment(55882193)" >Re:Don't call it a comeback, it's been here for ye</a>


		 	<span id="comment_score_55882193" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882193); return false"><span class=opt>Score:</span>5</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~RightwingNutjob">RightwingNutjob</a>  <span class="uid"><a href="//slashdot.org/~RightwingNutjob">( 1302813 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882193">		
		on Sunday January 07, 2018 @06:44PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882193">#55882193</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882193">What changed? Did someone let slip that bitcoin mining can be done in C faster than with remote calls to jquery?</div>
	</div>

	<div class="commentSub" id="comment_sub_55882193">
<span class="ind"></span><a id="reply_link_55882193" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882193" onclick="D2.replyTo(55882193); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=55882177" onclick="return D2.selectParent(55882177)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Don't call it a comeback, it's been here for ye by RightwingNutjob @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882193" data-title="Re:Don't call it a comeback, it's been here for ye">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Don't call it a comeback, it's been here for ye by RightwingNutjob" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882193" data-title="Re:Don't call it a comeback, it's been here for ye">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Don't call it a comeback, it's been here for ye by RightwingNutjob" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882193" data-title="Re:Don't call it a comeback, it's been here for ye">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11578625%26cid=55882193" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55882193" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882193" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55882193"></div>

<ul id="group_55882193">
	<li id="hiddens_55882193" class="hide"></li>
</ul>

<ul id="commtree_55882193"><li id="tree_55882781" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882781" class="commentstatus"></div>
<div id="comment_55882781" class="cw">
	<div id="comment_top_55882781" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882781" name="comment_link_55882781" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882781" onclick="return D2.setFocusComment(55882781)" >Re:</a>


		 	<span id="comment_score_55882781" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882781); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Tough+Love">Tough Love</a>  <span class="uid"><a href="//slashdot.org/~Tough+Love">( 215404 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882781"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882781"><p>Back to school.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882781">

</div>
</div>

<div id="replyto_55882781"></div>

<ul id="group_55882781">
	<li id="hiddens_55882781" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55882247" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882247" class="commentstatus"></div>
<div id="comment_55882247" class="cw">
	<div id="comment_top_55882247" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882247" name="comment_link_55882247" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882247" onclick="return D2.setFocusComment(55882247)" >C programs are too dangerous for net-connected</a>


		 	<span id="comment_score_55882247" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882247); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~presidenteloco">presidenteloco</a>  <span class="uid"><a href="//slashdot.org/~presidenteloco">( 659168 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882247"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882247"><p>computers.</p><p>No bounds checking, no type checking. In 2018. Get serious.</p><p>My guess is C programs are the underlying reason for a good majority of ways of hacking into systems.</p><p>I mean a buffer exploit? Seriously? In 2018? Why in the hell would that be remotely acceptable?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882247">

</div>
</div>

<div id="replyto_55882247"></div>

<ul id="group_55882247">
	<li id="hiddens_55882247" class="hide"></li>
</ul>

<ul id="commtree_55882247"><li id="tree_55882281" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882281" class="commentstatus"></div>
<div id="comment_55882281" class="cw">
	<div id="comment_top_55882281" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882281" name="comment_link_55882281" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882281" onclick="return D2.setFocusComment(55882281)" >Re:</a>


		 	<span id="comment_score_55882281" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882281); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~iggymanz">iggymanz</a>  <span class="uid"><a href="//slashdot.org/~iggymanz">( 596061 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882281"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882281"><p>Nah, I'm guessing browser tech such as javascript and flash, mobile apps with embedded malware, and on the server side PHP the cause for entry.</p><p>And now we're seeing our hardware itself is deeply flawed...from mobile chips to desktop to server to mainframe.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882281">

</div>
</div>

<div id="replyto_55882281"></div>

<ul id="group_55882281">
	<li id="hiddens_55882281" class="hide"></li>
</ul>

</li><li id="tree_55882289" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55882289" class="commentstatus"></div>
<div id="comment_55882289" class="cw">
	<div id="comment_top_55882289" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882289" name="comment_link_55882289" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882289" onclick="return D2.setFocusComment(55882289)" >Re:C programs are too dangerous for net-connected</a>


		 	<span id="comment_score_55882289" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882289); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Travelsonic">Travelsonic</a>  <span class="uid"><a href="//slashdot.org/~Travelsonic">( 870859 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882289">		
		on Sunday January 07, 2018 @07:06PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882289">#55882289</a>)
		<small><a href="//slashdot.org/~Travelsonic/journal/" title="Sunday April 17, 2005 @03:10PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882289">At some point, don't know where that is myself, one needs to look at programming practices as well, and not just the languages being used.</div>
	</div>

	<div class="commentSub" id="comment_sub_55882289">
<span class="ind"></span><a id="reply_link_55882289" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882289" onclick="D2.replyTo(55882289); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=55882247" onclick="return D2.selectParent(55882247)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:C programs are too dangerous for net-connected by Travelsonic @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882289" data-title="Re:C programs are too dangerous for net-connected">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:C programs are too dangerous for net-connected by Travelsonic" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882289" data-title="Re:C programs are too dangerous for net-connected">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:C programs are too dangerous for net-connected by Travelsonic" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882289" data-title="Re:C programs are too dangerous for net-connected">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11578625%26cid=55882289" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55882289" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882289" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55882289"></div>

<ul id="group_55882289">
	<li id="hiddens_55882289" class="hide"></li>
</ul>

<ul id="commtree_55882289"><li id="tree_55882581" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882581" class="commentstatus"></div>
<div id="comment_55882581" class="cw">
	<div id="comment_top_55882581" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882581" name="comment_link_55882581" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882581" onclick="return D2.setFocusComment(55882581)" >Re:programming practices</a>


		 	<span id="comment_score_55882581" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882581); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~presidenteloco">presidenteloco</a>  <span class="uid"><a href="//slashdot.org/~presidenteloco">( 659168 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882581"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882581"><p>Programming practices. Yeah ok.<br>But people are people, programmers are programmers, and there are bell curves of skill, care and attention, schedule reasonableness under which programs are created.</p><p>So let's not assume every programmer writing a potentially security-relevant piece of code is a really good, well educated in best practices, really safe designer and coder with enough time for testing and iteration. Assuming that would be naive.</p><p>So why not protect against common errors using the programming languag<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882581">

</div>
</div>

<div id="replyto_55882581"></div>

<ul id="group_55882581">
	<li id="hiddens_55882581" class="hide"></li>
</ul>

<ul id="commtree_55882581"><li id="tree_55882641" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882641" class="commentstatus"></div>
<div id="comment_55882641" class="cw">
</div>

<div id="replyto_55882641"></div>

<ul id="group_55882641">
	<li id="hiddens_55882641" class="hide"></li>
</ul>

<ul id="commtree_55882641"><li id="tree_55882789" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882789" class="commentstatus"></div>
<div id="comment_55882789" class="cw">
	<div id="comment_top_55882789" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882789" name="comment_link_55882789" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882789" onclick="return D2.setFocusComment(55882789)" >Re:</a>


		 	<span id="comment_score_55882789" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882789); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Pinky's+Brain">Pinky's Brain</a>  <span class="uid"><a href="//slashdot.org/~Pinky's+Brain">( 1158667 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882789"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882789"><p>So that's where all those C programmers who can avoid buffer overflows went, they ascended.</p><p>Shame we are stuck with the rest.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882789">

</div>
</div>

<div id="replyto_55882789"></div>

<ul id="group_55882789">
	<li id="hiddens_55882789" class="hide"></li>
</ul>

<ul id="commtree_55882789"><li id="tree_55882957" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882957" class="commentstatus"></div>
<div id="comment_55882957" class="cw">
</div>

<div id="replyto_55882957"></div>

<ul id="group_55882957">
	<li id="hiddens_55882957" class="hide"></li>
</ul>

</li><li id="hidestring_55882789"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882789">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55883207" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55883207" class="commentstatus"></div>
<div id="comment_55883207" class="cw">
	<div id="comment_top_55883207" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55883207" name="comment_link_55883207" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55883207" onclick="return D2.setFocusComment(55883207)" >Re:</a>


		 	<span id="comment_score_55883207" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55883207); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~WaffleMonster">WaffleMonster</a>  <span class="uid"><a href="//slashdot.org/~WaffleMonster">( 969671 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55883207"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55883207"><p><div class="quote"><p>But people are people, programmers are programmers, and there are bell curves of skill, care and attention, schedule reasonableness under which programs are created.</p><p>So let's not assume every programmer writing a potentially security-relevant piece of code is a really good, well educated in best practices, really safe designer and coder with enough time for testing and iteration. Assuming that would be naive.</p></div><p>It would be naive to assume general purpose language selection makes a meaningful difference with regards to security outcomes.</p><p>It's up to the architect to manage risk by selecting appropriate tools and methodologies to best address specific problem domain.  Placing programmers in an environment that ensures failure by giving them the wrong tool for the job before them or where they are required to always be extra careful in order to avert disaster is extremely counterproductive.</p><p><div class="quote"><p>So why not protect against common errors using the programming language constraints and checks? Most of these protections can be done with very little cost, performance wise or in loss of program expressive power.</p></div><p>It is not clear to me specifi<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55883207">

</div>
</div>

<div id="replyto_55883207"></div>

<ul id="group_55883207">
	<li id="hiddens_55883207" class="hide"></li>
</ul>

</li><li id="hidestring_55882581"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882581">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55882365" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882365" class="commentstatus"></div>
<div id="comment_55882365" class="cw">
</div>

<div id="replyto_55882365"></div>

<ul id="group_55882365">
	<li id="hiddens_55882365" class="hide"></li>
</ul>

</li><li id="tree_55882539" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882539" class="commentstatus"></div>
<div id="comment_55882539" class="cw">
	<div id="comment_top_55882539" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882539" name="comment_link_55882539" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882539" onclick="return D2.setFocusComment(55882539)" >Re:</a>


		 	<span id="comment_score_55882539" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882539); return false"><span class=opt>Score:</span>3</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Excelcia">Excelcia</a>  <span class="uid"><a href="//slashdot.org/~Excelcia">( 906188 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882539"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882539"><p>Oh Lord, seriously?  This again?  C is more dangerous than Java the way that a KA-Bar is more dangerous than a butter knife.  If you take a real programming language, hamstring it, put a bib on it, and pull its teeth so it can process nothing more than strained baby food, sure, it won't be dangerous but then again it won't do much useful either.</p><p>Write a device driver in Java or Python.  Or a kernel. C will always have a place in net-connected computers.  You just don't hand a loaded gun to a child and expect<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882539">

</div>
</div>

<div id="replyto_55882539"></div>

<ul id="group_55882539">
	<li id="hiddens_55882539" class="hide"></li>
</ul>

<ul id="commtree_55882539"><li id="tree_55882609" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882609" class="commentstatus"></div>
<div id="comment_55882609" class="cw">
	<div id="comment_top_55882609" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882609" name="comment_link_55882609" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882609" onclick="return D2.setFocusComment(55882609)" >Oh lord, that again?</a>


		 	<span id="comment_score_55882609" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882609); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~presidenteloco">presidenteloco</a>  <span class="uid"><a href="//slashdot.org/~presidenteloco">( 659168 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882609"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882609"><p>Someone who thinks that C is the only performant programming language today?<br>Someone who's never heard of Go or rust, apparently.</p><p>Someone who thinks that more than, say, 10% of programs require "C-like" performance, with today's processors which are about 600,000 times faster than an Apple II, and thinks that both safety and maintenance cost are less important than having C-like performance on programs that don't need it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882609">

</div>
</div>

<div id="replyto_55882609"></div>

<ul id="group_55882609">
	<li id="hiddens_55882609" class="hide"></li>
</ul>

<ul id="commtree_55882609"><li id="tree_55882649" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55882649" class="commentstatus"></div>
<div id="comment_55882649" class="cw">
	<div id="comment_top_55882649" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882649" name="comment_link_55882649" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882649" onclick="return D2.setFocusComment(55882649)" >Re:Oh lord, that again?</a>


		 	<span id="comment_score_55882649" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882649); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Travelsonic">Travelsonic</a>  <span class="uid"><a href="//slashdot.org/~Travelsonic">( 870859 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882649">		
		on Sunday January 07, 2018 @08:40PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882649">#55882649</a>)
		<small><a href="//slashdot.org/~Travelsonic/journal/" title="Sunday April 17, 2005 @03:10PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882649">You're not suggesting that we make programs less efficient than possible because we have more resources, are you?  IMO, while going nuts is not helpful, we shouldn't use resources inefficiently, or the like, "just because" we have the room - not only that, but not every programming project, career, involves software that has that sort of safety - embedded systems, for instance.</div>
	</div>

	<div class="commentSub" id="comment_sub_55882649">
<span class="ind"></span><a id="reply_link_55882649" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882649" onclick="D2.replyTo(55882649); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=55882609" onclick="return D2.selectParent(55882609)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Oh lord, that again? by Travelsonic @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882649" data-title="Re:Oh lord, that again?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Oh lord, that again? by Travelsonic" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882649" data-title="Re:Oh lord, that again?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Oh lord, that again? by Travelsonic" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882649" data-title="Re:Oh lord, that again?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11578625%26cid=55882649" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55882649" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882649" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55882649"></div>

<ul id="group_55882649">
	<li id="hiddens_55882649" class="hide"></li>
</ul>

<ul id="commtree_55882649"><li id="tree_55882815" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882815" class="commentstatus"></div>
<div id="comment_55882815" class="cw">
	<div id="comment_top_55882815" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882815" name="comment_link_55882815" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882815" onclick="return D2.setFocusComment(55882815)" >Re:</a>


		 	<span id="comment_score_55882815" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882815); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Pinky's+Brain">Pinky's Brain</a>  <span class="uid"><a href="//slashdot.org/~Pinky's+Brain">( 1158667 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882815"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882815"><p>Execution speed for the inputs the programmer deemed to test with isn't the be all and end all of efficiency.</p><p>C is not cost efficient for society at large<nobr> <wbr></nobr>... C is a trillion dollar mistake.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882815">

</div>
</div>

<div id="replyto_55882815"></div>

<ul id="group_55882815">
	<li id="hiddens_55882815" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55882689" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882689" class="commentstatus"></div>
<div id="comment_55882689" class="cw">
	<div id="comment_top_55882689" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882689" name="comment_link_55882689" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882689" onclick="return D2.setFocusComment(55882689)" >not go</a>


		 	<span id="comment_score_55882689" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882689); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nten">nten</a>  <span class="uid"><a href="//slashdot.org/~nten">( 709128 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882689"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882689"><p>Go is less performant than java. Rust is on par with c++. They have nearly opposite design goals.  Use go for server back end services, not kernels or drivers. The rest of your post is spot on.  Citation is the benchmark game.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882689">

</div>
</div>

<div id="replyto_55882689"></div>

<ul id="group_55882689">
	<li id="hiddens_55882689" class="hide"></li>
</ul>

<ul id="commtree_55882689"><li id="tree_55882751" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882751" class="commentstatus"></div>
<div id="comment_55882751" class="cw">
</div>

<div id="replyto_55882751"></div>

<ul id="group_55882751">
	<li id="hiddens_55882751" class="hide"></li>
</ul>

</li><li id="tree_55882803" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882803" class="commentstatus"></div>
<div id="comment_55882803" class="cw">
	<div id="comment_top_55882803" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882803" name="comment_link_55882803" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882803" onclick="return D2.setFocusComment(55882803)" >Re:</a>


		 	<span id="comment_score_55882803" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882803); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lucasnate1">lucasnate1</a>  <span class="uid"><a href="//slashdot.org/~lucasnate1">( 4682951 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882803"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882803"><p>How come go is slower than java? It compiles to native code and is more low level (except for channels and goroutines). Do you have any idea how java is faster?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882803">

</div>
</div>

<div id="replyto_55882803"></div>

<ul id="group_55882803">
	<li id="hiddens_55882803" class="hide"></li>
</ul>

</li><li id="hidestring_55882689"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882689">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882755" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882755" class="commentstatus"></div>
<div id="comment_55882755" class="cw">
	<div id="comment_top_55882755" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882755" name="comment_link_55882755" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882755" onclick="return D2.setFocusComment(55882755)" >Re:</a>


		 	<span id="comment_score_55882755" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882755); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Excelcia">Excelcia</a>  <span class="uid"><a href="//slashdot.org/~Excelcia">( 906188 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882755"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882755"><p>Attitudes like this are why people need a computer 600,000 times faster with 262144 times the memory in order to load something just to check their e-mail.  I don't use Rust.  I use Go when I must.  It's not a bad language as new languages go - Syncthing, a project I've contributed to, uses Go and it's not terrible.</p><p>In a way you're correct.  I'd agree that only about 10% of software really needs the performance and versatility of C.  Most others can get away with C++, for better organization, or some other n<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882755">

</div>
</div>

<div id="replyto_55882755"></div>

<ul id="group_55882755">
	<li id="hiddens_55882755" class="hide"></li>
</ul>

</li><li id="tree_55882799" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882799" class="commentstatus"></div>
<div id="comment_55882799" class="cw">
	<div id="comment_top_55882799" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882799" name="comment_link_55882799" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882799" onclick="return D2.setFocusComment(55882799)" >Re:</a>


		 	<span id="comment_score_55882799" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882799); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lucasnate1">lucasnate1</a>  <span class="uid"><a href="//slashdot.org/~lucasnate1">( 4682951 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882799"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882799"><p>Golang with its ad hoc interfaces, ever changing specs, missing apis, and dynamic typing when generics are needed, may end up introducing just as many security holes as c if it becomes popular.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882799">

</div>
</div>

<div id="replyto_55882799"></div>

<ul id="group_55882799">
	<li id="hiddens_55882799" class="hide"></li>
</ul>

</li><li id="tree_55882807" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882807" class="commentstatus"></div>
<div id="comment_55882807" class="cw">
	<div id="comment_top_55882807" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882807" name="comment_link_55882807" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882807" onclick="return D2.setFocusComment(55882807)" >Re:</a>


		 	<span id="comment_score_55882807" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882807); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Tough+Love">Tough Love</a>  <span class="uid"><a href="//slashdot.org/~Tough+Love">( 215404 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882807"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882807"><p><div class="quote"><p>Someone who thinks that C is the only performant programming language today? Someone who's never heard of Go or rust...</p></div><p>C and c++ (same code generator) kick the tails of go and rust, the former more so.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882807">

</div>
</div>

<div id="replyto_55882807"></div>

<ul id="group_55882807">
	<li id="hiddens_55882807" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55882623" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882623" class="commentstatus"></div>
<div id="comment_55882623" class="cw">
	<div id="comment_top_55882623" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882623" name="comment_link_55882623" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882623" onclick="return D2.setFocusComment(55882623)" >Re:</a>


		 	<span id="comment_score_55882623" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882623); return false"><span class=opt>Score:</span>2</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882623"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882623"><p>I disagree. Too much of the modern economy now depends upon code to leave safety to the whims, skills or vanity of the programmer. Frankly, the "trust me, I'm good" argument isn't good enough and neither are you. Type safety, bounds checking, protected memory and access control are no longer optional in 2018. You either begin accepting these things or the product liability lawyers are going to win out in court eventually and you will be held financially liable for every bug in your C code. Software has long<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882623">

</div>
</div>

<div id="replyto_55882623"></div>

<ul id="group_55882623">
	<li id="hiddens_55882623" class="hide"></li>
</ul>

<ul id="commtree_55882623"><li id="tree_55882737" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882737" class="commentstatus"></div>
<div id="comment_55882737" class="cw">
</div>

<div id="replyto_55882737"></div>

<ul id="group_55882737">
	<li id="hiddens_55882737" class="hide"></li>
</ul>

<ul id="commtree_55882737"><li id="tree_55882805" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882805" class="commentstatus"></div>
<div id="comment_55882805" class="cw">
	<div id="comment_top_55882805" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882805" name="comment_link_55882805" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882805" onclick="return D2.setFocusComment(55882805)" >Re:</a>


		 	<span id="comment_score_55882805" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882805); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lucasnate1">lucasnate1</a>  <span class="uid"><a href="//slashdot.org/~lucasnate1">( 4682951 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882805"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882805"><p>It is easier to write a compiler in C for a safer language than to write everything in C.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882805">

</div>
</div>

<div id="replyto_55882805"></div>

<ul id="group_55882805">
	<li id="hiddens_55882805" class="hide"></li>
</ul>

</li><li id="tree_55882831" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882831" class="commentstatus"></div>
<div id="comment_55882831" class="cw">
	<div id="comment_top_55882831" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882831" name="comment_link_55882831" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882831" onclick="return D2.setFocusComment(55882831)" >Re:</a>


		 	<span id="comment_score_55882831" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882831); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AHuxley">AHuxley</a>  <span class="uid"><a href="//slashdot.org/~AHuxley">( 892839 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882831"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882831">The people who work with Ada.</div>
	</div>

	<div class="commentSub" id="comment_sub_55882831">

</div>
</div>

<div id="replyto_55882831"></div>

<ul id="group_55882831">
	<li id="hiddens_55882831" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_55882623"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882623">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_55882733" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882733" class="commentstatus"></div>
<div id="comment_55882733" class="cw">
	<div id="comment_top_55882733" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882733" name="comment_link_55882733" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882733" onclick="return D2.setFocusComment(55882733)" >Re:</a>


		 	<span id="comment_score_55882733" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882733); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~arth1">arth1</a>  <span class="uid"><a href="//slashdot.org/~arth1">( 260657 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882733"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882733"><p><div class="quote"><p>No bounds checking, no type checking. In 2018. Get serious.</p></div><p>A halfway good programmer doesn't need to trust the language to do that for him and is capable of ensuring boundaries.  The problem is that halfway good programmers have become scarce, and today's coders are content to leave critical parts to a compiler they don't understand and black box libraries they don't know what do behind the scenes.  So they need the handholding.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882733">

</div>
</div>

<div id="replyto_55882733"></div>

<ul id="group_55882733">
	<li id="hiddens_55882733" class="hide"></li>
</ul>

<ul id="commtree_55882733"><li id="tree_55882877" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882877" class="commentstatus"></div>
<div id="comment_55882877" class="cw">
</div>

<div id="replyto_55882877"></div>

<ul id="group_55882877">
	<li id="hiddens_55882877" class="hide"></li>
</ul>

</li><li id="hidestring_55882733"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882733">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882885" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882885" class="commentstatus"></div>
<div id="comment_55882885" class="cw">
	<div id="comment_top_55882885" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882885" name="comment_link_55882885" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882885" onclick="return D2.setFocusComment(55882885)" >Re:</a>


		 	<span id="comment_score_55882885" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882885); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DCFusor">DCFusor</a>  <span class="uid"><a href="//slashdot.org/~DCFusor">( 1763438 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882885"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882885">No checking?  That's what we have programmers for.  Now, a lot of people have that title who aren't even coders, frankly....and buffer overflows are usually trivial to prevent, and even actively search for possibilities of (like text search for strcpy instead of strncpy  for the simplest imaginable example).<br>Maybe expecting and getting a programming job that requires experience to do well without that experience (so the employer doesn't have to pay you as much) is more the issue, or could it be that language</div>
	</div>

	<div class="commentSub" id="comment_sub_55882885">

</div>
</div>

<div id="replyto_55882885"></div>

<ul id="group_55882885">
	<li id="hiddens_55882885" class="hide"></li>
</ul>

</li><li id="tree_55883025" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55883025" class="commentstatus"></div>
<div id="comment_55883025" class="cw">
</div>

<div id="replyto_55883025"></div>

<ul id="group_55883025">
	<li id="hiddens_55883025" class="hide"></li>
</ul>

</li><li id="tree_55883137" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55883137" class="commentstatus"></div>
<div id="comment_55883137" class="cw">
	<div id="comment_top_55883137" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55883137" name="comment_link_55883137" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55883137" onclick="return D2.setFocusComment(55883137)" >Re:</a>


		 	<span id="comment_score_55883137" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55883137); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55883137"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55883137">The most common exploit today is the SQL Injection exploit. If you think your language makes your code safe, then you almost certainly have security flaws, huge ones.</div>
	</div>

	<div class="commentSub" id="comment_sub_55883137">

</div>
</div>

<div id="replyto_55883137"></div>

<ul id="group_55883137">
	<li id="hiddens_55883137" class="hide"></li>
</ul>

</li><li id="hidestring_55882247"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882247">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882345" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882345" class="commentstatus"></div>
<div id="comment_55882345" class="cw">
	<div id="comment_top_55882345" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882345" name="comment_link_55882345" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882345" onclick="return D2.setFocusComment(55882345)" >Re:</a>


		 	<span id="comment_score_55882345" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882345); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Hognoxious">Hognoxious</a>  <span class="uid"><a href="//slashdot.org/~Hognoxious">( 631665 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882345"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882345"><blockquote><div><p> whatever bullshit venture-captial-seeking-paradigm-of-the-month was en vogue for that month.</p></div>    </blockquote><p>These days, whatevers-of-the month barely last a week.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882345">

</div>
</div>

<div id="replyto_55882345"></div>

<ul id="group_55882345">
	<li id="hiddens_55882345" class="hide"></li>
</ul>

<ul id="commtree_55882345"><li id="tree_55882349" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882349" class="commentstatus"></div>
<div id="comment_55882349" class="cw">
</div>

<div id="replyto_55882349"></div>

<ul id="group_55882349">
	<li id="hiddens_55882349" class="hide"></li>
</ul>

</li><li id="hidestring_55882345"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882345">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882775" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882775" class="commentstatus"></div>
<div id="comment_55882775" class="cw">
	<div id="comment_top_55882775" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882775" name="comment_link_55882775" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882775" onclick="return D2.setFocusComment(55882775)" >Don't call Tiobe a reliable metric</a>


		 	<span id="comment_score_55882775" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882775); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Tough+Love">Tough Love</a>  <span class="uid"><a href="//slashdot.org/~Tough+Love">( 215404 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882775"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882775"><p>I'm not saying C did or did not come back, or did or did not go away. I am saying, you won't know from Tiobe, it way too random. They count language questions, not language usage, and don't make the slightest attempt to correct for predictable skew like selection bias due to who hangs out there as opposed to, say, stackoverflow.</p><p>My totally on reliable take on it? C dev population stays about the same: very few, very skilled, and very highly paid. Because of the latter, the number of C wannabes spikes from ti<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882775">

</div>
</div>

<div id="replyto_55882775"></div>

<ul id="group_55882775">
	<li id="hiddens_55882775" class="hide"></li>
</ul>

</li><li id="tree_55883135" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55883135" class="commentstatus"></div>
<div id="comment_55883135" class="cw">
</div>

<div id="replyto_55883135"></div>

<ul id="group_55883135">
	<li id="hiddens_55883135" class="hide"></li>
</ul>

</li><li id="hidestring_55882177"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882177">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882183" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882183" class="commentstatus"></div>
<div id="comment_55882183" class="cw">
</div>

<div id="replyto_55882183"></div>

<ul id="group_55882183">
	<li id="hiddens_55882183" class="hide"></li>
</ul>

<ul id="commtree_55882183"><li id="tree_55883009" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55883009" class="commentstatus"></div>
<div id="comment_55883009" class="cw">
</div>

<div id="replyto_55883009"></div>

<ul id="group_55883009">
	<li id="hiddens_55883009" class="hide"></li>
</ul>

</li><li id="hidestring_55882183"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882183">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882189" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882189" class="commentstatus"></div>
<div id="comment_55882189" class="cw">
</div>

<div id="replyto_55882189"></div>

<ul id="group_55882189">
	<li id="hiddens_55882189" class="hide"></li>
</ul>

<ul id="commtree_55882189"><li id="tree_55882233" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882233" class="commentstatus"></div>
<div id="comment_55882233" class="cw">
</div>

<div id="replyto_55882233"></div>

<ul id="group_55882233">
	<li id="hiddens_55882233" class="hide"></li>
</ul>

</li><li id="hidestring_55882189"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882189">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882203" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882203" class="commentstatus"></div>
<div id="comment_55882203" class="cw">
	<div id="comment_top_55882203" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882203" name="comment_link_55882203" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882203" onclick="return D2.setFocusComment(55882203)" >More Popular?</a>


		 	<span id="comment_score_55882203" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882203); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Neuronwelder">Neuronwelder</a>  <span class="uid"><a href="//slashdot.org/~Neuronwelder">( 990842 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882203"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882203">Maybe they are trying to say it's more popular now? Either way I'm glad!</div>
	</div>

	<div class="commentSub" id="comment_sub_55882203">

</div>
</div>

<div id="replyto_55882203"></div>

<ul id="group_55882203">
	<li id="hiddens_55882203" class="hide"></li>
</ul>

<ul id="commtree_55882203"><li id="tree_55882253" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882253" class="commentstatus"></div>
<div id="comment_55882253" class="cw">
</div>

<div id="replyto_55882253"></div>

<ul id="group_55882253">
	<li id="hiddens_55882253" class="hide"></li>
</ul>

</li><li id="hidestring_55882203"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882203">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882221" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882221" class="commentstatus"></div>
<div id="comment_55882221" class="cw">
</div>

<div id="replyto_55882221"></div>

<ul id="group_55882221">
	<li id="hiddens_55882221" class="hide"></li>
</ul>

</li><li id="tree_55882263" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882263" class="commentstatus"></div>
<div id="comment_55882263" class="cw">
	<div id="comment_top_55882263" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882263" name="comment_link_55882263" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882263" onclick="return D2.setFocusComment(55882263)" >both indexes are search popularity rankings</a>


		 	<span id="comment_score_55882263" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882263); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~iggymanz">iggymanz</a>  <span class="uid"><a href="//slashdot.org/~iggymanz">( 596061 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882263"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882263"><p>These aren't measures of how much languages are used, they're useless bullshit as asking which languages generate the most Twitter Tweets?  Facebook posts?  News articles?</p><p>Number of jobs held would be interesting.</p><p>So would number of unique jobs openings for each language.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882263">

</div>
</div>

<div id="replyto_55882263"></div>

<ul id="group_55882263">
	<li id="hiddens_55882263" class="hide"></li>
</ul>

<ul id="commtree_55882263"><li id="tree_55882331" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882331" class="commentstatus"></div>
<div id="comment_55882331" class="cw">
	<div id="comment_top_55882331" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882331" name="comment_link_55882331" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882331" onclick="return D2.setFocusComment(55882331)" >Re: both indexes are search popularity rankings</a>


		 	<span id="comment_score_55882331" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882331); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sg_oneill">sg_oneill</a>  <span class="uid"><a href="//slashdot.org/~sg_oneill">( 159032 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882331"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882331"><p>Job adverts are certainly an interesting method but never the whole story. I've been checking job listings since the 90s for python and up till about 3-4 years ago where rarer than hens teeth (there's a tonne now since the management types finally discovered it). But all that time there was a huge amount of local devs using python for personal projects , glueing things together with it in server racks, holding conferences and meets and so on. Hell one of the founding devs of Django even lives near me. But g<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882331">

</div>
</div>

<div id="replyto_55882331"></div>

<ul id="group_55882331">
	<li id="hiddens_55882331" class="hide"></li>
</ul>

</li></ul></li><li id="tree_55882269" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55882269" class="commentstatus"></div>
<div id="comment_55882269" class="cw">
	<div id="comment_top_55882269" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882269" name="comment_link_55882269" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882269" onclick="return D2.setFocusComment(55882269)" >Driven by Raspberry Pi?</a>


		 	<span id="comment_score_55882269" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882269); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~smist08">smist08</a>  <span class="uid"><a href="//slashdot.org/~smist08">( 1059006 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882269">		
		on Sunday January 07, 2018 @07:02PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882269">#55882269</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882269">With all the low cost ARM computers, perhap people appreciate the speed of C. Generally you get smaller faster programs. Or perhaps more people are working on the Linux kernel?</div>
	</div>

	<div class="commentSub" id="comment_sub_55882269">
<span class="ind"></span><a id="reply_link_55882269" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882269" onclick="D2.replyTo(55882269); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Driven by Raspberry Pi? by smist08 @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882269" data-title="Driven by Raspberry Pi?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Driven by Raspberry Pi? by smist08" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882269" data-title="Driven by Raspberry Pi?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Driven by Raspberry Pi? by smist08" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882269" data-title="Driven by Raspberry Pi?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11578625%26cid=55882269" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55882269" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882269" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55882269"></div>

<ul id="group_55882269">
	<li id="hiddens_55882269" class="hide"></li>
</ul>

<ul id="commtree_55882269"><li id="tree_55882295" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55882295" class="commentstatus"></div>
<div id="comment_55882295" class="cw">
	<div id="comment_top_55882295" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882295" name="comment_link_55882295" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882295" onclick="return D2.setFocusComment(55882295)" >Re:Driven by Raspberry Pi?</a>


		 	<span id="comment_score_55882295" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882295); return false"><span class=opt>Score:</span>4</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sourcerror">sourcerror</a>  <span class="uid"><a href="//slashdot.org/~sourcerror">( 1718066 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882295">		
		on Sunday January 07, 2018 @07:09PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882295">#55882295</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882295"><p>You can use more advanced programming languages on the Pi that have decent execution speed too, like Java or C#. I think C's popularity is more driven by Arduino, where other alternatives don't exist.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882295">
<span class="ind"></span><a id="reply_link_55882295" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882295" onclick="D2.replyTo(55882295); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=55882269" onclick="return D2.selectParent(55882269)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Driven by Raspberry Pi? by sourcerror @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882295" data-title="Re:Driven by Raspberry Pi?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Driven by Raspberry Pi? by sourcerror" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882295" data-title="Re:Driven by Raspberry Pi?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Driven by Raspberry Pi? by sourcerror" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882295" data-title="Re:Driven by Raspberry Pi?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11578625%26cid=55882295" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55882295" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882295" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55882295"></div>

<ul id="group_55882295">
	<li id="hiddens_55882295" class="hide"></li>
</ul>

<ul id="commtree_55882295"><li id="tree_55882709" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882709" class="commentstatus"></div>
<div id="comment_55882709" class="cw">
	<div id="comment_top_55882709" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882709" name="comment_link_55882709" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882709" onclick="return D2.setFocusComment(55882709)" >Re:</a>


		 	<span id="comment_score_55882709" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882709); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~TypoNAM">TypoNAM</a>  <span class="uid"><a href="//slashdot.org/~TypoNAM">( 695420 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882709"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882709"><p>Except the fact that Arduino IDE uses C++ not C.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882709">

</div>
</div>

<div id="replyto_55882709"></div>

<ul id="group_55882709">
	<li id="hiddens_55882709" class="hide"></li>
</ul>

<ul id="commtree_55882709"><li id="tree_55882905" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882905" class="commentstatus"></div>
<div id="comment_55882905" class="cw">
	<div id="comment_top_55882905" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882905" name="comment_link_55882905" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882905" onclick="return D2.setFocusComment(55882905)" >Re:</a>


		 	<span id="comment_score_55882905" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882905); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DCFusor">DCFusor</a>  <span class="uid"><a href="//slashdot.org/~DCFusor">( 1763438 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882905"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882905">I kind of like arduino's slightly relaxed version of C++ myself, and use perl or C/C++ in pies to do the linux type stuff - databases and web servers - for my arduino based automation devices (often ESP based).  Works for me - use C(++) where you are super time-dependent and need utter control and some higher level language for the glue that saves programmer time and effort and catches some of the errors.  I personally missed the Java and PHP trains, but I hear I didn't miss much...something about fractals</div>
	</div>

	<div class="commentSub" id="comment_sub_55882905">

</div>
</div>

<div id="replyto_55882905"></div>

<ul id="group_55882905">
	<li id="hiddens_55882905" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_55882299" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882299" class="commentstatus"></div>
<div id="comment_55882299" class="cw">
</div>

<div id="replyto_55882299"></div>

<ul id="group_55882299">
	<li id="hiddens_55882299" class="hide"></li>
</ul>

</li><li id="tree_55882303" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882303" class="commentstatus"></div>
<div id="comment_55882303" class="cw">
	<div id="comment_top_55882303" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882303" name="comment_link_55882303" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882303" onclick="return D2.setFocusComment(55882303)" >Needs updating</a>


		 	<span id="comment_score_55882303" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882303); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Ichijo">Ichijo</a>  <span class="uid"><a href="//slashdot.org/~Ichijo">( 607641 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882303"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882303">In Standard C, how do you find the least significant set bit of an integer type? Most CPUs these days support a <a href="https://stackoverflow.com/questions/9353973/implementation-of-builtin-clz" title="stackoverflow.com">clz</a> [stackoverflow.com] instruction, but Standard C doesn't.</div>
	</div>

	<div class="commentSub" id="comment_sub_55882303">

</div>
</div>

<div id="replyto_55882303"></div>

<ul id="group_55882303">
	<li id="hiddens_55882303" class="hide"></li>
</ul>

<ul id="commtree_55882303"><li id="tree_55882381" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882381" class="commentstatus"></div>
<div id="comment_55882381" class="cw">
</div>

<div id="replyto_55882381"></div>

<ul id="group_55882381">
	<li id="hiddens_55882381" class="hide"></li>
</ul>

</li><li id="tree_55882497" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882497" class="commentstatus"></div>
<div id="comment_55882497" class="cw">
	<div id="comment_top_55882497" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882497" name="comment_link_55882497" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882497" onclick="return D2.setFocusComment(55882497)" >Re:</a>


		 	<span id="comment_score_55882497" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882497); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~chrism238">chrism238</a>  <span class="uid"><a href="//slashdot.org/~chrism238">( 657741 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882497"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882497">Why do you believe that a programming language Standard needs to provide a standard for a specific CPU-level instruction?
Can you name another standardised language that does so as part of the language?</div>
	</div>

	<div class="commentSub" id="comment_sub_55882497">

</div>
</div>

<div id="replyto_55882497"></div>

<ul id="group_55882497">
	<li id="hiddens_55882497" class="hide"></li>
</ul>

</li><li id="tree_55882561" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882561" class="commentstatus"></div>
<div id="comment_55882561" class="cw">
</div>

<div id="replyto_55882561"></div>

<ul id="group_55882561">
	<li id="hiddens_55882561" class="hide"></li>
</ul>

<ul id="commtree_55882561"><li id="tree_55883171" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55883171" class="commentstatus"></div>
<div id="comment_55883171" class="cw">
</div>

<div id="replyto_55883171"></div>

<ul id="group_55883171">
	<li id="hiddens_55883171" class="hide"></li>
</ul>

</li><li id="hidestring_55882561"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882561">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882571" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882571" class="commentstatus"></div>
<div id="comment_55882571" class="cw">
	<div id="comment_top_55882571" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882571" name="comment_link_55882571" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882571" onclick="return D2.setFocusComment(55882571)" >Re:</a>


		 	<span id="comment_score_55882571" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882571); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Darinbob">Darinbob</a>  <span class="uid"><a href="//slashdot.org/~Darinbob">( 1142669 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882571"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882571"><p>A good compiler will convert a loop for finding the bit into the single instruction.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882571">

</div>
</div>

<div id="replyto_55882571"></div>

<ul id="group_55882571">
	<li id="hiddens_55882571" class="hide"></li>
</ul>

<ul id="commtree_55882571"><li id="tree_55882643" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882643" class="commentstatus"></div>
<div id="comment_55882643" class="cw">
</div>

<div id="replyto_55882643"></div>

<ul id="group_55882643">
	<li id="hiddens_55882643" class="hide"></li>
</ul>

</li><li id="hidestring_55882571"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882571">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882595" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882595" class="commentstatus"></div>
<div id="comment_55882595" class="cw">
</div>

<div id="replyto_55882595"></div>

<ul id="group_55882595">
	<li id="hiddens_55882595" class="hide"></li>
</ul>

</li><li id="tree_55882647" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882647" class="commentstatus"></div>
<div id="comment_55882647" class="cw">
	<div id="comment_top_55882647" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882647" name="comment_link_55882647" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882647" onclick="return D2.setFocusComment(55882647)" >Re:</a>


		 	<span id="comment_score_55882647" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882647); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Pseudonym">Pseudonym</a>  <span class="uid"><a href="//slashdot.org/~Pseudonym">( 62607 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882647"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882647"><p>If your C standard library doesn't have <tt>ffs()</tt>, then... sorry, Windows user. I guess there's always <tt>_BitScanForward</tt> or <tt>__lzcnt</tt>.</p><p>Oh, and if your CPU uses clz to count trailing zeroes, you should report that as a bug.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882647">

</div>
</div>

<div id="replyto_55882647"></div>

<ul id="group_55882647">
	<li id="hiddens_55882647" class="hide"></li>
</ul>

</li><li id="tree_55882785" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882785" class="commentstatus"></div>
<div id="comment_55882785" class="cw">
	<div id="comment_top_55882785" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882785" name="comment_link_55882785" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882785" onclick="return D2.setFocusComment(55882785)" >Re:</a>


		 	<span id="comment_score_55882785" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882785); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~arth1">arth1</a>  <span class="uid"><a href="//slashdot.org/~arth1">( 260657 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882785"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882785"><p><div class="quote"><p>In Standard C, how do you find the least significant set bit of an integer type?</p></div><p>Is this a trick question?  Something like this in a #define, I suppose?<br>for (i=0;iwhy you would need to do that - chances are that you're complicating things when you don't need to, and just need an &amp; operation.  If you stumbled upon this when trying to do netmasks, be assured that the problem is already solved, and quite efficiently too.<br>C is helpful in making you think and find simpler algorithms, which execute far more efficiently than bloated libraries and language intrinsics that have to deal with ca<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882785">

</div>
</div>

<div id="replyto_55882785"></div>

<ul id="group_55882785">
	<li id="hiddens_55882785" class="hide"></li>
</ul>

<ul id="commtree_55882785"><li id="tree_55882795" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882795" class="commentstatus"></div>
<div id="comment_55882795" class="cw">
	<div id="comment_top_55882795" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882795" name="comment_link_55882795" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882795" onclick="return D2.setFocusComment(55882795)" >Re:</a>


		 	<span id="comment_score_55882795" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882795); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~arth1">arth1</a>  <span class="uid"><a href="//slashdot.org/~arth1">( 260657 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882795"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882795"><p>Oops, forgot about slashdot parsing &lt;</p><p>for (i=0;i&lt;sizeof(var)&lt;&lt;8 &amp;&amp; var % (1&lt;&lt;i); i++);</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882795">

</div>
</div>

<div id="replyto_55882795"></div>

<ul id="group_55882795">
	<li id="hiddens_55882795" class="hide"></li>
</ul>

<ul id="commtree_55882795"><li id="tree_55882903" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882903" class="commentstatus"></div>
<div id="comment_55882903" class="cw">
	<div id="comment_top_55882903" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882903" name="comment_link_55882903" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882903" onclick="return D2.setFocusComment(55882903)" >Re:</a>


		 	<span id="comment_score_55882903" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882903); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AmiMoJo">AmiMoJo</a>  <span class="uid"><a href="//slashdot.org/~AmiMoJo">( 196126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882903"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882903"><p>I think you meant &amp; instead of %.</p><p>In any case, there are better ways to do this: <a href="http://graphics.stanford.edu/~seander/bithacks.html#ZerosOnRightLinear" title="stanford.edu">http://graphics.stanford.edu/~...<span class="substr"> </span></a> [stanford.edu] </p><p>My favourite is the second example using only AND operations with constants. It's faster and has more predictable execution time, although it's not constant.</p><p>I seem to recall that some systems (BSD?) have a prototype function for this in their standard library too, which on some CPUs complies to a single instruction.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882903">

</div>
</div>

<div id="replyto_55882903"></div>

<ul id="group_55882903">
	<li id="hiddens_55882903" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="hidestring_55882303"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882303">3 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882399" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882399" class="commentstatus"></div>
<div id="comment_55882399" class="cw">
</div>

<div id="replyto_55882399"></div>

<ul id="group_55882399">
	<li id="hiddens_55882399" class="hide"></li>
</ul>

</li><li id="tree_55882445" class="comment full contain"><span class="ind"></span>
<div id="comment_status_55882445" class="commentstatus"></div>
<div id="comment_55882445" class="cw">
	<div id="comment_top_55882445" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882445" name="comment_link_55882445" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882445" onclick="return D2.setFocusComment(55882445)" >This really only indicates where jobs are now...</a>


		 	<span id="comment_score_55882445" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882445); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~StevenMaurer">StevenMaurer</a>  <span class="uid"><a href="//slashdot.org/~StevenMaurer">( 115071 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882445">		
		on Sunday January 07, 2018 @07:48PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882445">#55882445</a>)
		<small><a href="http://slashdot.org/" title="http://slashdot.org/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882445"><p>
No one is seriously going to try to use C for front end web development, just as no one is seriously going to try to use Javascript in an embedded microprocessor. So what this study is doing is just pointing out where the current jobs are.</p><p>Trying to compare languages, is like asking "which is better? a band saw or a screw driver?". They're entirely different. And anyone who doesn't understand that, simply doesn't have enough experience with other programming tools yet.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882445">
<span class="ind"></span><a id="reply_link_55882445" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882445" onclick="D2.replyTo(55882445); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="This really only indicates where jobs are now... by StevenMaurer @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882445" data-title="This really only indicates where jobs are now...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="This really only indicates where jobs are now... by StevenMaurer" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882445" data-title="This really only indicates where jobs are now...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="This really only indicates where jobs are now... by StevenMaurer" data-url="https://developers.slashdot.org/comments.pl?sid=11578625&cid=55882445" data-title="This really only indicates where jobs are now...">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11578625%26cid=55882445" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_55882445" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=55882445" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_55882445"></div>

<ul id="group_55882445">
	<li id="hiddens_55882445" class="hide"></li>
</ul>

<ul id="commtree_55882445"><li id="tree_55882897" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882897" class="commentstatus"></div>
<div id="comment_55882897" class="cw">
	<div id="comment_top_55882897" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882897" name="comment_link_55882897" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882897" onclick="return D2.setFocusComment(55882897)" >Re:</a>


		 	<span id="comment_score_55882897" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882897); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~4wdloop">4wdloop</a>  <span class="uid"><a href="//slashdot.org/~4wdloop">( 1031398 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882897"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882897"><p>You are right in general...but wrong here.<br>This report is not a beauty context or any other comparison of tools but rather statistics of web searches. As such it got reported and misinterpreted as "popularity" as if it was a preference.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882897">

</div>
</div>

<div id="replyto_55882897"></div>

<ul id="group_55882897">
	<li id="hiddens_55882897" class="hide"></li>
</ul>

</li><li id="tree_55882907" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882907" class="commentstatus"></div>
<div id="comment_55882907" class="cw">
	<div id="comment_top_55882907" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882907" name="comment_link_55882907" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882907" onclick="return D2.setFocusComment(55882907)" >Re:</a>


		 	<span id="comment_score_55882907" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882907); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DCFusor">DCFusor</a>  <span class="uid"><a href="//slashdot.org/~DCFusor">( 1763438 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882907"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882907">Mod parent up - I posted so I can't use my points.  This is correct.</div>
	</div>

	<div class="commentSub" id="comment_sub_55882907">

</div>
</div>

<div id="replyto_55882907"></div>

<ul id="group_55882907">
	<li id="hiddens_55882907" class="hide"></li>
</ul>

</li><li id="tree_55883211" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55883211" class="commentstatus"></div>
<div id="comment_55883211" class="cw">
</div>

<div id="replyto_55883211"></div>

<ul id="group_55883211">
	<li id="hiddens_55883211" class="hide"></li>
</ul>

</li><li id="hidestring_55882445"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882445">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882471" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882471" class="commentstatus"></div>
<div id="comment_55882471" class="cw">
</div>

<div id="replyto_55882471"></div>

<ul id="group_55882471">
	<li id="hiddens_55882471" class="hide"></li>
</ul>

</li><li id="tree_55882577" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882577" class="commentstatus"></div>
<div id="comment_55882577" class="cw">
</div>

<div id="replyto_55882577"></div>

<ul id="group_55882577">
	<li id="hiddens_55882577" class="hide"></li>
</ul>

</li><li id="tree_55882603" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882603" class="commentstatus"></div>
<div id="comment_55882603" class="cw">
	<div id="comment_top_55882603" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882603" name="comment_link_55882603" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882603" onclick="return D2.setFocusComment(55882603)" >The language stack is sorted out</a>


		 	<span id="comment_score_55882603" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882603); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~drolli">drolli</a>  <span class="uid"><a href="//slashdot.org/~drolli">( 522659 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882603"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882603"><p>I consider this the transition to a more stable period. For some time it was unclear how functions would be split between programming languages. All kind of ideas were in the room, with interesting new contenders. Still the programming community decided that the areas covered by Java, Javascript, C, Python are well distributed in the way in which they are and that "good enough is still good".</p><p>C# (competitor to C++ and Java in my eyes) seems to be dying. Swift doenst take over from objective C as fast as that<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882603">

</div>
</div>

<div id="replyto_55882603"></div>

<ul id="group_55882603">
	<li id="hiddens_55882603" class="hide"></li>
</ul>

<ul id="commtree_55882603"><li id="tree_55882813" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882813" class="commentstatus"></div>
<div id="comment_55882813" class="cw">
</div>

<div id="replyto_55882813"></div>

<ul id="group_55882813">
	<li id="hiddens_55882813" class="hide"></li>
</ul>

</li><li id="hidestring_55882603"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882603">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882669" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882669" class="commentstatus"></div>
<div id="comment_55882669" class="cw">
</div>

<div id="replyto_55882669"></div>

<ul id="group_55882669">
	<li id="hiddens_55882669" class="hide"></li>
</ul>

</li><li id="tree_55882705" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882705" class="commentstatus"></div>
<div id="comment_55882705" class="cw">
	<div id="comment_top_55882705" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882705" name="comment_link_55882705" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882705" onclick="return D2.setFocusComment(55882705)" >C is still king, thank Engineering Schools</a>


		 	<span id="comment_score_55882705" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882705); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Proudrooster">Proudrooster</a>  <span class="uid"><a href="//slashdot.org/~Proudrooster">( 580120 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882705"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882705"><p>Everything on planet freaking earth has firmware in it now and guess what compiler makes the smallest binaries that can talk to hardware?</p><p>Yes, that's right C.</p><p>Python can talk to C, but you aren't going to write firmware or low level interrupt handling code (like reading IR pulses) or monitoring an I2C bus.</p><p>Java is C's fat lazy son that lives in the basement and consumes all available resources can do things eventually, if you give him enough resources, time, and be able to tolerate the odor.</p><p>As long as computer<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882705">

</div>
</div>

<div id="replyto_55882705"></div>

<ul id="group_55882705">
	<li id="hiddens_55882705" class="hide"></li>
</ul>

<ul id="commtree_55882705"><li id="tree_55882791" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882791" class="commentstatus"></div>
<div id="comment_55882791" class="cw">
</div>

<div id="replyto_55882791"></div>

<ul id="group_55882791">
	<li id="hiddens_55882791" class="hide"></li>
</ul>

<ul id="commtree_55882791"><li id="tree_55882931" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882931" class="commentstatus"></div>
<div id="comment_55882931" class="cw">
</div>

<div id="replyto_55882931"></div>

<ul id="group_55882931">
	<li id="hiddens_55882931" class="hide"></li>
</ul>

</li><li id="hidestring_55882791"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882791">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_55882705"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=55882705">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_55882707" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882707" class="commentstatus"></div>
<div id="comment_55882707" class="cw">
	<div id="comment_top_55882707" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882707" name="comment_link_55882707" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882707" onclick="return D2.setFocusComment(55882707)" >how much is it used is almost KLOCs</a>


		 	<span id="comment_score_55882707" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882707); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~superwiz">superwiz</a>  <span class="uid"><a href="//slashdot.org/~superwiz">( 655733 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882707"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882707">The fact that it is searched-for a lot can just as easily indicate that the projects in other languages get completed quicker.  That would make it a less useful (and **therefore** more used) language.  The fact that more C gets used is about as telling as how many KLOCs of one language (vs another language) gets written.  It just substitutes how much time is spent on one language over another for how KLOCs are written.  Measuring output of work by the effort put in is always bad measure.  It elevates effort</div>
	</div>

	<div class="commentSub" id="comment_sub_55882707">

</div>
</div>

<div id="replyto_55882707"></div>

<ul id="group_55882707">
	<li id="hiddens_55882707" class="hide"></li>
</ul>

</li><li id="tree_55882859" class="comment hidden"><span class="ind"></span>
<div id="comment_status_55882859" class="commentstatus"></div>
<div id="comment_55882859" class="cw">
</div>

<div id="replyto_55882859"></div>

<ul id="group_55882859">
	<li id="hiddens_55882859" class="hide"></li>
</ul>

</li><li id="tree_55882983" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55882983" class="commentstatus"></div>
<div id="comment_55882983" class="cw">
	<div id="comment_top_55882983" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55882983" name="comment_link_55882983" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55882983" onclick="return D2.setFocusComment(55882983)" >Turbo Pascal</a>


		 	<span id="comment_score_55882983" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55882983); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ka9dgx">ka9dgx</a>  <span class="uid"><a href="//slashdot.org/~ka9dgx">( 72702 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55882983"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55882983"><p>So when is Turbo Pascal coming back?<nobr> <wbr></nobr>;-)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55882983">

</div>
</div>

<div id="replyto_55882983"></div>

<ul id="group_55882983">
	<li id="hiddens_55882983" class="hide"></li>
</ul>

</li><li id="tree_55883097" class="comment oneline"><span class="ind"></span>
<div id="comment_status_55883097" class="commentstatus"></div>
<div id="comment_55883097" class="cw">
	<div id="comment_top_55883097" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_55883097" name="comment_link_55883097" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;cid=55883097" onclick="return D2.setFocusComment(55883097)" >Search index = popularity?</a>


		 	<span id="comment_score_55883097" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 55883097); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nitehawk214">nitehawk214</a>  <span class="uid"><a href="//slashdot.org/~nitehawk214">( 222219 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_55883097"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_55883097"><p>Or maybe it's a reflection that nearly every developer out there knows C to some degree and doesn't have to search for help as much?</p><p>Maybe it means there are more older C devs that are more likely to go to a book than Stack overflow?</p><p>Either way, it's a garbage metric designed to generate lazy clickbait articles, like this one.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_55883097">

</div>
</div>

<div id="replyto_55883097"></div>

<ul id="group_55883097">
	<li id="hiddens_55883097" class="hide"></li>
</ul>

</li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11578625&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">11 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//developers.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 36;
		D2.currents()['full']     = 7;
		D2.currents()['oneline']  = 41;
		// D2.currents_total(84);

		D2.abbrev_comments({55882539:522,55882623:515,55882705:543,55883207:1230,55882905:511,55882885:516,55882603:522,55882581:533,55882903:229,55882707:512,55882775:522,55882755:522,55882331:515,55882785:638});
		D2.noshow_comments([55882157,55882197,55882275,55882239,55882633,55882171,55882641,55882957,55882365,55882751,55882737,55882877,55883025,55882349,55883135,55882183,55883009,55882189,55882233,55882253,55882221,55882299,55882381,55882561,55883171,55882643,55882595,55882399,55883211,55882471,55882577,55882813,55882669,55882791,55882931,55882859]);
		D2.pieces_comments([55882781,55882247,55882281,55882581,55882789,55883207,55882539,55882609,55882815,55882689,55882803,55882755,55882799,55882807,55882623,55882805,55882831,55882733,55882885,55883137,55882345,55882775,55882203,55882263,55882331,55882709,55882905,55882303,55882497,55882571,55882647,55882785,55882795,55882903,55882897,55882907,55882603,55882705,55882707,55882983,55883097]);
		D2.init_hiddens([55882197,55882157,55882789,55882581,55882689,55882623,55882733,55882247,55882345,55882177,55882183,55882189,55882203,55882561,55882571,55882303,55882445,55882603,55882791,55882705,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(335799);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1001<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/03/01/1643251/programmers-are-confessing-their-coding-sins-to-protest-a-broken-job-interview-process?sdsrc=popbyskidbtmprev">Programmers Are Confessing Their Coding Sins To Protest a Broken Job Interview Process</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>656<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/03/27/2115233/prominent-drupal-php-developer-kicked-from-the-drupal-project-over-unconventional-sex-life?sdsrc=popbyskidbtmprev">Prominent Drupal, PHP Developer Kicked From the Drupal Project Over Unconventional Sex Life</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>608<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/11/27/039226/why-esr-hates-c-respects-java-and-thinks-go-but-not-rust-will-replace-c?sdsrc=popbyskidbtmprev">Why ESR Hates C++, Respects Java, and Thinks Go (But Not Rust) Will Replace C</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>600<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/02/04/1751211/developer-argues-for-forgotten-code-constructs-like-goto-and-eval?sdsrc=popbyskidbtmprev">Developer Argues For 'Forgotten Code Constructs' Like GOTO and Eval</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>595<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/11/11/0115219/esr-sees-three-viable-alternatives-to-c?sdsrc=popbyskidbtmprev">ESR Sees Three Viable Alternatives To C </a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//apple.slashdot.org/story/18/01/07/2354218/some-smartphone-salesmen-arent-sold-on-the-iphone-x?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/iphone_64.png" width="64" height="64" alt="Iphone"></span>
	    
					<p class="grid_12"><a href="//apple.slashdot.org/story/18/01/07/2354218/some-smartphone-salesmen-arent-sold-on-the-iphone-x?sdsrc=nextbtmprev">Some Smartphone Salesmen Aren't Sold on the iPhone X</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>88<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//linux.slashdot.org/story/18/01/07/228222/can-you-install-linux-on-a-1993-pc?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/linux_64.png" width="64" height="64" alt="Linux"></span>
	    
					<p class="grid_12"><a href="//linux.slashdot.org/story/18/01/07/228222/can-you-install-linux-on-a-1993-pc?sdsrc=prevbtmprev">Can You Install Linux On a 1993 PC?</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>133<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=11578625&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">84</span> of <span class="totalcommentcnt">84</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>Nothing happens.</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2018 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<script type="text/javascript">
_linkedin_data_partner_id = "113712";
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=113712&fmt=gif" />
</noscript>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?619">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?209">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->