<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	

<script>
(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '66');
</script>

	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '572859595719872852',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Oracle Releases Java 10, Promises Much Faster Release Schedule - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	  
		<meta name="description" content="An anonymous reader quotes Application Development Trends:
Oracle announced the general availability of Java SE 10 (JDK 10) this week. This release, which comes barely six months after the release of Java SE 9, is the first in the new rapid release cadence Oracle announced late last year.  The new r...">
	    
		<meta name="twitter:card" content="summary">
		<meta name="twitter:site" content="@slashdot">
		<meta name="twitter:domain" content="developers.slashdot.org">
		<meta property="og:url" content="https://developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+Slashdot%2Fslashdot+%28Slashdot%29">
	    
		<meta property="og:title" content="Oracle Releases Java 10, Promises Much Faster Release Schedule - Slashdot">
		<meta property="og:description" content="An anonymous reader quotes Application Development Trends:
Oracle announced the general availability of Java SE 10 (JDK 10) this week. This release, which comes barely six months after the release of Java SE 9, is the first in the new rapid release cadence Oracle announced late last year.  The new r...">
	  
	
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/java_64.png">
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<link rel="canonical" href="https://developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/338805" >
	

		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?99e6c9e30a015780" ><![endif]-->
		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?99e6c9e30a015780" >
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?99e6c9e30a015780" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?99e6c9e30a015780">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?99e6c9e30a015780"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?99e6c9e30a015780" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			'googleplus',
			'facebook',
			'twitter',
			'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//developers.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotDevelopers" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //developers.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  onclick="getModalPrefs('newUserModal', 'Create Account', 1); $('#modal_box').addClass('join'); return false;"><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Follow <a href="//slashdot.org/blog">Slashdot blog</a> updates by <a href="http://feeds.feedburner.com/SlashdotSitenews">subscribing to our blog RSS feed</a>
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
 Have you <strong><a href="https://slashdot.org/firehose.pl?op=metamod">META-MODERATED</a></strong> today? <a href="https://slashdot.org/newsletter" rel="nofollow">Sign up for the Slashdot Daily Newsletter!</a> <strong><a href="http://hshd.io/nuLx" rel="nofollow">DEAL: For $25 - Add A Second Phone Number To Your Smartphone for life! Use promo code SLASHDOT25.</a></strong>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 28 });
}
</script>
				<article id="firehose-98934387" data-fhid="98934387" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">98934387</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-98934387">
			<a href="//developers.slashdot.org/index2.pl?fhfilter=java" onclick="return addfhfilter('java');">
			
				<img src="//a.fsdn.com/sd/topics/java_64.png" width="64" height="64" alt="Java" title="Java">
			
		</a>
		
	
		
		
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=oracle" onclick="return addfhfilter('oracle');">
			
				<img src="//a.fsdn.com/sd/topics/oracle_64.png" width="64" height="64" alt="Oracle" title="Oracle">
			
		</a>
		
	
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=programming" onclick="return addfhfilter('programming');">
			
				<img src="//a.fsdn.com/sd/topics/programming_64.png" width="64" height="64" alt="Programming" title="Programming">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-98934387" class="story-title"> <a   href="//developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule">Oracle Releases Java 10, Promises Much Faster Release Schedule</a> <span class=" no extlnk"><a class="story-sourcelnk" href="https://adtmag.com/articles/2018/03/21/java-10.aspx"  title="External link - https://adtmag.com/articles/2018/03/21/java-10.aspx" target="_blank"> (adtmag.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-98934387" >119</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule#comments" title="">119</a></span>
		
	</h2>
	<div class="details" id="details-98934387">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  EditorDavid
			
		
		

		
		
		<time id="fhtime-98934387" datetime="on Saturday March 24, 2018 @02:34PM">on Saturday March 24, 2018 @02:34PM</time>
		
		
			 from the <span class="dept-text">just-in-time</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-98934387">
	
		
	

	
		
		<div id="text-98934387" class="p">
			
		 	
				An anonymous reader quotes <em>Application Development Trends:</em>
<i>Oracle announced the general availability of Java SE 10 (JDK 10) this week. This release, which comes barely six months after the release of Java SE 9, is <a href="https://adtmag.com/articles/2018/03/21/java-10.aspx">the first in the new rapid release cadence Oracle announced</a> late last year.  The new release schedule, which the company is calling an "innovation cycle," calls for a feature release every six months, update releases every quarter, and a long-term support (LTS) release every three years. Java 10 is a feature release that obsoletes Java 9. The next LTS release will be Java 11, expected in September. The next LTS version after that will be Java 17, scheduled for release in September 2021...<br> <br>
The six-month feature release cadence is meant to reduce the latency between major releases, explained is Sharat Chander, director of Oracle's Java SE Product Management group, said in a blog post.   "This release model <a href="https://blogs.oracle.com/java-platform-group/introducing-java-se-10">takes inspiration from the release models used by other platforms</a> and by various operating-system distributions addressing the modern application development landscape," Chander wrote. "The pace of innovation is happening at an ever-increasing rate and this new release model will allow developers to leverage new features in production as soon as possible. Modern application development expects simple open licensing and a predictable time-based cadence, and the new release model delivers on both." </i> <br>

This release finally adds <tt>var</tt> to the Java language (though its use is limited to local variables with initializers or declared in a for-loop).  It's being added "to improve the developer experience by <a href="http://openjdk.java.net/jeps/286">reducing the ceremony associated with writing Java code</a>, while maintaining Java's commitment to static type safety, by allowing developers to elide the often-unnecessary manifest declaration of local variable type."<br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-98934387" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule"
								  data-janrain-title="Oracle Releases Java 10, Promises Much Faster Release Schedule"
								  data-janrain-message="Oracle Releases Java 10, Promises Much Faster Release Schedule @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-98934387" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/java" target="_blank">java</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/oracle" target="_blank">oracle</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/programming" target="_blank">programming</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//tech.slashdot.org/story/18/03/24/049223/tim-berners-lee-urges-web-users-care-about-your-data?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//tech.slashdot.org/story/18/03/24/0345216/a-new-era-for-linuxs-low-level-graphics?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//tech.slashdot.org/story/18/03/24/049223/tim-berners-lee-urges-web-users-care-about-your-data?sdsrc=prev">Tim Berners-Lee Urges Web Users: 'Care About Your Data' </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//developers.slashdot.org/story/16/07/02/1639241/oracle-may-have-stopped-funding-and-developing-java-ee?sdsrc=rel">Oracle May Have Stopped Funding and Developing Java EE</a></h3><h3><a href="//developers.slashdot.org/story/16/11/13/0428203/javas-open-sourcing-still-controversial-ten-years-later?sdsrc=rel">Java's Open Sourcing Still Controversial Ten Years Later</a></h3><h3><a href="//developers.slashdot.org/story/17/06/03/0455225/java-9-delayed-due-to-modularity-controversy?sdsrc=rel">Java 9 Delayed Due To Modularity Controversy</a></h3><h3><a href="//developers.slashdot.org/story/17/09/13/1440236/java-ee-is-moving-to-the-eclipse-foundation?sdsrc=rel">Java EE Is Moving To the Eclipse Foundation</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//tech.slashdot.org/story/18/03/24/0345216/a-new-era-for-linuxs-low-level-graphics?sdsrc=next">A New Era For Linux's Low-level Graphics</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
	if ( isAdBlockActive) {
	    $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }

            }
        });

	};
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule" title="Back to Article - Oracle Releases Java 10, Promises Much Faster Release Schedule">Oracle Releases Java 10, Promises Much Faster Release Schedule</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Oracle Releases Java 10, Promises Much Faster Release Schedule" href="//developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule">Oracle Releases Java 10, Promises Much Faster Release Schedule</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=11898087" class="btn">Search <span class="totalcommentcnt">119</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//developers.slashdot.org/comments.pl?sid=11898087">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=11898087" class="ui-icon search_comments">Search <span class="totalcommentcnt">119</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//developers.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/03/24/0331253/oracle-releases-java-10-promises-much-faster-release-schedule/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?99e6c9e30a015780" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_56319729" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56319729" class="commentstatus"></div>
<div id="comment_56319729" class="cw">
	<div id="comment_top_56319729" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56319729" name="comment_link_56319729" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319729" onclick="return D2.setFocusComment(56319729)" >6 Months?</a>


		 	<span id="comment_score_56319729" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56319729); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56319729"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56319729"><p>Is this Oracles attempt to finally destroy Java for good? How enterprise friendly...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56319729">

</div>
</div>

<div id="replyto_56319729"></div>

<ul id="group_56319729">
	<li id="hiddens_56319729" class="hide"></li>
</ul>

<ul id="commtree_56319729"><li id="tree_56319847" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56319847" class="commentstatus"></div>
<div id="comment_56319847" class="cw">
	<div id="comment_top_56319847" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56319847" name="comment_link_56319847" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319847" onclick="return D2.setFocusComment(56319847)" >Re:6 Months?</a>


		 	<span id="comment_score_56319847" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56319847); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Z00L00K">Z00L00K</a>  <span class="uid"><a href="//slashdot.org/~Z00L00K">( 682162 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56319847">		
		on Saturday March 24, 2018 @03:14PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319847">#56319847</a>)
		<small><a href="http://www.bedug.com/" title="http://www.bedug.com/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56319847"><p>The 'var' that exists in C# is one of the worst ideas ever and the fact that Java didn't have it was one of the benefits of Java.</p><p>'var' is an item for lazy coders.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56319847">
<span class="ind"></span><a id="reply_link_56319847" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56319847" onclick="D2.replyTo(56319847); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=56319729" onclick="return D2.selectParent(56319729)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:6 Months? by Z00L00K @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319847" data-title="Re:6 Months?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:6 Months? by Z00L00K" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319847" data-title="Re:6 Months?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:6 Months? by Z00L00K" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319847" data-title="Re:6 Months?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11898087%26cid=56319847" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56319847" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56319847" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56319847"></div>

<ul id="group_56319847">
	<li id="hiddens_56319847" class="hide"></li>
</ul>

<ul id="commtree_56319847"><li id="tree_56319897" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56319897" class="commentstatus"></div>
<div id="comment_56319897" class="cw">
</div>

<div id="replyto_56319897"></div>

<ul id="group_56319897">
	<li id="hiddens_56319897" class="hide"></li>
</ul>

</li><li id="tree_56320025" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320025" class="commentstatus"></div>
<div id="comment_56320025" class="cw">
	<div id="comment_top_56320025" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320025" name="comment_link_56320025" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320025" onclick="return D2.setFocusComment(56320025)" >Re:</a>


		 	<span id="comment_score_56320025" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320025); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320025"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320025"><p><i>'var' is an item for lazy coders.</i><br>Please explain<nobr> <wbr></nobr>...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320025">

</div>
</div>

<div id="replyto_56320025"></div>

<ul id="group_56320025">
	<li id="hiddens_56320025" class="hide"></li>
</ul>

<ul id="commtree_56320025"><li id="tree_56320495" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320495" class="commentstatus"></div>
<div id="comment_56320495" class="cw">
	<div id="comment_top_56320495" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320495" name="comment_link_56320495" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320495" onclick="return D2.setFocusComment(56320495)" >Re:</a>


		 	<span id="comment_score_56320495" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320495); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320495"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320495"><p>Easy: He's trolling. <tt>var</tt> is actually one of the <em>best</em> features in Java, just as <tt>auto</tt> is one of the best features of modern C++. Anyone who says otherwise is trolling.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320495">

</div>
</div>

<div id="replyto_56320495"></div>

<ul id="group_56320495">
	<li id="hiddens_56320495" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56320039" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320039" class="commentstatus"></div>
<div id="comment_56320039" class="cw">
	<div id="comment_top_56320039" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320039" name="comment_link_56320039" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320039" onclick="return D2.setFocusComment(56320039)" >Re:</a>


		 	<span id="comment_score_56320039" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320039); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ChatHuant">ChatHuant</a>  <span class="uid"><a href="//slashdot.org/~ChatHuant">( 801522 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320039"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320039"><p><div class="quote"><p>'var' is an item for lazy coders.</p></div><p>'var' is necessary for anonymous types, which can be very useful in some scenarios. I do discourage lazy use of var for declaring instances of known types though.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320039">

</div>
</div>

<div id="replyto_56320039"></div>

<ul id="group_56320039">
	<li id="hiddens_56320039" class="hide"></li>
</ul>

<ul id="commtree_56320039"><li id="tree_56320063" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320063" class="commentstatus"></div>
<div id="comment_56320063" class="cw">
	<div id="comment_top_56320063" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320063" name="comment_link_56320063" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320063" onclick="return D2.setFocusComment(56320063)" >Re:</a>


		 	<span id="comment_score_56320063" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320063); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Z00L00K">Z00L00K</a>  <span class="uid"><a href="//slashdot.org/~Z00L00K">( 682162 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320063"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320063"><p>And why would you want anonymous types - it's making it just a lot harder to understand the solution and also harder to do code analysis.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320063">

</div>
</div>

<div id="replyto_56320063"></div>

<ul id="group_56320063">
	<li id="hiddens_56320063" class="hide"></li>
</ul>

<ul id="commtree_56320063"><li id="tree_56320141" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320141" class="commentstatus"></div>
<div id="comment_56320141" class="cw">
	<div id="comment_top_56320141" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320141" name="comment_link_56320141" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320141" onclick="return D2.setFocusComment(56320141)" >Re:</a>


		 	<span id="comment_score_56320141" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320141); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ChatHuant">ChatHuant</a>  <span class="uid"><a href="//slashdot.org/~ChatHuant">( 801522 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320141"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320141"><p><div class="quote"><p>And why would you want anonymous types</p></div><p>It's another tool in a programmer's toolbox; if used properly, it saves time and effort. It saves you from a proliferation of classes that will only be used once, in some method scope. Having to distinguish for example between class Employee; class EmployeeDataFromDatabase; class EmployeeFilteredBySalary; class EmployeeWithSalaryAndBonus etc will NOT help with maintainability.</p><p>The compiler also defines GetHashCode/Equals for you implicitly, so you can use anonymous types in LINQ queries with less bother.</p><p><div class="quote"><p>it's making it just a lot harder to understand the solution</p></div><p>Anon<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320141">

</div>
</div>

<div id="replyto_56320141"></div>

<ul id="group_56320141">
	<li id="hiddens_56320141" class="hide"></li>
</ul>

<ul id="commtree_56320141"><li id="tree_56320369" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320369" class="commentstatus"></div>
<div id="comment_56320369" class="cw">
</div>

<div id="replyto_56320369"></div>

<ul id="group_56320369">
	<li id="hiddens_56320369" class="hide"></li>
</ul>

<ul id="commtree_56320369"><li id="tree_56320883" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320883" class="commentstatus"></div>
<div id="comment_56320883" class="cw">
	<div id="comment_top_56320883" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320883" name="comment_link_56320883" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320883" onclick="return D2.setFocusComment(56320883)" >Re:</a>


		 	<span id="comment_score_56320883" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320883); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~radarskiy">radarskiy</a>  <span class="uid"><a href="//slashdot.org/~radarskiy">( 2874255 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320883"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320883"><p>Idiot. Do you not understand OOP?</p><p>You declare the variable as the superclass when you want polymorphism. In ChatHuant's example, only inheritance is desired.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320883">

</div>
</div>

<div id="replyto_56320883"></div>

<ul id="group_56320883">
	<li id="hiddens_56320883" class="hide"></li>
</ul>

<ul id="commtree_56320883"><li id="tree_56320927" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320927" class="commentstatus"></div>
<div id="comment_56320927" class="cw">
</div>

<div id="replyto_56320927"></div>

<ul id="group_56320927">
	<li id="hiddens_56320927" class="hide"></li>
</ul>

</li><li id="hidestring_56320883"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56320883">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56321115" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321115" class="commentstatus"></div>
<div id="comment_56321115" class="cw">
	<div id="comment_top_56321115" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321115" name="comment_link_56321115" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321115" onclick="return D2.setFocusComment(56321115)" >Re:</a>


		 	<span id="comment_score_56321115" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321115); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321115"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321115"><p>You don't know what var is about<nobr> <wbr></nobr>... makes you look like an idiot.</p><p>No var:<br><span class="substr"> </span> <tt> <br>
    HashMap&lt;String,Employee&gt; employeeByName = new HashMap&lt;String,Employee&gt;();<br> </tt> </p><p>Why do I have to write the left hand side before employeeByName when the compiler and a human reader implicitly sees that the type should be "HashMap&lt;String,Employee&gt;" ?</p><p>Hence we like to write:<br>
 <tt> <br>
    <b>var</b> employeeByName = new HashMap&lt;String,Employee&gt;();<br> </tt> </p><p>And all that has nothing to do w</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321115">

</div>
</div>

<div id="replyto_56321115"></div>

<ul id="group_56321115">
	<li id="hiddens_56321115" class="hide"></li>
</ul>

<ul id="commtree_56321115"><li id="tree_56321523" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321523" class="commentstatus"></div>
<div id="comment_56321523" class="cw">
	<div id="comment_top_56321523" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321523" name="comment_link_56321523" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321523" onclick="return D2.setFocusComment(56321523)" >Re:</a>


		 	<span id="comment_score_56321523" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321523); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Z00L00K">Z00L00K</a>  <span class="uid"><a href="//slashdot.org/~Z00L00K">( 682162 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321523"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321523"><p>var is about creating code that is harder to read and maintain. The type isn't clear until it's assigned and that is a ticking bomb.</p><p>Maintainability of the code is essential in the long run. If you have to write some extra at the declaration is not a major issue.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321523">

</div>
</div>

<div id="replyto_56321523"></div>

<ul id="group_56321523">
	<li id="hiddens_56321523" class="hide"></li>
</ul>

<ul id="commtree_56321523"><li id="tree_56321591" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321591" class="commentstatus"></div>
<div id="comment_56321591" class="cw">
	<div id="comment_top_56321591" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321591" name="comment_link_56321591" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321591" onclick="return D2.setFocusComment(56321591)" >Re:</a>


		 	<span id="comment_score_56321591" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321591); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321591"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321591"><p>Erm,<br>the assignment is in the same line as the var is, obviously. How can you not know the type?<br>No one is declaring variables with var at the top of a method and starts assigning values several lines later<nobr> <wbr></nobr>...</p><p><i>If you have to write some extra at the declaration is not a major issue.</i><br>Actually that is what most developers hate: verbosity.<br>So it is not an issue, but an annoyance.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321591">

</div>
</div>

<div id="replyto_56321591"></div>

<ul id="group_56321591">
	<li id="hiddens_56321591" class="hide"></li>
</ul>

</li><li id="tree_56322147" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56322147" class="commentstatus"></div>
<div id="comment_56322147" class="cw">
	<div id="comment_top_56322147" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56322147" name="comment_link_56322147" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56322147" onclick="return D2.setFocusComment(56322147)" >Re: 6 Months?</a>


		 	<span id="comment_score_56322147" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56322147); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~spongman">spongman</a>  <span class="uid"><a href="//slashdot.org/~spongman">( 182339 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56322147"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56322147"><p>You can't use car unless it's assigned a value in the declaration.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56322147">

</div>
</div>

<div id="replyto_56322147"></div>

<ul id="group_56322147">
	<li id="hiddens_56322147" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56321805" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321805" class="commentstatus"></div>
<div id="comment_56321805" class="cw">
	<div id="comment_top_56321805" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321805" name="comment_link_56321805" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321805" onclick="return D2.setFocusComment(56321805)" >Re:</a>


		 	<span id="comment_score_56321805" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321805); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ayesnymous">ayesnymous</a>  <span class="uid"><a href="//slashdot.org/~ayesnymous">( 3665205 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321805"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321805">In Java 7 and later, you can just do: HashMap employeeByName = new HashMap();</div>
	</div>

	<div class="commentSub" id="comment_sub_56321805">

</div>
</div>

<div id="replyto_56321805"></div>

<ul id="group_56321805">
	<li id="hiddens_56321805" class="hide"></li>
</ul>

<ul id="commtree_56321805"><li id="tree_56321807" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321807" class="commentstatus"></div>
<div id="comment_56321807" class="cw">
	<div id="comment_top_56321807" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321807" name="comment_link_56321807" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321807" onclick="return D2.setFocusComment(56321807)" >Re:</a>


		 	<span id="comment_score_56321807" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321807); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ayesnymous">ayesnymous</a>  <span class="uid"><a href="//slashdot.org/~ayesnymous">( 3665205 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321807"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321807">Disregard previous post, I had stuff in angle brackets that got deleted, not going to bother to fix that.</div>
	</div>

	<div class="commentSub" id="comment_sub_56321807">

</div>
</div>

<div id="replyto_56321807"></div>

<ul id="group_56321807">
	<li id="hiddens_56321807" class="hide"></li>
</ul>

</li><li id="tree_56321979" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321979" class="commentstatus"></div>
<div id="comment_56321979" class="cw">
	<div id="comment_top_56321979" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321979" name="comment_link_56321979" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321979" onclick="return D2.setFocusComment(56321979)" >Re:</a>


		 	<span id="comment_score_56321979" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321979); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321979"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321979"><p>You could always do that<nobr> <wbr></nobr>:D<br>But perhaps you mean the new diamond constructor?</p><p>HashMap&lt;String, Employee&gt; map = new HashMap&lt;&gt;();</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321979">

</div>
</div>

<div id="replyto_56321979"></div>

<ul id="group_56321979">
	<li id="hiddens_56321979" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_56322011" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56322011" class="commentstatus"></div>
<div id="comment_56322011" class="cw">
	<div id="comment_top_56322011" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56322011" name="comment_link_56322011" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56322011" onclick="return D2.setFocusComment(56322011)" >Re:</a>


		 	<span id="comment_score_56322011" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56322011); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56322011"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56322011"><p><div class="quote"><p>Do you not understand OOP?</p></div><p>Many people don't. You, for example. Yes, Smalltalk doesn't need var. Of course, it doesn't need to "declare the variable with the highest superclass" either.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56322011">

</div>
</div>

<div id="replyto_56322011"></div>

<ul id="group_56322011">
	<li id="hiddens_56322011" class="hide"></li>
</ul>

</li></ul></li><li id="hidestring_56320141"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56320141">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56320205" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320205" class="commentstatus"></div>
<div id="comment_56320205" class="cw">
	<div id="comment_top_56320205" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320205" name="comment_link_56320205" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320205" onclick="return D2.setFocusComment(56320205)" >Re:</a>


		 	<span id="comment_score_56320205" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320205); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~PmanAce">PmanAce</a>  <span class="uid"><a href="//slashdot.org/~PmanAce">( 1679902 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320205"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320205">Wrong, why would I need to declare a class for a one time use in the same context? I had to do something similar just this week, create an anonymous object comprising of 2 fields from a class that had 10+ more but didn't need them.</div>
	</div>

	<div class="commentSub" id="comment_sub_56320205">

</div>
</div>

<div id="replyto_56320205"></div>

<ul id="group_56320205">
	<li id="hiddens_56320205" class="hide"></li>
</ul>

</li><li id="tree_56321039" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321039" class="commentstatus"></div>
<div id="comment_56321039" class="cw">
	<div id="comment_top_56321039" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321039" name="comment_link_56321039" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321039" onclick="return D2.setFocusComment(56321039)" >Re:</a>


		 	<span id="comment_score_56321039" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321039); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ndykman">ndykman</a>  <span class="uid"><a href="//slashdot.org/~ndykman">( 659315 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321039"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321039"><p>For the same reason Scala and Go has them, when dealing with functional programming with classes it is really useful to select and filter only the wanted properties of objects (possibly with multiple different types, mind you) without having to declare every possible permutation of them as it's own class. It's still type checked and you don't lose type safety. There's more advanced uses as well.</p><p>I know it is easy to think C# must be bad because of Microsoft, but it is a very well designed language and other<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321039">

</div>
</div>

<div id="replyto_56321039"></div>

<ul id="group_56321039">
	<li id="hiddens_56321039" class="hide"></li>
</ul>

</li><li id="tree_56321057" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56321057" class="commentstatus"></div>
<div id="comment_56321057" class="cw">
</div>

<div id="replyto_56321057"></div>

<ul id="group_56321057">
	<li id="hiddens_56321057" class="hide"></li>
</ul>

</li><li id="hidestring_56320063"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56320063">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56320877" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320877" class="commentstatus"></div>
<div id="comment_56320877" class="cw">
</div>

<div id="replyto_56320877"></div>

<ul id="group_56320877">
	<li id="hiddens_56320877" class="hide"></li>
</ul>

</li><li id="hidestring_56320039"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56320039">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56320199" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320199" class="commentstatus"></div>
<div id="comment_56320199" class="cw">
	<div id="comment_top_56320199" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320199" name="comment_link_56320199" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320199" onclick="return D2.setFocusComment(56320199)" >Re:</a>


		 	<span id="comment_score_56320199" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320199); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~PmanAce">PmanAce</a>  <span class="uid"><a href="//slashdot.org/~PmanAce">( 1679902 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320199"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320199">Speak for yourself. It is not an item for lazy coders, if I can write less code, the better. Having to write twice in most cases the type to declare a variable, it's so antiquated! The compiler already knows the type, and so should you! You should already be writing clean code anyways, method names should be concise and clear.</div>
	</div>

	<div class="commentSub" id="comment_sub_56320199">

</div>
</div>

<div id="replyto_56320199"></div>

<ul id="group_56320199">
	<li id="hiddens_56320199" class="hide"></li>
</ul>

</li><li id="tree_56320325" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320325" class="commentstatus"></div>
<div id="comment_56320325" class="cw">
</div>

<div id="replyto_56320325"></div>

<ul id="group_56320325">
	<li id="hiddens_56320325" class="hide"></li>
</ul>

</li><li id="tree_56320691" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320691" class="commentstatus"></div>
<div id="comment_56320691" class="cw">
	<div id="comment_top_56320691" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320691" name="comment_link_56320691" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320691" onclick="return D2.setFocusComment(56320691)" >Re:</a>


		 	<span id="comment_score_56320691" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320691); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ls671">ls671</a>  <span class="uid"><a href="//slashdot.org/~ls671">( 1122017 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320691"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320691"><p>I agree, in Java, it is recommended to declare variables as Object since it is an OO language. And this works since java 1.0!</p><p>Here is how I do it:</p><p>Object locale =  new java.util.Locale("US");<br>Object count = new Integer("0");<br>Object lowerCase = "USA".toLowerCase();</p><p>This way, you will never encounter type problems!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320691">

</div>
</div>

<div id="replyto_56320691"></div>

<ul id="group_56320691">
	<li id="hiddens_56320691" class="hide"></li>
</ul>

<ul id="commtree_56320691"><li id="tree_56321093" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321093" class="commentstatus"></div>
<div id="comment_56321093" class="cw">
	<div id="comment_top_56321093" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321093" name="comment_link_56321093" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321093" onclick="return D2.setFocusComment(56321093)" >Re:</a>


		 	<span id="comment_score_56321093" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321093); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321093"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321093"><p>Well,<br>I just tried it, but<br><tt><br>
&nbsp; &nbsp; System.out.prinline(locale.toLowerCase());<br></tt><br>does not compile<nobr> <wbr></nobr>... can you tell me why?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321093">

</div>
</div>

<div id="replyto_56321093"></div>

<ul id="group_56321093">
	<li id="hiddens_56321093" class="hide"></li>
</ul>

<ul id="commtree_56321093"><li id="tree_56321175" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321175" class="commentstatus"></div>
<div id="comment_56321175" class="cw">
	<div id="comment_top_56321175" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321175" name="comment_link_56321175" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321175" onclick="return D2.setFocusComment(56321175)" >Re:</a>


		 	<span id="comment_score_56321175" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321175); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ls671">ls671</a>  <span class="uid"><a href="//slashdot.org/~ls671">( 1122017 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321175"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321175"><p>Sure! It is easy!</p><p>Do:<br>
&nbsp; System.out.println(locale.toString().toLowerCase());</p><p>aahhh... beginners that weren't there circa 1.0!<nobr> <wbr></nobr>:)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321175">

</div>
</div>

<div id="replyto_56321175"></div>

<ul id="group_56321175">
	<li id="hiddens_56321175" class="hide"></li>
</ul>

<ul id="commtree_56321175"><li id="tree_56321191" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321191" class="commentstatus"></div>
<div id="comment_56321191" class="cw">
	<div id="comment_top_56321191" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321191" name="comment_link_56321191" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321191" onclick="return D2.setFocusComment(56321191)" >Re:</a>


		 	<span id="comment_score_56321191" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321191); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321191"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321191"><p>Hehe, nice try<nobr> <wbr></nobr>:D</p><p>Actually my original code would have compiled, because there is a println() method that accepts Object's and calls toString() on them<nobr> <wbr></nobr>... the parent was just an idiot I liked to tease.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321191">

</div>
</div>

<div id="replyto_56321191"></div>

<ul id="group_56321191">
	<li id="hiddens_56321191" class="hide"></li>
</ul>

<ul id="commtree_56321191"><li id="tree_56321239" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321239" class="commentstatus"></div>
<div id="comment_56321239" class="cw">
	<div id="comment_top_56321239" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321239" name="comment_link_56321239" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321239" onclick="return D2.setFocusComment(56321239)" >Re:</a>


		 	<span id="comment_score_56321239" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321239); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ls671">ls671</a>  <span class="uid"><a href="//slashdot.org/~ls671">( 1122017 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321239"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321239"><p>Nope, your code would never have compiled.</p><p>System.out.println(locale.toLowerCase());</p><p>wouldn't have compiled since<nobr> <wbr></nobr>.toLowerCase() is undefined for Object types.</p><p>This would have compiled although and I understand that this was what you were trying to say:</p><p>System.out.println(locale);</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321239">

</div>
</div>

<div id="replyto_56321239"></div>

<ul id="group_56321239">
	<li id="hiddens_56321239" class="hide"></li>
</ul>

<ul id="commtree_56321239"><li id="tree_56321291" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321291" class="commentstatus"></div>
<div id="comment_56321291" class="cw">
	<div id="comment_top_56321291" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321291" name="comment_link_56321291" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321291" onclick="return D2.setFocusComment(56321291)" >Re:</a>


		 	<span id="comment_score_56321291" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321291); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321291"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321291"><p>Ah, right, that actually was my original point.<br>However your "object.toString()" misslead me again<nobr> <wbr></nobr>...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321291">

</div>
</div>

<div id="replyto_56321291"></div>

<ul id="group_56321291">
	<li id="hiddens_56321291" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li></ul></li><li id="tree_56320995" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320995" class="commentstatus"></div>
<div id="comment_56320995" class="cw">
	<div id="comment_top_56320995" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320995" name="comment_link_56320995" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320995" onclick="return D2.setFocusComment(56320995)" >Re:</a>


		 	<span id="comment_score_56320995" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320995); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mikaere">mikaere</a>  <span class="uid"><a href="//slashdot.org/~mikaere">( 748605 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320995"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320995">I call bollocks on this.  I use var all the time in C# - it simply does not hinder understanding at all.  If you adhere to principles of clean code then your methods should be small and entirely focused on one thing (aka Single Responsibility).  And, of course, the variable names should clearly indicate their role or purpose.  Repeating the in the variable declaration simply adds noise (making the code dirtier, not cleaner).
<br> <br>
Let me guess - you love using static method calls and can't see the point of unit</div>
	</div>

	<div class="commentSub" id="comment_sub_56320995">

</div>
</div>

<div id="replyto_56320995"></div>

<ul id="group_56320995">
	<li id="hiddens_56320995" class="hide"></li>
</ul>

<ul id="commtree_56320995"><li id="tree_56321061" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56321061" class="commentstatus"></div>
<div id="comment_56321061" class="cw">
</div>

<div id="replyto_56321061"></div>

<ul id="group_56321061">
	<li id="hiddens_56321061" class="hide"></li>
</ul>

</li><li id="hidestring_56320995"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56320995">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56321047" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56321047" class="commentstatus"></div>
<div id="comment_56321047" class="cw">
</div>

<div id="replyto_56321047"></div>

<ul id="group_56321047">
	<li id="hiddens_56321047" class="hide"></li>
</ul>

</li><li id="tree_56319865" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56319865" class="commentstatus"></div>
<div id="comment_56319865" class="cw">
</div>

<div id="replyto_56319865"></div>

<ul id="group_56319865">
	<li id="hiddens_56319865" class="hide"></li>
</ul>

<ul id="commtree_56319865"><li id="tree_56320029" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320029" class="commentstatus"></div>
<div id="comment_56320029" class="cw">
	<div id="comment_top_56320029" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320029" name="comment_link_56320029" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320029" onclick="return D2.setFocusComment(56320029)" >Re:</a>


		 	<span id="comment_score_56320029" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320029); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320029"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320029"><p>So you'd prefer to write code of the form</p><p>FooBarObjectWithALongAssName foo = new FooBarObjectWithALongAssName();</p><p>Rather than</p><p>var foo = new FooBarObjectWithALongAssName();</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320029">

</div>
</div>

<div id="replyto_56320029"></div>

<ul id="group_56320029">
	<li id="hiddens_56320029" class="hide"></li>
</ul>

<ul id="commtree_56320029"><li id="tree_56320059" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320059" class="commentstatus"></div>
<div id="comment_56320059" class="cw">
	<div id="comment_top_56320059" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320059" name="comment_link_56320059" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320059" onclick="return D2.setFocusComment(56320059)" >Re:</a>


		 	<span id="comment_score_56320059" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320059); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ChatHuant">ChatHuant</a>  <span class="uid"><a href="//slashdot.org/~ChatHuant">( 801522 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320059"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320059"><p>In my team, I allow using <i>var</i> in this case; however</p><blockquote><div><p> <tt>var foo = GetFooBarObjectWithALongAssName();</tt></p></div> </blockquote><p>is not allowed, because it makes maintaining the code more difficult.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320059">

</div>
</div>

<div id="replyto_56320059"></div>

<ul id="group_56320059">
	<li id="hiddens_56320059" class="hide"></li>
</ul>

<ul id="commtree_56320059"><li id="tree_56321305" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321305" class="commentstatus"></div>
<div id="comment_56321305" class="cw">
	<div id="comment_top_56321305" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321305" name="comment_link_56321305" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321305" onclick="return D2.setFocusComment(56321305)" >Re:</a>


		 	<span id="comment_score_56321305" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321305); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Dog-Cow">Dog-Cow</a>  <span class="uid"><a href="//slashdot.org/~Dog-Cow">( 21281 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321305"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321305"><p>If <i>that</i> makes your code more difficult to maintain, it was already a mass of shit.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321305">

</div>
</div>

<div id="replyto_56321305"></div>

<ul id="group_56321305">
	<li id="hiddens_56321305" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56320165" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320165" class="commentstatus"></div>
<div id="comment_56320165" class="cw">
</div>

<div id="replyto_56320165"></div>

<ul id="group_56320165">
	<li id="hiddens_56320165" class="hide"></li>
</ul>

</li><li id="tree_56320847" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320847" class="commentstatus"></div>
<div id="comment_56320847" class="cw">
</div>

<div id="replyto_56320847"></div>

<ul id="group_56320847">
	<li id="hiddens_56320847" class="hide"></li>
</ul>

</li><li id="tree_56321961" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321961" class="commentstatus"></div>
<div id="comment_56321961" class="cw">
	<div id="comment_top_56321961" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321961" name="comment_link_56321961" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321961" onclick="return D2.setFocusComment(56321961)" >Re:</a>


		 	<span id="comment_score_56321961" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321961); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Sesostris+III">Sesostris III</a>  <span class="uid"><a href="//slashdot.org/~Sesostris+III">( 730910 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321961"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321961">Excepting standard Java objects, I would probably declare against an interface and instantiate using a setter. Makes unit testing of the calling class easier as you can mock out the object.
<br> <br>
If I did declare and instantiate in the same statement, I would copy/paste the name anyway!</div>
	</div>

	<div class="commentSub" id="comment_sub_56321961">

</div>
</div>

<div id="replyto_56321961"></div>

<ul id="group_56321961">
	<li id="hiddens_56321961" class="hide"></li>
</ul>

</li><li id="hidestring_56320029"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56320029">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56320261" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320261" class="commentstatus"></div>
<div id="comment_56320261" class="cw">
</div>

<div id="replyto_56320261"></div>

<ul id="group_56320261">
	<li id="hiddens_56320261" class="hide"></li>
</ul>

</li><li id="tree_56320767" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320767" class="commentstatus"></div>
<div id="comment_56320767" class="cw">
	<div id="comment_top_56320767" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320767" name="comment_link_56320767" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320767" onclick="return D2.setFocusComment(56320767)" >Re:</a>


		 	<span id="comment_score_56320767" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320767); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320767"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320767">How on earth do you find a C# dev that doesn't use var <i>ever</i>? <br>
Maybe you should have just ended the interview after they said they use C#. That's just as arbitrary but more likely to yield good results.</div>
	</div>

	<div class="commentSub" id="comment_sub_56320767">

</div>
</div>

<div id="replyto_56320767"></div>

<ul id="group_56320767">
	<li id="hiddens_56320767" class="hide"></li>
</ul>

</li><li id="tree_56321171" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56321171" class="commentstatus"></div>
<div id="comment_56321171" class="cw">
</div>

<div id="replyto_56321171"></div>

<ul id="group_56321171">
	<li id="hiddens_56321171" class="hide"></li>
</ul>

</li><li id="tree_56321189" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56321189" class="commentstatus"></div>
<div id="comment_56321189" class="cw">
</div>

<div id="replyto_56321189"></div>

<ul id="group_56321189">
	<li id="hiddens_56321189" class="hide"></li>
</ul>

</li><li id="tree_56322143" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56322143" class="commentstatus"></div>
<div id="comment_56322143" class="cw">
	<div id="comment_top_56322143" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56322143" name="comment_link_56322143" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56322143" onclick="return D2.setFocusComment(56322143)" >Re: 6 Months?</a>


		 	<span id="comment_score_56322143" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56322143); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~spongman">spongman</a>  <span class="uid"><a href="//slashdot.org/~spongman">( 182339 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56322143"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56322143"><p>Anything containing an anonymous type?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56322143">

</div>
</div>

<div id="replyto_56322143"></div>

<ul id="group_56322143">
	<li id="hiddens_56322143" class="hide"></li>
</ul>

</li><li id="hidestring_56319865"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56319865">3 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_56319847"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56319847">3 replies</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_56319809" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56319809" class="commentstatus"></div>
<div id="comment_56319809" class="cw">
	<div id="comment_top_56319809" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56319809" name="comment_link_56319809" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319809" onclick="return D2.setFocusComment(56319809)" >So the one good thing: corporate stability is gone</a>


		 	<span id="comment_score_56319809" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56319809); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56319809"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56319809"><p>There are other things I like about Java but a lot of them were stripped away by Oracle and the language "innovation". I like slow and stable. That's what Java was about. Not running after every fad. Thinking and taking things slowly.</p><p>That's gone. Shame.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56319809">

</div>
</div>

<div id="replyto_56319809"></div>

<ul id="group_56319809">
	<li id="hiddens_56319809" class="hide"></li>
</ul>

</li><li id="tree_56319845" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56319845" class="commentstatus"></div>
<div id="comment_56319845" class="cw">
	<div id="comment_top_56319845" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56319845" name="comment_link_56319845" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319845" onclick="return D2.setFocusComment(56319845)" >So....Even MORE Broken Then?</a>


		 	<span id="comment_score_56319845" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56319845); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Templer421">Templer421</a>  <span class="uid"><a href="//slashdot.org/~Templer421">( 4988421 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56319845">		
		on Saturday March 24, 2018 @03:14PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319845">#56319845</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56319845"><p>Problem with JAVA is syncing up all the damn versions between servers and clients.</p><p>FASTER versions isn't helping.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56319845">
<span class="ind"></span><a id="reply_link_56319845" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56319845" onclick="D2.replyTo(56319845); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="So....Even MORE Broken Then? by Templer421 @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319845" data-title="So....Even MORE Broken Then?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="So....Even MORE Broken Then? by Templer421" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319845" data-title="So....Even MORE Broken Then?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="So....Even MORE Broken Then? by Templer421" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319845" data-title="So....Even MORE Broken Then?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11898087%26cid=56319845" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56319845" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56319845" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56319845"></div>

<ul id="group_56319845">
	<li id="hiddens_56319845" class="hide"></li>
</ul>

<ul id="commtree_56319845"><li id="tree_56319899" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56319899" class="commentstatus"></div>
<div id="comment_56319899" class="cw">
	<div id="comment_top_56319899" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56319899" name="comment_link_56319899" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319899" onclick="return D2.setFocusComment(56319899)" >Re:</a>


		 	<span id="comment_score_56319899" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56319899); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~e432776">e432776</a>  <span class="uid"><a href="//slashdot.org/~e432776">( 4495975 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56319899"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56319899">I clicked on the story just to post this. Why are more frequent releases per unit time a good thing? What shortcoming in Java does this address? Those more knowledgeable might be able to say something, but I thought the stability was a *good* thing...</div>
	</div>

	<div class="commentSub" id="comment_sub_56319899">

</div>
</div>

<div id="replyto_56319899"></div>

<ul id="group_56319899">
	<li id="hiddens_56319899" class="hide"></li>
</ul>

<ul id="commtree_56319899"><li id="tree_56320131" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320131" class="commentstatus"></div>
<div id="comment_56320131" class="cw">
</div>

<div id="replyto_56320131"></div>

<ul id="group_56320131">
	<li id="hiddens_56320131" class="hide"></li>
</ul>

<ul id="commtree_56320131"><li id="tree_56320209" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56320209" class="commentstatus"></div>
<div id="comment_56320209" class="cw">
	<div id="comment_top_56320209" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320209" name="comment_link_56320209" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320209" onclick="return D2.setFocusComment(56320209)" >Re:So....Even MORE released Then?</a>


		 	<span id="comment_score_56320209" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320209); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~careysub">careysub</a>  <span class="uid"><a href="//slashdot.org/~careysub">( 976506 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320209">		
		on Saturday March 24, 2018 @05:04PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320209">#56320209</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320209"><p><div class="quote"><p>Why is "release early, release often" good for Linux, but not Java?</p></div><p>The correct comparison is between Linux releases and JVM releases. If you want to have new improved JVMs for the same language specification, go nuts, its all good. Everything will continue to run on the <b>virtual</b> machine, just like applications continue to run on the <b>actual</b> machine with Linux releases. Changing the Java language is akin to changing the Linux API. That would create application compatibility problems at the very least, most likely break many.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320209">
<span class="ind"></span><a id="reply_link_56320209" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56320209" onclick="D2.replyTo(56320209); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=56320131" onclick="return D2.selectParent(56320131)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:So....Even MORE released Then? by careysub @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56320209" data-title="Re:So....Even MORE released Then?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:So....Even MORE released Then? by careysub" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56320209" data-title="Re:So....Even MORE released Then?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:So....Even MORE released Then? by careysub" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56320209" data-title="Re:So....Even MORE released Then?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11898087%26cid=56320209" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56320209" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56320209" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56320209"></div>

<ul id="group_56320209">
	<li id="hiddens_56320209" class="hide"></li>
</ul>

<ul id="commtree_56320209"><li id="tree_56320639" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320639" class="commentstatus"></div>
<div id="comment_56320639" class="cw">
	<div id="comment_top_56320639" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320639" name="comment_link_56320639" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320639" onclick="return D2.setFocusComment(56320639)" >Re:</a>


		 	<span id="comment_score_56320639" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320639); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Billly+Gates">Billly Gates</a>  <span class="uid"><a href="//slashdot.org/~Billly+Gates">( 198444 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320639"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320639"><p>From a system administrator and desktop support angle this also creates a nightmare scenario of breaking client endpoint applications such as SAP or other IE specific websites.</p><p>Java 6,7,8, and 9 runtimes are incompatible with each other. Companies want one ancient jre to rule them all. Now the developers have to keep their apps secure BUT use an unpatched JRE or else the customer will find someone else who will. LOL</p><p>Gee this is why kids today don't want to learn Java.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320639">

</div>
</div>

<div id="replyto_56320639"></div>

<ul id="group_56320639">
	<li id="hiddens_56320639" class="hide"></li>
</ul>

<ul id="commtree_56320639"><li id="tree_56321067" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321067" class="commentstatus"></div>
<div id="comment_56321067" class="cw">
	<div id="comment_top_56321067" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321067" name="comment_link_56321067" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321067" onclick="return D2.setFocusComment(56321067)" >Re:</a>


		 	<span id="comment_score_56321067" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321067); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321067"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321067"><p><i>Java 6,7,8, and 9 runtimes are incompatible with each other.</i><br>What is that supposed to mean?</p><p>A application compiled for Java 6 runs just fine on a Java 8 VM, and I would bet on Java 9, too.</p><p>To launch an Application with the "correct" JVM you have that magical thing called a PATH variable. You can have as many Java installations on your computer as you have disk space, nothing special here, nothing incompatible.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321067">

</div>
</div>

<div id="replyto_56321067"></div>

<ul id="group_56321067">
	<li id="hiddens_56321067" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56321059" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321059" class="commentstatus"></div>
<div id="comment_56321059" class="cw">
	<div id="comment_top_56321059" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321059" name="comment_link_56321059" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321059" onclick="return D2.setFocusComment(56321059)" >Re:</a>


		 	<span id="comment_score_56321059" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321059); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321059"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321059"><p>Upgrading to a new Java version hardly ever broke anything.</p><p>Java uses an annotation to @depricate parts of APIs<nobr> <wbr></nobr>... but keeps those parts around for several versions.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321059">

</div>
</div>

<div id="replyto_56321059"></div>

<ul id="group_56321059">
	<li id="hiddens_56321059" class="hide"></li>
</ul>

<ul id="commtree_56321059"><li id="tree_56321319" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321319" class="commentstatus"></div>
<div id="comment_56321319" class="cw">
	<div id="comment_top_56321319" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321319" name="comment_link_56321319" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321319" onclick="return D2.setFocusComment(56321319)" >Re:</a>


		 	<span id="comment_score_56321319" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321319); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Dog-Cow">Dog-Cow</a>  <span class="uid"><a href="//slashdot.org/~Dog-Cow">( 21281 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321319"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321319"><p>You must not have been around in the early days.  Perhaps it's better now, but I remember Java 1.x releases.  There wasn't even forward compatibility at that point.  That is, applications compiled with Java 1.2 would not always run correctly, or at all, on 1.3 VMs.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321319">

</div>
</div>

<div id="replyto_56321319"></div>

<ul id="group_56321319">
	<li id="hiddens_56321319" class="hide"></li>
</ul>

<ul id="commtree_56321319"><li id="tree_56321583" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321583" class="commentstatus"></div>
<div id="comment_56321583" class="cw">
	<div id="comment_top_56321583" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321583" name="comment_link_56321583" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321583" onclick="return D2.setFocusComment(56321583)" >Re:</a>


		 	<span id="comment_score_56321583" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321583); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321583"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321583"><p>I never had a problem like that.<br>But usually when you are developing and mid term you upgrade the VM/JDK, you recompile anyway.</p><p>Hm, I believe there was indeed a problem with Java 1.3, I remember Java 1.4 broke serialization on IBM VMs, or cross serialization between IBMs and SUNs VMs<nobr> <wbr></nobr>... don't remember.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321583">

</div>
</div>

<div id="replyto_56321583"></div>

<ul id="group_56321583">
	<li id="hiddens_56321583" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li><li id="tree_56320327" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320327" class="commentstatus"></div>
<div id="comment_56320327" class="cw">
</div>

<div id="replyto_56320327"></div>

<ul id="group_56320327">
	<li id="hiddens_56320327" class="hide"></li>
</ul>

</li><li id="hidestring_56319899"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56319899">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56320781" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320781" class="commentstatus"></div>
<div id="comment_56320781" class="cw">
</div>

<div id="replyto_56320781"></div>

<ul id="group_56320781">
	<li id="hiddens_56320781" class="hide"></li>
</ul>

</li><li id="hidestring_56319845"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56319845">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56319853" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56319853" class="commentstatus"></div>
<div id="comment_56319853" class="cw">
	<div id="comment_top_56319853" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56319853" name="comment_link_56319853" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319853" onclick="return D2.setFocusComment(56319853)" >Instead of not updating the JRE every few years</a>


		 	<span id="comment_score_56319853" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56319853); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Shemmie">Shemmie</a>  <span class="uid"><a href="//slashdot.org/~Shemmie">( 909181 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56319853">		
		on Saturday March 24, 2018 @03:15PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319853">#56319853</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56319853"><p>I'll now not update it on a 6 monthly basis?<nobr> <wbr></nobr>:/</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56319853">
<span class="ind"></span><a id="reply_link_56319853" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56319853" onclick="D2.replyTo(56319853); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Instead of not updating the JRE every few years by Shemmie @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319853" data-title="Instead of not updating the JRE every few years">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Instead of not updating the JRE every few years by Shemmie" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319853" data-title="Instead of not updating the JRE every few years">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Instead of not updating the JRE every few years by Shemmie" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319853" data-title="Instead of not updating the JRE every few years">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11898087%26cid=56319853" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56319853" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56319853" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56319853"></div>

<ul id="group_56319853">
	<li id="hiddens_56319853" class="hide"></li>
</ul>

<ul id="commtree_56319853"><li id="tree_56319873" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56319873" class="commentstatus"></div>
<div id="comment_56319873" class="cw">
</div>

<div id="replyto_56319873"></div>

<ul id="group_56319873">
	<li id="hiddens_56319873" class="hide"></li>
</ul>

<ul id="commtree_56319873"><li id="tree_56320005" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320005" class="commentstatus"></div>
<div id="comment_56320005" class="cw">
	<div id="comment_top_56320005" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320005" name="comment_link_56320005" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320005" onclick="return D2.setFocusComment(56320005)" >Re:</a>


		 	<span id="comment_score_56320005" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320005); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Billly+Gates">Billly Gates</a>  <span class="uid"><a href="//slashdot.org/~Billly+Gates">( 198444 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320005"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320005"><p>Shrugs shoulders and will keep installing Java6 and java7 JRes for my users.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320005">

</div>
</div>

<div id="replyto_56320005"></div>

<ul id="group_56320005">
	<li id="hiddens_56320005" class="hide"></li>
</ul>

<ul id="commtree_56320005"><li id="tree_56320759" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320759" class="commentstatus"></div>
<div id="comment_56320759" class="cw">
	<div id="comment_top_56320759" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320759" name="comment_link_56320759" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320759" onclick="return D2.setFocusComment(56320759)" >Re:</a>


		 	<span id="comment_score_56320759" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320759); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ls671">ls671</a>  <span class="uid"><a href="//slashdot.org/~ls671">( 1122017 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320759"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320759"><p>I guess you could move to java 8. I plan to stay on 8 for while.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320759">

</div>
</div>

<div id="replyto_56320759"></div>

<ul id="group_56320759">
	<li id="hiddens_56320759" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56321193" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56321193" class="commentstatus"></div>
<div id="comment_56321193" class="cw">
</div>

<div id="replyto_56321193"></div>

<ul id="group_56321193">
	<li id="hiddens_56321193" class="hide"></li>
</ul>

</li><li id="tree_56321321" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321321" class="commentstatus"></div>
<div id="comment_56321321" class="cw">
	<div id="comment_top_56321321" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321321" name="comment_link_56321321" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321321" onclick="return D2.setFocusComment(56321321)" >So</a>


		 	<span id="comment_score_56321321" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321321); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~BitztreamNotARealNam">BitztreamNotARealNam</a>  <span class="uid"><a href="//slashdot.org/~BitztreamNotARealNam">( 4784739 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321321"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321321">How's life in the <a href="https://slashdot.org/comments.pl?sid=9977525&amp;cid=53459345" title="slashdot.org">hypocrite lane</a> [slashdot.org]?</div>
	</div>

	<div class="commentSub" id="comment_sub_56321321">

</div>
</div>

<div id="replyto_56321321"></div>

<ul id="group_56321321">
	<li id="hiddens_56321321" class="hide"></li>
</ul>

</li><li id="hidestring_56319873"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56319873">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_56319871" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56319871" class="commentstatus"></div>
<div id="comment_56319871" class="cw">
	<div id="comment_top_56319871" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56319871" name="comment_link_56319871" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319871" onclick="return D2.setFocusComment(56319871)" >why not Kotlin?</a>


		 	<span id="comment_score_56319871" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56319871); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Snotnose">Snotnose</a>  <span class="uid"><a href="//slashdot.org/~Snotnose">( 212196 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56319871"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56319871">If the var statement is a big feature for you then Kotlin is way ahead.  Just sayin.
<br> <br>
And if you think I'm updating my Java environment every 6 months then you must think my farts smell like rose water.</div>
	</div>

	<div class="commentSub" id="comment_sub_56319871">

</div>
</div>

<div id="replyto_56319871"></div>

<ul id="group_56319871">
	<li id="hiddens_56319871" class="hide"></li>
</ul>

<ul id="commtree_56319871"><li id="tree_56320345" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320345" class="commentstatus"></div>
<div id="comment_56320345" class="cw">
</div>

<div id="replyto_56320345"></div>

<ul id="group_56320345">
	<li id="hiddens_56320345" class="hide"></li>
</ul>

</li><li id="tree_56320555" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320555" class="commentstatus"></div>
<div id="comment_56320555" class="cw">
</div>

<div id="replyto_56320555"></div>

<ul id="group_56320555">
	<li id="hiddens_56320555" class="hide"></li>
</ul>

<ul id="commtree_56320555"><li id="tree_56321079" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56321079" class="commentstatus"></div>
<div id="comment_56321079" class="cw">
</div>

<div id="replyto_56321079"></div>

<ul id="group_56321079">
	<li id="hiddens_56321079" class="hide"></li>
</ul>

</li><li id="hidestring_56320555"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56320555">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="hidestring_56319871"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56319871">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56319893" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56319893" class="commentstatus"></div>
<div id="comment_56319893" class="cw">
	<div id="comment_top_56319893" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56319893" name="comment_link_56319893" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319893" onclick="return D2.setFocusComment(56319893)" >Did anyone ask for this?</a>


		 	<span id="comment_score_56319893" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56319893); return false"><span class=opt>Score:</span>3</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~93+Escort+Wagon">93 Escort Wagon</a>  <span class="uid"><a href="//slashdot.org/~93+Escort+Wagon">( 326346 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56319893">		
		on Saturday March 24, 2018 @03:29PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319893">#56319893</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56319893"><p>I don&rsquo;t think I&rsquo;ve ever heard anyone ask for a faster release cycle for java.</p><p>I have, however, heard (many times) people requesting that java die in a fire.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56319893">
<span class="ind"></span><a id="reply_link_56319893" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56319893" onclick="D2.replyTo(56319893); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Did anyone ask for this? by 93 Escort Wagon @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319893" data-title="Did anyone ask for this?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Did anyone ask for this? by 93 Escort Wagon" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319893" data-title="Did anyone ask for this?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Did anyone ask for this? by 93 Escort Wagon" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319893" data-title="Did anyone ask for this?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11898087%26cid=56319893" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56319893" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56319893" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56319893"></div>

<ul id="group_56319893">
	<li id="hiddens_56319893" class="hide"></li>
</ul>

<ul id="commtree_56319893"><li id="tree_56320615" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320615" class="commentstatus"></div>
<div id="comment_56320615" class="cw">
</div>

<div id="replyto_56320615"></div>

<ul id="group_56320615">
	<li id="hiddens_56320615" class="hide"></li>
</ul>

</li><li id="tree_56322051" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56322051" class="commentstatus"></div>
<div id="comment_56322051" class="cw">
	<div id="comment_top_56322051" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56322051" name="comment_link_56322051" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56322051" onclick="return D2.setFocusComment(56322051)" >Re:</a>


		 	<span id="comment_score_56322051" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56322051); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nateman1352">nateman1352</a>  <span class="uid"><a href="//slashdot.org/~nateman1352">( 971364 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56322051"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56322051">Indeed, no one asked for this except Larry Ellison. Make no mistake, Oracle doesn't do a damn thing unless it serves as a way to screw their customers harder than they did before. You can be sure that these every 6 month releases introduce many more frequent opportunities to add small subtle "bugs" that just so happen to break popular enterprise software packages. This is nothing more than a shameless attempt to charge you through the teeth for the JRE. The LTS JRE that is actually able to run your software</div>
	</div>

	<div class="commentSub" id="comment_sub_56322051">

</div>
</div>

<div id="replyto_56322051"></div>

<ul id="group_56322051">
	<li id="hiddens_56322051" class="hide"></li>
</ul>

</li><li id="hidestring_56319893"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56319893">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56319939" class="comment full contain"><span class="ind"></span>
<div id="comment_status_56319939" class="commentstatus"></div>
<div id="comment_56319939" class="cw">
	<div id="comment_top_56319939" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56319939" name="comment_link_56319939" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319939" onclick="return D2.setFocusComment(56319939)" >This will be a good thing</a>


		 	<span id="comment_score_56319939" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56319939); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DeplorableCodeMonkey">DeplorableCodeMonkey</a>  <span class="uid"><a href="//slashdot.org/~DeplorableCodeMonkey">( 4828467 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56319939">		
		on Saturday March 24, 2018 @03:44PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319939">#56319939</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56319939"><p>Explicit LTS versions vs non-LTS will enable the conservative to have a roadmap and the adventurous to keep going with new ideas and features where the two eventually converge.</p><p>I'm personally quite sick of joining "enterprise" teams that use wildly past their shelf life versions of Java and then get indignant when I pointedly ask them WTF they're doing calling it "secure" when the product has been abandonware WRT security for over a year.</p><p>Right now it feels like "Java 7 vs 8 vs 9" is a matter of opinion. Now at least we can say "you chose a non-LTS version and didn't keep up... WTF?" and stuff like that. Oracle is at least now saying "this is for this type of user and that is for that type of user" and if you try a third way the answer is "you're wrong" unless you accept full responsibility.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56319939">
<span class="ind"></span><a id="reply_link_56319939" class="btn link" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56319939" onclick="D2.replyTo(56319939); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="This will be a good thing by DeplorableCodeMonkey @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319939" data-title="This will be a good thing">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="This will be a good thing by DeplorableCodeMonkey" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319939" data-title="This will be a good thing">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="This will be a good thing by DeplorableCodeMonkey" data-url="https://developers.slashdot.org/comments.pl?sid=11898087&cid=56319939" data-title="This will be a good thing">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=11898087%26cid=56319939" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_56319939" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=56319939" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_56319939"></div>

<ul id="group_56319939">
	<li id="hiddens_56319939" class="hide"></li>
</ul>

<ul id="commtree_56319939"><li id="tree_56319993" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56319993" class="commentstatus"></div>
<div id="comment_56319993" class="cw">
	<div id="comment_top_56319993" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56319993" name="comment_link_56319993" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56319993" onclick="return D2.setFocusComment(56319993)" >Re:</a>


		 	<span id="comment_score_56319993" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56319993); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Billly+Gates">Billly Gates</a>  <span class="uid"><a href="//slashdot.org/~Billly+Gates">( 198444 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56319993"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56319993"><p>We still use Java6 at work lol. Change for the sake of change is expensive and our Oracle12g based tools and version SQL Developer work best onthat version. Upgrading puts us on a rent like EULA so we can't ever upgrade according to our finance guys. My previous employer just switched to java 7 and will stay there for years to come. All it;s customers have standardized only on Java jre7 for things like certs and code signing so we need an ancient version to make sure their tools work on our machines.</p><p>Oracle<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56319993">

</div>
</div>

<div id="replyto_56319993"></div>

<ul id="group_56319993">
	<li id="hiddens_56319993" class="hide"></li>
</ul>

<ul id="commtree_56319993"><li id="tree_56320023" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320023" class="commentstatus"></div>
<div id="comment_56320023" class="cw">
	<div id="comment_top_56320023" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320023" name="comment_link_56320023" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320023" onclick="return D2.setFocusComment(56320023)" >Re:</a>


		 	<span id="comment_score_56320023" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320023); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~supremebob">supremebob</a>  <span class="uid"><a href="//slashdot.org/~supremebob">( 574732 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320023"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320023"><p>I think that a LOT of organizations are still using Java 6 and Java 7 in their business. I know that last two organizations that I worked for have.</p><p>An officially LT supported Java 11 release might be the excuse they were looking for to skip upgrading to Java 9 and Java 10 and go straight for that version.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320023">

</div>
</div>

<div id="replyto_56320023"></div>

<ul id="group_56320023">
	<li id="hiddens_56320023" class="hide"></li>
</ul>

</li><li id="tree_56320041" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320041" class="commentstatus"></div>
<div id="comment_56320041" class="cw">
	<div id="comment_top_56320041" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320041" name="comment_link_56320041" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320041" onclick="return D2.setFocusComment(56320041)" >Re:</a>


		 	<span id="comment_score_56320041" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320041); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320041"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320041"><p>What would be an alternative to Java?</p><p>C#/.NET? I don't think so.</p><p>So, what else? We could put a nice tool chain on CLANG to support everything that Java can, e.g. Reflection/Introspection/Serialization<nobr> <wbr></nobr>... but it seems no one is doing that at the moment.</p><p>A sanitized C++ running on a VM with optional GC, that would be fine<nobr> <wbr></nobr>... but I see no one going there.</p><p>Or an open source Eiffel<nobr> <wbr></nobr>... but then again it would be verbose like Java.</p><p>On the other hand, image based environments like Smalltalk would be cool, no one is r<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320041">

</div>
</div>

<div id="replyto_56320041"></div>

<ul id="group_56320041">
	<li id="hiddens_56320041" class="hide"></li>
</ul>

<ul id="commtree_56320041"><li id="tree_56320213" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320213" class="commentstatus"></div>
<div id="comment_56320213" class="cw">
	<div id="comment_top_56320213" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320213" name="comment_link_56320213" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320213" onclick="return D2.setFocusComment(56320213)" >Re:</a>


		 	<span id="comment_score_56320213" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320213); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~PmanAce">PmanAce</a>  <span class="uid"><a href="//slashdot.org/~PmanAce">( 1679902 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320213"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320213">Explain why C#/.Net isn't a viable alternative? With the open source<nobr> <wbr></nobr>.net core on its way, things are very interesting.</div>
	</div>

	<div class="commentSub" id="comment_sub_56320213">

</div>
</div>

<div id="replyto_56320213"></div>

<ul id="group_56320213">
	<li id="hiddens_56320213" class="hide"></li>
</ul>

<ul id="commtree_56320213"><li id="tree_56320421" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320421" class="commentstatus"></div>
<div id="comment_56320421" class="cw">
</div>

<div id="replyto_56320421"></div>

<ul id="group_56320421">
	<li id="hiddens_56320421" class="hide"></li>
</ul>

</li><li id="tree_56321017" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321017" class="commentstatus"></div>
<div id="comment_56321017" class="cw">
	<div id="comment_top_56321017" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321017" name="comment_link_56321017" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321017" onclick="return D2.setFocusComment(56321017)" >Re:</a>


		 	<span id="comment_score_56321017" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321017); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lamer01">lamer01</a>  <span class="uid"><a href="//slashdot.org/~lamer01">( 1097759 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321017"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321017">.net core is not on the way. It's been here for 2 years now.</div>
	</div>

	<div class="commentSub" id="comment_sub_56321017">

</div>
</div>

<div id="replyto_56321017"></div>

<ul id="group_56321017">
	<li id="hiddens_56321017" class="hide"></li>
</ul>

</li><li id="tree_56321043" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321043" class="commentstatus"></div>
<div id="comment_56321043" class="cw">
	<div id="comment_top_56321043" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321043" name="comment_link_56321043" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321043" onclick="return D2.setFocusComment(56321043)" >Re:</a>


		 	<span id="comment_score_56321043" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321043); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321043"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321043"><p>Because it lacks all the open source tools and libraries, Java has. It has no web server, like tomcat e.g.<br>C# versus Java is simply an awful language, but you could use managed C++ of course, that wold be a plus. Most Java alternatives like Groovy, Scala, Kotlin etc. doc. don't run on<nobr> <wbr></nobr>.Net</p><p>And the naming conventions of C# just suck<nobr> <wbr></nobr>:D a pain for my eyes<nobr> <wbr></nobr>...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321043">

</div>
</div>

<div id="replyto_56321043"></div>

<ul id="group_56321043">
	<li id="hiddens_56321043" class="hide"></li>
</ul>

<ul id="commtree_56321043"><li id="tree_56321065" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321065" class="commentstatus"></div>
<div id="comment_56321065" class="cw">
	<div id="comment_top_56321065" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321065" name="comment_link_56321065" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321065" onclick="return D2.setFocusComment(56321065)" >Re:</a>


		 	<span id="comment_score_56321065" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321065); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lgw">lgw</a>  <span class="uid"><a href="//slashdot.org/~lgw">( 121541 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321065"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321065"><p>C#, the full language, is years ahead of Java and a far, far better language.  So much less boilerplate with C#.  Heck, Java is plain unusable without Lombok.</p><p>OTOH, until the language has fully rich open source support on Linux, I'll pass.  Does seem to be headed that way, however, so I'm hopeful.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321065">

</div>
</div>

<div id="replyto_56321065"></div>

<ul id="group_56321065">
	<li id="hiddens_56321065" class="hide"></li>
</ul>

<ul id="commtree_56321065"><li id="tree_56321137" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321137" class="commentstatus"></div>
<div id="comment_56321137" class="cw">
	<div id="comment_top_56321137" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321137" name="comment_link_56321137" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321137" onclick="return D2.setFocusComment(56321137)" >Re:</a>


		 	<span id="comment_score_56321137" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321137); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321137"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321137"><p>I guess that is a matter of taste, I find C# nearly unusable and you think the same about Java<nobr> <wbr></nobr>... but that is why I mostly use Groovy and hope that my current project slowly shifts to Scala<nobr> <wbr></nobr>:D</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321137">

</div>
</div>

<div id="replyto_56321137"></div>

<ul id="group_56321137">
	<li id="hiddens_56321137" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56322181" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56322181" class="commentstatus"></div>
<div id="comment_56322181" class="cw">
	<div id="comment_top_56322181" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56322181" name="comment_link_56322181" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56322181" onclick="return D2.setFocusComment(56322181)" >Re: This will be a good thing</a>


		 	<span id="comment_score_56322181" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56322181); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~spongman">spongman</a>  <span class="uid"><a href="//slashdot.org/~spongman">( 182339 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56322181"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56322181"><p>None of the statements of fact about c#/.net in that post are correct.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56322181">

</div>
</div>

<div id="replyto_56322181"></div>

<ul id="group_56322181">
	<li id="hiddens_56322181" class="hide"></li>
</ul>

</li><li id="tree_56322201" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56322201" class="commentstatus"></div>
<div id="comment_56322201" class="cw">
	<div id="comment_top_56322201" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56322201" name="comment_link_56322201" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56322201" onclick="return D2.setFocusComment(56322201)" >Re:</a>


		 	<span id="comment_score_56322201" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56322201); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Richard_at_work">Richard_at_work</a>  <span class="uid"><a href="//slashdot.org/~Richard_at_work">( 517087 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56322201"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56322201"><p>I've looked at Tomcat in the past and could never understand why anyone would want such an unwieldy piece of shit - sure,<nobr> <wbr></nobr>.Net has nothing like it (thank fuck), and as a result I prefer to use OWIN self hosting or Kestrel httpd (the<nobr> <wbr></nobr>.Net Core httpd by MS) for my web apps, and stick them behind a standard reverse proxy like Nginx or HAProxy so the heavy lifting is done by an app dedicated to it.</p><p>Lack of a "Tomcat" is not a negative., and you seem to be missing the massive nuget library which is mostly open so<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_56322201">

</div>
</div>

<div id="replyto_56322201"></div>

<ul id="group_56322201">
	<li id="hiddens_56322201" class="hide"></li>
</ul>

<ul id="commtree_56322201"><li id="tree_56322365" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56322365" class="commentstatus"></div>
<div id="comment_56322365" class="cw">
	<div id="comment_top_56322365" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56322365" name="comment_link_56322365" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56322365" onclick="return D2.setFocusComment(56322365)" >Re:</a>


		 	<span id="comment_score_56322365" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56322365); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56322365"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56322365"><p>Tomcat was just an example for the implementation of the Servlet API.<br>APIs in Java are generally defined by experts of the field.</p><p>In<nobr> <wbr></nobr>.Net I have no idea why everything is so horrible unusable. But: I did not use it since 10 years, so perhaps it got better<nobr> <wbr></nobr>;D</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56322365">

</div>
</div>

<div id="replyto_56322365"></div>

<ul id="group_56322365">
	<li id="hiddens_56322365" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="hidestring_56320213"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56320213">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56320273" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320273" class="commentstatus"></div>
<div id="comment_56320273" class="cw">
	<div id="comment_top_56320273" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320273" name="comment_link_56320273" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320273" onclick="return D2.setFocusComment(56320273)" >Re:</a>


		 	<span id="comment_score_56320273" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320273); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Billly+Gates">Billly Gates</a>  <span class="uid"><a href="//slashdot.org/~Billly+Gates">( 198444 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320273"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320273"><p><div class="quote"><p>What would be an alternative to Java?</p><p>C#/.NET? I don't think so.</p><p>So, what else? We could put a nice tool chain on CLANG to support everything that Java can, e.g. Reflection/Introspection/Serialization<nobr> <wbr></nobr>... but it seems no one is doing that at the moment.</p><p>A sanitized C++ running on a VM with optional GC, that would be fine<nobr> <wbr></nobr>... but I see no one going there.</p><p>Or an open source Eiffel<nobr> <wbr></nobr>... but then again it would be verbose like Java.</p><p>On the other hand, image based environments like Smalltalk would be cool, no one is really pushing that either.</p><p>So, it looks like we are stuck with Java the next 30 years.</p><p>I for my part don't mind that.</p></div><p>Easy <a href="https://www.youtube.com/watch?v=rRbY3TMUcgQ" title="youtube.com">Erlang the new hip rockstar language<span class="substr"> </span></a> [youtube.com] </p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320273">

</div>
</div>

<div id="replyto_56320273"></div>

<ul id="group_56320273">
	<li id="hiddens_56320273" class="hide"></li>
</ul>

<ul id="commtree_56320273"><li id="tree_56321049" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321049" class="commentstatus"></div>
<div id="comment_56321049" class="cw">
	<div id="comment_top_56321049" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321049" name="comment_link_56321049" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321049" onclick="return D2.setFocusComment(56321049)" >Re:</a>


		 	<span id="comment_score_56321049" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321049); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321049"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321049"><p>Erlang is nice for highly interactive multi threaded environments, e.g. in telecommunications.<br>But pretty difficult to use for desktop applications or apps.</p><p>Perhaps OCaml<nobr> <wbr></nobr>...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321049">

</div>
</div>

<div id="replyto_56321049"></div>

<ul id="group_56321049">
	<li id="hiddens_56321049" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56320355" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320355" class="commentstatus"></div>
<div id="comment_56320355" class="cw">
</div>

<div id="replyto_56320355"></div>

<ul id="group_56320355">
	<li id="hiddens_56320355" class="hide"></li>
</ul>

</li><li id="hidestring_56320041"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56320041">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56320183" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320183" class="commentstatus"></div>
<div id="comment_56320183" class="cw">
</div>

<div id="replyto_56320183"></div>

<ul id="group_56320183">
	<li id="hiddens_56320183" class="hide"></li>
</ul>

</li><li id="hidestring_56319993"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=56319993">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_56321083" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321083" class="commentstatus"></div>
<div id="comment_56321083" class="cw">
	<div id="comment_top_56321083" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321083" name="comment_link_56321083" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321083" onclick="return D2.setFocusComment(56321083)" >Re:</a>


		 	<span id="comment_score_56321083" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321083); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~angel'o'sphere">angel'o'sphere</a>  <span class="uid"><a href="//slashdot.org/~angel'o'sphere">( 80593 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321083"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321083"><p>Actually you should have the recent JDK/JRE for modern libraries, like the streams, but program in Scala and Groovy<nobr> <wbr></nobr>... the progress Java makes as a language is simply not radical enough.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321083">

</div>
</div>

<div id="replyto_56321083"></div>

<ul id="group_56321083">
	<li id="hiddens_56321083" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56319979" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56319979" class="commentstatus"></div>
<div id="comment_56319979" class="cw">
</div>

<div id="replyto_56319979"></div>

<ul id="group_56319979">
	<li id="hiddens_56319979" class="hide"></li>
</ul>

</li><li id="tree_56320111" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320111" class="commentstatus"></div>
<div id="comment_56320111" class="cw">
	<div id="comment_top_56320111" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320111" name="comment_link_56320111" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320111" onclick="return D2.setFocusComment(56320111)" >Don't we want a slower release schedule.</a>


		 	<span id="comment_score_56320111" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320111); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320111"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320111"><p>The best would be 1 release, no schedule. A complete language fixed in its function forever with no bugs.</p><p>Having a faster release cycle means either they are spinning the language or patching a lot of bugs. So yes patching the bugs faster is better but I would prefer they spend the time to not have bugs in the first place.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320111">

</div>
</div>

<div id="replyto_56320111"></div>

<ul id="group_56320111">
	<li id="hiddens_56320111" class="hide"></li>
</ul>

</li><li id="tree_56320123" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320123" class="commentstatus"></div>
<div id="comment_56320123" class="cw">
	<div id="comment_top_56320123" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320123" name="comment_link_56320123" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320123" onclick="return D2.setFocusComment(56320123)" >The cancerous meme of fast release schedules.</a>


		 	<span id="comment_score_56320123" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320123); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320123"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320123"><p>They serve no good point, but virtually guarantee lower quality. Yet, like flat UIs with non-detectable interactive elements, they have to be done, "because everyone is doing them".</p><p>The stupidity of humanity is without bounds.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320123">

</div>
</div>

<div id="replyto_56320123"></div>

<ul id="group_56320123">
	<li id="hiddens_56320123" class="hide"></li>
</ul>

<ul id="commtree_56320123"><li id="tree_56320185" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56320185" class="commentstatus"></div>
<div id="comment_56320185" class="cw">
	<div id="comment_top_56320185" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56320185" name="comment_link_56320185" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56320185" onclick="return D2.setFocusComment(56320185)" >Re:</a>


		 	<span id="comment_score_56320185" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56320185); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~careysub">careysub</a>  <span class="uid"><a href="//slashdot.org/~careysub">( 976506 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56320185"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56320185"><p>Yeah, the subject line should read "Oracle Releases Java 10, <b>Threatens</b> Much Faster Release Schedule".</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56320185">

</div>
</div>

<div id="replyto_56320185"></div>

<ul id="group_56320185">
	<li id="hiddens_56320185" class="hide"></li>
</ul>

</li></ul></li><li id="tree_56320173" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320173" class="commentstatus"></div>
<div id="comment_56320173" class="cw">
</div>

<div id="replyto_56320173"></div>

<ul id="group_56320173">
	<li id="hiddens_56320173" class="hide"></li>
</ul>

</li><li id="tree_56320191" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320191" class="commentstatus"></div>
<div id="comment_56320191" class="cw">
</div>

<div id="replyto_56320191"></div>

<ul id="group_56320191">
	<li id="hiddens_56320191" class="hide"></li>
</ul>

</li><li id="tree_56320235" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320235" class="commentstatus"></div>
<div id="comment_56320235" class="cw">
</div>

<div id="replyto_56320235"></div>

<ul id="group_56320235">
	<li id="hiddens_56320235" class="hide"></li>
</ul>

</li><li id="tree_56320241" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320241" class="commentstatus"></div>
<div id="comment_56320241" class="cw">
</div>

<div id="replyto_56320241"></div>

<ul id="group_56320241">
	<li id="hiddens_56320241" class="hide"></li>
</ul>

</li><li id="tree_56320483" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320483" class="commentstatus"></div>
<div id="comment_56320483" class="cw">
</div>

<div id="replyto_56320483"></div>

<ul id="group_56320483">
	<li id="hiddens_56320483" class="hide"></li>
</ul>

</li><li id="tree_56320697" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320697" class="commentstatus"></div>
<div id="comment_56320697" class="cw">
</div>

<div id="replyto_56320697"></div>

<ul id="group_56320697">
	<li id="hiddens_56320697" class="hide"></li>
</ul>

</li><li id="tree_56320793" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320793" class="commentstatus"></div>
<div id="comment_56320793" class="cw">
</div>

<div id="replyto_56320793"></div>

<ul id="group_56320793">
	<li id="hiddens_56320793" class="hide"></li>
</ul>

</li><li id="tree_56320935" class="comment hidden"><span class="ind"></span>
<div id="comment_status_56320935" class="commentstatus"></div>
<div id="comment_56320935" class="cw">
</div>

<div id="replyto_56320935"></div>

<ul id="group_56320935">
	<li id="hiddens_56320935" class="hide"></li>
</ul>

</li><li id="tree_56321873" class="comment oneline"><span class="ind"></span>
<div id="comment_status_56321873" class="commentstatus"></div>
<div id="comment_56321873" class="cw">
	<div id="comment_top_56321873" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_56321873" name="comment_link_56321873" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;cid=56321873" onclick="return D2.setFocusComment(56321873)" >var: useless feature</a>


		 	<span id="comment_score_56321873" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 56321873); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~drolli">drolli</a>  <span class="uid"><a href="//slashdot.org/~drolli">( 522659 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_56321873"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_56321873"><p>Right way: ask your ide to guess the variable type, and insert variable with this type. It's good to know if the inferred type changed.....</p></div>
	</div>

	<div class="commentSub" id="comment_sub_56321873">

</div>
</div>

<div id="replyto_56321873"></div>

<ul id="group_56321873">
	<li id="hiddens_56321873" class="hide"></li>
</ul>

</li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=11898087&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">9 replies</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//developers.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 33;
		D2.currents()['full']     = 6;
		D2.currents()['oneline']  = 61;
		// D2.currents_total(100);

		D2.abbrev_comments({56320041:604,56319993:521,56322201:558,56320995:520,56321115:105,56320273:883,56322051:512,56321039:521,56320141:696});
		D2.noshow_comments([56319897,56320369,56320927,56321057,56320877,56320325,56321061,56321047,56319865,56320165,56320847,56320261,56321171,56321189,56320131,56320327,56320781,56319873,56321193,56320345,56320555,56321079,56320615,56320421,56320355,56320183,56319979,56320173,56320191,56320235,56320241,56320483,56320697,56320793,56320935]);
		D2.pieces_comments([56319729,56320025,56320495,56320039,56320063,56320141,56320883,56321115,56321523,56321591,56322147,56321805,56321807,56321979,56322011,56320205,56321039,56320199,56320691,56321093,56321175,56321191,56321239,56321291,56320995,56320029,56320059,56321305,56321961,56320767,56322143,56319809,56319899,56320639,56321067,56321059,56321319,56321583,56320005,56320759,56321321,56319871,56322051,56319993,56320023,56320041,56320213,56321017,56321043,56321065,56321137,56322181,56322201,56322365,56320273,56321049,56321083,56320111,56320123,56320185,56321873]);
		D2.init_hiddens([56320883,56320141,56320063,56320039,56320995,56320029,56319865,56319847,56319899,56319845,56319873,56320555,56319871,56319893,56320213,56320041,56319993,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(338805);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>656<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/03/27/2115233/prominent-drupal-php-developer-kicked-from-the-drupal-project-over-unconventional-sex-life?sdsrc=popbyskidbtmprev">Prominent Drupal, PHP Developer Kicked From the Drupal Project Over Unconventional Sex Life</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>608<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/11/27/039226/why-esr-hates-c-respects-java-and-thinks-go-but-not-rust-will-replace-c?sdsrc=popbyskidbtmprev">Why ESR Hates C++, Respects Java, and Thinks Go (But Not Rust) Will Replace C</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>595<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/11/11/0115219/esr-sees-three-viable-alternatives-to-c?sdsrc=popbyskidbtmprev">ESR Sees Three Viable Alternatives To C </a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>515<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/06/15/1431253/developers-who-use-spaces-make-more-money-than-those-who-use-tabs?sdsrc=popbyskidbtmprev">Developers Who Use Spaces Make More Money Than Those Who Use Tabs</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>505<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/17/07/16/1715256/techcrunch-urges-developers-replace-c-code-with-rust?sdsrc=popbyskidbtmprev">TechCrunch Urges Developers: Replace C Code With Rust</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/18/03/24/0345216/a-new-era-for-linuxs-low-level-graphics?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/graphics_64.png" width="64" height="64" alt="Graphics"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/18/03/24/0345216/a-new-era-for-linuxs-low-level-graphics?sdsrc=nextbtmprev">A New Era For Linux's Low-level Graphics</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>50<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//tech.slashdot.org/story/18/03/24/049223/tim-berners-lee-urges-web-users-care-about-your-data?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/internet_64.png" width="64" height="64" alt="The Internet"></span>
	    
					<p class="grid_12"><a href="//tech.slashdot.org/story/18/03/24/049223/tim-berners-lee-urges-web-users-care-about-your-data?sdsrc=prevbtmprev">Tim Berners-Lee Urges Web Users: 'Care About Your Data'</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>100<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=11898087&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">100</span> of <span class="totalcommentcnt">118</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>You know that feeling when you're leaning back on a stool and it starts to tip 
over?  Well, that's how I feel all the time.
-- Steven Wright</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy</a></li>
				<li id="teconsent"></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt Out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2018 SlashdotMedia. All Rights Reserved.</span></div>
                <script type="text/javascript" src="//consent-st.truste.com/get?name=notice.js&amp;domain=slashdot.org&amp;c=teconsent&amp;text=true"></script>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);




  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			//$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
            if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
                if(topBannerViewed) {
                    console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
        if($('.adwrap-viewed-railad').length > 0){
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//analytics.slashdotmedia.com/sd.php?idsite=40" style="border:0;" alt="" /></p></noscript>

<!-- Sponsored Whitepaper/Documents -->
<script>
    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });

        $.ajax({
            url: '/ajax.pl?op=geo',
            success: function(geo){
                var text = "";
                var possible = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
                for( var i=0; i < 15; i++ )
                        text += possible.charAt(Math.floor(Math.random() * possible.length));
                window.addEventListener('message', receiveMessage, false);
                function receiveMessage(evt){
                    if (evt.data && evt.data.lf_iframeid && evt.data.lf_height) {
                        //resize iframe to fit larger leadgen form
                        document.getElementById(evt.data.lf_iframeid).height = (evt.data.lf_height) + "px";
                    }
                }
                $('#firehoselist article').eq(12).after('<iframe width="100%" height="0" scrolling="no" frameborder="0" id="bz-lf-'+text+'" name="bz-lf-'+text+'" src="//d1o5u7ifbz3swt.cloudfront.net/showcase/index.php?id=dynamic&lp=SD_IMM&country='+geo+'"></iframe>');
            }
        });
    }
</script>

<script type="text/javascript">
_linkedin_data_partner_id = "113712";
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=113712&fmt=gif" />
</noscript>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?212">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?541">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

        <script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({flush: true}); 
        </script>       

	</body>
	</html>


	<!-- footer type=current end -->