<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	

<script>window.is_euro_union = 1;</script>
<script src="https://a.fsdn.com/con/js/sftheme/vendor/promise.polyfill.min.js"></script>
<script src="https://a.fsdn.com/con/js/sftheme/cmp.js"></script>
<script src="https://slashdot.org/country.js"></script>
<script type='text/javascript'>
if (window.is_euro_union) {
  bizx.cmp.init({
      // to test:   'Display UI': 'always',
      'Publisher Name': 'Slashdot',
      'Publisher Logo': 'https://a.fsdn.com/sd/sdlogo.svg',
      'Consent Scope': 'global group',
      'Consent Scope Group URL': 'https://slashdot.org/gdpr-cookies.pl',
    });
}
</script>
<link rel="stylesheet" href="//a.fsdn.com/con/css/sftheme/sandiego/cmp.css" type="text/css">
<style type="text/css">
.qc-cmp-publisher-logo, .qc-cmp-nav-bar-publisher-logo {
    background-color: #016765;
}
</style>
<script>
if (!window.is_euro_union) {
(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '66');
}
</script>

	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '823266331265558326',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>OpenJDK Bug Report Complains Source Code 'Has Too Many Swear Words' - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	  
		<meta name="description" content="Thursday a bug report complained that the source code for OpenJDK, the free and open-source implementation of Java, &#34;has too many swear words.&#34; An anonymous reader writes:

&#34;There are many instances of swear words inside OpenJDK jdk/jdk source, scattered all over the place,&#34; reads the bug report. &#34;A...">
	    
		<meta name="twitter:card" content="summary">
		<meta name="twitter:site" content="@slashdot">
		<meta name="twitter:domain" content="developers.slashdot.org">
		<meta property="og:url" content="https://developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words?sdsrc=nextbtmprev">
	    
		<meta property="og:title" content="OpenJDK Bug Report Complains Source Code 'Has Too Many Swear Words' - Slashdot">
		<meta property="og:description" content="Thursday a bug report complained that the source code for OpenJDK, the free and open-source implementation of Java, &#34;has too many swear words.&#34; An anonymous reader writes:

&#34;There are many instances of swear words inside OpenJDK jdk/jdk source, scattered all over the place,&#34; reads the bug report. &#34;A...">
	  
	
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/java_64.png">
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<link rel="canonical" href="https://developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/349676" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?0771f26796689b4c" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?0771f26796689b4c" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?0771f26796689b4c" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?0771f26796689b4c">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];

    window.Ads_disallowPersonalization = 1;
    bizx.cmp.ifConsent('all', 'all', function(){
        window.Ads_disallowPersonalization = 0;
      }, function(){
        window.Ads_disallowPersonalization = 1;
      }, function () {
        window.bizxPrebid.Ads.initPrebid(window.bizxPrebid.adUnits);
      });
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?0771f26796689b4c"></script>

</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?0771f26796689b4c" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			    'googleplus',
			    'facebook',
			    'twitter',
			    'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"native-facebook",
							"twitter",
							"linkedin",
							"native-googleplus",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	if (!window.is_euro_union) {
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	}
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//developers.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotDevelopers" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //developers.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  ><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://plus.google.com/112601993642376762846/" target="_blank"><i class="icon-gplus-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Catch up on stories from the past week (and beyond) at the <a href="//slashdot.org/archive.pl">Slashdot story archive</a>
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
  <div id="announcementText" style="display: none;"> <span class="headline">Migrate from GitHub to SourceForge quickly and easily with <strong><a href="https://sourceforge.net/p/forge/documentation/GitHub%20Importer/">this tool</a></strong>.</span> Check out all of SourceForge&rsquo;s <strong><a href="https://sourceforge.net/blog/brief-history-sourceforge-look-to-future/">recent improvements.</a></strong></div>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 1 });
}
</script>
				<article id="firehose-105098092" data-fhid="105098092" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">105098092</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-105098092">
			<a href="//developers.slashdot.org/index2.pl?fhfilter=java" onclick="return addfhfilter('java');">
			
				<img src="//a.fsdn.com/sd/topics/java_64.png" width="64" height="64" alt="Java" title="Java">
			
		</a>
		
	
		
		
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=opensource" onclick="return addfhfilter('opensource');">
			
				<img src="//a.fsdn.com/sd/topics/opensource_64.png" width="64" height="64" alt="Open Source" title="Open Source">
			
		</a>
		
	
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=it" onclick="return addfhfilter('it');">
			
				<img src="//a.fsdn.com/sd/topics/it_64.png" width="64" height="64" alt="IT" title="IT">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-105098092" class="story-title"> <a   href="//developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words">OpenJDK Bug Report Complains Source Code 'Has Too Many Swear Words'</a> <span class=" no extlnk"><a class="story-sourcelnk" href="https://bugs.openjdk.java.net/browse/JDK-8215217"  title="External link - https://bugs.openjdk.java.net/browse/JDK-8215217" target="_blank"> (java.net) </a></span></span>

		
		
		<!--<span class="comments commentcnt-105098092" >243</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words#comments" title="">243</a></span>
		
	</h2>
	<div class="details" id="details-105098092">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  EditorDavid
			
		
		

		
		
		<time id="fhtime-105098092" datetime="on Saturday December 15, 2018 @10:34AM">on Saturday December 15, 2018 @10:34AM</time>
		
		
			 from the <span class="dept-text">professionalism</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-105098092">
	
		
	

	
		
		<div id="text-105098092" class="p">
			
		 	
				Thursday a bug report complained that the source code for OpenJDK, the free and open-source implementation of Java, "has too many swear words." An anonymous reader writes:

<i>"There are many instances of swear words inside OpenJDK jdk/jdk source, scattered all over the place," reads <a href="https://bugs.openjdk.java.net/browse/JDK-8215217">the bug report</a>. "As OpenJDK is used in a professional context, it seems inappropriate to leave these 12 instances in there, so here's a changeset to remove them."</i> <br>

IBM software developer (and OpenJDK team member and contributor) Adam Farley responded that "after discussion with the community, three determinations were reached":<ul>
<li> <em>"Damn" and "Crap" are not swear words.</em> </li></ul><ul> <li> <em>Three of the four f-bombs are located in jszip.js, which should be corrected upstream (will follow up).</em> </li></ul><ul> <li> <em>The f-bomb in BitArray.java, as well as the rude typo in SoftChannel.java, *are* swear words and should be removed to resolve this work item.</em> </li></ul><p>
He promised a new webrev would be uploaded to reflect these determinations, and the bug has been marked as "resolved."</p><br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-105098092" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words"
								  data-janrain-title="OpenJDK Bug Report Complains Source Code 'Has Too Many Swear Words'"
								  data-janrain-message="OpenJDK Bug Report Complains Source Code 'Has Too Many Swear Words' @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-105098092" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/it" target="_blank">it</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/java" target="_blank">java</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/opensource" target="_blank">opensource</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//mobile.slashdot.org/story/18/12/15/0414228/could-you-live-without-a-smartphone-for-a-year?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//mobile.slashdot.org/story/18/12/15/0354231/screen-time-changes-structure-of-kids-brains-nih-study-shows?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//mobile.slashdot.org/story/18/12/15/0414228/could-you-live-without-a-smartphone-for-a-year?sdsrc=prev">Could You Live Without a Smartphone For a Year? </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//developers.slashdot.org/story/17/08/28/0156209/openjdk-may-tackle-java-security-gaps-with-a-secretive-new-group?sdsrc=rel">OpenJDK May Tackle Java Security Gaps With A Secretive New Group</a></h3><h3><a href="//news.slashdot.org/story/18/10/23/1418225/richard-stallman-announces-gnu-kind-communication-guidelines?sdsrc=rel">Richard Stallman Announces GNU Kind Communication Guidelines</a></h3><h3><a href="//developers.slashdot.org/story/18/11/18/1851231/amazon-releases-a-no-cost-distribution-of-openjdk?sdsrc=rel">Amazon Releases A No-Cost Distribution of OpenJDK</a></h3><h3><a href="//idle.slashdot.org/story/18/12/01/2331223/developer-misinterprets-linux-code-of-conduct-suggests-replacing-f-word-with-hug?sdsrc=rel">Developer Misinterprets Linux Code of Conduct, Suggests Replacing F-Word with 'Hug'</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//mobile.slashdot.org/story/18/12/15/0354231/screen-time-changes-structure-of-kids-brains-nih-study-shows?sdsrc=next">Screen Time Changes Structure of Kids' Brains, NIH Study Shows</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
if (!window.is_euro_union) {
    if (isAdBlockActive) {
        $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }
            }
        });
    };
}
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words" title="Back to Article - OpenJDK Bug Report Complains Source Code 'Has Too Many Swear Words'">OpenJDK Bug Report Complains Source Code 'Has Too Many Swear Words'</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - OpenJDK Bug Report Complains Source Code 'Has Too Many Swear Words'" href="//developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words">OpenJDK Bug Report Complains Source Code 'Has Too Many Swear Words'</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
								<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=13060244" class="btn">Search <span class="totalcommentcnt">244</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//developers.slashdot.org/comments.pl?sid=13060244">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=13060244" class="ui-icon search_comments">Search <span class="totalcommentcnt">244</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//developers.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/18/12/15/0021252/openjdk-bug-report-complains-source-code-has-too-many-swear-words/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?0771f26796689b4c" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_57808182" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808182" class="commentstatus"></div>
<div id="comment_57808182" class="cw">
	<div id="comment_top_57808182" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808182" name="comment_link_57808182" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808182" onclick="return D2.setFocusComment(57808182)" >Well, for an expansive definition of "bug"</a>


		 	<span id="comment_score_57808182" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808182); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Geoffrey.landis">Geoffrey.landis</a>  <span class="uid"><a href="//slashdot.org/~Geoffrey.landis">( 926948 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808182">		
		on Saturday December 15, 2018 @10:37AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808182">#57808182</a>)
		<small><a href="http://www.geoffreylandis.com/" title="http://www.geoffreylandis.com/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808182"><p>That's a pretty wide definition of "bug".<br>I'd think that maybe they could devote their debugging efforts to more annoying bugs...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808182">
<span class="ind"></span><a id="reply_link_57808182" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808182" onclick="D2.replyTo(57808182); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Well, for an expansive definition of &#34;bug&#34; by Geoffrey.landis @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808182" data-title="Well, for an expansive definition of &#34;bug&#34;">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Well, for an expansive definition of &#34;bug&#34; by Geoffrey.landis" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808182" data-title="Well, for an expansive definition of &#34;bug&#34;">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Well, for an expansive definition of &#34;bug&#34; by Geoffrey.landis" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808182" data-title="Well, for an expansive definition of &#34;bug&#34;">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808182" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808182" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808182" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808182"></div>

<ul id="group_57808182">
	<li id="hiddens_57808182" class="hide"></li>
</ul>

<ul id="commtree_57808182"><li id="tree_57808370" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808370" class="commentstatus"></div>
<div id="comment_57808370" class="cw">
	<div id="comment_top_57808370" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808370" name="comment_link_57808370" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808370" onclick="return D2.setFocusComment(57808370)" >Re:</a>


		 	<span id="comment_score_57808370" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808370); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~SirSlud">SirSlud</a>  <span class="uid"><a href="//slashdot.org/~SirSlud">( 67381 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808370"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808370"><p>You would think you have better things to do, like eat, drink, work, sleep than comment on a<nobr> <wbr></nobr>/. story.</p><p>Actually not too many people would think that because they'd recognize that we can do lots of things. In your code bases, do minor and easy to address bugs never get addressed on the basis that there 'should be more important bugs'? See how stupid that sounds?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808370">

</div>
</div>

<div id="replyto_57808370"></div>

<ul id="group_57808370">
	<li id="hiddens_57808370" class="hide"></li>
</ul>

</li><li id="tree_57808952" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808952" class="commentstatus"></div>
<div id="comment_57808952" class="cw">
	<div id="comment_top_57808952" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808952" name="comment_link_57808952" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808952" onclick="return D2.setFocusComment(57808952)" >Slightly better than what you and I did</a>


		 	<span id="comment_score_57808952" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808952); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~raymorris">raymorris</a>  <span class="uid"><a href="//slashdot.org/~raymorris">( 2726007 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808952"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808952"><p>If someone went on a tirade cussing out the developers for the occasional profanity, and demanding everyone else change their behavior, I would tell them to fuck off. From what I can tell, they do didn't have a freak out, they just did a pull request to clean things up.</p><p>&gt; I'd think that maybe they could devote their debugging efforts to more annoying bugs...</p><p>While I don't disagree, I also note that their work is slightly more useful than what you and I contributed to OpenJDK.</p><p>If this person wants to remove<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808952">

</div>
</div>

<div id="replyto_57808952"></div>

<ul id="group_57808952">
	<li id="hiddens_57808952" class="hide"></li>
</ul>

<ul id="commtree_57808952"><li id="tree_57810860" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57810860" class="commentstatus"></div>
<div id="comment_57810860" class="cw">
	<div id="comment_top_57810860" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57810860" name="comment_link_57810860" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57810860" onclick="return D2.setFocusComment(57810860)" >Re:</a>


		 	<span id="comment_score_57810860" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57810860); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rtb61">rtb61</a>  <span class="uid"><a href="//slashdot.org/~rtb61">( 674572 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57810860"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57810860"><p>Why exactly is 'FUCK' more offensive than 'SEXUAL INTERCOURSE', I mean is it evil to use less letters, or are 'F' and 'K' inherently disturbing. I mean how about hump or screw, is hump OK because camels do it and of course banning the word screw would be stupid even when it is the implication in context. </p><p>How about you silly fuckers try to stop taking offence at everything, chill the fuck out, and realise the difference between words and physical actions. You know like I learnt in kindy, sticks and stones ma<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_57810860">

</div>
</div>

<div id="replyto_57810860"></div>

<ul id="group_57810860">
	<li id="hiddens_57810860" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57809018" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809018" class="commentstatus"></div>
<div id="comment_57809018" class="cw">
	<div id="comment_top_57809018" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809018" name="comment_link_57809018" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809018" onclick="return D2.setFocusComment(57809018)" >Re:</a>


		 	<span id="comment_score_57809018" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809018); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809018"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809018">But now the committer can put on their resume "Committed code to OpenJDK."</div>
	</div>

	<div class="commentSub" id="comment_sub_57809018">

</div>
</div>

<div id="replyto_57809018"></div>

<ul id="group_57809018">
	<li id="hiddens_57809018" class="hide"></li>
</ul>

</li><li id="tree_57809334" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809334" class="commentstatus"></div>
<div id="comment_57809334" class="cw">
	<div id="comment_top_57809334" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809334" name="comment_link_57809334" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809334" onclick="return D2.setFocusComment(57809334)" >Re:</a>


		 	<span id="comment_score_57809334" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809334); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thegarbz">thegarbz</a>  <span class="uid"><a href="//slashdot.org/~thegarbz">( 1787294 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809334"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809334"><p><div class="quote"><p>debugging efforts</p></div><p>If running grep to find some swear words is your definition of "effort" then you have no business commenting on how someone manages code.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809334">

</div>
</div>

<div id="replyto_57809334"></div>

<ul id="group_57809334">
	<li id="hiddens_57809334" class="hide"></li>
</ul>

</li><li id="tree_57808190" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808190" class="commentstatus"></div>
<div id="comment_57808190" class="cw">
</div>

<div id="replyto_57808190"></div>

<ul id="group_57808190">
	<li id="hiddens_57808190" class="hide"></li>
</ul>

<ul id="commtree_57808190"><li id="tree_57808234" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808234" class="commentstatus"></div>
<div id="comment_57808234" class="cw">
	<div id="comment_top_57808234" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808234" name="comment_link_57808234" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808234" onclick="return D2.setFocusComment(57808234)" >Re:</a>


		 	<span id="comment_score_57808234" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808234); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Geoffrey.landis">Geoffrey.landis</a>  <span class="uid"><a href="//slashdot.org/~Geoffrey.landis">( 926948 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808234"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808234"><p><div class="quote"><p>What is your definition of annoying?</p></div><p>Well, software that freezes for no apparent reason is annoying, to start.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808234">

</div>
</div>

<div id="replyto_57808234"></div>

<ul id="group_57808234">
	<li id="hiddens_57808234" class="hide"></li>
</ul>

<ul id="commtree_57808234"><li id="tree_57808344" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808344" class="commentstatus"></div>
<div id="comment_57808344" class="cw">
</div>

<div id="replyto_57808344"></div>

<ul id="group_57808344">
	<li id="hiddens_57808344" class="hide"></li>
</ul>

<ul id="commtree_57808344"><li id="tree_57808612" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808612" class="commentstatus"></div>
<div id="comment_57808612" class="cw">
	<div id="comment_top_57808612" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808612" name="comment_link_57808612" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808612" onclick="return D2.setFocusComment(57808612)" >Re: Well, for an expansive definition of "bug"</a>


		 	<span id="comment_score_57808612" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808612); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Cylix">Cylix</a>  <span class="uid"><a href="//slashdot.org/~Cylix">( 55374 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808612">		
		on Saturday December 15, 2018 @12:11PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808612">#57808612</a>)
		<small><a href="http://www.notacult.com/" title="http://www.notacult.com/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~Cylix/journal/" title="Thursday March 07, 2002 @11:05AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808612"><p>That people who look for swear words in code have too much free time and too fragile personalities.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808612">
<span class="ind"></span><a id="reply_link_57808612" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808612" onclick="D2.replyTo(57808612); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=57808344" onclick="return D2.selectParent(57808344)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re: Well, for an expansive definition of &#34;bug&#34; by Cylix @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808612" data-title="Re: Well, for an expansive definition of &#34;bug&#34;">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re: Well, for an expansive definition of &#34;bug&#34; by Cylix" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808612" data-title="Re: Well, for an expansive definition of &#34;bug&#34;">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re: Well, for an expansive definition of &#34;bug&#34; by Cylix" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808612" data-title="Re: Well, for an expansive definition of &#34;bug&#34;">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808612" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808612" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808612" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808612"></div>

<ul id="group_57808612">
	<li id="hiddens_57808612" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_57808944" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808944" class="commentstatus"></div>
<div id="comment_57808944" class="cw">
	<div id="comment_top_57808944" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808944" name="comment_link_57808944" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808944" onclick="return D2.setFocusComment(57808944)" >Re: Well, for an expansive definition of "bug"</a>


		 	<span id="comment_score_57808944" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808944); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Dunbal">Dunbal</a>  <span class="uid"><a href="//slashdot.org/~Dunbal">( 464142 )</a></span></a> <a href="/faq/subscriptions.shtml#subscription_other_advantages">*</a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808944">		
		on Saturday December 15, 2018 @01:26PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808944">#57808944</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808944"><p><div class="quote"><p>What is your definition of annoying?</p></div><p>People who go around looking at code comment sections and bitch about swear words while adding absolutely nothing to the actual code development. That's pretty fucking annoying.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808944">
<span class="ind"></span><a id="reply_link_57808944" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808944" onclick="D2.replyTo(57808944); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=57808190" onclick="return D2.selectParent(57808190)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re: Well, for an expansive definition of &#34;bug&#34; by Dunbal @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808944" data-title="Re: Well, for an expansive definition of &#34;bug&#34;">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re: Well, for an expansive definition of &#34;bug&#34; by Dunbal" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808944" data-title="Re: Well, for an expansive definition of &#34;bug&#34;">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re: Well, for an expansive definition of &#34;bug&#34; by Dunbal" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808944" data-title="Re: Well, for an expansive definition of &#34;bug&#34;">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808944" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808944" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808944" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808944"></div>

<ul id="group_57808944">
	<li id="hiddens_57808944" class="hide"></li>
</ul>

</li><li id="tree_57808206" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808206" class="commentstatus"></div>
<div id="comment_57808206" class="cw">
</div>

<div id="replyto_57808206"></div>

<ul id="group_57808206">
	<li id="hiddens_57808206" class="hide"></li>
</ul>

<ul id="commtree_57808206"><li id="tree_57808246" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808246" class="commentstatus"></div>
<div id="comment_57808246" class="cw">
	<div id="comment_top_57808246" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808246" name="comment_link_57808246" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808246" onclick="return D2.setFocusComment(57808246)" >Re:</a>


		 	<span id="comment_score_57808246" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808246); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MrMr">MrMr</a>  <span class="uid"><a href="//slashdot.org/~MrMr">( 219533 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808246"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808246">I find people pretending to own an ios device by deliberately typing &#226;(TM) instead of ' rather annoying.</div>
	</div>

	<div class="commentSub" id="comment_sub_57808246">

</div>
</div>

<div id="replyto_57808246"></div>

<ul id="group_57808246">
	<li id="hiddens_57808246" class="hide"></li>
</ul>

<ul id="commtree_57808246"><li id="tree_57808372" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808372" class="commentstatus"></div>
<div id="comment_57808372" class="cw">
	<div id="comment_top_57808372" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808372" name="comment_link_57808372" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808372" onclick="return D2.setFocusComment(57808372)" >Re:  Well, for an expansive definition of "bug"</a>


		 	<span id="comment_score_57808372" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808372); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tysonedwards">tysonedwards</a>  <span class="uid"><a href="//slashdot.org/~tysonedwards">( 969693 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808372"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808372">Speaking of that, I am surprised that after all these years Slashdot still does not support Unicode. At this point it is starting to feel like beligerance rather than a legitimate technical issue.</div>
	</div>

	<div class="commentSub" id="comment_sub_57808372">

</div>
</div>

<div id="replyto_57808372"></div>

<ul id="group_57808372">
	<li id="hiddens_57808372" class="hide"></li>
</ul>

<ul id="commtree_57808372"><li id="tree_57808474" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808474" class="commentstatus"></div>
<div id="comment_57808474" class="cw">
	<div id="comment_top_57808474" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808474" name="comment_link_57808474" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808474" onclick="return D2.setFocusComment(57808474)" >Re:   Well, for an expansive definition of "bug"</a>


		 	<span id="comment_score_57808474" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808474); return false"><span class=opt>Score:</span>1</a>, Offtopic)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Cmdln+Daco">Cmdln Daco</a>  <span class="uid"><a href="//slashdot.org/~Cmdln+Daco">( 1183119 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808474"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808474"><p>Apple just needs to deprecate 'Dumbquotes' to default as off, so people with iGadgets don't spam us with buggy comments.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808474">

</div>
</div>

<div id="replyto_57808474"></div>

<ul id="group_57808474">
	<li id="hiddens_57808474" class="hide"></li>
</ul>

</li><li id="tree_57808710" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808710" class="commentstatus"></div>
<div id="comment_57808710" class="cw">
	<div id="comment_top_57808710" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808710" name="comment_link_57808710" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808710" onclick="return D2.setFocusComment(57808710)" >Re:</a>


		 	<span id="comment_score_57808710" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808710); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CrashNBrn">CrashNBrn</a>  <span class="uid"><a href="//slashdot.org/~CrashNBrn">( 1143981 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808710"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808710"><p>It is belligerence, the "red site" (soylent) fixed all the outstanding Slashcode bugs, along with quality-of-life improvements, with a single developer over the course of 6-8 weeks.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808710">

</div>
</div>

<div id="replyto_57808710"></div>

<ul id="group_57808710">
	<li id="hiddens_57808710" class="hide"></li>
</ul>

</li><li id="tree_57808738" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808738" class="commentstatus"></div>
<div id="comment_57808738" class="cw">
	<div id="comment_top_57808738" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808738" name="comment_link_57808738" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808738" onclick="return D2.setFocusComment(57808738)" >Bidirectionality abuse (5:erocS)</a>


		 	<span id="comment_score_57808738" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808738); return false"><span class=opt>Score:</span>5</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tepples">tepples</a>  <span class="uid"><a href="//slashdot.org/~tepples">( 727027 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808738">		 &lt;<a href="mailto:tepples%40gmail.c3.1415926om+minus+pi">tepples@gmail.c3.1415926om minus pi</a>&gt;
		on Saturday December 15, 2018 @12:35PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808738">#57808738</a>)
		<small><a href="https://pineight.com/" title="https://pineight.com/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~tepples/journal/" title="Thursday September 07, 2017 @10:55AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808738"><p>Vandals were abusing Unicode bidirectionality control characters to break the layout and spoof moderation scores, which I've called the <a href="https://yro.slashdot.org/comments.pl?sid=543514&amp;cid=23306292" title="slashdot.org">erocS problem</a> [slashdot.org]. A secondary problem is many other Unicode code points are more suited for making lewd "ASCII art" (in the broad sense) than for polite discussion using English language prose. How did SoylentNews, which runs a fork of Slashdot's software, solve these two issues?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808738">
<span class="ind"></span><a id="reply_link_57808738" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808738" onclick="D2.replyTo(57808738); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=57808372" onclick="return D2.selectParent(57808372)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Bidirectionality abuse (5:erocS) by tepples @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808738" data-title="Bidirectionality abuse (5:erocS)">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Bidirectionality abuse (5:erocS) by tepples" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808738" data-title="Bidirectionality abuse (5:erocS)">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Bidirectionality abuse (5:erocS) by tepples" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808738" data-title="Bidirectionality abuse (5:erocS)">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808738" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808738" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808738" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808738"></div>

<ul id="group_57808738">
	<li id="hiddens_57808738" class="hide"></li>
</ul>

<ul id="commtree_57808738"><li id="tree_57811554" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811554" class="commentstatus"></div>
<div id="comment_57811554" class="cw">
	<div id="comment_top_57811554" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811554" name="comment_link_57811554" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811554" onclick="return D2.setFocusComment(57811554)" >Re:</a>


		 	<span id="comment_score_57811554" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811554); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~iampiti">iampiti</a>  <span class="uid"><a href="//slashdot.org/~iampiti">( 1059688 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811554"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811554">Couldn't that just be solved with whitelisting? It's not an ideal solution but if you just whitelist the most common unicode characters and disallow everything else the situation would be better than just allowing legacy encodings</div>
	</div>

	<div class="commentSub" id="comment_sub_57811554">

</div>
</div>

<div id="replyto_57811554"></div>

<ul id="group_57811554">
	<li id="hiddens_57811554" class="hide"></li>
</ul>

<ul id="commtree_57811554"><li id="tree_57812008" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57812008" class="commentstatus"></div>
<div id="comment_57812008" class="cw">
	<div id="comment_top_57812008" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57812008" name="comment_link_57812008" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57812008" onclick="return D2.setFocusComment(57812008)" >Re:</a>


		 	<span id="comment_score_57812008" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57812008); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tepples">tepples</a>  <span class="uid"><a href="//slashdot.org/~tepples">( 727027 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57812008"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57812008"><p><div class="quote"><p>just whitelist the most common unicode characters and disallow everything else</p></div><p>Slashdot does exactly this. You disagree with its administrators on which numeric character entities to allow and which to disallow.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57812008">

</div>
</div>

<div id="replyto_57812008"></div>

<ul id="group_57812008">
	<li id="hiddens_57812008" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57811586" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811586" class="commentstatus"></div>
<div id="comment_57811586" class="cw">
	<div id="comment_top_57811586" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811586" name="comment_link_57811586" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811586" onclick="return D2.setFocusComment(57811586)" >Re:</a>


		 	<span id="comment_score_57811586" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811586); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Waccoon">Waccoon</a>  <span class="uid"><a href="//slashdot.org/~Waccoon">( 1186667 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811586"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811586"><p>Well, at the very least they could implement a filtering hack so apostrophes are no longer broken, which is the most common UTF-8 problem I see around here.  A partial solution would be better than nothing.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811586">

</div>
</div>

<div id="replyto_57811586"></div>

<ul id="group_57811586">
	<li id="hiddens_57811586" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_57808532" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808532" class="commentstatus"></div>
<div id="comment_57808532" class="cw">
</div>

<div id="replyto_57808532"></div>

<ul id="group_57808532">
	<li id="hiddens_57808532" class="hide"></li>
</ul>

<ul id="commtree_57808532"><li id="tree_57809820" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809820" class="commentstatus"></div>
<div id="comment_57809820" class="cw">
	<div id="comment_top_57809820" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809820" name="comment_link_57809820" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809820" onclick="return D2.setFocusComment(57809820)" >Re:  Well, for an expansive definition of "bug"</a>


		 	<span id="comment_score_57809820" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809820); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Malc">Malc</a>  <span class="uid"><a href="//slashdot.org/~Malc">( 1751 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809820"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809820"><p>Well I ain&#226;(TM)t no millennial (see my UID).  Sounds like you worked at a place with no code review.  Even old school places with any gumption have better engineering processes then you describe, and I work at place that develops SDKs with a C API, uses C++11 and assembly optimises important parts of the code.  Macros are sometimes important to extend a language to features it doesn&#226;(TM)t have natively, but don&#226;(TM)t take the piss.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809820">

</div>
</div>

<div id="replyto_57809820"></div>

<ul id="group_57809820">
	<li id="hiddens_57809820" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_57808240" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808240" class="commentstatus"></div>
<div id="comment_57808240" class="cw">
</div>

<div id="replyto_57808240"></div>

<ul id="group_57808240">
	<li id="hiddens_57808240" class="hide"></li>
</ul>

<ul id="commtree_57808240"><li id="tree_57808368" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808368" class="commentstatus"></div>
<div id="comment_57808368" class="cw">
	<div id="comment_top_57808368" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808368" name="comment_link_57808368" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808368" onclick="return D2.setFocusComment(57808368)" >Re: Well, for an expansive definition of "bug"</a>


		 	<span id="comment_score_57808368" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808368); return false"><span class=opt>Score:</span>1</a>, Troll)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Aboroth">Aboroth</a>  <span class="uid"><a href="//slashdot.org/~Aboroth">( 1841308 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808368"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808368">Ah yes, when I think of who would be most likely to be offended by swear words, my mind also totally ignores the possibility of religious people. Intense hatred of SJWs that borders on unhealthy obsession is fun!</div>
	</div>

	<div class="commentSub" id="comment_sub_57808368">

</div>
</div>

<div id="replyto_57808368"></div>

<ul id="group_57808368">
	<li id="hiddens_57808368" class="hide"></li>
</ul>

<ul id="commtree_57808368"><li id="tree_57808580" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808580" class="commentstatus"></div>
<div id="comment_57808580" class="cw">
</div>

<div id="replyto_57808580"></div>

<ul id="group_57808580">
	<li id="hiddens_57808580" class="hide"></li>
</ul>

<ul id="commtree_57808580"><li id="tree_57808890" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808890" class="commentstatus"></div>
<div id="comment_57808890" class="cw">
	<div id="comment_top_57808890" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808890" name="comment_link_57808890" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808890" onclick="return D2.setFocusComment(57808890)" >Re:  Well, for an expansive definition of "bug"</a>


		 	<span id="comment_score_57808890" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808890); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Aboroth">Aboroth</a>  <span class="uid"><a href="//slashdot.org/~Aboroth">( 1841308 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808890"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808890">I did not say that I cared what they thought, or even that anybody should care. All I said was that religious people are more likely to dislike swearing than SJWs. Be careful, your hatred is making you retarded.</div>
	</div>

	<div class="commentSub" id="comment_sub_57808890">

</div>
</div>

<div id="replyto_57808890"></div>

<ul id="group_57808890">
	<li id="hiddens_57808890" class="hide"></li>
</ul>

</li><li id="tree_57808674" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808674" class="commentstatus"></div>
<div id="comment_57808674" class="cw">
</div>

<div id="replyto_57808674"></div>

<ul id="group_57808674">
	<li id="hiddens_57808674" class="hide"></li>
</ul>

<ul id="commtree_57808674"><li id="tree_57808764" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808764" class="commentstatus"></div>
<div id="comment_57808764" class="cw">
	<div id="comment_top_57808764" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808764" name="comment_link_57808764" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808764" onclick="return D2.setFocusComment(57808764)" >Parents Television Council</a>


		 	<span id="comment_score_57808764" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808764); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tepples">tepples</a>  <span class="uid"><a href="//slashdot.org/~tepples">( 727027 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808764">		 &lt;<a href="mailto:tepples%40gmail.c3.1415926om+minus+pi">tepples@gmail.c3.1415926om minus pi</a>&gt;
		on Saturday December 15, 2018 @12:41PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808764">#57808764</a>)
		<small><a href="https://pineight.com/" title="https://pineight.com/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~tepples/journal/" title="Thursday September 07, 2017 @10:55AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808764"><p><div class="quote"><p>religion doesn't prohibit others from swearing. It only prohibits the religious person themselves from swearing.</p></div><p>Until the religious people set up organizations like Parents Television Council that lobby governments to prohibit swearing.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808764">
<span class="ind"></span><a id="reply_link_57808764" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808764" onclick="D2.replyTo(57808764); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=57808674" onclick="return D2.selectParent(57808674)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Parents Television Council by tepples @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808764" data-title="Parents Television Council">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Parents Television Council by tepples" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808764" data-title="Parents Television Council">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Parents Television Council by tepples" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808764" data-title="Parents Television Council">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808764" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808764" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808764" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808764"></div>

<ul id="group_57808764">
	<li id="hiddens_57808764" class="hide"></li>
</ul>

</li><li id="tree_57808970" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808970" class="commentstatus"></div>
<div id="comment_57808970" class="cw">
</div>

<div id="replyto_57808970"></div>

<ul id="group_57808970">
	<li id="hiddens_57808970" class="hide"></li>
</ul>

<ul id="commtree_57808970"><li id="tree_57810236" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57810236" class="commentstatus"></div>
<div id="comment_57810236" class="cw">
	<div id="comment_top_57810236" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57810236" name="comment_link_57810236" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57810236" onclick="return D2.setFocusComment(57810236)" >Re:</a>


		 	<span id="comment_score_57810236" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57810236); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~zbaron">zbaron</a>  <span class="uid"><a href="//slashdot.org/~zbaron">( 649094 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57810236"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57810236">... or drink water from the wrong cup.</div>
	</div>

	<div class="commentSub" id="comment_sub_57810236">

</div>
</div>

<div id="replyto_57810236"></div>

<ul id="group_57810236">
	<li id="hiddens_57810236" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li></ul></li></ul></li><li id="tree_57808186" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808186" class="commentstatus"></div>
<div id="comment_57808186" class="cw">
	<div id="comment_top_57808186" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808186" name="comment_link_57808186" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808186" onclick="return D2.setFocusComment(57808186)" >Yeah ...</a>


		 	<span id="comment_score_57808186" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808186); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~cpurdy">cpurdy</a>  <span class="uid"><a href="//slashdot.org/~cpurdy">( 4838085 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808186"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808186">Fuck this shit<nobr> <wbr></nobr>...</div>
	</div>

	<div class="commentSub" id="comment_sub_57808186">

</div>
</div>

<div id="replyto_57808186"></div>

<ul id="group_57808186">
	<li id="hiddens_57808186" class="hide"></li>
</ul>

<ul id="commtree_57808186"><li id="tree_57808490" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808490" class="commentstatus"></div>
<div id="comment_57808490" class="cw">
	<div id="comment_top_57808490" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808490" name="comment_link_57808490" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808490" onclick="return D2.setFocusComment(57808490)" >Re:</a>


		 	<span id="comment_score_57808490" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808490); return false"><span class=opt>Score:</span>2</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~coastwalker">coastwalker</a>  <span class="uid"><a href="//slashdot.org/~coastwalker">( 307620 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808490"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808490"><p>The "outraged" need to fuck off and die because they are actually excluding the possibility of consensus from the public forum. Authoritarianism fails as the Soviet Union proved and as Putin will discover in the long run. The "outraged" are no less authoritarian than any other dictator.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808490">

</div>
</div>

<div id="replyto_57808490"></div>

<ul id="group_57808490">
	<li id="hiddens_57808490" class="hide"></li>
</ul>

<ul id="commtree_57808490"><li id="tree_57808516" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808516" class="commentstatus"></div>
<div id="comment_57808516" class="cw">
</div>

<div id="replyto_57808516"></div>

<ul id="group_57808516">
	<li id="hiddens_57808516" class="hide"></li>
</ul>

<ul id="commtree_57808516"><li id="tree_57808958" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808958" class="commentstatus"></div>
<div id="comment_57808958" class="cw">
	<div id="comment_top_57808958" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808958" name="comment_link_57808958" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808958" onclick="return D2.setFocusComment(57808958)" >Re:  Yeah ...</a>


		 	<span id="comment_score_57808958" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808958); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~edris90">Noah Draper</a> <span class="socialbadge"><a class="f" href="#" title="From Facebook"></a></span> <span class="uid"><a href="//slashdot.org/~edris90">( 5166365 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808958"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808958">Those who prioritize social constructs such as professionism above function , are not mentally capable of the technical focus required to work in a technical field.   If those are your priorities maybe you should be in a debate Forum instead arguing ethics for a living</div>
	</div>

	<div class="commentSub" id="comment_sub_57808958">

</div>
</div>

<div id="replyto_57808958"></div>

<ul id="group_57808958">
	<li id="hiddens_57808958" class="hide"></li>
</ul>

<ul id="commtree_57808958"><li id="tree_57809198" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809198" class="commentstatus"></div>
<div id="comment_57809198" class="cw">
	<div id="comment_top_57809198" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809198" name="comment_link_57809198" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809198" onclick="return D2.setFocusComment(57809198)" >Re:   Yeah ...</a>


		 	<span id="comment_score_57809198" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809198); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jd">jd</a>  <span class="uid"><a href="//slashdot.org/~jd">( 1658 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809198"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809198"><p>Those who prioritize quality in code don't use Windows, Linux, *BSD or any other general purpose OS, except as a text editor. And, frankly, I doubt more than three or four of us use Slashdot.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809198">

</div>
</div>

<div id="replyto_57809198"></div>

<ul id="group_57809198">
	<li id="hiddens_57809198" class="hide"></li>
</ul>

<ul id="commtree_57809198"><li id="tree_57811458" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811458" class="commentstatus"></div>
<div id="comment_57811458" class="cw">
	<div id="comment_top_57811458" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811458" name="comment_link_57811458" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811458" onclick="return D2.setFocusComment(57811458)" >Re:    Yeah ...</a>


		 	<span id="comment_score_57811458" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811458); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~astrofurter">astrofurter</a>  <span class="uid"><a href="//slashdot.org/~astrofurter">( 5464356 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811458"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811458"><p>Which OS, then, is preferred by those who prioritize quality in code?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811458">

</div>
</div>

<div id="replyto_57811458"></div>

<ul id="group_57811458">
	<li id="hiddens_57811458" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li><li id="tree_57808994" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808994" class="commentstatus"></div>
<div id="comment_57808994" class="cw">
	<div id="comment_top_57808994" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808994" name="comment_link_57808994" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808994" onclick="return D2.setFocusComment(57808994)" >Re:</a>


		 	<span id="comment_score_57808994" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808994); return false"><span class=opt>Score:</span>2</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808994"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808994">The world changes. Who would have guessed that the party on the left would become the prudes? Next we'll hear that Republicans want to legalize prostitution.</div>
	</div>

	<div class="commentSub" id="comment_sub_57808994">

</div>
</div>

<div id="replyto_57808994"></div>

<ul id="group_57808994">
	<li id="hiddens_57808994" class="hide"></li>
</ul>

<ul id="commtree_57808994"><li id="tree_57809812" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809812" class="commentstatus"></div>
<div id="comment_57809812" class="cw">
	<div id="comment_top_57809812" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809812" name="comment_link_57809812" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809812" onclick="return D2.setFocusComment(57809812)" >Re:</a>


		 	<span id="comment_score_57809812" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809812); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DontBeAMoran">DontBeAMoran</a>  <span class="uid"><a href="//slashdot.org/~DontBeAMoran">( 4843879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809812"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809812"><blockquote><div><p>Next we'll hear that Republicans want to legalize prostitution.</p></div></blockquote><p>As long as they can tax it as health services you bet they'll approve it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809812">

</div>
</div>

<div id="replyto_57809812"></div>

<ul id="group_57809812">
	<li id="hiddens_57809812" class="hide"></li>
</ul>

<ul id="commtree_57809812"><li id="tree_57809850" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809850" class="commentstatus"></div>
<div id="comment_57809850" class="cw">
	<div id="comment_top_57809850" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809850" name="comment_link_57809850" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809850" onclick="return D2.setFocusComment(57809850)" >Re:</a>


		 	<span id="comment_score_57809850" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809850); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809850"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809850">Apparently <a href="https://www.washingtonpost.com/national/health-science/federal-judge-in-texas-rules-obama-health-care-law-unconstitutional/2018/12/14/9e8bb5a2-fd63-11e8-862a-b6a6f3ce8199_story.html?utm_term=.d9fd2e58a9cd" title="washingtonpost.com">health services aren't a tax anymore</a> [washingtonpost.com]. Well well well, three holes in the ground.</div>
	</div>

	<div class="commentSub" id="comment_sub_57809850">

</div>
</div>

<div id="replyto_57809850"></div>

<ul id="group_57809850">
	<li id="hiddens_57809850" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_57808188" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808188" class="commentstatus"></div>
<div id="comment_57808188" class="cw">
	<div id="comment_top_57808188" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808188" name="comment_link_57808188" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808188" onclick="return D2.setFocusComment(57808188)" >Reasonable approach</a>


		 	<span id="comment_score_57808188" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808188); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rsilvergun">rsilvergun</a>  <span class="uid"><a href="//slashdot.org/~rsilvergun">( 571051 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808188"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808188">let the programmers &amp; community decide by up-voting this if they care.</div>
	</div>

	<div class="commentSub" id="comment_sub_57808188">

</div>
</div>

<div id="replyto_57808188"></div>

<ul id="group_57808188">
	<li id="hiddens_57808188" class="hide"></li>
</ul>

<ul id="commtree_57808188"><li id="tree_57808242" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808242" class="commentstatus"></div>
<div id="comment_57808242" class="cw">
</div>

<div id="replyto_57808242"></div>

<ul id="group_57808242">
	<li id="hiddens_57808242" class="hide"></li>
</ul>

<ul id="commtree_57808242"><li id="tree_57808270" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808270" class="commentstatus"></div>
<div id="comment_57808270" class="cw">
	<div id="comment_top_57808270" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808270" name="comment_link_57808270" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808270" onclick="return D2.setFocusComment(57808270)" >Re:</a>


		 	<span id="comment_score_57808270" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808270); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808270"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808270"><p>Cunts with no life. They spend so much time on inane bullshit because they've convinced themselves they're doing something worthwhile. So cunts with no life who feel righteous about it.</p><p>Oxygen thieves the lot of them.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808270">

</div>
</div>

<div id="replyto_57808270"></div>

<ul id="group_57808270">
	<li id="hiddens_57808270" class="hide"></li>
</ul>

</li><li id="tree_57809818" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809818" class="commentstatus"></div>
<div id="comment_57809818" class="cw">
	<div id="comment_top_57809818" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809818" name="comment_link_57809818" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809818" onclick="return D2.setFocusComment(57809818)" >Re:</a>


		 	<span id="comment_score_57809818" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809818); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~DontBeAMoran">DontBeAMoran</a>  <span class="uid"><a href="//slashdot.org/~DontBeAMoran">( 4843879 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809818"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809818"><blockquote><div><p>That's the problem with sjws. They're cunts. One person can out-vote a majority or cause a lot of damage given their incredible motivations for their own agendas.</p></div></blockquote><p>"'We can't win against obsession. They care, we don't. They win." &mdash; Douglas Adams</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809818">

</div>
</div>

<div id="replyto_57809818"></div>

<ul id="group_57809818">
	<li id="hiddens_57809818" class="hide"></li>
</ul>

</li><li id="tree_57808356" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808356" class="commentstatus"></div>
<div id="comment_57808356" class="cw">
</div>

<div id="replyto_57808356"></div>

<ul id="group_57808356">
	<li id="hiddens_57808356" class="hide"></li>
</ul>

<ul id="commtree_57808356"><li id="tree_57811472" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811472" class="commentstatus"></div>
<div id="comment_57811472" class="cw">
	<div id="comment_top_57811472" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811472" name="comment_link_57811472" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811472" onclick="return D2.setFocusComment(57811472)" >Re: Reasonable approach</a>


		 	<span id="comment_score_57811472" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811472); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~astrofurter">astrofurter</a>  <span class="uid"><a href="//slashdot.org/~astrofurter">( 5464356 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811472"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811472"><p>True, hypocrisy is the house of social just-us nazis.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811472">

</div>
</div>

<div id="replyto_57811472"></div>

<ul id="group_57811472">
	<li id="hiddens_57811472" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_57808216" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808216" class="commentstatus"></div>
<div id="comment_57808216" class="cw">
	<div id="comment_top_57808216" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808216" name="comment_link_57808216" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808216" onclick="return D2.setFocusComment(57808216)" >The rot is growing stronger</a>


		 	<span id="comment_score_57808216" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808216); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808216">		
		on Saturday December 15, 2018 @10:45AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808216">#57808216</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808216"><p>Obviously, we are moving more towards NewSpeak. It seems nobody reads the classics anymore and the same evil mistakes are getting prevalent again.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808216">
<span class="ind"></span><a id="reply_link_57808216" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808216" onclick="D2.replyTo(57808216); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="The rot is growing stronger by gweihir @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808216" data-title="The rot is growing stronger">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="The rot is growing stronger by gweihir" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808216" data-title="The rot is growing stronger">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="The rot is growing stronger by gweihir" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808216" data-title="The rot is growing stronger">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808216" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808216" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808216" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808216"></div>

<ul id="group_57808216">
	<li id="hiddens_57808216" class="hide"></li>
</ul>

<ul id="commtree_57808216"><li id="tree_57808294" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808294" class="commentstatus"></div>
<div id="comment_57808294" class="cw">
	<div id="comment_top_57808294" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808294" name="comment_link_57808294" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808294" onclick="return D2.setFocusComment(57808294)" >Re:</a>


		 	<span id="comment_score_57808294" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808294); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~alvinrod">alvinrod</a>  <span class="uid"><a href="//slashdot.org/~alvinrod">( 889928 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808294"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808294">Don't you mean the same doubleplusungood mistakes?</div>
	</div>

	<div class="commentSub" id="comment_sub_57808294">

</div>
</div>

<div id="replyto_57808294"></div>

<ul id="group_57808294">
	<li id="hiddens_57808294" class="hide"></li>
</ul>

<ul id="commtree_57808294"><li id="tree_57808496" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808496" class="commentstatus"></div>
<div id="comment_57808496" class="cw">
	<div id="comment_top_57808496" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808496" name="comment_link_57808496" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808496" onclick="return D2.setFocusComment(57808496)" >Re:</a>


		 	<span id="comment_score_57808496" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808496); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jmccue">jmccue</a>  <span class="uid"><a href="//slashdot.org/~jmccue">( 834797 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808496"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808496"><p>Nah, singleplusgood</p><p>But I would like to know. what self respecting programmer even reads the comments</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808496">

</div>
</div>

<div id="replyto_57808496"></div>

<ul id="group_57808496">
	<li id="hiddens_57808496" class="hide"></li>
</ul>

<ul id="commtree_57808496"><li id="tree_57811850" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811850" class="commentstatus"></div>
<div id="comment_57811850" class="cw">
	<div id="comment_top_57811850" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811850" name="comment_link_57811850" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811850" onclick="return D2.setFocusComment(57811850)" >Re:</a>


		 	<span id="comment_score_57811850" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811850); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AmiMoJo">AmiMoJo</a>  <span class="uid"><a href="//slashdot.org/~AmiMoJo">( 196126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811850"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811850"><p>I'm starting to suspect that the compiler doesn't...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811850">

</div>
</div>

<div id="replyto_57811850"></div>

<ul id="group_57811850">
	<li id="hiddens_57811850" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_57808396" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808396" class="commentstatus"></div>
<div id="comment_57808396" class="cw">
	<div id="comment_top_57808396" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808396" name="comment_link_57808396" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808396" onclick="return D2.setFocusComment(57808396)" >Correction: a proper rewording of the rot...</a>


		 	<span id="comment_score_57808396" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808396); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Texmaize">Texmaize</a>  <span class="uid"><a href="//slashdot.org/~Texmaize">( 2823935 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808396"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808396">To some life forms with a certain point of view, civil society is developing a preference for the non-threading, emotional positive form of communication that some but not all refer to as NewSpeak. Due to misogynist, patriarchal, and racial bias of European based civilization, no correct thinking person would read the heteronormative propaganda that some maladjusted life forms would self-proclaim as classics, wrongly implying they had more, not equal value, to the works of other races, cultures, or pronounc</div>
	</div>

	<div class="commentSub" id="comment_sub_57808396">

</div>
</div>

<div id="replyto_57808396"></div>

<ul id="group_57808396">
	<li id="hiddens_57808396" class="hide"></li>
</ul>

</li><li id="tree_57808520" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808520" class="commentstatus"></div>
<div id="comment_57808520" class="cw">
	<div id="comment_top_57808520" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808520" name="comment_link_57808520" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808520" onclick="return D2.setFocusComment(57808520)" >Re:</a>


		 	<span id="comment_score_57808520" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808520); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~swillden">swillden</a>  <span class="uid"><a href="//slashdot.org/~swillden">( 191260 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808520"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808520"><p><div class="quote"><p>Obviously, we are moving more towards NewSpeak. It seems nobody reads the classics anymore and the same evil mistakes are getting prevalent again.</p></div><p>Come off it, avoiding profanity in written professional communication is hardly equivalent to NewSpeak.

</p><p>Sheesh, some people just like getting worked up, I guess.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808520">

</div>
</div>

<div id="replyto_57808520"></div>

<ul id="group_57808520">
	<li id="hiddens_57808520" class="hide"></li>
</ul>

<ul id="commtree_57808520"><li id="tree_57808546" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808546" class="commentstatus"></div>
<div id="comment_57808546" class="cw">
	<div id="comment_top_57808546" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808546" name="comment_link_57808546" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808546" onclick="return D2.setFocusComment(57808546)" >Re:</a>


		 	<span id="comment_score_57808546" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808546); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~swillden">swillden</a>  <span class="uid"><a href="//slashdot.org/~swillden">( 191260 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808546"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808546"><p><div class="quote"><p><div class="quote"><p>Obviously, we are moving more towards NewSpeak. It seems nobody reads the classics anymore and the same evil mistakes are getting prevalent again.</p></div><p>Come off it, avoiding profanity in written professional communication is hardly equivalent to NewSpeak.

</p><p>Sheesh, some people just like getting worked up, I guess.</p></div><p>I should mention that IMO this includes people who get annoyed enough about swear words in source code to find them and submit patches to remove them.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808546">

</div>
</div>

<div id="replyto_57808546"></div>

<ul id="group_57808546">
	<li id="hiddens_57808546" class="hide"></li>
</ul>

<ul id="commtree_57808546"><li id="tree_57809244" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809244" class="commentstatus"></div>
<div id="comment_57809244" class="cw">
	<div id="comment_top_57809244" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809244" name="comment_link_57809244" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809244" onclick="return D2.setFocusComment(57809244)" >Re: The rot is growing stronger</a>


		 	<span id="comment_score_57809244" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809244); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jd">jd</a>  <span class="uid"><a href="//slashdot.org/~jd">( 1658 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809244"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809244"><p>The idea of open source being that if you don't like something, you write fixes. Sorry, the procedure worked entity as designed. If there are undocumented features to it, submit patches.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809244">

</div>
</div>

<div id="replyto_57809244"></div>

<ul id="group_57809244">
	<li id="hiddens_57809244" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57809268" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57809268" class="commentstatus"></div>
<div id="comment_57809268" class="cw">
	<div id="comment_top_57809268" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809268" name="comment_link_57809268" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809268" onclick="return D2.setFocusComment(57809268)" >Re:The rot is growing stronger</a>


		 	<span id="comment_score_57809268" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809268); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~djinn6">djinn6</a>  <span class="uid"><a href="//slashdot.org/~djinn6">( 1868030 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809268">		
		on Saturday December 15, 2018 @02:38PM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809268">#57809268</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809268"><p>Open source is a hobby, not a profession. Yes, there are some people who are paid to create open source software. They can censor their own communication if they so desire, or their boss might force it upon them, but they do not have a right to control others.</p><p>IMO if a particular curse word is the best way to communicate something, then they should use it without reservation. E.g. writing "this implementation makes no fucking sense" communicates a very different level of confusion and urgency than "this implementation makes no sense" or  "this needs to be refactored asap".</p><p>Personally, if I saw that in the code base, I would not remove the curse word until I'm able to refactor the code and make the comment obsolete.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809268">
<span class="ind"></span><a id="reply_link_57809268" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57809268" onclick="D2.replyTo(57809268); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=57808520" onclick="return D2.selectParent(57808520)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:The rot is growing stronger by djinn6 @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57809268" data-title="Re:The rot is growing stronger">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:The rot is growing stronger by djinn6" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57809268" data-title="Re:The rot is growing stronger">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:The rot is growing stronger by djinn6" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57809268" data-title="Re:The rot is growing stronger">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57809268" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57809268" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57809268" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57809268"></div>

<ul id="group_57809268">
	<li id="hiddens_57809268" class="hide"></li>
</ul>

<ul id="commtree_57809268"><li id="tree_57810534" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57810534" class="commentstatus"></div>
<div id="comment_57810534" class="cw">
	<div id="comment_top_57810534" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57810534" name="comment_link_57810534" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57810534" onclick="return D2.setFocusComment(57810534)" >Re:</a>


		 	<span id="comment_score_57810534" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57810534); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~swillden">swillden</a>  <span class="uid"><a href="//slashdot.org/~swillden">( 191260 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57810534"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57810534"><p><div class="quote"><p>Open source is a hobby, not a profession.</p></div><p>To a first approximation, no widely-used open source software is written by hobbyists. OpenJDK certainly is not.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57810534">

</div>
</div>

<div id="replyto_57810534"></div>

<ul id="group_57810534">
	<li id="hiddens_57810534" class="hide"></li>
</ul>

</li><li id="tree_57810546" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57810546" class="commentstatus"></div>
<div id="comment_57810546" class="cw">
	<div id="comment_top_57810546" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57810546" name="comment_link_57810546" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57810546" onclick="return D2.setFocusComment(57810546)" >Re:</a>


		 	<span id="comment_score_57810546" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57810546); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AuMatar">AuMatar</a>  <span class="uid"><a href="//slashdot.org/~AuMatar">( 183847 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57810546"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57810546"><p>No, its mostly a profession these days.  In the major open source projects, the number of people paid to contribute by major tech companies vastly outnumber the number of hobbyist coders.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57810546">

</div>
</div>

<div id="replyto_57810546"></div>

<ul id="group_57810546">
	<li id="hiddens_57810546" class="hide"></li>
</ul>

</li><li id="tree_57811588" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811588" class="commentstatus"></div>
<div id="comment_57811588" class="cw">
	<div id="comment_top_57811588" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811588" name="comment_link_57811588" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811588" onclick="return D2.setFocusComment(57811588)" >Re:</a>


		 	<span id="comment_score_57811588" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811588); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Waccoon">Waccoon</a>  <span class="uid"><a href="//slashdot.org/~Waccoon">( 1186667 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811588"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811588"><p>Most people are so desensitized to foul language that swear words don't convey urgency.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811588">

</div>
</div>

<div id="replyto_57811588"></div>

<ul id="group_57811588">
	<li id="hiddens_57811588" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57811480" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811480" class="commentstatus"></div>
<div id="comment_57811480" class="cw">
	<div id="comment_top_57811480" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811480" name="comment_link_57811480" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811480" onclick="return D2.setFocusComment(57811480)" >Re: The rot is growing stronger</a>


		 	<span id="comment_score_57811480" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811480); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~astrofurter">astrofurter</a>  <span class="uid"><a href="//slashdot.org/~astrofurter">( 5464356 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811480"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811480"><p>"avoiding profanity in written professional communication"</p><p>Professionalism is when you hold your work product to a high standard, and refuse to obey unethical orders.</p><p>What this human turd is doing, censoring strong language, is _prudery_ not professionalism.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811480">

</div>
</div>

<div id="replyto_57811480"></div>

<ul id="group_57811480">
	<li id="hiddens_57811480" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57808646" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808646" class="commentstatus"></div>
<div id="comment_57808646" class="cw">
	<div id="comment_top_57808646" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808646" name="comment_link_57808646" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808646" onclick="return D2.setFocusComment(57808646)" >Re:</a>


		 	<span id="comment_score_57808646" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808646); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dryeo">dryeo</a>  <span class="uid"><a href="//slashdot.org/~dryeo">( 100693 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808646"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808646"><p>Well what should we do about the religious snowflakes? Perhaps get rid of freedom of religion and as someone above suggested, murder all the religious right wing nut jobs that are so easily offended by body parts and natural things like sex?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808646">

</div>
</div>

<div id="replyto_57808646"></div>

<ul id="group_57808646">
	<li id="hiddens_57808646" class="hide"></li>
</ul>

<ul id="commtree_57808646"><li id="tree_57811890" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811890" class="commentstatus"></div>
<div id="comment_57811890" class="cw">
	<div id="comment_top_57811890" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811890" name="comment_link_57811890" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811890" onclick="return D2.setFocusComment(57811890)" >Re:</a>


		 	<span id="comment_score_57811890" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811890); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~goose-incarnated">goose-incarnated</a>  <span class="uid"><a href="//slashdot.org/~goose-incarnated">( 1145029 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811890"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811890"><p><div class="quote"><p>Well what should we do about the religious snowflakes? Perhaps get rid of freedom of religion and as someone above suggested, murder all the religious right wing nut jobs that are so easily offended by body parts and natural things like sex?</p></div><p>That's funny - the people asking to silence me aren't from the right. The people actually <b>succeeding</b> in silencing others also aren't from the right.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811890">

</div>
</div>

<div id="replyto_57811890"></div>

<ul id="group_57811890">
	<li id="hiddens_57811890" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57808654" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808654" class="commentstatus"></div>
<div id="comment_57808654" class="cw">
	<div id="comment_top_57808654" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808654" name="comment_link_57808654" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808654" onclick="return D2.setFocusComment(57808654)" >Re:</a>


		 	<span id="comment_score_57808654" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808654); return false"><span class=opt>Score:</span>3</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AmiMoJo">AmiMoJo</a>  <span class="uid"><a href="//slashdot.org/~AmiMoJo">( 196126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808654"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808654"><p>While I personally don't five a flying fuck about swearing in source code and can't really see how it could be an issue when using the JDK in a "professional" environment, you are massively over-reacting.</p><p>If the source contained stuff like personal attacks, doxing, or giant ASCII penises that stuff would probably be removed for what are hopefully obvious reasons. So clearly there are already some standards in place that have been widely enforced for as long as modern English has existed, and didn't cause any<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808654">

</div>
</div>

<div id="replyto_57808654"></div>

<ul id="group_57808654">
	<li id="hiddens_57808654" class="hide"></li>
</ul>

<ul id="commtree_57808654"><li id="tree_57810826" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57810826" class="commentstatus"></div>
<div id="comment_57810826" class="cw">
	<div id="comment_top_57810826" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57810826" name="comment_link_57810826" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57810826" onclick="return D2.setFocusComment(57810826)" >Re:</a>


		 	<span id="comment_score_57810826" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57810826); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AHuxley">AHuxley</a>  <span class="uid"><a href="//slashdot.org/~AHuxley">( 892839 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57810826"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57810826">Should a "professional" environment want good code they can pay for that their own clean code.<br>
Using their own staff. Hire staff to write code for them that is "professional".<br>
Why should anyone have to worry about their code been '"professional" and what "environment" then later selects to use that code.<br>
Who gets to set the SJW standards?  The people who work on the code every day?<br>
A '"professional" who later wants to use that code?</div>
	</div>

	<div class="commentSub" id="comment_sub_57810826">

</div>
</div>

<div id="replyto_57810826"></div>

<ul id="group_57810826">
	<li id="hiddens_57810826" class="hide"></li>
</ul>

<ul id="commtree_57810826"><li id="tree_57812218" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57812218" class="commentstatus"></div>
<div id="comment_57812218" class="cw">
	<div id="comment_top_57812218" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57812218" name="comment_link_57812218" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57812218" onclick="return D2.setFocusComment(57812218)" >Re:</a>


		 	<span id="comment_score_57812218" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57812218); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AmiMoJo">AmiMoJo</a>  <span class="uid"><a href="//slashdot.org/~AmiMoJo">( 196126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57812218"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57812218"><p>Linux has benefitted immensely from commercial contributions. In fact the majority of work is now done by people being paid to do it. I don't know about JDK but it seems similar.</p><p>Seems that for the sake of retaining a few swear words out of the source that could be a big loss.</p><p>As to who decides, I guess it's the same SJWs who decided you masturbate in public, i.e. fascists.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57812218">

</div>
</div>

<div id="replyto_57812218"></div>

<ul id="group_57812218">
	<li id="hiddens_57812218" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_57808302" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808302" class="commentstatus"></div>
<div id="comment_57808302" class="cw">
</div>

<div id="replyto_57808302"></div>

<ul id="group_57808302">
	<li id="hiddens_57808302" class="hide"></li>
</ul>

<ul id="commtree_57808302"><li id="tree_57809218" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809218" class="commentstatus"></div>
<div id="comment_57809218" class="cw">
	<div id="comment_top_57809218" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809218" name="comment_link_57809218" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809218" onclick="return D2.setFocusComment(57809218)" >Re:  The rot is growing stronger</a>


		 	<span id="comment_score_57809218" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809218); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jd">jd</a>  <span class="uid"><a href="//slashdot.org/~jd">( 1658 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809218"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809218"><p>NewSpeak is what American Republicans, Libertarians and Democrats use.</p><p>Those left may or may not, depends on the day.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809218">

</div>
</div>

<div id="replyto_57809218"></div>

<ul id="group_57809218">
	<li id="hiddens_57809218" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57809790" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57809790" class="commentstatus"></div>
<div id="comment_57809790" class="cw">
</div>

<div id="replyto_57809790"></div>

<ul id="group_57809790">
	<li id="hiddens_57809790" class="hide"></li>
</ul>

<ul id="commtree_57809790"><li id="tree_57811668" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811668" class="commentstatus"></div>
<div id="comment_57811668" class="cw">
	<div id="comment_top_57811668" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811668" name="comment_link_57811668" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811668" onclick="return D2.setFocusComment(57811668)" >Re:</a>


		 	<span id="comment_score_57811668" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811668); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~gweihir">gweihir</a>  <span class="uid"><a href="//slashdot.org/~gweihir">( 88907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811668"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811668"><p>JRR Tolkien was a Nazi? You seem to be confused...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811668">

</div>
</div>

<div id="replyto_57811668"></div>

<ul id="group_57811668">
	<li id="hiddens_57811668" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_57808218" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808218" class="commentstatus"></div>
<div id="comment_57808218" class="cw">
	<div id="comment_top_57808218" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808218" name="comment_link_57808218" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808218" onclick="return D2.setFocusComment(57808218)" >Next it'll be git commit messages</a>


		 	<span id="comment_score_57808218" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808218); return false"><span class=opt>Score:</span>4</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808218">		
		on Saturday December 15, 2018 @10:45AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808218">#57808218</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808218"><p>I can see the one for this ticket now:</p><p>"Updated comments to remove 'fuck' 'shit' and 'bollocks' as some millenial wanker decided to complain. Pussy."</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808218">
<span class="ind"></span><a id="reply_link_57808218" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808218" onclick="D2.replyTo(57808218); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Next it'll be git commit messages by Anonymous Coward @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808218" data-title="Next it'll be git commit messages">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Next it'll be git commit messages by Anonymous Coward" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808218" data-title="Next it'll be git commit messages">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Next it'll be git commit messages by Anonymous Coward" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808218" data-title="Next it'll be git commit messages">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808218" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808218" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808218" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808218"></div>

<ul id="group_57808218">
	<li id="hiddens_57808218" class="hide"></li>
</ul>

<ul id="commtree_57808218"><li id="tree_57808628" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808628" class="commentstatus"></div>
<div id="comment_57808628" class="cw">
	<div id="comment_top_57808628" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808628" name="comment_link_57808628" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808628" onclick="return D2.setFocusComment(57808628)" >Re:</a>


		 	<span id="comment_score_57808628" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808628); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808628"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808628">"Also, we've removed all instances of 'java' as well."</div>
	</div>

	<div class="commentSub" id="comment_sub_57808628">

</div>
</div>

<div id="replyto_57808628"></div>

<ul id="group_57808628">
	<li id="hiddens_57808628" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57808220" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808220" class="commentstatus"></div>
<div id="comment_57808220" class="cw">
	<div id="comment_top_57808220" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808220" name="comment_link_57808220" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808220" onclick="return D2.setFocusComment(57808220)" >Kill all the children...</a>


		 	<span id="comment_score_57808220" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808220); return false"><span class=opt>Score:</span>4</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808220">		
		on Saturday December 15, 2018 @10:45AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808220">#57808220</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808220">One of my favourite code comments came from a French Canadian coder in a shutdown routine for a Unix daemon process that spawned a lot of child processes where he wrote: "And now we kill all the children...".</div>
	</div>

	<div class="commentSub" id="comment_sub_57808220">
<span class="ind"></span><a id="reply_link_57808220" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808220" onclick="D2.replyTo(57808220); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Kill all the children... by Anonymous Coward @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808220" data-title="Kill all the children...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Kill all the children... by Anonymous Coward" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808220" data-title="Kill all the children...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Kill all the children... by Anonymous Coward" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808220" data-title="Kill all the children...">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808220" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808220" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808220" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808220"></div>

<ul id="group_57808220">
	<li id="hiddens_57808220" class="hide"></li>
</ul>

<ul id="commtree_57808220"><li id="tree_57808984" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808984" class="commentstatus"></div>
<div id="comment_57808984" class="cw">
	<div id="comment_top_57808984" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808984" name="comment_link_57808984" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808984" onclick="return D2.setFocusComment(57808984)" >Re:</a>


		 	<span id="comment_score_57808984" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808984); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Kjella">Kjella</a>  <span class="uid"><a href="//slashdot.org/~Kjella">( 173770 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808984"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808984"><p><div class="quote"><p>One of my favourite code comments came from a French Canadian coder in a shutdown routine for a Unix daemon process that spawned a lot of child processes where he wrote: "And now we kill all the children...".</p></div><p>It's all well and fun until you hit the wrong person. I remember reading a story, it might have been on the daily WTF but I couldn't find it about a guy who called up a coworker about a "child killed" problem. There was just a *click* then no answer... a colleague filled him in, the other type of "child killed" just recently. Ouch.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808984">

</div>
</div>

<div id="replyto_57808984"></div>

<ul id="group_57808984">
	<li id="hiddens_57808984" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57808222" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808222" class="commentstatus"></div>
<div id="comment_57808222" class="cw">
	<div id="comment_top_57808222" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808222" name="comment_link_57808222" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808222" onclick="return D2.setFocusComment(57808222)" >Challenge Accepted</a>


		 	<span id="comment_score_57808222" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808222); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~SirDrinksAlot">SirDrinksAlot</a>  <span class="uid"><a href="//slashdot.org/~SirDrinksAlot">( 226001 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808222"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808222">Mental note: Next utility I don't want to make will be entirely constructed using profanity.<br><br>Just need to work out the style guide for it now, high level is open to discussion.</div>
	</div>

	<div class="commentSub" id="comment_sub_57808222">

</div>
</div>

<div id="replyto_57808222"></div>

<ul id="group_57808222">
	<li id="hiddens_57808222" class="hide"></li>
</ul>

<ul id="commtree_57808222"><li id="tree_57811396" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811396" class="commentstatus"></div>
<div id="comment_57811396" class="cw">
	<div id="comment_top_57811396" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811396" name="comment_link_57811396" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811396" onclick="return D2.setFocusComment(57811396)" >Re:</a>


		 	<span id="comment_score_57811396" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811396); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Mal-2">Mal-2</a>  <span class="uid"><a href="//slashdot.org/~Mal-2">( 675116 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811396"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811396"><p>You could fork Ook to use whatever word you want.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811396">

</div>
</div>

<div id="replyto_57811396"></div>

<ul id="group_57811396">
	<li id="hiddens_57811396" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57808236" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808236" class="commentstatus"></div>
<div id="comment_57808236" class="cw">
	<div id="comment_top_57808236" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808236" name="comment_link_57808236" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808236" onclick="return D2.setFocusComment(57808236)" >Heat</a>


		 	<span id="comment_score_57808236" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808236); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JBMcB">JBMcB</a>  <span class="uid"><a href="//slashdot.org/~JBMcB">( 73720 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808236">		
		on Saturday December 15, 2018 @10:47AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808236">#57808236</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808236"><p>I've seen very select cases where swearing in comments can be useful.</p><p>There was a piece of code I saw that people thought was a bug, but was actually purposefully written a particular way to get around a bug in the compiler. Even after comments like<nobr> <wbr></nobr>// SERIOUSLY do not touch this it's a workaround for CVXXXXXX</p><p>People kept messing with it. Finally the dev checked in<nobr> <wbr></nobr>// DO NOT F****ING TOUCH THIS</p><p>and the regressions went away. Again, niche applications, but still valid.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808236">
<span class="ind"></span><a id="reply_link_57808236" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808236" onclick="D2.replyTo(57808236); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Heat by JBMcB @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808236" data-title="Heat">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Heat by JBMcB" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808236" data-title="Heat">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Heat by JBMcB" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808236" data-title="Heat">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808236" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808236" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808236" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808236"></div>

<ul id="group_57808236">
	<li id="hiddens_57808236" class="hide"></li>
</ul>

<ul id="commtree_57808236"><li id="tree_57808500" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808500" class="commentstatus"></div>
<div id="comment_57808500" class="cw">
	<div id="comment_top_57808500" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808500" name="comment_link_57808500" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808500" onclick="return D2.setFocusComment(57808500)" >This is exactly why you should try not to swear</a>


		 	<span id="comment_score_57808500" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808500); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~SuperKendall">SuperKendall</a>  <span class="uid"><a href="//slashdot.org/~SuperKendall">( 25149 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808500">		
		on Saturday December 15, 2018 @11:39AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808500">#57808500</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808500"><p><em>People kept messing with it. Finally the dev checked in<nobr> <wbr></nobr>// DO NOT F****ING TOUCH THIS - and the regressions went away.</em></p><p>This is exactly why you should really try not to swear, in writing or in speech...</p><p>It's because it cheapens the words, and they loose effect.</p><p>These days if someone called you a motherfucker, it's kind of like calling you annoying. It has no power.</p><p>The reason that comment kept people away is because swearing in code is still relatively uncommon, so it has power.  So keep the F-bombs out of code, so when the time comes where it is needed, it still works.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808500">
<span class="ind"></span><a id="reply_link_57808500" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808500" onclick="D2.replyTo(57808500); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=57808236" onclick="return D2.selectParent(57808236)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="This is exactly why you should try not to swear by SuperKendall @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808500" data-title="This is exactly why you should try not to swear">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="This is exactly why you should try not to swear by SuperKendall" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808500" data-title="This is exactly why you should try not to swear">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="This is exactly why you should try not to swear by SuperKendall" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808500" data-title="This is exactly why you should try not to swear">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808500" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808500" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808500" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808500"></div>

<ul id="group_57808500">
	<li id="hiddens_57808500" class="hide"></li>
</ul>

<ul id="commtree_57808500"><li id="tree_57808534" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808534" class="commentstatus"></div>
<div id="comment_57808534" class="cw">
	<div id="comment_top_57808534" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808534" name="comment_link_57808534" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808534" onclick="return D2.setFocusComment(57808534)" >Case by case</a>


		 	<span id="comment_score_57808534" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808534); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JBMcB">JBMcB</a>  <span class="uid"><a href="//slashdot.org/~JBMcB">( 73720 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808534"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808534"><p>I think they should be evaluated on a case by case basis. If for some reason the devs on a project keep messing with the magic number assigned to a file type, a well placed comment cussing them out to prevent that behavior is probably called for. Cussing someone out for a dumb mistake in the code is probably not warranted and should be reverted.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808534">

</div>
</div>

<div id="replyto_57808534"></div>

<ul id="group_57808534">
	<li id="hiddens_57808534" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57809286" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809286" class="commentstatus"></div>
<div id="comment_57809286" class="cw">
	<div id="comment_top_57809286" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809286" name="comment_link_57809286" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809286" onclick="return D2.setFocusComment(57809286)" >Re: Heat</a>


		 	<span id="comment_score_57809286" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809286); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jd">jd</a>  <span class="uid"><a href="//slashdot.org/~jd">( 1658 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809286"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809286"><p>Badly designed code, comment and corrective action.</p><p>Good code should have contracts that prevent breakage from (ideally) compiling or, at worst, passing absolutely any of the tests in the test harness you've got rigged to run on code checked in to the repository.</p><p>Good comments should explain what is done, not simply justify it. Code reviews should validate that future changes to the code do not invalidate the description.</p><p>The corrective action for checking in broken code, regardless of the nature of the breaka<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809286">

</div>
</div>

<div id="replyto_57809286"></div>

<ul id="group_57809286">
	<li id="hiddens_57809286" class="hide"></li>
</ul>

<ul id="commtree_57809286"><li id="tree_57809500" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57809500" class="commentstatus"></div>
<div id="comment_57809500" class="cw">
</div>

<div id="replyto_57809500"></div>

<ul id="group_57809500">
	<li id="hiddens_57809500" class="hide"></li>
</ul>

<ul id="commtree_57809500"><li id="tree_57810114" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57810114" class="commentstatus"></div>
<div id="comment_57810114" class="cw">
	<div id="comment_top_57810114" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57810114" name="comment_link_57810114" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57810114" onclick="return D2.setFocusComment(57810114)" >Re:</a>


		 	<span id="comment_score_57810114" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57810114); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jd">jd</a>  <span class="uid"><a href="//slashdot.org/~jd">( 1658 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57810114"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57810114"><p>And their code won't compile, no matter what they do.</p><p>Eventually, they'll give up and go back to reading "Fly Fishing" by J. R. Hartley.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57810114">

</div>
</div>

<div id="replyto_57810114"></div>

<ul id="group_57810114">
	<li id="hiddens_57810114" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_57811854" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811854" class="commentstatus"></div>
<div id="comment_57811854" class="cw">
	<div id="comment_top_57811854" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811854" name="comment_link_57811854" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811854" onclick="return D2.setFocusComment(57811854)" >Re:</a>


		 	<span id="comment_score_57811854" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811854); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AmiMoJo">AmiMoJo</a>  <span class="uid"><a href="//slashdot.org/~AmiMoJo">( 196126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811854"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811854"><p>I always thought the "increase this counter every time you try to improve this and fail" comment was more effective for keeping people away from tricky code. I normally start at 7.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811854">

</div>
</div>

<div id="replyto_57811854"></div>

<ul id="group_57811854">
	<li id="hiddens_57811854" class="hide"></li>
</ul>

</li><li id="tree_57812146" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57812146" class="commentstatus"></div>
<div id="comment_57812146" class="cw">
	<div id="comment_top_57812146" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57812146" name="comment_link_57812146" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57812146" onclick="return D2.setFocusComment(57812146)" >Re:</a>


		 	<span id="comment_score_57812146" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57812146); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~c">c</a>  <span class="uid"><a href="//slashdot.org/~c">( 8461 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57812146"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57812146"><p>I've used some pretty harsh language in the context of compiler bugs.</p><p>Spending days to discover that adding "assert(sizeof(char)==1);" is needed to force sizeof(char) to be 1 is worthy of a good cathartic vent, IMHO.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57812146">

</div>
</div>

<div id="replyto_57812146"></div>

<ul id="group_57812146">
	<li id="hiddens_57812146" class="hide"></li>
</ul>

</li><li id="tree_57808338" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808338" class="commentstatus"></div>
<div id="comment_57808338" class="cw">
</div>

<div id="replyto_57808338"></div>

<ul id="group_57808338">
	<li id="hiddens_57808338" class="hide"></li>
</ul>

<ul id="commtree_57808338"><li id="tree_57808440" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808440" class="commentstatus"></div>
<div id="comment_57808440" class="cw">
	<div id="comment_top_57808440" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808440" name="comment_link_57808440" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808440" onclick="return D2.setFocusComment(57808440)" >Open Source</a>


		 	<span id="comment_score_57808440" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808440); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~JBMcB">JBMcB</a>  <span class="uid"><a href="//slashdot.org/~JBMcB">( 73720 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808440"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808440"><p>It was an old open source project in the late 90's. I could probably dig it up, if it's still around and the repo goes back that far..</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808440">

</div>
</div>

<div id="replyto_57808440"></div>

<ul id="group_57808440">
	<li id="hiddens_57808440" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_57808298" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808298" class="commentstatus"></div>
<div id="comment_57808298" class="cw">
	<div id="comment_top_57808298" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808298" name="comment_link_57808298" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808298" onclick="return D2.setFocusComment(57808298)" >Changing the word won't make it so.</a>


		 	<span id="comment_score_57808298" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808298); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~SchroedingersCat">SchroedingersCat</a>  <span class="uid"><a href="//slashdot.org/~SchroedingersCat">( 583063 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808298">		
		on Saturday December 15, 2018 @10:57AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808298">#57808298</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808298">As if removing the words will make that monstrous ball of crap better.</div>
	</div>

	<div class="commentSub" id="comment_sub_57808298">
<span class="ind"></span><a id="reply_link_57808298" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808298" onclick="D2.replyTo(57808298); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Changing the word won't make it so. by SchroedingersCat @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808298" data-title="Changing the word won't make it so.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Changing the word won't make it so. by SchroedingersCat" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808298" data-title="Changing the word won't make it so.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Changing the word won't make it so. by SchroedingersCat" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808298" data-title="Changing the word won't make it so.">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808298" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808298" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808298" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808298"></div>

<ul id="group_57808298">
	<li id="hiddens_57808298" class="hide"></li>
</ul>

<ul id="commtree_57808298"><li id="tree_57808448" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808448" class="commentstatus"></div>
<div id="comment_57808448" class="cw">
</div>

<div id="replyto_57808448"></div>

<ul id="group_57808448">
	<li id="hiddens_57808448" class="hide"></li>
</ul>

<ul id="commtree_57808448"><li id="tree_57808680" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808680" class="commentstatus"></div>
<div id="comment_57808680" class="cw">
</div>

<div id="replyto_57808680"></div>

<ul id="group_57808680">
	<li id="hiddens_57808680" class="hide"></li>
</ul>

<ul id="commtree_57808680"><li id="tree_57808820" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808820" class="commentstatus"></div>
<div id="comment_57808820" class="cw">
	<div id="comment_top_57808820" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808820" name="comment_link_57808820" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808820" onclick="return D2.setFocusComment(57808820)" >Re:</a>


		 	<span id="comment_score_57808820" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808820); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~CrashNBrn">CrashNBrn</a>  <span class="uid"><a href="//slashdot.org/~CrashNBrn">( 1143981 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808820"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808820"><p><span class="substr"> </span> <a href="https://www.snopes.com/fact-check/thomas-crapper/" title="snopes.com">https://www.snopes.com/fact-check/thomas-crapper/</a> [snopes.com] </p><blockquote><div><p>...<br>Thomas Crapper took out nine plumbing patents between 1881 and 1896, but none of these patents was for the &ldquo;valveless water-waste preventer&rdquo; he is often credited with having invented. The first patent for a siphonic flush was taken out by Joseph Adamson in 1853, eight years before Crapper started his plumbing business. Many types of siphonic systems were patented in the 1880s, but none by a Crapper until George Crapper, Thomas&rsquo; nephew, w</p></div></blockquote></div>
	</div>

	<div class="commentSub" id="comment_sub_57808820">

</div>
</div>

<div id="replyto_57808820"></div>

<ul id="group_57808820">
	<li id="hiddens_57808820" class="hide"></li>
</ul>

</li><li id="tree_57809290" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809290" class="commentstatus"></div>
<div id="comment_57809290" class="cw">
	<div id="comment_top_57809290" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809290" name="comment_link_57809290" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809290" onclick="return D2.setFocusComment(57809290)" >Re:  Changing the word won't make it so.</a>


		 	<span id="comment_score_57809290" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809290); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jd">jd</a>  <span class="uid"><a href="//slashdot.org/~jd">( 1658 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809290"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809290"><p>Urban legend, long since... dismissed.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809290">

</div>
</div>

<div id="replyto_57809290"></div>

<ul id="group_57809290">
	<li id="hiddens_57809290" class="hide"></li>
</ul>

</li><li id="tree_57808892" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808892" class="commentstatus"></div>
<div id="comment_57808892" class="cw">
</div>

<div id="replyto_57808892"></div>

<ul id="group_57808892">
	<li id="hiddens_57808892" class="hide"></li>
</ul>

<ul id="commtree_57808892"><li id="tree_57811526" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811526" class="commentstatus"></div>
<div id="comment_57811526" class="cw">
	<div id="comment_top_57811526" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811526" name="comment_link_57811526" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811526" onclick="return D2.setFocusComment(57811526)" >Re:  Changing the word won't make it so.</a>


		 	<span id="comment_score_57811526" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811526); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~astrofurter">astrofurter</a>  <span class="uid"><a href="//slashdot.org/~astrofurter">( 5464356 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811526"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811526"><p>Thank you, Dr Pedant, for that learned and insightful commentary.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811526">

</div>
</div>

<div id="replyto_57811526"></div>

<ul id="group_57811526">
	<li id="hiddens_57811526" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li><li id="tree_57808336" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808336" class="commentstatus"></div>
<div id="comment_57808336" class="cw">
	<div id="comment_top_57808336" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808336" name="comment_link_57808336" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808336" onclick="return D2.setFocusComment(57808336)" >Why are the swear words there?</a>


		 	<span id="comment_score_57808336" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808336); return false"><span class=opt>Score:</span>4</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ameline">ameline</a>  <span class="uid"><a href="//slashdot.org/~ameline">( 771895 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808336">		 &lt;<a href="mailto:ian.ameline%40g+m+a+i+l+.+com">ian.ameline@g m a i l . com</a>&gt;
		on Saturday December 15, 2018 @11:05AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808336">#57808336</a>)
		<small><a href="http://www.aliassketchbookpro.com/" title="http://www.aliassketchbookpro.com/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~ameline/journal/" title="Sunday September 04, 2005 @10:37AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808336"><p>Perhaps it might be a good idea to figure out (and fix) the underlying reasons prompting developers to swear in comments.</p><p>As an aside, One late evening, I once constructed an sql query to look for a variety of swear words in the bug database used at Alias (before Autodesk bought us) -- Amon several, one stood out. It was originally opened by a customer (working in New Zealand on some small films made there -- something about a ring or whatever). It was epic in its use of invective. It tore a strip off of the software and the cretins who had written it (myself included, but not specifically named).  The author had been hired and was working at Alias at the time of my query (this was a few years later) (Hi Dave<nobr> <wbr></nobr>:-) ). We had some fun passing the link to the bug report around.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808336">
<span class="ind"></span><a id="reply_link_57808336" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808336" onclick="D2.replyTo(57808336); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Why are the swear words there? by ameline @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808336" data-title="Why are the swear words there?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Why are the swear words there? by ameline" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808336" data-title="Why are the swear words there?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Why are the swear words there? by ameline" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808336" data-title="Why are the swear words there?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808336" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808336" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808336" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808336"></div>

<ul id="group_57808336">
	<li id="hiddens_57808336" class="hide"></li>
</ul>

<ul id="commtree_57808336"><li id="tree_57808648" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808648" class="commentstatus"></div>
<div id="comment_57808648" class="cw">
	<div id="comment_top_57808648" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808648" name="comment_link_57808648" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808648" onclick="return D2.setFocusComment(57808648)" >Re:</a>


		 	<span id="comment_score_57808648" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808648); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Chelloveck">Chelloveck</a>  <span class="uid"><a href="//slashdot.org/~Chelloveck">( 14643 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808648"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808648"><blockquote><div><p>Perhaps it might be a good idea to figure out (and fix) the underlying reasons prompting developers to swear in comments.</p></div></blockquote><p>And sometimes the underlying reasons are dictated by product management.  Like the ridiculous feature they required a whole alternative firmware build for.  Ah, such fond memories of <tt>#ifdef CLUSTERFUCK</tt>.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808648">

</div>
</div>

<div id="replyto_57808648"></div>

<ul id="group_57808648">
	<li id="hiddens_57808648" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57808350" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808350" class="commentstatus"></div>
<div id="comment_57808350" class="cw">
	<div id="comment_top_57808350" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808350" name="comment_link_57808350" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808350" onclick="return D2.setFocusComment(57808350)" >Grow the fuck up</a>


		 	<span id="comment_score_57808350" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808350); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Mike">Mike</a>  <span class="uid"><a href="//slashdot.org/~Mike">( 1172 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808350"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808350"><p>Jesus!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808350">

</div>
</div>

<div id="replyto_57808350"></div>

<ul id="group_57808350">
	<li id="hiddens_57808350" class="hide"></li>
</ul>

<ul id="commtree_57808350"><li id="tree_57808562" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808562" class="commentstatus"></div>
<div id="comment_57808562" class="cw">
	<div id="comment_top_57808562" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808562" name="comment_link_57808562" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808562" onclick="return D2.setFocusComment(57808562)" >Re:</a>


		 	<span id="comment_score_57808562" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808562); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mark-t">mark-t</a>  <span class="uid"><a href="//slashdot.org/~mark-t">( 151149 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808562"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808562">I understand your point,  but swearing is still considered immature and unprofessional.  Honestly, it's surprising that this kind of stuff got past code review, let alone making it into a permanent public repository.</div>
	</div>

	<div class="commentSub" id="comment_sub_57808562">

</div>
</div>

<div id="replyto_57808562"></div>

<ul id="group_57808562">
	<li id="hiddens_57808562" class="hide"></li>
</ul>

<ul id="commtree_57808562"><li id="tree_57811904" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811904" class="commentstatus"></div>
<div id="comment_57811904" class="cw">
	<div id="comment_top_57811904" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811904" name="comment_link_57811904" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811904" onclick="return D2.setFocusComment(57811904)" >Re:</a>


		 	<span id="comment_score_57811904" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811904); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~goose-incarnated">goose-incarnated</a>  <span class="uid"><a href="//slashdot.org/~goose-incarnated">( 1145029 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811904"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811904"><p><div class="quote"><p>I understand your point,  but swearing is still considered immature and unprofessional.</p>  </div><p>Is it more or less immature than performing deep searches for things that might offend you?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811904">

</div>
</div>

<div id="replyto_57811904"></div>

<ul id="group_57811904">
	<li id="hiddens_57811904" class="hide"></li>
</ul>

</li><li id="tree_57809304" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57809304" class="commentstatus"></div>
<div id="comment_57809304" class="cw">
</div>

<div id="replyto_57809304"></div>

<ul id="group_57809304">
	<li id="hiddens_57809304" class="hide"></li>
</ul>

<ul id="commtree_57809304"><li id="tree_57809858" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809858" class="commentstatus"></div>
<div id="comment_57809858" class="cw">
	<div id="comment_top_57809858" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809858" name="comment_link_57809858" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809858" onclick="return D2.setFocusComment(57809858)" >Re:</a>


		 	<span id="comment_score_57809858" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809858); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mark-t">mark-t</a>  <span class="uid"><a href="//slashdot.org/~mark-t">( 151149 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809858"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809858">Only in the opinion of people who don't actually have a clue how to act like adults.</div>
	</div>

	<div class="commentSub" id="comment_sub_57809858">

</div>
</div>

<div id="replyto_57809858"></div>

<ul id="group_57809858">
	<li id="hiddens_57809858" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_57808374" class="comment full contain"><span class="ind"></span>
<div id="comment_status_57808374" class="commentstatus"></div>
<div id="comment_57808374" class="cw">
	<div id="comment_top_57808374" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808374" name="comment_link_57808374" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808374" onclick="return D2.setFocusComment(57808374)" >So: that is English swear words dealed with ...</a>


		 	<span id="comment_score_57808374" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808374); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Alain+Williams">Alain Williams</a>  <span class="uid"><a href="//slashdot.org/~Alain+Williams">( 2972 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808374">		 &lt;<a href="mailto:addw%40phcomp.co.uk">addw@phcomp.co.uk</a>&gt;
		on Saturday December 15, 2018 @11:11AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808374">#57808374</a>)
		<small><a href="https://www.phcomp.co.uk/" title="https://www.phcomp.co.uk/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808374"><p>is someone now going to waste their time checking for variable names, words in comments,<nobr> <wbr></nobr>... that just happen to be a swear word in French, German,<nobr> <wbr></nobr>... and by transliteration Hindi, Chinese,<nobr> <wbr></nobr>... ?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808374">
<span class="ind"></span><a id="reply_link_57808374" class="btn link" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808374" onclick="D2.replyTo(57808374); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="So: that is English swear words dealed with ... by Alain Williams @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808374" data-title="So: that is English swear words dealed with ...">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="So: that is English swear words dealed with ... by Alain Williams" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808374" data-title="So: that is English swear words dealed with ...">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="So: that is English swear words dealed with ... by Alain Williams" data-url="https://developers.slashdot.org/comments.pl?sid=13060244&cid=57808374" data-title="So: that is English swear words dealed with ...">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=13060244%26cid=57808374" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_57808374" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=57808374" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_57808374"></div>

<ul id="group_57808374">
	<li id="hiddens_57808374" class="hide"></li>
</ul>

<ul id="commtree_57808374"><li id="tree_57809010" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809010" class="commentstatus"></div>
<div id="comment_57809010" class="cw">
	<div id="comment_top_57809010" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809010" name="comment_link_57809010" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809010" onclick="return D2.setFocusComment(57809010)" >Re:</a>


		 	<span id="comment_score_57809010" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809010); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Bite+The+Pillow">Bite The Pillow</a>  <span class="uid"><a href="//slashdot.org/~Bite+The+Pillow">( 3087109 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809010"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809010"><p>No.</p><p>Unless you submit a bug report to do so, which will be closed as not enough information, so still no.</p><p>I bet you were proud of this comment. Stop it. You're not helping.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809010">

</div>
</div>

<div id="replyto_57809010"></div>

<ul id="group_57809010">
	<li id="hiddens_57809010" class="hide"></li>
</ul>

</li><li id="tree_57811858" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811858" class="commentstatus"></div>
<div id="comment_57811858" class="cw">
	<div id="comment_top_57811858" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811858" name="comment_link_57811858" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811858" onclick="return D2.setFocusComment(57811858)" >Re:</a>


		 	<span id="comment_score_57811858" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811858); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~AmiMoJo">AmiMoJo</a>  <span class="uid"><a href="//slashdot.org/~AmiMoJo">( 196126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811858"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811858"><p>Does Chinese even have swear words? Japanese doesn't, not really. Even on kids shows they say things like "kuso" (shit) because it's seen as impolite but the concept of "words that simply should not be uttered even though they mean the same as other words that are impolite but not swear words" doesn't exist.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811858">

</div>
</div>

<div id="replyto_57811858"></div>

<ul id="group_57811858">
	<li id="hiddens_57811858" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57808462" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808462" class="commentstatus"></div>
<div id="comment_57808462" class="cw">
	<div id="comment_top_57808462" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808462" name="comment_link_57808462" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808462" onclick="return D2.setFocusComment(57808462)" >Virtuous</a>


		 	<span id="comment_score_57808462" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808462); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jader3rd">jader3rd</a>  <span class="uid"><a href="//slashdot.org/~jader3rd">( 2222716 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808462"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808462">When you self proclaim to be virtuous (ie open source is more cirtuous than proprietary) you will eventually attract people who consider themselves to be virtuous. This is a consequence of that.</div>
	</div>

	<div class="commentSub" id="comment_sub_57808462">

</div>
</div>

<div id="replyto_57808462"></div>

<ul id="group_57808462">
	<li id="hiddens_57808462" class="hide"></li>
</ul>

<ul id="commtree_57808462"><li id="tree_57809310" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809310" class="commentstatus"></div>
<div id="comment_57809310" class="cw">
	<div id="comment_top_57809310" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809310" name="comment_link_57809310" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809310" onclick="return D2.setFocusComment(57809310)" >Re:</a>


		 	<span id="comment_score_57809310" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809310); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~djinn6">djinn6</a>  <span class="uid"><a href="//slashdot.org/~djinn6">( 1868030 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809310"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809310"><p>Free software is actually not as virtuous in the political and moral sense. Businesses can be pressured to stop servicing bad people, but free software can be used by everyone.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809310">

</div>
</div>

<div id="replyto_57809310"></div>

<ul id="group_57809310">
	<li id="hiddens_57809310" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57808564" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808564" class="commentstatus"></div>
<div id="comment_57808564" class="cw">
	<div id="comment_top_57808564" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808564" name="comment_link_57808564" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808564" onclick="return D2.setFocusComment(57808564)" >Professionally?</a>


		 	<span id="comment_score_57808564" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808564); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bill_mcgonigle">bill_mcgonigle</a>  <span class="uid"><a href="//slashdot.org/~bill_mcgonigle">( 4333 )</a></span></a> <a href="/faq/subscriptions.shtml#subscription_other_advantages">*</a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808564"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808564"><p>Does this reporter have any evidence of people using the <i>source</i> of OpenJDK and being somehow unable to cope with the comments or otherwise having problems because of the language?</p><p>It sounds to me like he's making shit up.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808564">

</div>
</div>

<div id="replyto_57808564"></div>

<ul id="group_57808564">
	<li id="hiddens_57808564" class="hide"></li>
</ul>

<ul id="commtree_57808564"><li id="tree_57810894" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57810894" class="commentstatus"></div>
<div id="comment_57810894" class="cw">
	<div id="comment_top_57810894" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57810894" name="comment_link_57810894" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57810894" onclick="return D2.setFocusComment(57810894)" >Re:</a>


		 	<span id="comment_score_57810894" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57810894); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~cascadingstylesheet">cascadingstylesheet</a>  <span class="uid"><a href="//slashdot.org/~cascadingstylesheet">( 140919 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57810894"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57810894"><p><div class="quote"><p>Does this reporter have any evidence of people using the <i>source</i> of OpenJDK and being somehow unable to cope with the comments or otherwise having problems because of the language?</p><p>It sounds to me like he's making shit up.</p></div><p>It's not about being "unable to cope".
</p><p> <i>All</i> words are just arbitrary sounds that convey meaning. So what? Part of the meaning that offensive words convey is offensive meaning. They are literally intended to give offense; that's their meaning. Which is not appropriate in professional settings.
</p><p>There's nothing superior about not knowing or caring (or pretending not to know or care) about the meanings of words.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57810894">

</div>
</div>

<div id="replyto_57810894"></div>

<ul id="group_57810894">
	<li id="hiddens_57810894" class="hide"></li>
</ul>

</li></ul></li><li id="tree_57808622" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808622" class="commentstatus"></div>
<div id="comment_57808622" class="cw">
	<div id="comment_top_57808622" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808622" name="comment_link_57808622" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808622" onclick="return D2.setFocusComment(57808622)" >"Too many"?</a>


		 	<span id="comment_score_57808622" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808622); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nagora">nagora</a>  <span class="uid"><a href="//slashdot.org/~nagora">( 177841 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808622"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808622"><p>What is the sufficient amount?</p><p>Here's a tip: do something about something that matters and stick your moronic childish worries about some words up your ass.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808622">

</div>
</div>

<div id="replyto_57808622"></div>

<ul id="group_57808622">
	<li id="hiddens_57808622" class="hide"></li>
</ul>

</li><li id="tree_57808728" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808728" class="commentstatus"></div>
<div id="comment_57808728" class="cw">
	<div id="comment_top_57808728" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808728" name="comment_link_57808728" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808728" onclick="return D2.setFocusComment(57808728)" >Common in all code bases</a>


		 	<span id="comment_score_57808728" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808728); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~140Mandak262Jamuna">140Mandak262Jamuna</a>  <span class="uid"><a href="//slashdot.org/~140Mandak262Jamuna">( 970587 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808728"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808728">One of our developers used a couple of very off color limericks as static strings to test some of his functions in our string utilities library. Well, he forgot to take it out before committing them, and it ended up in code, and some customer ran <tt>strings</tt> on it<nobr> <wbr></nobr>... <p>
Another developer left in <tt>ShowError("Fuck! Got null again!",true/*=fatal*/)</tt> in shipping code. </p><p>
Another one had a long rant denouncing Osama Bin Laden as a static string, unused but visible in <tt>strings</tt>.</p><p>
It happens a lot.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808728">

</div>
</div>

<div id="replyto_57808728"></div>

<ul id="group_57808728">
	<li id="hiddens_57808728" class="hide"></li>
</ul>

</li><li id="tree_57808742" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808742" class="commentstatus"></div>
<div id="comment_57808742" class="cw">
	<div id="comment_top_57808742" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808742" name="comment_link_57808742" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808742" onclick="return D2.setFocusComment(57808742)" >I've used JDK</a>


		 	<span id="comment_score_57808742" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808742); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~PPH">PPH</a>  <span class="uid"><a href="//slashdot.org/~PPH">( 736903 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808742"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808742"><p>In my opinion, there aren't enough.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808742">

</div>
</div>

<div id="replyto_57808742"></div>

<ul id="group_57808742">
	<li id="hiddens_57808742" class="hide"></li>
</ul>

</li><li id="tree_57808960" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57808960" class="commentstatus"></div>
<div id="comment_57808960" class="cw">
	<div id="comment_top_57808960" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57808960" name="comment_link_57808960" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57808960" onclick="return D2.setFocusComment(57808960)" >If you don't like comments...</a>


		 	<span id="comment_score_57808960" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57808960); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Glasswire">Glasswire</a>  <span class="uid"><a href="//slashdot.org/~Glasswire">( 302197 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57808960"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57808960"><p>..or code submitted, feel free to provide "better" submissions with cleaner code or cleaner comments and if people like your version better, it gets in.  This is Open Source, no one should be allowed to push out content (incl comments) the project agrees is good without providing a superior submission.  Besides this criticism totally ignores the possibility that the thing being described was not so bad that profanity was the most accurate description.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57808960">

</div>
</div>

<div id="replyto_57808960"></div>

<ul id="group_57808960">
	<li id="hiddens_57808960" class="hide"></li>
</ul>

</li><li id="tree_57809008" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809008" class="commentstatus"></div>
<div id="comment_57809008" class="cw">
	<div id="comment_top_57809008" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809008" name="comment_link_57809008" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809008" onclick="return D2.setFocusComment(57809008)" >Cultural hegemony</a>


		 	<span id="comment_score_57809008" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809008); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~pegdhcp">pegdhcp</a>  <span class="uid"><a href="//slashdot.org/~pegdhcp">( 1158827 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809008"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809008">If these snow flakes are that sensitive for perceived insults, I demand all references to "problem" to be removed from OpenJDK. See "problem" translates to my native language as "sknt", which is written as "sikinti" when ASCII used. "Sikinti" in turn can be used in several different contexts those are related to "dick", "fuck" and "fucking".

OTOH I am afraid we can actually find some morons who would take my complaint above seriously and try to "correct" this issue. My apologies in advance for any inconven</div>
	</div>

	<div class="commentSub" id="comment_sub_57809008">

</div>
</div>

<div id="replyto_57809008"></div>

<ul id="group_57809008">
	<li id="hiddens_57809008" class="hide"></li>
</ul>

</li><li id="tree_57809066" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809066" class="commentstatus"></div>
<div id="comment_57809066" class="cw">
	<div id="comment_top_57809066" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809066" name="comment_link_57809066" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809066" onclick="return D2.setFocusComment(57809066)" >Keep it clean, keep it simple. </a>


		 	<span id="comment_score_57809066" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809066); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~westlake">westlake</a>  <span class="uid"><a href="//slashdot.org/~westlake">( 615356 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809066"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809066">Mark Twain had to trash the first print run of Huckleberry Finn because an engraver made a subtle pornographic change in an illustration. I doubt he cared whether this off-color joke was ever meant to become public --- as an editor and publisher he had to answer for it. Think about who will be reading your comments and whether they are actually useful.</div>
	</div>

	<div class="commentSub" id="comment_sub_57809066">

</div>
</div>

<div id="replyto_57809066"></div>

<ul id="group_57809066">
	<li id="hiddens_57809066" class="hide"></li>
</ul>

</li><li id="tree_57809250" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809250" class="commentstatus"></div>
<div id="comment_57809250" class="cw">
	<div id="comment_top_57809250" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809250" name="comment_link_57809250" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809250" onclick="return D2.setFocusComment(57809250)" >Not enough blasphemy</a>


		 	<span id="comment_score_57809250" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809250); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~OrangeTide">OrangeTide</a>  <span class="uid"><a href="//slashdot.org/~OrangeTide">( 124937 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809250"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809250"><p>For religious reasons I insist source code contains a significant amount of blasphemy. Time to open a bug.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809250">

</div>
</div>

<div id="replyto_57809250"></div>

<ul id="group_57809250">
	<li id="hiddens_57809250" class="hide"></li>
</ul>

</li><li id="tree_57809302" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809302" class="commentstatus"></div>
<div id="comment_57809302" class="cw">
	<div id="comment_top_57809302" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809302" name="comment_link_57809302" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809302" onclick="return D2.setFocusComment(57809302)" >Java should probably be deleted</a>


		 	<span id="comment_score_57809302" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809302); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jd">jd</a>  <span class="uid"><a href="//slashdot.org/~jd">( 1658 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809302"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809302"><p>It doesn't meet the original design criteria, it's unclear it meets the current one either, it's abysmally slow, it encourages bad programming and it causes profuse profanities.</p><p>So it's still better than C#, but really isn't fit for any kind of professional setting.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809302">

</div>
</div>

<div id="replyto_57809302"></div>

<ul id="group_57809302">
	<li id="hiddens_57809302" class="hide"></li>
</ul>

</li><li id="tree_57809418" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809418" class="commentstatus"></div>
<div id="comment_57809418" class="cw">
	<div id="comment_top_57809418" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809418" name="comment_link_57809418" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809418" onclick="return D2.setFocusComment(57809418)" >Usually just one or two devs.</a>


		 	<span id="comment_score_57809418" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809418); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~shess">shess</a>  <span class="uid"><a href="//slashdot.org/~shess">( 31691 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809418"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809418"><p>In my experience, swears in comments are like swears in real life - usually 90% of the f-bombs in a given group are one or two people.  It's not that the other people are so prim and proper that they won't swear, it's that they only swear when it's called for.  But there'll be that one person who has to whip out fuck for as an adjective for every minor ailment in their life.</p><p>[Of course, it's different in groups where 90% of the sentences spoken contain a swear word.  I haven't often been in such groups since<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809418">

</div>
</div>

<div id="replyto_57809418"></div>

<ul id="group_57809418">
	<li id="hiddens_57809418" class="hide"></li>
</ul>

</li><li id="tree_57810272" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57810272" class="commentstatus"></div>
<div id="comment_57810272" class="cw">
	<div id="comment_top_57810272" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57810272" name="comment_link_57810272" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57810272" onclick="return D2.setFocusComment(57810272)" >What a fucking snowflake :]</a>


		 	<span id="comment_score_57810272" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57810272); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~najajomo">najajomo</a>  <span class="uid"><a href="//slashdot.org/~najajomo">( 4890785 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57810272"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57810272">Adam Farley is a fucking snowflake and has no sense of humor<nobr> <wbr></nobr>:]</div>
	</div>

	<div class="commentSub" id="comment_sub_57810272">

</div>
</div>

<div id="replyto_57810272"></div>

<ul id="group_57810272">
	<li id="hiddens_57810272" class="hide"></li>
</ul>

</li><li id="tree_57811040" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811040" class="commentstatus"></div>
<div id="comment_57811040" class="cw">
	<div id="comment_top_57811040" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811040" name="comment_link_57811040" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811040" onclick="return D2.setFocusComment(57811040)" >WTF</a>


		 	<span id="comment_score_57811040" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811040); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dos1">dos1</a>  <span class="uid"><a href="//slashdot.org/~dos1">( 2950945 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811040"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811040"><p>This is such a non-news. There wasn't even any controversy inside the project. Just a patch, short discussion, resolution, like many others that happen in many different projects each day. How is this newsworthy in any way?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811040">

</div>
</div>

<div id="replyto_57811040"></div>

<ul id="group_57811040">
	<li id="hiddens_57811040" class="hide"></li>
</ul>

</li><li id="tree_57811080" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811080" class="commentstatus"></div>
<div id="comment_57811080" class="cw">
	<div id="comment_top_57811080" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811080" name="comment_link_57811080" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811080" onclick="return D2.setFocusComment(57811080)" >obligatory...</a>


		 	<span id="comment_score_57811080" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811080); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Espectr0">Espectr0</a>  <span class="uid"><a href="//slashdot.org/~Espectr0">( 577637 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811080"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811080"><p>..NOT XKCD.</p><p><a href="http://www.osnews.com/story/19266/WTFs_m" title="osnews.com">WTF/m</a> [osnews.com]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811080">

</div>
</div>

<div id="replyto_57811080"></div>

<ul id="group_57811080">
	<li id="hiddens_57811080" class="hide"></li>
</ul>

</li><li id="tree_57811580" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811580" class="commentstatus"></div>
<div id="comment_57811580" class="cw">
	<div id="comment_top_57811580" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811580" name="comment_link_57811580" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811580" onclick="return D2.setFocusComment(57811580)" >fuck them</a>


		 	<span id="comment_score_57811580" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811580); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Tom">Tom</a>  <span class="uid"><a href="//slashdot.org/~Tom">( 822 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811580"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811580"><p>I've written tens a couple hundred thousand lines of code in my life.</p><p>Sometimes, "fuck" is the exact word that expresses things correctly, precisely and honestly. Didn't they teach you in CS class to write good documentation? There's stuff out there that cannot be captured any more perfect than writing "fuck".</p><p>I'm all for maturity and professionalism. And when I get a piece of code from someone else and I need to fix it or maintain it or extend it, I don't want it white-washed to conform to someones idea of p<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811580">

</div>
</div>

<div id="replyto_57811580"></div>

<ul id="group_57811580">
	<li id="hiddens_57811580" class="hide"></li>
</ul>

</li><li id="tree_57811754" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57811754" class="commentstatus"></div>
<div id="comment_57811754" class="cw">
	<div id="comment_top_57811754" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57811754" name="comment_link_57811754" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57811754" onclick="return D2.setFocusComment(57811754)" >What is the point?</a>


		 	<span id="comment_score_57811754" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57811754); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thsths">thsths</a>  <span class="uid"><a href="//slashdot.org/~thsths">( 31372 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57811754"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57811754"><p>Even if "crap" and "damn" are not swear words, I fail to imagine a situation where they are appropriate in a comment or a variable name (unless you are building a bad language filter, of course).</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57811754">

</div>
</div>

<div id="replyto_57811754"></div>

<ul id="group_57811754">
	<li id="hiddens_57811754" class="hide"></li>
</ul>

</li><li id="tree_57808228" class="comment hidden"><span class="ind"></span>
<div id="comment_status_57808228" class="commentstatus"></div>
<div id="comment_57808228" class="cw">
</div>

<div id="replyto_57808228"></div>

<ul id="group_57808228">
	<li id="hiddens_57808228" class="hide"></li>
</ul>

<ul id="commtree_57808228"><li id="tree_57809254" class="comment oneline"><span class="ind"></span>
<div id="comment_status_57809254" class="commentstatus"></div>
<div id="comment_57809254" class="cw">
	<div id="comment_top_57809254" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_57809254" name="comment_link_57809254" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;cid=57809254" onclick="return D2.setFocusComment(57809254)" >Re: Dear Snoflakes,</a>


		 	<span id="comment_score_57809254" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 57809254); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jd">jd</a>  <span class="uid"><a href="//slashdot.org/~jd">( 1658 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_57809254"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_57809254"><p>Mankind: zombie process</p></div>
	</div>

	<div class="commentSub" id="comment_sub_57809254">

</div>
</div>

<div id="replyto_57809254"></div>

<ul id="group_57809254">
	<li id="hiddens_57809254" class="hide"></li>
</ul>

</li></ul></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//developers.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 0;
		D2.currents()['full']     = 14;
		D2.currents()['oneline']  = 86;
		// D2.currents_total(100);

		D2.abbrev_comments({57808820:3,57808654:522,57809008:512,57811580:529,57809286:536,57809418:522,57808396:512,57808952:535,57810860:522});
		D2.noshow_comments([57808190,57808344,57808206,57808532,57808240,57808580,57808674,57808970,57808516,57808242,57808356,57808302,57809790,57809500,57808338,57808448,57808680,57808892,57809304,57808228]);
		D2.pieces_comments([57808370,57808952,57810860,57809018,57809334,57808234,57808246,57808372,57808474,57808710,57811554,57812008,57811586,57809820,57808368,57808890,57810236,57808186,57808490,57808958,57809198,57811458,57808994,57809812,57809850,57808188,57808270,57809818,57811472,57808294,57808496,57811850,57808396,57808520,57808546,57809244,57810534,57810546,57811588,57811480,57808646,57811890,57808654,57810826,57812218,57809218,57811668,57808628,57808984,57808222,57811396,57808534,57809286,57810114,57811854,57812146,57808440,57808820,57809290,57811526,57808648,57808350,57808562,57811904,57809858,57809010,57811858,57808462,57809310,57808564,57810894,57808622,57808728,57808742,57808960,57809008,57809066,57809250,57809302,57809418,57810272,57811040,57811080,57811580,57811754,57809254]);
		D2.init_hiddens([]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(349676);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1342<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/18/09/13/1523229/python-joins-movement-to-dump-offensive-master-slave-terms?sdsrc=popbyskidbtmprev">Python Joins Movement To Dump 'Offensive' Master, Slave Terms</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>1235<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/18/05/03/1639245/one-of-llvms-top-contributors-quits-development-over-code-of-conduct-outreach-program?sdsrc=popbyskidbtmprev">One Of LLVM's Top Contributors Quits Development Over Code of Conduct, Outreach Program</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>707<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/18/06/19/2332240/github-medium-remove-public-ice-employee-data-repository?sdsrc=popbyskidbtmprev">GitHub, Medium Remove Public ICE Employee Data Repository</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>663<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/18/11/15/160240/the-internet-has-a-huge-cc-problem-and-developers-dont-want-to-deal-with-it?sdsrc=popbyskidbtmprev">The Internet Has a Huge C/C++ Problem and Developers Don't Want to Deal With It</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>653<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/18/10/22/2034211/sqlite-adopts-monastic-code-of-conduct?sdsrc=popbyskidbtmprev">SQLite Adopts 'Monastic' Code of Conduct</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//mobile.slashdot.org/story/18/12/15/0354231/screen-time-changes-structure-of-kids-brains-nih-study-shows?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/cellphones_64.png" width="64" height="64" alt="Cellphones"></span>
	    
					<p class="grid_12"><a href="//mobile.slashdot.org/story/18/12/15/0354231/screen-time-changes-structure-of-kids-brains-nih-study-shows?sdsrc=nextbtmprev">Screen Time Changes Structure of Kids' Brains, NIH Study Shows</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>86<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//mobile.slashdot.org/story/18/12/15/0414228/could-you-live-without-a-smartphone-for-a-year?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/cellphones_64.png" width="64" height="64" alt="Cellphones"></span>
	    
					<p class="grid_12"><a href="//mobile.slashdot.org/story/18/12/15/0414228/could-you-live-without-a-smartphone-for-a-year?sdsrc=prevbtmprev">Could You Live Without a Smartphone For a Year?</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>163<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=13060244&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">100</span> of <span class="totalcommentcnt">244</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>"Life sucks, but death doesn't put out at all...."
-- Thomas J. Kopp</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/">Privacy Statement</a></li>
				<li id='eu_privacy' style='display:none'><a href="#" title="Privacy Choices" onclick="bizx.cmp.promptConsent();return false;">Privacy Choices</a></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/">Opt-out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<script>
		if (window.is_euro_union) {
			document.getElementById('eu_privacy').style.display = 'inline';
		}
		</script>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2018 SlashdotMedia. All Rights Reserved.</span></div>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
if (!window.is_euro_union) {
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
}
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);


if (!window.is_euro_union) {
  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
}
</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && $('#div-gpt-ad-300x250_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			//$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
        if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
        if(topBannerViewed) {
                    //console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
								//console.log('topBannerViewed', topBannerViewed);
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
		  //console.log('ads topBanner displayed');
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
    if($('.adwrap-viewed-railad').length > 0){
						//console.log('ads sidebar displayed');
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
function initPiwikAndNels() {
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();

    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });
    }
    //announcement NEL
    if(document.getElementById('announcementText')){
      $('#announcementText').hide();
      var hlUrl = '/ajax.pl?op=hl_nel';
      if(nelId){
        hlUrl += '&nel_id='+nelId;
      }
      $.ajax({
        url: hlUrl,
        success: function(html){
          if(html.length < 10){
            $('#announcementText').show();
            return;
          }
          $('#announcementText').html(html).show();
        },
        error: function () {
          $('#announcementText').show();
        }
      });
    }
}
bizx.cmp.ifConsent('publisher', ['storage', 'measurement'], initPiwikAndNels);
</script>


<script type="text/javascript">
_linkedin_data_partner_id = "113712";
</script><script type="text/javascript">
if (!window.is_euro_union) {
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
}
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=113712&fmt=gif" />
</noscript>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?267">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?712">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

	<script type="text/javascript">
	if (!window.is_euro_union) {
		window._taboola = window._taboola || [];
		_taboola.push({flush: true});
	}
	</script>

	</body>
	</html>


	<!-- footer type=current end -->