<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	

<script>
if (!window.is_euro_union) {
(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '66');
}
</script>

	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '539896862775333803',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Python 'Dominates' IEEE Spectrum's 2020 List of Top Programming Languages - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	  
		<meta name="description" content="IEEE Spectrum's August issue will include an article titled &#34;The Top Programming Languages.&#34;
 
Calculated using metrics from 11 online sources, it concludes that &#34;One thing remains constant: the dominance of Python.&#34;
Our default ranking is weighted toward the interests of an IEEE member, and looking...">
	    
		<meta name="twitter:card" content="summary">
		<meta name="twitter:site" content="@slashdot">
		<meta name="twitter:domain" content="developers.slashdot.org">
		<meta property="og:url" content="https://developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages">
	    
		<meta property="og:title" content="Python 'Dominates' IEEE Spectrum's 2020 List of Top Programming Languages - Slashdot">
		<meta property="og:description" content="IEEE Spectrum's August issue will include an article titled &#34;The Top Programming Languages.&#34;
 
Calculated using metrics from 11 online sources, it concludes that &#34;One thing remains constant: the dominance of Python.&#34;
Our default ranking is weighted toward the interests of an IEEE member, and looking...">
	  
	
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/python_64.png">
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<link rel="canonical" href="https://developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/373803" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?41df8099025e5377" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?41df8099025e5377" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?41df8099025e5377" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?41df8099025e5377">

	<script src="//a.fsdn.com/con/js/sftheme/cmp3.js"></script>
	<script src="https://slashdot.org/country.js"></script>
	<script>
		if (window.is_euro_union == '1' || (window.region == 'CA' && window.country_code2 == 'US')) {
			window.bizx.cmp.init({cmp_id: 12126}, 'consentmanager.net');
		}
	</script>
	<script src="https://a.fsdn.com/con/js/sftheme/vendor/promise.polyfill.min.js"></script>
	<link rel="stylesheet" href="//a.fsdn.com/con/css/sftheme/sandiego/cmp.css?2020-06-11" type="text/css">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];

    	window.SD = {};
		window.SD.Ads = {};

		window.SD.Ads.slotsById = {};
		window.SD.Ads.idsByPath = {};

		window.SD.Ads.visibleTime = {};
		window.SD.Ads.Helpers = {};

		//window.SD = SD;

    bizx.cmp.ifConsent('', ['all','google-ads'], function(){
        window.bizxPrebid.Ads.initPrebid(window.bizxPrebid.adUnits);
    });
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>

<!-- CrossPixel -->
<script type="text/javascript">
if (!window.is_euro_union) {
    bizx.cmp.ifConsent('', ['all'], function(){
        try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){}
    });
}
</script>




<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?41df8099025e5377"></script>
</head>

<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?41df8099025e5377" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			    'googleplus',
			    'facebook',
			    'twitter',
			    'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"native-facebook",
							"twitter",
							"linkedin",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	if (!window.is_euro_union) {
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	}
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//developers.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotDevelopers" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //developers.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  ><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank" rel="nofollow"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank" rel="nofollow"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://www.linkedin.com/company/slashdot" target="_blank" rel="nofollow"><i class="icon-linkedin-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank" rel="nofollow"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank" rel="nofollow"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Want to read Slashdot from your mobile device? Point it at <a href="http://m.slashdot.org">m.slashdot.org</a> and keep reading!
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
  <div id="announcementText" style="display: none;"> Automatically sync your GitHub releases to SourceForge quickly and easily with <strong><a href="https://sourceforge.net/p/forge/documentation/GitHub%20Importer/" rel="nofollow">this tool</a></strong> and take advantage of SourceForge's massive reach.</span> Check out all of SourceForge&rsquo;s <strong><a href="https://sourceforge.net/blog/brief-history-sourceforge-look-to-future/" rel="nofollow">improvements.</a></strong> | <span class="headline">Follow Slashdot on <a href="https://www.linkedin.com/company/slashdot" rel="nofollow">LinkedIn</a></div>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 1 });
}
</script>
				<article id="firehose-133870689" data-fhid="133870689" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">133870689</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-133870689">
			<a href="//developers.slashdot.org/index2.pl?fhfilter=python" onclick="return addfhfilter('python');">
			
				<img src="//a.fsdn.com/sd/topics/python_64.png" width="64" height="64" alt="Python" title="Python">
			
		</a>
		
	
		
		
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=programming" onclick="return addfhfilter('programming');">
			
				<img src="//a.fsdn.com/sd/topics/programming_64.png" width="64" height="64" alt="Programming" title="Programming">
			
		</a>
		
	
		
		

		
		<a href="//developers.slashdot.org/index2.pl?fhfilter=stats" onclick="return addfhfilter('stats');">
			
				<img src="//a.fsdn.com/sd/topics/stats_64.png" width="64" height="64" alt="Stats" title="Stats">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-133870689" class="story-title"> <a   href="//developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages">Python 'Dominates' IEEE Spectrum's 2020 List of Top Programming Languages</a> <span class=" no extlnk"><a class="story-sourcelnk" href="https://spectrum.ieee.org/at-work/tech-careers/top-programming-language-2020"  title="External link - https://spectrum.ieee.org/at-work/tech-careers/top-programming-language-2020" target="_blank"> (ieee.org) </a></span></span>

		
		
		<!--<span class="comments commentcnt-133870689" >136</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages#comments" title="">136</a></span>
		
	</h2>
	<div class="details" id="details-133870689">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'green')" title="Filter Firehose to entries rated green or better"></span><span class="icon-beaker pop4 " alt="Popularity" title="Filter Firehose to entries rated green or better" onclick="firehose_set_options('color', 'green')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  EditorDavid
			
		
		

		
		
		<time id="fhtime-133870689" datetime="on Monday July 27, 2020 @12:01AM">on Monday July 27, 2020 @12:01AM</time>
		
		
			 from the <span class="dept-text">better-call-Guido</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-133870689">
	
		
	

	
		
		<div id="text-133870689" class="p">
			
		 	
				IEEE Spectrum's August issue will include an article titled "The Top Programming Languages."
<br> <br>
Calculated using metrics from 11 online sources, it concludes that "<a href="https://spectrum.ieee.org/at-work/tech-careers/top-programming-language-2020">One thing remains constant: the dominance of Python</a>."
<i>Our default ranking is weighted toward the interests of an IEEE member, and looking at the top entries, we see that Python has held onto its comfortable lead, with Java and C once again coming in second and third place, respectively. Arduino has seen a big jump, rising from 11th place to seventh. (Purists may argue that Arduino is not a language but rather a hardware platform that is programmed using a derivative of Wiring, which itself is derived from C/C++. But we have always taken a very pragmatic approach to our definition of "programming language," and the reality is that when people are looking to use an Arduino-compatible microcontroller, they typically search for "Arduino code" or buy books about "Arduino programming," not "Wiring code" or "C programming.")<br> <br>

One interpretation of Python's high ranking is that its metrics are inflated by its increasing use as a teaching language: Students are simply asking and searching for the answers to the same elementary questions over and over. There's an historical parallel here. In the 1980s, BASIC was very visible... But few professional programmers used it, and when the home computer bubble burst, so did BASIC's, although some advanced descendants like Microsoft Visual Basic are still relatively popular professionally.<br> <br>

There are two counterarguments, though: The first is that students are people, too! If we pay attention only to what professional and expert coders do, we're at risk of missing an important part of the picture. The second is that, unlike BASIC, Python is frequently used professionally and in high-profile realms, such as machine learning, thanks to its enormous collection of high quality, specialized libraries.</i> <br>C++ came in fourth, followed by JavaScript, R, "Arduino," Go, Swift, and Matlab.<br> <br>
But because different programmers have different needs, they've also created a special interactive version of their rankings online, "allowing you to weight the metrics as you see fit... "<br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-133870689" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages"
								  data-janrain-title="Python 'Dominates' IEEE Spectrum's 2020 List of Top Programming Languages"
								  data-janrain-message="Python 'Dominates' IEEE Spectrum's 2020 List of Top Programming Languages @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-133870689" class="tag-bar none">
			<a  class="popular popular topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/nix" target="_blank">nix</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//slashdot.org/story/20/07/27/0158259/how-a-chinese-agent-used-linkedin-to-lure-american-targets?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//science.slashdot.org/story/20/07/26/170224/slashdot-interviews-an-oxford-vaccine-trial-participant?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//slashdot.org/story/20/07/27/0158259/how-a-chinese-agent-used-linkedin-to-lure-american-targets?sdsrc=prev">How a Chinese Agent Used LinkedIn to 'Lure' American Targets </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//developers.slashdot.org/story/16/04/25/0046240/interview-with-python-creator-guido-van-rossum?sdsrc=rel">Interview With Python Creator Guido Van Rossum</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//science.slashdot.org/story/20/07/26/170224/slashdot-interviews-an-oxford-vaccine-trial-participant?sdsrc=next">Slashdot Interviews an Oxford Vaccine Trial Participant</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
if (!window.is_euro_union) {
    if (isAdBlockActive) {
        $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }
            }
        });
    };
}
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages" title="Back to Article - Python 'Dominates' IEEE Spectrum's 2020 List of Top Programming Languages">Python 'Dominates' IEEE Spectrum's 2020 List of Top Programming Languages</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Python 'Dominates' IEEE Spectrum's 2020 List of Top Programming Languages" href="//developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages">Python 'Dominates' IEEE Spectrum's 2020 List of Top Programming Languages</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
						 		<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=16842865" class="btn">Search <span class="totalcommentcnt">135</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//developers.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//developers.slashdot.org/comments.pl?sid=16842865">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//developers.slashdot.org/search.pl?op=comments&amp;sid=16842865" class="ui-icon search_comments">Search <span class="totalcommentcnt">135</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//developers.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//developers.slashdot.org/story/20/07/27/0235203/python-dominates-ieee-spectrums-2020-list-of-top-programming-languages/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?41df8099025e5377" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_60334853" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60334853" class="commentstatus"></div>
<div id="comment_60334853" class="cw">
	<div id="comment_top_60334853" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60334853" name="comment_link_60334853" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334853" onclick="return D2.setFocusComment(60334853)" >Engineers love python?</a>


		 	<span id="comment_score_60334853" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60334853); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~93+Escort+Wagon">93 Escort Wagon</a>  <span class="uid"><a href="//slashdot.org/~93+Escort+Wagon">( 326346 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60334853"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60334853"><p>Knock me over with a feather! Glad I was sitting down when I read that...</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60334853">

</div>
</div>

<div id="replyto_60334853"></div>

<ul id="group_60334853">
	<li id="hiddens_60334853" class="hide"></li>
</ul>

<ul id="commtree_60334853"><li id="tree_60334973" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60334973" class="commentstatus"></div>
<div id="comment_60334973" class="cw">
	<div id="comment_top_60334973" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60334973" name="comment_link_60334973" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334973" onclick="return D2.setFocusComment(60334973)" >Re:Engineers love python?</a>


		 	<span id="comment_score_60334973" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60334973); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sg_oneill">sg_oneill</a>  <span class="uid"><a href="//slashdot.org/~sg_oneill">( 159032 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60334973">		
		on Monday July 27, 2020 @01:06AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334973">#60334973</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60334973"><p>That engineers love python is definatly not new. I started using it in the 1990s due to its phenomenally straight forward RS232 library which was immensely useful for my day job of reverse engineering RS232 hardware to write software to control it. Before that the default was QBasic which was an *awful* language, but had a weirdly excellent Serial implementation (OPEN "com1:",8,N,1,9600 or something like that, its been a while). And I fell *immediately* in love with the language having more or less learned it in an afternoon.</p><p>The problem for me was it took almost a decade before I actually started seeing jobs advertising for it, and its only in the last 5 years I've started seeing it regularly advertised.</p><p>Which makes it a bit surreal seeing all the Javascript and Ruby hipsters suddenly singing high praise of it and behaving as if its a brand new languange. No kids, Python is one of the oldest languages still in common use, older than Java, Ruby, Javascript, any number of functional languages, Swift, Kotlin, etc etc etc. Its *almost* as old as C++.</p><p>Still, I'm not complaining. I still rather enjoy Python even if the novelty has long since passed. the 3.x range has considerably modernised it. I just hope the new converts don't bring their bad habits across and infect the package ecosystem with the sort of half arsed badly written and promptly abandoned hellscape that blighted JS and to a lesser extent Ruby. Pythons advantage was a big ecosytem that developed slowly and carefully over a couple of decades. Our APIs are conservative and planned, our contracts rarely change. Lets hope the new kids learn a few things from us.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60334973">
<span class="ind"></span><a id="reply_link_60334973" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334973" onclick="D2.replyTo(60334973); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=60334853" onclick="return D2.selectParent(60334853)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Engineers love python? by sg_oneill @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334973" data-title="Re:Engineers love python?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Engineers love python? by sg_oneill" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334973" data-title="Re:Engineers love python?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Engineers love python? by sg_oneill" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334973" data-title="Re:Engineers love python?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60334973" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60334973" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334973" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60334973"></div>

<ul id="group_60334973">
	<li id="hiddens_60334973" class="hide"></li>
</ul>

<ul id="commtree_60334973"><li id="tree_60335219" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60335219" class="commentstatus"></div>
<div id="comment_60335219" class="cw">
	<div id="comment_top_60335219" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335219" name="comment_link_60335219" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335219" onclick="return D2.setFocusComment(60335219)" >Re:Engineers love python?</a>


		 	<span id="comment_score_60335219" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335219); return false"><span class=opt>Score:</span>5</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335219">		
		on Monday July 27, 2020 @04:11AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335219">#60335219</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335219"><p><div class="quote"><p>any number of functional languages</p></div><p>The functional languages in widespread use, namely Haskell, ML, Erlang and such, are as old or older than Python.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335219">
<span class="ind"></span><a id="reply_link_60335219" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335219" onclick="D2.replyTo(60335219); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=60334973" onclick="return D2.selectParent(60334973)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Engineers love python? by K. S. Kyosuke @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335219" data-title="Re:Engineers love python?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Engineers love python? by K. S. Kyosuke" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335219" data-title="Re:Engineers love python?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Engineers love python? by K. S. Kyosuke" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335219" data-title="Re:Engineers love python?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60335219" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60335219" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335219" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60335219"></div>

<ul id="group_60335219">
	<li id="hiddens_60335219" class="hide"></li>
</ul>

<ul id="commtree_60335219"><li id="tree_60335831" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335831" class="commentstatus"></div>
<div id="comment_60335831" class="cw">
	<div id="comment_top_60335831" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335831" name="comment_link_60335831" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335831" onclick="return D2.setFocusComment(60335831)" >Re:</a>


		 	<span id="comment_score_60335831" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335831); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~HiThere">HiThere</a>  <span class="uid"><a href="//slashdot.org/~HiThere">( 15173 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335831"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335831"><p>Erlang, well maybe.  But Haskell?  ML?  Widespread use?  I think even LISP is more widespread, and certainly Scheme.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335831">

</div>
</div>

<div id="replyto_60335831"></div>

<ul id="group_60335831">
	<li id="hiddens_60335831" class="hide"></li>
</ul>

<ul id="commtree_60335831"><li id="tree_60335999" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335999" class="commentstatus"></div>
<div id="comment_60335999" class="cw">
	<div id="comment_top_60335999" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335999" name="comment_link_60335999" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335999" onclick="return D2.setFocusComment(60335999)" >Re:</a>


		 	<span id="comment_score_60335999" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335999); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335999"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335999">Apparently ML and Haskell are quite popular at financial institutions nowadays. You could probably find Scheme in some Cisco gear, but I'm not sure how many of their products actually contain it. And if by "LISP" you mean Common Lisp, that's not really a functional language, hence me not having mentioned it.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335999">

</div>
</div>

<div id="replyto_60335999"></div>

<ul id="group_60335999">
	<li id="hiddens_60335999" class="hide"></li>
</ul>

<ul id="commtree_60335999"><li id="tree_60336513" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336513" class="commentstatus"></div>
<div id="comment_60336513" class="cw">
	<div id="comment_top_60336513" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336513" name="comment_link_60336513" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336513" onclick="return D2.setFocusComment(60336513)" >Re:</a>


		 	<span id="comment_score_60336513" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336513); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Weekend+Triathlete">Weekend Triathlete</a>  <span class="uid"><a href="//slashdot.org/~Weekend+Triathlete">( 6446590 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336513"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336513"><blockquote><div><p>And if by "LISP" you mean Common Lisp, that's not really a functional language</p></div></blockquote><p>

I'm not sure what else you'd call a language whose primary encoding is functions and primary datatype is functions.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336513">

</div>
</div>

<div id="replyto_60336513"></div>

<ul id="group_60336513">
	<li id="hiddens_60336513" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60336197" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336197" class="commentstatus"></div>
<div id="comment_60336197" class="cw">
	<div id="comment_top_60336197" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336197" name="comment_link_60336197" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336197" onclick="return D2.setFocusComment(60336197)" >Re:</a>


		 	<span id="comment_score_60336197" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336197); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Aighearach">Aighearach</a>  <span class="uid"><a href="//slashdot.org/~Aighearach">( 97333 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336197"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336197"><p>Haskell is all over the place on the backend, LISP, not so much. Scheme is often available as a plugin language in places where nobody is expected to actually write plugins. That seems to be the main use case.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336197">

</div>
</div>

<div id="replyto_60336197"></div>

<ul id="group_60336197">
	<li id="hiddens_60336197" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60336313" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336313" class="commentstatus"></div>
<div id="comment_60336313" class="cw">
	<div id="comment_top_60336313" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336313" name="comment_link_60336313" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336313" onclick="return D2.setFocusComment(60336313)" >Re:</a>


		 	<span id="comment_score_60336313" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336313); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jellomizer">jellomizer</a>  <span class="uid"><a href="//slashdot.org/~jellomizer">( 103300 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336313"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336313"><p>I think you have a different meaning of widespread.</p><p>Still today functional programmings languages are mostly relegated to academic and research based use.</p><p>You can often apply functional types of methodologies to your procedural/OO based languages much easier than applying Procedural and OO based mythologies in a functional language.</p><p>Don't get me wrong, I like the idea of functional languages, and my coding style is heavily influenced on them.  But if I am going to write code, which I don't want to be the only<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336313">

</div>
</div>

<div id="replyto_60336313"></div>

<ul id="group_60336313">
	<li id="hiddens_60336313" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335261" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335261" class="commentstatus"></div>
<div id="comment_60335261" class="cw">
	<div id="comment_top_60335261" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335261" name="comment_link_60335261" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335261" onclick="return D2.setFocusComment(60335261)" >In an afternoon?</a>


		 	<span id="comment_score_60335261" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335261); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Viol8">Viol8</a>  <span class="uid"><a href="//slashdot.org/~Viol8">( 599362 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335261"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335261"><p>" And I fell *immediately* in love with the language having more or less learned it in an afternoon."</p><p>Sorry, but you can't learn a language as large as Python in an afternoon. Sure, you may have learned enough to do what you needed to do but I suspect that was it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335261">

</div>
</div>

<div id="replyto_60335261"></div>

<ul id="group_60335261">
	<li id="hiddens_60335261" class="hide"></li>
</ul>

<ul id="commtree_60335261"><li id="tree_60335263" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335263" class="commentstatus"></div>
<div id="comment_60335263" class="cw">
	<div id="comment_top_60335263" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335263" name="comment_link_60335263" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335263" onclick="return D2.setFocusComment(60335263)" >Re:</a>


		 	<span id="comment_score_60335263" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335263); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335263"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335263">That's probably partly because it used to be smaller back then.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335263">

</div>
</div>

<div id="replyto_60335263"></div>

<ul id="group_60335263">
	<li id="hiddens_60335263" class="hide"></li>
</ul>

</li><li id="tree_60335469" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335469" class="commentstatus"></div>
<div id="comment_60335469" class="cw">
	<div id="comment_top_60335469" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335469" name="comment_link_60335469" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335469" onclick="return D2.setFocusComment(60335469)" >Re:</a>


		 	<span id="comment_score_60335469" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335469); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sg_oneill">sg_oneill</a>  <span class="uid"><a href="//slashdot.org/~sg_oneill">( 159032 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335469"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335469"><p>Of course mastery took longer, but the core of the Python 1.x language can absolutely be learned in an afternoon. The tutorial on the website took about 4 hours to finish and it more or less covered the entire language. Yes some parts took a bit longer to work out, mostly the introspection system, but the rest really was a fairly simple language.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335469">

</div>
</div>

<div id="replyto_60335469"></div>

<ul id="group_60335469">
	<li id="hiddens_60335469" class="hide"></li>
</ul>

</li><li id="tree_60336205" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336205" class="commentstatus"></div>
<div id="comment_60336205" class="cw">
	<div id="comment_top_60336205" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336205" name="comment_link_60336205" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336205" onclick="return D2.setFocusComment(60336205)" >Re:</a>


		 	<span id="comment_score_60336205" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336205); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Aighearach">Aighearach</a>  <span class="uid"><a href="//slashdot.org/~Aighearach">( 97333 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336205"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336205"><p><div class="quote"><p>Sorry, but you can't learn a language as large as Python in an afternoon. Sure, you may have learned enough to do what you needed to do but I suspect that was it.</p></div><p>Your comment is only true for awful programmers who memorize language features and confuse them with algorithms or design patterns.</p><p>Like the idiots who think that to know C means memorizing the spec.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336205">

</div>
</div>

<div id="replyto_60336205"></div>

<ul id="group_60336205">
	<li id="hiddens_60336205" class="hide"></li>
</ul>

<ul id="commtree_60336205"><li id="tree_60336419" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336419" class="commentstatus"></div>
<div id="comment_60336419" class="cw">
	<div id="comment_top_60336419" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336419" name="comment_link_60336419" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336419" onclick="return D2.setFocusComment(60336419)" >Re:</a>


		 	<span id="comment_score_60336419" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336419); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jellomizer">jellomizer</a>  <span class="uid"><a href="//slashdot.org/~jellomizer">( 103300 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336419"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336419"><p>Back in the olden days before Google. Your compiler/interpreter would come with a book with all the commands and what they do.  Newer pre-google languages may had the book in a digital searchable form, Borland IDEs for example.  They usually had every command, it parameters and often an example code of it being used.</p><p>No one ever needed to memorize the spec, those who did, were not necessarily good programmers either.  As the language is the tool, but the programmer is the craftsman.  It is if you go to a woo<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336419">

</div>
</div>

<div id="replyto_60336419"></div>

<ul id="group_60336419">
	<li id="hiddens_60336419" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60336355" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336355" class="commentstatus"></div>
<div id="comment_60336355" class="cw">
	<div id="comment_top_60336355" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336355" name="comment_link_60336355" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336355" onclick="return D2.setFocusComment(60336355)" >Re:</a>


		 	<span id="comment_score_60336355" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336355); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jellomizer">jellomizer</a>  <span class="uid"><a href="//slashdot.org/~jellomizer">( 103300 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336355"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336355"><p>Well every language that I know and that I may have been programming in for over 20 years, I really only have learned enough to do what I needed to do.  When I need to do something different then I will look up something new.</p><p>A C++ Program written by an electrical engineer, to be interfacing with some electronics will be just as hard to debug for a C++ Programmer who has been writing 3d Simulations. As it would be for a skilled programmer to learn a new language all together.</p><p>Valuables, Loops, Conditionals, I<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336355">

</div>
</div>

<div id="replyto_60336355"></div>

<ul id="group_60336355">
	<li id="hiddens_60336355" class="hide"></li>
</ul>

<ul id="commtree_60336355"><li id="tree_60336529" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336529" class="commentstatus"></div>
<div id="comment_60336529" class="cw">
	<div id="comment_top_60336529" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336529" name="comment_link_60336529" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336529" onclick="return D2.setFocusComment(60336529)" >Re:</a>


		 	<span id="comment_score_60336529" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336529); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Weekend+Triathlete">Weekend Triathlete</a>  <span class="uid"><a href="//slashdot.org/~Weekend+Triathlete">( 6446590 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336529"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336529"><blockquote><div><p>A C++ Program written by an electrical engineer, to be interfacing with some electronics will be just as hard to debug for a C++ Programmer who has been writing 3d Simulations. As it would be for a skilled programmer to learn a new language all together.</p></div></blockquote><p>As an EE who has actually done both I can assure you that debugging one was not any more difficult than debugging the other.  And I find that new languages are pretty easy to pick up and start using productively.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336529">

</div>
</div>

<div id="replyto_60336529"></div>

<ul id="group_60336529">
	<li id="hiddens_60336529" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_60335473" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335473" class="commentstatus"></div>
<div id="comment_60335473" class="cw">
	<div id="comment_top_60335473" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335473" name="comment_link_60335473" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335473" onclick="return D2.setFocusComment(60335473)" >Re:</a>


		 	<span id="comment_score_60335473" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335473); return false"><span class=opt>Score:</span>2</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dfghjk">dfghjk</a>  <span class="uid"><a href="//slashdot.org/~dfghjk">( 711126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335473"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335473"><p>"Our APIs are conservative and planned, our contracts rarely change."</p><p>Who is this "our" you refer to?  Are you taking credit for Python personally?  If so, when will "our" performance improve?  When can we expect multi-threaded performance to not be an embarrassment?  When can we expect two threads within a Python application to actually run concurrently?  Is it "our" plan that threads be a mechanism to destroy determinism and not be a mechanism to improve performance?</p><p>I guess, considering "our" idea of progr<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335473">

</div>
</div>

<div id="replyto_60335473"></div>

<ul id="group_60335473">
	<li id="hiddens_60335473" class="hide"></li>
</ul>

<ul id="commtree_60335473"><li id="tree_60335609" class="comment hidden"><span class="ind"></span>
<div id="comment_status_60335609" class="commentstatus"></div>
<div id="comment_60335609" class="cw">
</div>

<div id="replyto_60335609"></div>

<ul id="group_60335609">
	<li id="hiddens_60335609" class="hide"></li>
</ul>

<ul id="commtree_60335609"><li id="tree_60335847" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335847" class="commentstatus"></div>
<div id="comment_60335847" class="cw">
	<div id="comment_top_60335847" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335847" name="comment_link_60335847" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335847" onclick="return D2.setFocusComment(60335847)" >Re:</a>


		 	<span id="comment_score_60335847" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335847); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~HiThere">HiThere</a>  <span class="uid"><a href="//slashdot.org/~HiThere">( 15173 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335847"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335847"><p>Because Python2 was good enough in most ways that there was no reason to change.  Good stable code is a treasure, and expensive to convert to something else.  Python2 had as it's main weakness a lack of ability to deal with Unicode.  Python3 pretty much solved that.  But if your text was in, say, English, the conversion didn't make much sense.  There are a few other edge cases were Python3 is better, and a few where Python2 is better, but they aren't large.</p><p>Personally, I like Python3's Unicode handling, so I<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335847">

</div>
</div>

<div id="replyto_60335847"></div>

<ul id="group_60335847">
	<li id="hiddens_60335847" class="hide"></li>
</ul>

<ul id="commtree_60335847"><li id="tree_60335899" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335899" class="commentstatus"></div>
<div id="comment_60335899" class="cw">
	<div id="comment_top_60335899" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335899" name="comment_link_60335899" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335899" onclick="return D2.setFocusComment(60335899)" >Re:</a>


		 	<span id="comment_score_60335899" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335899); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~fluffernutter">fluffernutter</a>  <span class="uid"><a href="//slashdot.org/~fluffernutter">( 1411889 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335899"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335899">I love Python myself, I think it is just faster to do things in.  However I don't understand how adding parenthesis to the print and having to use the format function made it any better.  The Python 2 replacement with the percentage symbol was great.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335899">

</div>
</div>

<div id="replyto_60335899"></div>

<ul id="group_60335899">
	<li id="hiddens_60335899" class="hide"></li>
</ul>

</li><li id="tree_60335913" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335913" class="commentstatus"></div>
<div id="comment_60335913" class="cw">
	<div id="comment_top_60335913" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335913" name="comment_link_60335913" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335913" onclick="return D2.setFocusComment(60335913)" >Re:</a>


		 	<span id="comment_score_60335913" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335913); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jythie">jythie</a>  <span class="uid"><a href="//slashdot.org/~jythie">( 914043 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335913"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335913">Unfortunately python 3's 'solving' of unicode became its own nightmare of upgrade problems.  I guess it is fine if you are starting a new project from scratch, but a year after upgrading and we are STILL running into little 'str vs byte' landmines.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335913">

</div>
</div>

<div id="replyto_60335913"></div>

<ul id="group_60335913">
	<li id="hiddens_60335913" class="hide"></li>
</ul>

<ul id="commtree_60335913"><li id="tree_60336445" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336445" class="commentstatus"></div>
<div id="comment_60336445" class="cw">
	<div id="comment_top_60336445" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336445" name="comment_link_60336445" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336445" onclick="return D2.setFocusComment(60336445)" >Re:</a>


		 	<span id="comment_score_60336445" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336445); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jellomizer">jellomizer</a>  <span class="uid"><a href="//slashdot.org/~jellomizer">( 103300 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336445"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336445"><p>The real problem was people being too stubborn to bother to upgrade.  It wasn't that hard to upgrade most python programs. Just as long you weren't too friendly with the likes of PIP.  (which I avoid third party libraries as much as I can. I don't say I never use them, eg I use PyPyODBC and elxwrtitter.  But I try to limit my use)</p><p>But more often than not, it is just because some stubborn guy doesn't want to bother to even test his code on Python 3 and fix the print statments.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336445">

</div>
</div>

<div id="replyto_60336445"></div>

<ul id="group_60336445">
	<li id="hiddens_60336445" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_60336209" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336209" class="commentstatus"></div>
<div id="comment_60336209" class="cw">
	<div id="comment_top_60336209" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336209" name="comment_link_60336209" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336209" onclick="return D2.setFocusComment(60336209)" >Re:</a>


		 	<span id="comment_score_60336209" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336209); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Aighearach">Aighearach</a>  <span class="uid"><a href="//slashdot.org/~Aighearach">( 97333 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336209"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336209"><p><div class="quote"><p>(Source: google)</p><p>Since we're now in 2020, I'd say that qualifies as "rarely change</p></div><p>I think that is a very poor argument when the change still hasn't succeeded, the change has been in progress for over a decade. That means, even when there are few specific changes, you're still stuck in the state of constant change, eternally in the middle of a switchover.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336209">

</div>
</div>

<div id="replyto_60336209"></div>

<ul id="group_60336209">
	<li id="hiddens_60336209" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_60335903" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335903" class="commentstatus"></div>
<div id="comment_60335903" class="cw">
	<div id="comment_top_60335903" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335903" name="comment_link_60335903" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335903" onclick="return D2.setFocusComment(60335903)" >Re:</a>


		 	<span id="comment_score_60335903" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335903); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jythie">jythie</a>  <span class="uid"><a href="//slashdot.org/~jythie">( 914043 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335903"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335903">Conservative and planned? <br> <br>Well, planned maybe, but one of python's big weaknesses is that so much changes between versions.   It is great for projects with short shelf lifes or that can be frozen in time, but with long running projects that want to update libraries python can be a nightmare.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335903">

</div>
</div>

<div id="replyto_60335903"></div>

<ul id="group_60335903">
	<li id="hiddens_60335903" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335057" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335057" class="commentstatus"></div>
<div id="comment_60335057" class="cw">
	<div id="comment_top_60335057" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335057" name="comment_link_60335057" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335057" onclick="return D2.setFocusComment(60335057)" >Re:</a>


		 	<span id="comment_score_60335057" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335057); return false"><span class=opt>Score:</span>3</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~peppepz">peppepz</a>  <span class="uid"><a href="//slashdot.org/~peppepz">( 1311345 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335057"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335057">I so much love languages in which every typo becomes an error that goes undetected until it crashes the program at runtime.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335057">

</div>
</div>

<div id="replyto_60335057"></div>

<ul id="group_60335057">
	<li id="hiddens_60335057" class="hide"></li>
</ul>

<ul id="commtree_60335057"><li id="tree_60335117" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335117" class="commentstatus"></div>
<div id="comment_60335117" class="cw">
	<div id="comment_top_60335117" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335117" name="comment_link_60335117" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335117" onclick="return D2.setFocusComment(60335117)" >Re:</a>


		 	<span id="comment_score_60335117" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335117); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ShanghaiBill">ShanghaiBill</a>  <span class="uid"><a href="//slashdot.org/~ShanghaiBill">( 739463 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335117"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335117"><p>Google "pylint".</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335117">

</div>
</div>

<div id="replyto_60335117"></div>

<ul id="group_60335117">
	<li id="hiddens_60335117" class="hide"></li>
</ul>

<ul id="commtree_60335117"><li id="tree_60335185" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60335185" class="commentstatus"></div>
<div id="comment_60335185" class="cw">
	<div id="comment_top_60335185" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335185" name="comment_link_60335185" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335185" onclick="return D2.setFocusComment(60335185)" >Re:Engineers love python?</a>


		 	<span id="comment_score_60335185" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335185); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~peppepz">peppepz</a>  <span class="uid"><a href="//slashdot.org/~peppepz">( 1311345 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335185">		
		on Monday July 27, 2020 @03:46AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335185">#60335185</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335185">And an IDE certainly helps too. But we're talking about the language here, the tools required to fix its defects are out of band wrt this discussion.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335185">
<span class="ind"></span><a id="reply_link_60335185" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335185" onclick="D2.replyTo(60335185); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=60335117" onclick="return D2.selectParent(60335117)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Engineers love python? by peppepz @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335185" data-title="Re:Engineers love python?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Engineers love python? by peppepz" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335185" data-title="Re:Engineers love python?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Engineers love python? by peppepz" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335185" data-title="Re:Engineers love python?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60335185" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60335185" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335185" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60335185"></div>

<ul id="group_60335185">
	<li id="hiddens_60335185" class="hide"></li>
</ul>

<ul id="commtree_60335185"><li id="tree_60335227" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335227" class="commentstatus"></div>
<div id="comment_60335227" class="cw">
	<div id="comment_top_60335227" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335227" name="comment_link_60335227" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335227" onclick="return D2.setFocusComment(60335227)" >Re:</a>


		 	<span id="comment_score_60335227" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335227); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335227"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335227">Even then the statement "every typo becomes an error that goes undetected until it crashes the program at runtime" is demonstrably wrong. Many typos that affect the syntactic structure of the program will be detected during parsing.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335227">

</div>
</div>

<div id="replyto_60335227"></div>

<ul id="group_60335227">
	<li id="hiddens_60335227" class="hide"></li>
</ul>

<ul id="commtree_60335227"><li id="tree_60336219" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336219" class="commentstatus"></div>
<div id="comment_60336219" class="cw">
	<div id="comment_top_60336219" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336219" name="comment_link_60336219" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336219" onclick="return D2.setFocusComment(60336219)" >Re:</a>


		 	<span id="comment_score_60336219" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336219); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Aighearach">Aighearach</a>  <span class="uid"><a href="//slashdot.org/~Aighearach">( 97333 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336219"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336219"><p><div class="quote"><p>is demonstrably wrong</p></div><p>When something is usually true, but stated without caveat, it doesn't automatically mean it is wrong. It might have merely been presented in a brief form.</p><p>In that case, presenting a demonstration of a case where it isn't true is called the exception that "proves the rule."</p><p>Don't leave meaning entirely out of your word analysis.<nobr> <wbr></nobr>;)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336219">

</div>
</div>

<div id="replyto_60336219"></div>

<ul id="group_60336219">
	<li id="hiddens_60336219" class="hide"></li>
</ul>

</li><li id="tree_60335605" class="comment hidden"><span class="ind"></span>
<div id="comment_status_60335605" class="commentstatus"></div>
<div id="comment_60335605" class="cw">
</div>

<div id="replyto_60335605"></div>

<ul id="group_60335605">
	<li id="hiddens_60335605" class="hide"></li>
</ul>

<ul id="commtree_60335605"><li id="tree_60335647" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335647" class="commentstatus"></div>
<div id="comment_60335647" class="cw">
	<div id="comment_top_60335647" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335647" name="comment_link_60335647" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335647" onclick="return D2.setFocusComment(60335647)" >Re:</a>


		 	<span id="comment_score_60335647" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335647); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335647"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335647">I don't remember; it's been twenty years since I ditched it. Having said that, I have no idea what how this is related to the fact that syntax errors don't crash a Python program at run-time.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335647">

</div>
</div>

<div id="replyto_60335647"></div>

<ul id="group_60335647">
	<li id="hiddens_60335647" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li></ul></li><li id="tree_60335119" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335119" class="commentstatus"></div>
<div id="comment_60335119" class="cw">
	<div id="comment_top_60335119" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335119" name="comment_link_60335119" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335119" onclick="return D2.setFocusComment(60335119)" >Re:</a>


		 	<span id="comment_score_60335119" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335119); return false"><span class=opt>Score:</span>2</a>, Troll)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Mr.+Dollar+Ton">Mr. Dollar Ton</a>  <span class="uid"><a href="//slashdot.org/~Mr.+Dollar+Ton">( 5495648 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335119"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335119"><p>Nevermind python, WTF is "Arduino" at #7? Never heard of computer language called "Arduino", is it hotter than Amber Heard shagged from her both ends by Musk and Depp?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335119">

</div>
</div>

<div id="replyto_60335119"></div>

<ul id="group_60335119">
	<li id="hiddens_60335119" class="hide"></li>
</ul>

<ul id="commtree_60335119"><li id="tree_60335149" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335149" class="commentstatus"></div>
<div id="comment_60335149" class="cw">
	<div id="comment_top_60335149" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335149" name="comment_link_60335149" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335149" onclick="return D2.setFocusComment(60335149)" >Re:</a>


		 	<span id="comment_score_60335149" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335149); return false"><span class=opt>Score:</span>2</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~hcs_%24reboot">hcs_$reboot</a>  <span class="uid"><a href="//slashdot.org/~hcs_%24reboot">( 1536101 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335149"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335149"><a href="https://www.arduino.cc/reference/en/" title="arduino.cc">You'll sleep less dumb tonight</a> [arduino.cc].</div>
	</div>

	<div class="commentSub" id="comment_sub_60335149">

</div>
</div>

<div id="replyto_60335149"></div>

<ul id="group_60335149">
	<li id="hiddens_60335149" class="hide"></li>
</ul>

<ul id="commtree_60335149"><li id="tree_60336223" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336223" class="commentstatus"></div>
<div id="comment_60336223" class="cw">
	<div id="comment_top_60336223" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336223" name="comment_link_60336223" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336223" onclick="return D2.setFocusComment(60336223)" >Re:</a>


		 	<span id="comment_score_60336223" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336223); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Aighearach">Aighearach</a>  <span class="uid"><a href="//slashdot.org/~Aighearach">( 97333 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336223"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336223"><p>OK, now, before you go to sleep this dumb, please read that fucking link you spammed to find out what "arduino" is, and if it is a programming language. (spoiler: it isn't)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336223">

</div>
</div>

<div id="replyto_60336223"></div>

<ul id="group_60336223">
	<li id="hiddens_60336223" class="hide"></li>
</ul>

<ul id="commtree_60336223"><li id="tree_60336429" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336429" class="commentstatus"></div>
<div id="comment_60336429" class="cw">
	<div id="comment_top_60336429" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336429" name="comment_link_60336429" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336429" onclick="return D2.setFocusComment(60336429)" >Re:</a>


		 	<span id="comment_score_60336429" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336429); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~hcs_%24reboot">hcs_$reboot</a>  <span class="uid"><a href="//slashdot.org/~hcs_%24reboot">( 1536101 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336429"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336429">And <a href="https://www.hackerearth.com/blog/developers/arduino-programming-for-beginners" title="hackerearth.com">that</a> [hackerearth.com]?</div>
	</div>

	<div class="commentSub" id="comment_sub_60336429">

</div>
</div>

<div id="replyto_60336429"></div>

<ul id="group_60336429">
	<li id="hiddens_60336429" class="hide"></li>
</ul>

</li><li id="tree_60336459" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336459" class="commentstatus"></div>
<div id="comment_60336459" class="cw">
	<div id="comment_top_60336459" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336459" name="comment_link_60336459" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336459" onclick="return D2.setFocusComment(60336459)" >Re:</a>


		 	<span id="comment_score_60336459" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336459); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~hcs_%24reboot">hcs_$reboot</a>  <span class="uid"><a href="//slashdot.org/~hcs_%24reboot">( 1536101 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336459"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336459">I own an Arduino board, and program it! The language is close to C/C++, but it's called the "Arduino language".</div>
	</div>

	<div class="commentSub" id="comment_sub_60336459">

</div>
</div>

<div id="replyto_60336459"></div>

<ul id="group_60336459">
	<li id="hiddens_60336459" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_60335477" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335477" class="commentstatus"></div>
<div id="comment_60335477" class="cw">
	<div id="comment_top_60335477" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335477" name="comment_link_60335477" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335477" onclick="return D2.setFocusComment(60335477)" >Re:</a>


		 	<span id="comment_score_60335477" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335477); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sg_oneill">sg_oneill</a>  <span class="uid"><a href="//slashdot.org/~sg_oneill">( 159032 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335477"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335477"><p>It helps to read the article before feigning ignorance.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335477">

</div>
</div>

<div id="replyto_60335477"></div>

<ul id="group_60335477">
	<li id="hiddens_60335477" class="hide"></li>
</ul>

<ul id="commtree_60335477"><li id="tree_60335687" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335687" class="commentstatus"></div>
<div id="comment_60335687" class="cw">
	<div id="comment_top_60335687" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335687" name="comment_link_60335687" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335687" onclick="return D2.setFocusComment(60335687)" >Re:</a>


		 	<span id="comment_score_60335687" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335687); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~drinkypoo">drinkypoo</a>  <span class="uid"><a href="//slashdot.org/~drinkypoo">( 153816 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335687"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335687"><p>The fact that they are willing to consider Arduino a language instead of lumping it with C++ shows that their rankings are bullshit. Do they also count "Minecraft code" as separate from Java? It's clickbait bullshit.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335687">

</div>
</div>

<div id="replyto_60335687"></div>

<ul id="group_60335687">
	<li id="hiddens_60335687" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_60336003" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336003" class="commentstatus"></div>
<div id="comment_60336003" class="cw">
	<div id="comment_top_60336003" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336003" name="comment_link_60336003" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336003" onclick="return D2.setFocusComment(60336003)" >Re:</a>


		 	<span id="comment_score_60336003" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336003); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~bobbied">bobbied</a>  <span class="uid"><a href="//slashdot.org/~bobbied">( 2522392 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336003"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336003"><p><div class="quote"><p>Knock me over with a feather! Glad I was sitting down when I read that...</p></div><p>This engineer doesn't like Python.. I detest it's lack of type checking during compile, it's use of white space as a syntactical element, they way object oriented programming hides nothing (no private variables) from your users and even how comments work and look.  There was a reason C and following (C++, Java, C##, etc) used curly braces and semi-colons and supported private class variables. </p><p>Where It's better than most of the shell scripting languages, the thing that really bothers me is the use of indenta<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336003">

</div>
</div>

<div id="replyto_60336003"></div>

<ul id="group_60336003">
	<li id="hiddens_60336003" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60334869" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60334869" class="commentstatus"></div>
<div id="comment_60334869" class="cw">
	<div id="comment_top_60334869" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60334869" name="comment_link_60334869" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334869" onclick="return D2.setFocusComment(60334869)" >Fad diet, yay sports team</a>


		 	<span id="comment_score_60334869" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60334869); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~yassa2020">yassa2020</a>  <span class="uid"><a href="//slashdot.org/~yassa2020">( 6703044 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60334869">		
		on Monday July 27, 2020 @12:14AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334869">#60334869</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60334869">All of these "top languages" lists are incredibly dumb and pointless. The methodology is always dubious and even if it wasn't there is nothing useful to gain from making such a list/ranking. <br>
Might as well be ranking tribes on categories like "coolest" and "best dressed" and other vapid nonsense.<br>
Not news. Definitely not nerdy. Just stop.</div>
	</div>

	<div class="commentSub" id="comment_sub_60334869">
<span class="ind"></span><a id="reply_link_60334869" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334869" onclick="D2.replyTo(60334869); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Fad diet, yay sports team by yassa2020 @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334869" data-title="Fad diet, yay sports team">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Fad diet, yay sports team by yassa2020" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334869" data-title="Fad diet, yay sports team">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Fad diet, yay sports team by yassa2020" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334869" data-title="Fad diet, yay sports team">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60334869" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60334869" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334869" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60334869"></div>

<ul id="group_60334869">
	<li id="hiddens_60334869" class="hide"></li>
</ul>

<ul id="commtree_60334869"><li id="tree_60334887" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60334887" class="commentstatus"></div>
<div id="comment_60334887" class="cw">
	<div id="comment_top_60334887" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60334887" name="comment_link_60334887" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334887" onclick="return D2.setFocusComment(60334887)" >Re: Fad diet, yay sports team</a>


		 	<span id="comment_score_60334887" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60334887); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~reanjr">reanjr</a>  <span class="uid"><a href="//slashdot.org/~reanjr">( 588767 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60334887"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60334887"><p>It's useful to track these things using multiple data sources and over time. You can spot important trends that way. For example, it would have been easy to see the fall of Ruby from such metrics.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60334887">

</div>
</div>

<div id="replyto_60334887"></div>

<ul id="group_60334887">
	<li id="hiddens_60334887" class="hide"></li>
</ul>

</li><li id="tree_60334899" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60334899" class="commentstatus"></div>
<div id="comment_60334899" class="cw">
	<div id="comment_top_60334899" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60334899" name="comment_link_60334899" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334899" onclick="return D2.setFocusComment(60334899)" >Re:</a>


		 	<span id="comment_score_60334899" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60334899); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~hjf">hjf</a>  <span class="uid"><a href="//slashdot.org/~hjf">( 703092 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60334899"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60334899"><p>Like i said in another post: WHERE IS C#? Where is the<nobr> <wbr></nobr>.NET stuff?</p><p>Always missing. I know most folks around here hate Microsoft, but, not including MS stuff in "top lists" isn't going to make it go away.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60334899">

</div>
</div>

<div id="replyto_60334899"></div>

<ul id="group_60334899">
	<li id="hiddens_60334899" class="hide"></li>
</ul>

<ul id="commtree_60334899"><li id="tree_60335591" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335591" class="commentstatus"></div>
<div id="comment_60335591" class="cw">
	<div id="comment_top_60335591" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335591" name="comment_link_60335591" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335591" onclick="return D2.setFocusComment(60335591)" >Re:</a>


		 	<span id="comment_score_60335591" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335591); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Stephan+Schulz">Stephan Schulz</a>  <span class="uid"><a href="//slashdot.org/~Stephan+Schulz">( 948 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335591"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335591"><p><div class="quote"><p>Like i said in another post: WHERE IS C#? Where is the<nobr> <wbr></nobr>.NET stuff?</p><p>Always missing. I know most folks around here hate Microsoft, but, not including MS stuff in "top lists" isn't going to make it go away.</p></div><p>If you click through to the full list of all  55 languages (as discussed in the article), you will find C# sitting comfortably on position 23, between "Processing" and "SAS". Still two places above Fortran.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335591">

</div>
</div>

<div id="replyto_60335591"></div>

<ul id="group_60335591">
	<li id="hiddens_60335591" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335885" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335885" class="commentstatus"></div>
<div id="comment_60335885" class="cw">
	<div id="comment_top_60335885" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335885" name="comment_link_60335885" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335885" onclick="return D2.setFocusComment(60335885)" >Re:</a>


		 	<span id="comment_score_60335885" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335885); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~pezpunk">pezpunk</a>  <span class="uid"><a href="//slashdot.org/~pezpunk">( 205653 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335885"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335885"><p>imagine getting this bitter and upset over a ranking of languages.  (by the way, i can think of few metrics MORE informative or important.  hope that upsets you even more)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335885">

</div>
</div>

<div id="replyto_60335885"></div>

<ul id="group_60335885">
	<li id="hiddens_60335885" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60334889" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60334889" class="commentstatus"></div>
<div id="comment_60334889" class="cw">
	<div id="comment_top_60334889" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60334889" name="comment_link_60334889" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334889" onclick="return D2.setFocusComment(60334889)" >yeah nah</a>


		 	<span id="comment_score_60334889" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60334889); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~hjf">hjf</a>  <span class="uid"><a href="//slashdot.org/~hjf">( 703092 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60334889">		
		on Monday July 27, 2020 @12:23AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334889">#60334889</a>)
		<small><a href="http://www.hjf.com.ar/" title="http://www.hjf.com.ar/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60334889"><p>No, I don't know where these people get those results, but no.<br>In all "TOP #1 BESTEST LANGUAGES" lists, Microsoft stuff is always missing. C# is never mentioned in any of these lists.</p><p>And yet,<nobr> <wbr></nobr>.NET Core is growing faster than anything else now. I don't know anyone who uses Rust but for some reason, Rust seems to squeeze its way into most "best language top 10s".</p><p>I honestly don't understand it. C# is used A LOT. Deal with it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60334889">
<span class="ind"></span><a id="reply_link_60334889" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334889" onclick="D2.replyTo(60334889); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="yeah nah by hjf @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334889" data-title="yeah nah">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="yeah nah by hjf" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334889" data-title="yeah nah">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="yeah nah by hjf" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334889" data-title="yeah nah">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60334889" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60334889" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334889" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60334889"></div>

<ul id="group_60334889">
	<li id="hiddens_60334889" class="hide"></li>
</ul>

<ul id="commtree_60334889"><li id="tree_60334961" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60334961" class="commentstatus"></div>
<div id="comment_60334961" class="cw">
	<div id="comment_top_60334961" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60334961" name="comment_link_60334961" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334961" onclick="return D2.setFocusComment(60334961)" >Re:yeah nah</a>


		 	<span id="comment_score_60334961" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60334961); return false"><span class=opt>Score:</span>5</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60334961">		
		on Monday July 27, 2020 @12:59AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334961">#60334961</a>)
		<small><a href="//slashdot.org/~phantomfive/journal/" title="Thursday February 18, 2016 @01:58AM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60334961"><a href="https://www.tiobe.com/tiobe-index/" title="tiobe.com">Tiobe puts C# at number 5</a> [tiobe.com]. It seems to have a third the popularity of Java. There, you can stop complaining now. <br> <br>
The IEEE survey is aimed at electrical engineers, and it's not surprising electrical engineers are not interested in C#.</div>
	</div>

	<div class="commentSub" id="comment_sub_60334961">
<span class="ind"></span><a id="reply_link_60334961" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334961" onclick="D2.replyTo(60334961); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=60334889" onclick="return D2.selectParent(60334889)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:yeah nah by phantomfive @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334961" data-title="Re:yeah nah">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:yeah nah by phantomfive" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334961" data-title="Re:yeah nah">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:yeah nah by phantomfive" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334961" data-title="Re:yeah nah">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60334961" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60334961" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334961" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60334961"></div>

<ul id="group_60334961">
	<li id="hiddens_60334961" class="hide"></li>
</ul>

<ul id="commtree_60334961"><li id="tree_60334997" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60334997" class="commentstatus"></div>
<div id="comment_60334997" class="cw">
	<div id="comment_top_60334997" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60334997" name="comment_link_60334997" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334997" onclick="return D2.setFocusComment(60334997)" >Re:</a>


		 	<span id="comment_score_60334997" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60334997); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Dutch+Gun">Dutch Gun</a>  <span class="uid"><a href="//slashdot.org/~Dutch+Gun">( 899105 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60334997"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60334997"><p>It's not just that.  I suspect their data is badly skewed.  For instance, if you customize their list to only include "active github repositories", Dart somehow winds up as the #2 programming language.  Julia is #3, and Arduino is #4.</p><p>Even accounting for whatever "active" means, there's just no way that can be accurate.  There's something seriously wrong with their data.  Or at least some subsets of their data - enough to seriously skew the results in some bizarre directions.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60334997">

</div>
</div>

<div id="replyto_60334997"></div>

<ul id="group_60334997">
	<li id="hiddens_60334997" class="hide"></li>
</ul>

<ul id="commtree_60334997"><li id="tree_60335021" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335021" class="commentstatus"></div>
<div id="comment_60335021" class="cw">
	<div id="comment_top_60335021" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335021" name="comment_link_60335021" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335021" onclick="return D2.setFocusComment(60335021)" >Re:</a>


		 	<span id="comment_score_60335021" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335021); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335021"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335021"><p><div class="quote"><p> Dart somehow winds up as the #2 programming language.</p></div><p>Google has been pushing Dart (with Flutter) for a couple years now as its newest cross-platform UI toolkit.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335021">

</div>
</div>

<div id="replyto_60335021"></div>

<ul id="group_60335021">
	<li id="hiddens_60335021" class="hide"></li>
</ul>

</li><li id="tree_60335181" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335181" class="commentstatus"></div>
<div id="comment_60335181" class="cw">
	<div id="comment_top_60335181" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335181" name="comment_link_60335181" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335181" onclick="return D2.setFocusComment(60335181)" >Re:</a>


		 	<span id="comment_score_60335181" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335181); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~cowdung">cowdung</a>  <span class="uid"><a href="//slashdot.org/~cowdung">( 702933 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335181"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335181"><p>The best way to measure popularity is go to a job site like indeed.com and see just how popular it is.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335181">

</div>
</div>

<div id="replyto_60335181"></div>

<ul id="group_60335181">
	<li id="hiddens_60335181" class="hide"></li>
</ul>

</li><li id="tree_60335381" class="comment hidden"><span class="ind"></span>
<div id="comment_status_60335381" class="commentstatus"></div>
<div id="comment_60335381" class="cw">
</div>

<div id="replyto_60335381"></div>

<ul id="group_60335381">
	<li id="hiddens_60335381" class="hide"></li>
</ul>

<ul id="commtree_60335381"><li id="tree_60335499" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335499" class="commentstatus"></div>
<div id="comment_60335499" class="cw">
	<div id="comment_top_60335499" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335499" name="comment_link_60335499" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335499" onclick="return D2.setFocusComment(60335499)" >Re:</a>


		 	<span id="comment_score_60335499" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335499); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~h33t+l4x0r">h33t l4x0r</a>  <span class="uid"><a href="//slashdot.org/~h33t+l4x0r">( 4107715 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335499"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335499">Well I'm just happy that they took time out of electrocuting themselves to answer a survey at all.  Let's face it, if you're on the IEEE Spectrum, you're lucky to live past 15.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335499">

</div>
</div>

<div id="replyto_60335499"></div>

<ul id="group_60335499">
	<li id="hiddens_60335499" class="hide"></li>
</ul>

</li><li id="tree_60336563" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336563" class="commentstatus"></div>
<div id="comment_60336563" class="cw">
	<div id="comment_top_60336563" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336563" name="comment_link_60336563" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336563" onclick="return D2.setFocusComment(60336563)" >Re:</a>


		 	<span id="comment_score_60336563" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336563); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Weekend+Triathlete">Weekend Triathlete</a>  <span class="uid"><a href="//slashdot.org/~Weekend+Triathlete">( 6446590 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336563"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336563"><p>What?  Remind me again how Autodesk's Eagle and Fusion 360 have C# integrations (hint: they don't.  They have Python integration.)</p><p>All the EE people doing EE work at my workplace (Fortune 50) use Matlab and Python.  The local university (Big 10 land grant school, 60,000 students) does not use C# in their EE curriculum at all.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336563">

</div>
</div>

<div id="replyto_60336563"></div>

<ul id="group_60336563">
	<li id="hiddens_60336563" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_60335005" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335005" class="commentstatus"></div>
<div id="comment_60335005" class="cw">
	<div id="comment_top_60335005" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335005" name="comment_link_60335005" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335005" onclick="return D2.setFocusComment(60335005)" >Re:</a>


		 	<span id="comment_score_60335005" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335005); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~h33t+l4x0r">h33t l4x0r</a>  <span class="uid"><a href="//slashdot.org/~h33t+l4x0r">( 4107715 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335005"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335005">They probably checked Python because it was the only word they recognized, bless their hearts.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335005">

</div>
</div>

<div id="replyto_60335005"></div>

<ul id="group_60335005">
	<li id="hiddens_60335005" class="hide"></li>
</ul>

</li><li id="tree_60336239" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336239" class="commentstatus"></div>
<div id="comment_60336239" class="cw">
	<div id="comment_top_60336239" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336239" name="comment_link_60336239" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336239" onclick="return D2.setFocusComment(60336239)" >Re:</a>


		 	<span id="comment_score_60336239" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336239); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Tablizer">Tablizer</a>  <span class="uid"><a href="//slashdot.org/~Tablizer">( 95088 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336239"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336239"><p>It would be interesting to see surveys by domain or platform usage percentages. Different languages tend to be used for different things. C# is common for corporate CRUD, but not for mobile devices, for example. Java is used for both, so generally gets a higher score. Here's a rough draft of suggested usage categories I'd like to see in language surveys:</p><p>Target Users:<br>- Business internal or custom<br>- Business packaged or subscription<br>- Consumers<br>- Other</p><p>Target end-user device:<br>- Mobile app (download)<br>- Web, mostly m<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336239">

</div>
</div>

<div id="replyto_60336239"></div>

<ul id="group_60336239">
	<li id="hiddens_60336239" class="hide"></li>
</ul>

<ul id="commtree_60336239"><li id="tree_60336543" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336543" class="commentstatus"></div>
<div id="comment_60336543" class="cw">
	<div id="comment_top_60336543" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336543" name="comment_link_60336543" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336543" onclick="return D2.setFocusComment(60336543)" >Re:</a>


		 	<span id="comment_score_60336543" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336543); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336543"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336543">The article has a lot of those categories, although you have to play around with it to get it to work.</div>
	</div>

	<div class="commentSub" id="comment_sub_60336543">

</div>
</div>

<div id="replyto_60336543"></div>

<ul id="group_60336543">
	<li id="hiddens_60336543" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335023" class="comment hidden"><span class="ind"></span>
<div id="comment_status_60335023" class="commentstatus"></div>
<div id="comment_60335023" class="cw">
</div>

<div id="replyto_60335023"></div>

<ul id="group_60335023">
	<li id="hiddens_60335023" class="hide"></li>
</ul>

<ul id="commtree_60335023"><li id="tree_60335027" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335027" class="commentstatus"></div>
<div id="comment_60335027" class="cw">
	<div id="comment_top_60335027" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335027" name="comment_link_60335027" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335027" onclick="return D2.setFocusComment(60335027)" >Re:</a>


		 	<span id="comment_score_60335027" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335027); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~phantomfive">phantomfive</a>  <span class="uid"><a href="//slashdot.org/~phantomfive">( 622387 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335027"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335027"><p><div class="quote"><p>Or perhaps c# wasn't event option/category in whatever means the I3E used to gather their data?</p></div><p>It was, it's number 15.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335027">

</div>
</div>

<div id="replyto_60335027"></div>

<ul id="group_60335027">
	<li id="hiddens_60335027" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_60336427" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336427" class="commentstatus"></div>
<div id="comment_60336427" class="cw">
	<div id="comment_top_60336427" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336427" name="comment_link_60336427" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336427" onclick="return D2.setFocusComment(60336427)" >Re:</a>


		 	<span id="comment_score_60336427" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336427); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~iggymanz">iggymanz</a>  <span class="uid"><a href="//slashdot.org/~iggymanz">( 596061 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336427"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336427"><p>"Microsoft stuff" will ALWAYS be missing in popularity list top 3 and also top 3 leading employment.</p><p>Java, SQL, C++</p><p>Deal with it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336427">

</div>
</div>

<div id="replyto_60336427"></div>

<ul id="group_60336427">
	<li id="hiddens_60336427" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60334911" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60334911" class="commentstatus"></div>
<div id="comment_60334911" class="cw">
	<div id="comment_top_60334911" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60334911" name="comment_link_60334911" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334911" onclick="return D2.setFocusComment(60334911)" >which Pyhon?</a>


		 	<span id="comment_score_60334911" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60334911); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~OrangeTide">OrangeTide</a>  <span class="uid"><a href="//slashdot.org/~OrangeTide">( 124937 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60334911">		
		on Monday July 27, 2020 @12:35AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334911">#60334911</a>)
		<small><a href="http://rm-f.net/" title="http://rm-f.net/" class="user_homepage_display">Homepage</a>
<a href="//slashdot.org/~OrangeTide/journal/" title="Tuesday January 15, 2008 @06:01PM" class="user_journal_display">Journal</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60334911"><p>Python is a set of incompatible versions spanning 30 years. While some versions are officially obsolete, they continue to be widely used and are de facto still active. Why? Because some developers resist refactoring or rewriting otherwise working code in order to track the latest and greatest tools.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60334911">
<span class="ind"></span><a id="reply_link_60334911" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334911" onclick="D2.replyTo(60334911); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="which Pyhon? by OrangeTide @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334911" data-title="which Pyhon?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="which Pyhon? by OrangeTide" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334911" data-title="which Pyhon?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="which Pyhon? by OrangeTide" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334911" data-title="which Pyhon?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60334911" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60334911" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334911" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60334911"></div>

<ul id="group_60334911">
	<li id="hiddens_60334911" class="hide"></li>
</ul>

<ul id="commtree_60334911"><li id="tree_60335145" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335145" class="commentstatus"></div>
<div id="comment_60335145" class="cw">
	<div id="comment_top_60335145" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335145" name="comment_link_60335145" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335145" onclick="return D2.setFocusComment(60335145)" >Re:</a>


		 	<span id="comment_score_60335145" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335145); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~augo">augo</a>  <span class="uid"><a href="//slashdot.org/~augo">( 6575028 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335145"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335145"><p>Thinking about refactoring Python code, I would also be pretty reluctant to do that even if I needed. Being dynamically typed makes it very easy to break stuff. Compare it to let say swift (or Java, or C#) with its strict type system, Optionals, switch statement exhaustiveness checks etc - it makes me really confident messing around with the code, because I know that compiler would not let screw-ups to pass easily. As a result, refactoring swift code for me is a common routine and with Python that probably<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335145">

</div>
</div>

<div id="replyto_60335145"></div>

<ul id="group_60335145">
	<li id="hiddens_60335145" class="hide"></li>
</ul>

<ul id="commtree_60335145"><li id="tree_60335241" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335241" class="commentstatus"></div>
<div id="comment_60335241" class="cw">
	<div id="comment_top_60335241" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335241" name="comment_link_60335241" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335241" onclick="return D2.setFocusComment(60335241)" >Re:</a>


		 	<span id="comment_score_60335241" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335241); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335241"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335241"><p><div class="quote"><p>that probably would not be the case</p></div><p>That's kind of funny in light of the fact that ("formalized") refactoring came out of Smalltalk where it was invented to make smalltalkers really confident messing around with the code.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335241">

</div>
</div>

<div id="replyto_60335241"></div>

<ul id="group_60335241">
	<li id="hiddens_60335241" class="hide"></li>
</ul>

<ul id="commtree_60335241"><li id="tree_60335857" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335857" class="commentstatus"></div>
<div id="comment_60335857" class="cw">
	<div id="comment_top_60335857" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335857" name="comment_link_60335857" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335857" onclick="return D2.setFocusComment(60335857)" >Do you mean ironic?</a>


		 	<span id="comment_score_60335857" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335857); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Latent+Heat">Latent Heat</a>  <span class="uid"><a href="//slashdot.org/~Latent+Heat">( 558884 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335857"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335857"><p>
Yes, I would agree that it is ironic that someone is casting shade on refactoring on a dynamically typed language when pioneering refactoring tools were developed for this type of language.
</p><p>
But there is too much use of "funny", "laughable", and the egregious lol on the Interwebs.  I am also bothered by "sad" for something that used to be described as unfortunate.
</p><p>
Maybe the English language has drifted semantically and I am old and not keeping up, much as I don't see the appeal of Python.
</p><p>
On the other ha<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335857">

</div>
</div>

<div id="replyto_60335857"></div>

<ul id="group_60335857">
	<li id="hiddens_60335857" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335267" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60335267" class="commentstatus"></div>
<div id="comment_60335267" class="cw">
	<div id="comment_top_60335267" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335267" name="comment_link_60335267" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335267" onclick="return D2.setFocusComment(60335267)" >Re:which Pyhon?</a>


		 	<span id="comment_score_60335267" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335267); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Viol8">Viol8</a>  <span class="uid"><a href="//slashdot.org/~Viol8">( 599362 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335267">		
		on Monday July 27, 2020 @04:44AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335267">#60335267</a>)
		<small><a href="http://blah.com/" title="http://blah.com/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335267"><p>Its not just the dynamic typing thats the problem - the idiotic whitespace denotes blocks syntax means its not difficult to accidentally delete a tab/spaces from the last line in a block but the interpreter still happily runs it. Doing that in a bracketed language would require deliberately moving the line to the other side of the delimiter bracket which is far less likely to happen accidentaly.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335267">
<span class="ind"></span><a id="reply_link_60335267" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335267" onclick="D2.replyTo(60335267); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=60335145" onclick="return D2.selectParent(60335145)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:which Pyhon? by Viol8 @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335267" data-title="Re:which Pyhon?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:which Pyhon? by Viol8" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335267" data-title="Re:which Pyhon?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:which Pyhon? by Viol8" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335267" data-title="Re:which Pyhon?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60335267" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60335267" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335267" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60335267"></div>

<ul id="group_60335267">
	<li id="hiddens_60335267" class="hide"></li>
</ul>

<ul id="commtree_60335267"><li id="tree_60336383" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336383" class="commentstatus"></div>
<div id="comment_60336383" class="cw">
	<div id="comment_top_60336383" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336383" name="comment_link_60336383" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336383" onclick="return D2.setFocusComment(60336383)" >Re:</a>


		 	<span id="comment_score_60336383" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336383); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Ksevio">Ksevio</a>  <span class="uid"><a href="//slashdot.org/~Ksevio">( 865461 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336383"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336383"><p>Makes much cleaner code though and it's easy to see indentation/blocks.  How many times have you seen people indenting a block without brackets in a language that uses optional brackets causing only the first line to be in the block?  Personally I've never accidentally deleted spaces from a line.</p><p>Plus having any sort of IDE makes most of the issues moot</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336383">

</div>
</div>

<div id="replyto_60336383"></div>

<ul id="group_60336383">
	<li id="hiddens_60336383" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335513" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335513" class="commentstatus"></div>
<div id="comment_60335513" class="cw">
	<div id="comment_top_60335513" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335513" name="comment_link_60335513" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335513" onclick="return D2.setFocusComment(60335513)" >Re:</a>


		 	<span id="comment_score_60335513" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335513); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~djinn6">djinn6</a>  <span class="uid"><a href="//slashdot.org/~djinn6">( 1868030 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335513"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335513"><p>That's what unit tests are for. If you don't have them, the code was bound to break the next time some idiot gets their hands on it. And that idiot is often the future you.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335513">

</div>
</div>

<div id="replyto_60335513"></div>

<ul id="group_60335513">
	<li id="hiddens_60335513" class="hide"></li>
</ul>

<ul id="commtree_60335513"><li id="tree_60335895" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335895" class="commentstatus"></div>
<div id="comment_60335895" class="cw">
	<div id="comment_top_60335895" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335895" name="comment_link_60335895" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335895" onclick="return D2.setFocusComment(60335895)" >Re:</a>


		 	<span id="comment_score_60335895" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335895); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~SlideRuleGuy">SlideRuleGuy</a>  <span class="uid"><a href="//slashdot.org/~SlideRuleGuy">( 987445 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335895"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335895"><p>If I'm working with a language that needs extra unit tests to catch stuff that a reasonable language wouldn't even suffer from in the first place, then I'm using the wrong language.  (I realize that once a person is familiar and comfortable with a language, they can't imagine it not being great.  But we have to get past fandom and learn to pick languages for their actual productivity.  And writing extra unit tests isn't my idea of being productive.)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335895">

</div>
</div>

<div id="replyto_60335895"></div>

<ul id="group_60335895">
	<li id="hiddens_60335895" class="hide"></li>
</ul>

<ul id="commtree_60335895"><li id="tree_60336017" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336017" class="commentstatus"></div>
<div id="comment_60336017" class="cw">
	<div id="comment_top_60336017" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336017" name="comment_link_60336017" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336017" onclick="return D2.setFocusComment(60336017)" >Re:</a>


		 	<span id="comment_score_60336017" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336017); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336017"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336017"><p><div class="quote"><p>If I'm working with a language that needs extra unit tests to catch stuff that a reasonable language wouldn't even suffer from in the first place, then I'm using the wrong language.</p></div><p>I think the idea was that unless you're into formal verification, unit tests are simultaneously necessary for correctness *and* sufficient for the type of checks that you claim to be missing. Which means that if you have to use them to ensure correctness anyway (because you won't catch program logic errors otherwise), the difference between the languages with these features and languages without them get erased.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336017">

</div>
</div>

<div id="replyto_60336017"></div>

<ul id="group_60336017">
	<li id="hiddens_60336017" class="hide"></li>
</ul>

<ul id="commtree_60336017"><li id="tree_60336387" class="comment hidden"><span class="ind"></span>
<div id="comment_status_60336387" class="commentstatus"></div>
<div id="comment_60336387" class="cw">
</div>

<div id="replyto_60336387"></div>

<ul id="group_60336387">
	<li id="hiddens_60336387" class="hide"></li>
</ul>

<ul id="commtree_60336387"><li id="tree_60336615" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336615" class="commentstatus"></div>
<div id="comment_60336615" class="cw">
	<div id="comment_top_60336615" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336615" name="comment_link_60336615" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336615" onclick="return D2.setFocusComment(60336615)" >Re:</a>


		 	<span id="comment_score_60336615" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336615); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~djinn6">djinn6</a>  <span class="uid"><a href="//slashdot.org/~djinn6">( 1868030 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336615"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336615"><p>You can use static typing in Python 3 actually. Here's a <a href="https://medium.com/@ageitgey/learn-how-to-use-static-type-checking-in-python-3-6-in-10-minutes-12c86d72677b" title="medium.com">guide</a> [medium.com].</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336615">

</div>
</div>

<div id="replyto_60336615"></div>

<ul id="group_60336615">
	<li id="hiddens_60336615" class="hide"></li>
</ul>

</li><li id="tree_60336723" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336723" class="commentstatus"></div>
<div id="comment_60336723" class="cw">
	<div id="comment_top_60336723" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336723" name="comment_link_60336723" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336723" onclick="return D2.setFocusComment(60336723)" >Re:</a>


		 	<span id="comment_score_60336723" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336723); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~munch117">munch117</a>  <span class="uid"><a href="//slashdot.org/~munch117">( 214551 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336723"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336723"><p><div class="quote"><p>2. They must be exhaustive (a few tests here or there wont help much)</p></div><p>Not necessarily.  Sometimes you can get a lot of mileage out of a very few tests.  If you test composite functionality that involves many modules, you can get reasonable coverage from a small number of high-level tests.  Strictly speaking that's not <em>unit</em> testing, even if you do use a unit testing framework for it, but it works, so who cares what it's called.</p><p><div class="quote"><p>Even if you have lots of tests and they are well maintained and correct, it still pretty much guaranteed that not all edge cases would be covered</p><span class="substr"> </span></div><p>Edge case errors are rarely type errors.   The way to catch edge case errors is by having unit tests, regardless of language. And of course, by writing</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336723">

</div>
</div>

<div id="replyto_60336723"></div>

<ul id="group_60336723">
	<li id="hiddens_60336723" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li></ul></li></ul></li><li id="tree_60335485" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335485" class="commentstatus"></div>
<div id="comment_60335485" class="cw">
	<div id="comment_top_60335485" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335485" name="comment_link_60335485" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335485" onclick="return D2.setFocusComment(60335485)" >Re:</a>


		 	<span id="comment_score_60335485" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335485); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dfghjk">dfghjk</a>  <span class="uid"><a href="//slashdot.org/~dfghjk">( 711126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335485"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335485"><p>And the "latest and greatest tools" can't be bothered to maintain compatibility, unlike other, more serious, programming tools.  The problem is not "some developers", just like the continued use of Cobol isn't because of "some developers".</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335485">

</div>
</div>

<div id="replyto_60335485"></div>

<ul id="group_60335485">
	<li id="hiddens_60335485" class="hide"></li>
</ul>

</li><li id="tree_60335501" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335501" class="commentstatus"></div>
<div id="comment_60335501" class="cw">
	<div id="comment_top_60335501" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335501" name="comment_link_60335501" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335501" onclick="return D2.setFocusComment(60335501)" >Re:</a>


		 	<span id="comment_score_60335501" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335501); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~sg_oneill">sg_oneill</a>  <span class="uid"><a href="//slashdot.org/~sg_oneill">( 159032 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335501"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335501"><p>Oh thats FUD nonsense. Theres a notable incompatibility break between the 2.x and 3.x series which mostly involves sticking brackets around print statements and tracking a few changes to the standard library. This is largely a historical problem however as almost all the major libraries and frameworks have moved to 3.x and new projects started on 2.7 are rare indeed.</p><p>Other than that Python has actually been remarkably satable in terms of language and API stability. I certainly can't think of any other langua<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335501">

</div>
</div>

<div id="replyto_60335501"></div>

<ul id="group_60335501">
	<li id="hiddens_60335501" class="hide"></li>
</ul>

<ul id="commtree_60335501"><li id="tree_60335519" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335519" class="commentstatus"></div>
<div id="comment_60335519" class="cw">
	<div id="comment_top_60335519" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335519" name="comment_link_60335519" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335519" onclick="return D2.setFocusComment(60335519)" >Re:</a>


		 	<span id="comment_score_60335519" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335519); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~djinn6">djinn6</a>  <span class="uid"><a href="//slashdot.org/~djinn6">( 1868030 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335519"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335519"><p>If we had the ability to know exactly how much Python 2 code is still running out there in terms of unique LoC, I think we'd see it's actually orders of magnitude more than Python 3. It's only recently that enough underlying libraries supported Python 3 and I could start coding in it. I still have tons of Python 2 scripts written anywhere between a decade ago and last year that I have not had time to update.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335519">

</div>
</div>

<div id="replyto_60335519"></div>

<ul id="group_60335519">
	<li id="hiddens_60335519" class="hide"></li>
</ul>

</li><li id="tree_60335941" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335941" class="commentstatus"></div>
<div id="comment_60335941" class="cw">
	<div id="comment_top_60335941" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335941" name="comment_link_60335941" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335941" onclick="return D2.setFocusComment(60335941)" >Re:</a>


		 	<span id="comment_score_60335941" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335941); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jythie">jythie</a>  <span class="uid"><a href="//slashdot.org/~jythie">( 914043 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335941"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335941">I would not really call if 'FUD', but instead YMMV.  The project I work on started with Python 2.3 and has been updated all the way to 3.8.  To this day we still run into bugs caused by the 2.3-&gt;2.6 update, and the 3.8 one has been a continuous nightmare due string being broken up into 'string' and 'bytes', with the unpredictable mess of various APIs now consuming or returning one or the other.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335941">

</div>
</div>

<div id="replyto_60335941"></div>

<ul id="group_60335941">
	<li id="hiddens_60335941" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335817" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335817" class="commentstatus"></div>
<div id="comment_60335817" class="cw">
	<div id="comment_top_60335817" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335817" name="comment_link_60335817" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335817" onclick="return D2.setFocusComment(60335817)" >No native array type?</a>


		 	<span id="comment_score_60335817" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335817); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Latent+Heat">Latent Heat</a>  <span class="uid"><a href="//slashdot.org/~Latent+Heat">( 558884 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335817"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335817"><p>
My gripe with Python, especially from the standpoint of numerical software important to engineering, is the lack of a primitive array type.  It appears that the fundamental data structure in Python is a "dictionary", which I guess is implemented as a hash list?
</p><p>
Matlab has a primitive array type.  Java has such a thing.  Yes, even the Julia programming language has it.  Yeah, yeah, and I guess yeah, Python has NumPy, which is grafted on to the language as an external library?  Last time I looked into Pytho<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335817">

</div>
</div>

<div id="replyto_60335817"></div>

<ul id="group_60335817">
	<li id="hiddens_60335817" class="hide"></li>
</ul>

<ul id="commtree_60335817"><li id="tree_60335967" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335967" class="commentstatus"></div>
<div id="comment_60335967" class="cw">
	<div id="comment_top_60335967" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335967" name="comment_link_60335967" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335967" onclick="return D2.setFocusComment(60335967)" >Re:</a>


		 	<span id="comment_score_60335967" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335967); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jythie">jythie</a>  <span class="uid"><a href="//slashdot.org/~jythie">( 914043 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335967"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335967">Ahm.. kinda sounds like you did not work with Python enough to find its array type.<br> <br>But yeah, it is a general purpose language.  If you want to do something more specialized with numbers you bring in something like numpy, kinda like how in C/C++ you would bring in a bignum library.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335967">

</div>
</div>

<div id="replyto_60335967"></div>

<ul id="group_60335967">
	<li id="hiddens_60335967" class="hide"></li>
</ul>

<ul id="commtree_60335967"><li id="tree_60336447" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336447" class="commentstatus"></div>
<div id="comment_60336447" class="cw">
	<div id="comment_top_60336447" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336447" name="comment_link_60336447" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336447" onclick="return D2.setFocusComment(60336447)" >There is no third planet; Python has an array type</a>


		 	<span id="comment_score_60336447" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336447); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Latent+Heat">Latent Heat</a>  <span class="uid"><a href="//slashdot.org/~Latent+Heat">( 558884 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336447"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336447"><p>
"Don't you think I know that.  There was, but not anymore!"
</p><p>
Yes, Python has always had an array type, but it is not a primitive array type benefiting from the widely used machine architecture where incrementing an address register steps through elements of the data structure.  Even Matlab has such a thing, especially Matlab because it was originally meant as a higher-level language than FORTRAN for engineers to access numerical routines.
</p><p>
One can get all computer sciency-y and say that it is a parochial c<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336447">

</div>
</div>

<div id="replyto_60336447"></div>

<ul id="group_60336447">
	<li id="hiddens_60336447" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60336039" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336039" class="commentstatus"></div>
<div id="comment_60336039" class="cw">
	<div id="comment_top_60336039" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336039" name="comment_link_60336039" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336039" onclick="return D2.setFocusComment(60336039)" >Re:</a>


		 	<span id="comment_score_60336039" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336039); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~K.+S.+Kyosuke">K. S. Kyosuke</a>  <span class="uid"><a href="//slashdot.org/~K.+S.+Kyosuke">( 729550 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336039"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336039">Technically any language with a decent FFI allows creation of primitive arrays using foreign arrays. Of course it depends on the FFI implementation how fast this approach is. In some cases, notably LuaJIT, it's very fast.</div>
	</div>

	<div class="commentSub" id="comment_sub_60336039">

</div>
</div>

<div id="replyto_60336039"></div>

<ul id="group_60336039">
	<li id="hiddens_60336039" class="hide"></li>
</ul>

</li><li id="tree_60336127" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336127" class="commentstatus"></div>
<div id="comment_60336127" class="cw">
	<div id="comment_top_60336127" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336127" name="comment_link_60336127" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336127" onclick="return D2.setFocusComment(60336127)" >Re:</a>


		 	<span id="comment_score_60336127" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336127); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~shellster_dude">shellster_dude</a>  <span class="uid"><a href="//slashdot.org/~shellster_dude">( 1261444 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336127"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336127">By "work" did you mean that you once typed up a "Hello World" app?  Python has both a primitive array type, with more powerful features that virtually any other languages array type, and a separate concept called a "tuple" which is like an ordered set, but which can also function as a very primitive array type in some use cases.</div>
	</div>

	<div class="commentSub" id="comment_sub_60336127">

</div>
</div>

<div id="replyto_60336127"></div>

<ul id="group_60336127">
	<li id="hiddens_60336127" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_60334927" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60334927" class="commentstatus"></div>
<div id="comment_60334927" class="cw">
	<div id="comment_top_60334927" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60334927" name="comment_link_60334927" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334927" onclick="return D2.setFocusComment(60334927)" >*Scripting* languages. To be precise.</a>


		 	<span id="comment_score_60334927" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60334927); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~BAReFO0t">BAReFO0t</a>  <span class="uid"><a href="//slashdot.org/~BAReFO0t">( 6240524 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60334927">		
		on Monday July 27, 2020 @12:43AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60334927">#60334927</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60334927"><p>Let's be honest, it is a scripting language.</p><p>Dynamic typing, simple, interpreted / JITed / VMed, high-level<nobr> <wbr></nobr>... It is made for scripting.</p><p>Don't get me wrong. It is a nice little language. I prefer it for scripting and small things.<br>But I'd still not put it in one box with C++, Haskell, Pascal, or even Java.<br>It goes in the VIP lounge in the box with JS, PHP, BASIC, etc.<nobr> <wbr></nobr>:)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60334927">
<span class="ind"></span><a id="reply_link_60334927" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334927" onclick="D2.replyTo(60334927); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="*Scripting* languages. To be precise. by BAReFO0t @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334927" data-title="*Scripting* languages. To be precise.">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="*Scripting* languages. To be precise. by BAReFO0t" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334927" data-title="*Scripting* languages. To be precise.">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="*Scripting* languages. To be precise. by BAReFO0t" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60334927" data-title="*Scripting* languages. To be precise.">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60334927" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60334927" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60334927" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60334927"></div>

<ul id="group_60334927">
	<li id="hiddens_60334927" class="hide"></li>
</ul>

<ul id="commtree_60334927"><li id="tree_60335361" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335361" class="commentstatus"></div>
<div id="comment_60335361" class="cw">
	<div id="comment_top_60335361" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335361" name="comment_link_60335361" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335361" onclick="return D2.setFocusComment(60335361)" >Re:</a>


		 	<span id="comment_score_60335361" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335361); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nagora">nagora</a>  <span class="uid"><a href="//slashdot.org/~nagora">( 177841 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335361"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335361"><p><div class="quote"><p>Let's be honest, it is a scripting language.</p></div><p>Yes. A shit one.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335361">

</div>
</div>

<div id="replyto_60335361"></div>

<ul id="group_60335361">
	<li id="hiddens_60335361" class="hide"></li>
</ul>

<ul id="commtree_60335361"><li id="tree_60335951" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335951" class="commentstatus"></div>
<div id="comment_60335951" class="cw">
	<div id="comment_top_60335951" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335951" name="comment_link_60335951" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335951" onclick="return D2.setFocusComment(60335951)" >Re:</a>


		 	<span id="comment_score_60335951" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335951); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jma05">jma05</a>  <span class="uid"><a href="//slashdot.org/~jma05">( 897351 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335951"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335951"><p>And which languages would you rather be scripting in?<br>Ruby, Perl, Raku, Tcl?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335951">

</div>
</div>

<div id="replyto_60335951"></div>

<ul id="group_60335951">
	<li id="hiddens_60335951" class="hide"></li>
</ul>

<ul id="commtree_60335951"><li id="tree_60336067" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336067" class="commentstatus"></div>
<div id="comment_60336067" class="cw">
	<div id="comment_top_60336067" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336067" name="comment_link_60336067" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336067" onclick="return D2.setFocusComment(60336067)" >Re:</a>


		 	<span id="comment_score_60336067" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336067); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~nagora">nagora</a>  <span class="uid"><a href="//slashdot.org/~nagora">( 177841 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336067"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336067"><p>Perl is better for a lot of things, especially if you don't need objects. Ruby obviously is better if you need objects.</p><p>Perl particularly stands head and shoulders above Python as not being "version of the week". I have four versions of Python installed here; I have no idea which ones are important to my system, they just get dragged . There'll be another version along soon enough. I can not be <i>arsed</i> with tracking the differences between 3.2, 3.4, 3.6, 3.7, 3.8 and bloody 3.9. It's the new PHP.</p><p>Example: 3.5 d<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336067">

</div>
</div>

<div id="replyto_60336067"></div>

<ul id="group_60336067">
	<li id="hiddens_60336067" class="hide"></li>
</ul>

<ul id="commtree_60336067"><li id="tree_60336341" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336341" class="commentstatus"></div>
<div id="comment_60336341" class="cw">
	<div id="comment_top_60336341" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336341" name="comment_link_60336341" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336341" onclick="return D2.setFocusComment(60336341)" >Re:</a>


		 	<span id="comment_score_60336341" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336341); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Waffle+Iron">Waffle Iron</a>  <span class="uid"><a href="//slashdot.org/~Waffle+Iron">( 339739 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336341"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336341"><p><div class="quote"><p>Perl particularly stands head and shoulders above Python as not being "version of the week".</p></div><p>That's only because the Perl developers drove off into the weeds 20 years ago and never found their way out, leaving behind their last mainstream version as a mostly static artifact.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336341">

</div>
</div>

<div id="replyto_60336341"></div>

<ul id="group_60336341">
	<li id="hiddens_60336341" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_60335765" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335765" class="commentstatus"></div>
<div id="comment_60335765" class="cw">
	<div id="comment_top_60335765" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335765" name="comment_link_60335765" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335765" onclick="return D2.setFocusComment(60335765)" >Re:</a>


		 	<span id="comment_score_60335765" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335765); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~drinkypoo">drinkypoo</a>  <span class="uid"><a href="//slashdot.org/~drinkypoo">( 153816 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335765"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335765"><p>Whether it's interpreted is irrelevant to the question of whether it's a programming language. If it's a scripting language, and it has control of the flow of execution, it's a programming language too.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335765">

</div>
</div>

<div id="replyto_60335765"></div>

<ul id="group_60335765">
	<li id="hiddens_60335765" class="hide"></li>
</ul>

</li><li id="tree_60335937" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335937" class="commentstatus"></div>
<div id="comment_60335937" class="cw">
	<div id="comment_top_60335937" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335937" name="comment_link_60335937" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335937" onclick="return D2.setFocusComment(60335937)" >Re:</a>


		 	<span id="comment_score_60335937" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335937); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jma05">jma05</a>  <span class="uid"><a href="//slashdot.org/~jma05">( 897351 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335937"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335937"><p>These distinctions are n00b distinctions.<br>If it isn't statically typed and doesn't make a native code exe, it is not a "real" language - is a n00b opinion.</p><p>This is a language that currently dominates the latest and greatest AI research.<br>You can write "scripts" in Haskell etc. You can write serious code in Python that is all but impractical in Pascal.</p><p>Python is simple, by default. But it can be a complex, highly configurable language with its metaclasses. It is closer to Lisp. You can JIT it like Java.<br>It's an ec<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335937">

</div>
</div>

<div id="replyto_60335937"></div>

<ul id="group_60335937">
	<li id="hiddens_60335937" class="hide"></li>
</ul>

<ul id="commtree_60335937"><li id="tree_60336417" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336417" class="commentstatus"></div>
<div id="comment_60336417" class="cw">
	<div id="comment_top_60336417" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336417" name="comment_link_60336417" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336417" onclick="return D2.setFocusComment(60336417)" >Re:</a>


		 	<span id="comment_score_60336417" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336417); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~leptons">leptons</a>  <span class="uid"><a href="//slashdot.org/~leptons">( 891340 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336417"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336417">I've created statically typed desktop ".exe" applications in Javascript (JScript.NET to be exact), as well as<nobr> <wbr></nobr>.DLLs. Javascript does blur the lines of "scripting language" sometimes.<br>
<br>
You're absolutely correct about the parent comment being a "noob opinion".</div>
	</div>

	<div class="commentSub" id="comment_sub_60336417">

</div>
</div>

<div id="replyto_60336417"></div>

<ul id="group_60336417">
	<li id="hiddens_60336417" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335975" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335975" class="commentstatus"></div>
<div id="comment_60335975" class="cw">
	<div id="comment_top_60335975" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335975" name="comment_link_60335975" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335975" onclick="return D2.setFocusComment(60335975)" >Re:</a>


		 	<span id="comment_score_60335975" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335975); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jythie">jythie</a>  <span class="uid"><a href="//slashdot.org/~jythie">( 914043 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335975"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335975">HEh.  While I am sitting on a multi-million line python application suite that was switched off Java because it handled thing better.  Python is interpreted, but so is Java.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335975">

</div>
</div>

<div id="replyto_60335975"></div>

<ul id="group_60335975">
	<li id="hiddens_60335975" class="hide"></li>
</ul>

</li><li id="tree_60336071" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336071" class="commentstatus"></div>
<div id="comment_60336071" class="cw">
	<div id="comment_top_60336071" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336071" name="comment_link_60336071" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336071" onclick="return D2.setFocusComment(60336071)" >Re:</a>


		 	<span id="comment_score_60336071" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336071); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~thegarbz">thegarbz</a>  <span class="uid"><a href="//slashdot.org/~thegarbz">( 1787294 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336071"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336071"><p>This is an IEEE study, no one gives a shit about Java, Pascal or anything else you strange programmers want to do with programming languages.</p><p>It helps to not be ignorant about the article you're reading.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336071">

</div>
</div>

<div id="replyto_60336071"></div>

<ul id="group_60336071">
	<li id="hiddens_60336071" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335007" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60335007" class="commentstatus"></div>
<div id="comment_60335007" class="cw">
	<div id="comment_top_60335007" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335007" name="comment_link_60335007" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335007" onclick="return D2.setFocusComment(60335007)" >Screwdriver is better than a hammer</a>


		 	<span id="comment_score_60335007" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335007); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~battingly">battingly</a>  <span class="uid"><a href="//slashdot.org/~battingly">( 5065477 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335007">		
		on Monday July 27, 2020 @01:30AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335007">#60335007</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335007">Screwdriver is more popular than hammer. Discuss why this makes a screwdriver better than a hammer.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335007">
<span class="ind"></span><a id="reply_link_60335007" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335007" onclick="D2.replyTo(60335007); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Screwdriver is better than a hammer by battingly @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335007" data-title="Screwdriver is better than a hammer">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Screwdriver is better than a hammer by battingly" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335007" data-title="Screwdriver is better than a hammer">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Screwdriver is better than a hammer by battingly" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335007" data-title="Screwdriver is better than a hammer">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60335007" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60335007" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335007" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60335007"></div>

<ul id="group_60335007">
	<li id="hiddens_60335007" class="hide"></li>
</ul>

<ul id="commtree_60335007"><li id="tree_60335011" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60335011" class="commentstatus"></div>
<div id="comment_60335011" class="cw">
	<div id="comment_top_60335011" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335011" name="comment_link_60335011" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335011" onclick="return D2.setFocusComment(60335011)" >Re:Screwdriver is better than a hammer</a>


		 	<span id="comment_score_60335011" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335011); return false"><span class=opt>Score:</span>5</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~h33t+l4x0r">h33t l4x0r</a>  <span class="uid"><a href="//slashdot.org/~h33t+l4x0r">( 4107715 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335011">		
		on Monday July 27, 2020 @01:33AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335011">#60335011</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335011">Realistically, it's easier to pound a nail with a screwdriver than to turn a screw with a hammer.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335011">
<span class="ind"></span><a id="reply_link_60335011" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335011" onclick="D2.replyTo(60335011); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=60335007" onclick="return D2.selectParent(60335007)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Screwdriver is better than a hammer by h33t l4x0r @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335011" data-title="Re:Screwdriver is better than a hammer">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Screwdriver is better than a hammer by h33t l4x0r" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335011" data-title="Re:Screwdriver is better than a hammer">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Screwdriver is better than a hammer by h33t l4x0r" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335011" data-title="Re:Screwdriver is better than a hammer">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60335011" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60335011" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335011" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60335011"></div>

<ul id="group_60335011">
	<li id="hiddens_60335011" class="hide"></li>
</ul>

<ul id="commtree_60335011"><li id="tree_60335143" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335143" class="commentstatus"></div>
<div id="comment_60335143" class="cw">
	<div id="comment_top_60335143" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335143" name="comment_link_60335143" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335143" onclick="return D2.setFocusComment(60335143)" >Re:</a>


		 	<span id="comment_score_60335143" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335143); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335143"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335143"><p>But it's easier to pound a screw with a hammer than to screw a nail with a screwdriver.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335143">

</div>
</div>

<div id="replyto_60335143"></div>

<ul id="group_60335143">
	<li id="hiddens_60335143" class="hide"></li>
</ul>

<ul id="commtree_60335143"><li id="tree_60335171" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60335171" class="commentstatus"></div>
<div id="comment_60335171" class="cw">
	<div id="comment_top_60335171" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335171" name="comment_link_60335171" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335171" onclick="return D2.setFocusComment(60335171)" >Re:Screwdriver is better than a hammer</a>


		 	<span id="comment_score_60335171" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335171); return false"><span class=opt>Score:</span>4</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~h33t+l4x0r">h33t l4x0r</a>  <span class="uid"><a href="//slashdot.org/~h33t+l4x0r">( 4107715 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335171">		
		on Monday July 27, 2020 @03:39AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335171">#60335171</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335171">You crazy hammer people are ruining this country. #TeamScrewdriver</div>
	</div>

	<div class="commentSub" id="comment_sub_60335171">
<span class="ind"></span><a id="reply_link_60335171" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335171" onclick="D2.replyTo(60335171); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=60335143" onclick="return D2.selectParent(60335143)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Screwdriver is better than a hammer by h33t l4x0r @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335171" data-title="Re:Screwdriver is better than a hammer">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Screwdriver is better than a hammer by h33t l4x0r" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335171" data-title="Re:Screwdriver is better than a hammer">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Screwdriver is better than a hammer by h33t l4x0r" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335171" data-title="Re:Screwdriver is better than a hammer">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60335171" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60335171" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335171" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60335171"></div>

<ul id="group_60335171">
	<li id="hiddens_60335171" class="hide"></li>
</ul>

<ul id="commtree_60335171"><li id="tree_60335375" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335375" class="commentstatus"></div>
<div id="comment_60335375" class="cw">
	<div id="comment_top_60335375" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335375" name="comment_link_60335375" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335375" onclick="return D2.setFocusComment(60335375)" >Re:</a>


		 	<span id="comment_score_60335375" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335375); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Opportunist">Opportunist</a>  <span class="uid"><a href="//slashdot.org/~Opportunist">( 166417 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335375"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335375"><p>You screw-heads are screwed, finally admit it and face the facts!</p><p>#ItsHammerTime</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335375">

</div>
</div>

<div id="replyto_60335375"></div>

<ul id="group_60335375">
	<li id="hiddens_60335375" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60336771" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336771" class="commentstatus"></div>
<div id="comment_60336771" class="cw">
	<div id="comment_top_60336771" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336771" name="comment_link_60336771" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336771" onclick="return D2.setFocusComment(60336771)" >Re:</a>


		 	<span id="comment_score_60336771" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336771); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~shanen">shanen</a>  <span class="uid"><a href="//slashdot.org/~shanen">( 462549 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336771"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336771"><p>Don't force it. Use a bigger hammer!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336771">

</div>
</div>

<div id="replyto_60336771"></div>

<ul id="group_60336771">
	<li id="hiddens_60336771" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335195" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335195" class="commentstatus"></div>
<div id="comment_60335195" class="cw">
	<div id="comment_top_60335195" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335195" name="comment_link_60335195" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335195" onclick="return D2.setFocusComment(60335195)" >Re:</a>


		 	<span id="comment_score_60335195" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335195); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~q_e_t">q_e_t</a>  <span class="uid"><a href="//slashdot.org/~q_e_t">( 5104099 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335195"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335195">I came here to say this.

Although you can pound a screw in with a hammer into softer wood, but you'd be better off actually finding a nail.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335195">

</div>
</div>

<div id="replyto_60335195"></div>

<ul id="group_60335195">
	<li id="hiddens_60335195" class="hide"></li>
</ul>

<ul id="commtree_60335195"><li id="tree_60335491" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335491" class="commentstatus"></div>
<div id="comment_60335491" class="cw">
	<div id="comment_top_60335491" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335491" name="comment_link_60335491" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335491" onclick="return D2.setFocusComment(60335491)" >Re:</a>


		 	<span id="comment_score_60335491" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335491); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dfghjk">dfghjk</a>  <span class="uid"><a href="//slashdot.org/~dfghjk">( 711126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335491"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335491"><p>also, the people doing the survey, and likely the survey subjects, are likely the very people who view the screwdriver and hammer in exactly these terms.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335491">

</div>
</div>

<div id="replyto_60335491"></div>

<ul id="group_60335491">
	<li id="hiddens_60335491" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_60335621" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335621" class="commentstatus"></div>
<div id="comment_60335621" class="cw">
	<div id="comment_top_60335621" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335621" name="comment_link_60335621" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335621" onclick="return D2.setFocusComment(60335621)" >Re:</a>


		 	<span id="comment_score_60335621" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335621); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~coofercat">coofercat</a>  <span class="uid"><a href="//slashdot.org/~coofercat">( 719737 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335621"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335621"><p>...only true since "too legit to quit", MC Hammer... quit. Before then, Hammer was far more popular than screwdriver. And Jimmy Nail.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335621">

</div>
</div>

<div id="replyto_60335621"></div>

<ul id="group_60335621">
	<li id="hiddens_60335621" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335083" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60335083" class="commentstatus"></div>
<div id="comment_60335083" class="cw">
	<div id="comment_top_60335083" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335083" name="comment_link_60335083" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335083" onclick="return D2.setFocusComment(60335083)" >C libraries</a>


		 	<span id="comment_score_60335083" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335083); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Dr.+Tom">Dr. Tom</a>  <span class="uid"><a href="//slashdot.org/~Dr.+Tom">( 23206 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335083">		 &lt;<a href="mailto:tomh%40nih.gov">tomh@nih.gov</a>&gt;
		on Monday July 27, 2020 @02:42AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335083">#60335083</a>)
		<small><a href="http://members.tripod.com/professor_tom/" title="http://members.tripod.com/professor_tom/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335083"><tt>I'm not sure about GPL inheritance and whatnot, but does it count if I've wrapped all my old C libraries in Python?<br>Honestly my users hate compilers and can barely stand the command line. The "code" they are using is still written in C, but their interface to it is thru a Python API, like a huge % of useful Python modules</tt></div>
	</div>

	<div class="commentSub" id="comment_sub_60335083">
<span class="ind"></span><a id="reply_link_60335083" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335083" onclick="D2.replyTo(60335083); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="C libraries by Dr. Tom @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335083" data-title="C libraries">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="C libraries by Dr. Tom" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335083" data-title="C libraries">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="C libraries by Dr. Tom" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335083" data-title="C libraries">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60335083" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60335083" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335083" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60335083"></div>

<ul id="group_60335083">
	<li id="hiddens_60335083" class="hide"></li>
</ul>

<ul id="commtree_60335083"><li id="tree_60335495" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335495" class="commentstatus"></div>
<div id="comment_60335495" class="cw">
	<div id="comment_top_60335495" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335495" name="comment_link_60335495" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335495" onclick="return D2.setFocusComment(60335495)" >Re:</a>


		 	<span id="comment_score_60335495" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335495); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dfghjk">dfghjk</a>  <span class="uid"><a href="//slashdot.org/~dfghjk">( 711126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335495"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335495"><p>All that code is still single threaded because the environment that ultimately executes it is terrible.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335495">

</div>
</div>

<div id="replyto_60335495"></div>

<ul id="group_60335495">
	<li id="hiddens_60335495" class="hide"></li>
</ul>

<ul id="commtree_60335495"><li id="tree_60335541" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335541" class="commentstatus"></div>
<div id="comment_60335541" class="cw">
	<div id="comment_top_60335541" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335541" name="comment_link_60335541" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335541" onclick="return D2.setFocusComment(60335541)" >Re:</a>


		 	<span id="comment_score_60335541" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335541); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~djinn6">djinn6</a>  <span class="uid"><a href="//slashdot.org/~djinn6">( 1868030 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335541"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335541"><p>It would be awesome to get rid of the GIL, but for now you can SWIG a multithreaded C library if you really need it. Or call out to a separate program to do the heavy lifting.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335541">

</div>
</div>

<div id="replyto_60335541"></div>

<ul id="group_60335541">
	<li id="hiddens_60335541" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_60335431" class="comment full contain"><span class="ind"></span>
<div id="comment_status_60335431" class="commentstatus"></div>
<div id="comment_60335431" class="cw">
	<div id="comment_top_60335431" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335431" name="comment_link_60335431" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335431" onclick="return D2.setFocusComment(60335431)" >pragmatic approach to our definition</a>


		 	<span id="comment_score_60335431" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335431); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~dfghjk">dfghjk</a>  <span class="uid"><a href="//slashdot.org/~dfghjk">( 711126 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335431">		
		on Monday July 27, 2020 @06:49AM (<span class="ind"></span><a href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335431">#60335431</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335431"><p>Sorry, but it's not a "pragmatic approach" to categorize a programming language by what ignorant people search for.  C code is still C code even when non-programmers don't realize it.  Even worse, they know they are wrong so they instead cast people who would call them out as "purists".  It is not "purist" to insist that results not be deliberately cooked by manipulating definitions and then lying about it.</p><p>Arduino is not a language, not to purists and not to anyone else.</p><p>Then, of course, there's the two "counterarguments".  Counterarguments to what?  Students are people too!?!?  This is a counterargument to what exactly?</p><p>IEEE Spectrum == The Verge</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335431">
<span class="ind"></span><a id="reply_link_60335431" class="btn link" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335431" onclick="D2.replyTo(60335431); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="pragmatic approach to our definition by dfghjk @slashdot" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335431" data-title="pragmatic approach to our definition">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="pragmatic approach to our definition by dfghjk" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335431" data-title="pragmatic approach to our definition">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="pragmatic approach to our definition by dfghjk" data-url="https://developers.slashdot.org/comments.pl?sid=16842865&cid=60335431" data-title="pragmatic approach to our definition">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://developers.slashdot.org/comments.pl?sid=16842865%26cid=60335431" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_60335431" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=60335431" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_60335431"></div>

<ul id="group_60335431">
	<li id="hiddens_60335431" class="hide"></li>
</ul>

</li><li id="tree_60335849" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335849" class="commentstatus"></div>
<div id="comment_60335849" class="cw">
	<div id="comment_top_60335849" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335849" name="comment_link_60335849" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335849" onclick="return D2.setFocusComment(60335849)" >Diabolical Plan to make Forth most popular</a>


		 	<span id="comment_score_60335849" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335849); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~MountainLogic">MountainLogic</a>  <span class="uid"><a href="//slashdot.org/~MountainLogic">( 92466 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335849"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335849">I'm going to fork <a href="https://en.wikipedia.org/wiki/Forth_(programming_language)" title="wikipedia.org">Forth</a> [wikipedia.org], rename it Corona and win the internet.  Never had a change to seriously program in Forth, but always wanted to until spare stack pointer got dropped from the architectures.  I may also fork BarinFuck and rename it Covid-19 and win twitter too.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335849">

</div>
</div>

<div id="replyto_60335849"></div>

<ul id="group_60335849">
	<li id="hiddens_60335849" class="hide"></li>
</ul>

</li><li id="tree_60335909" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335909" class="commentstatus"></div>
<div id="comment_60335909" class="cw">
	<div id="comment_top_60335909" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335909" name="comment_link_60335909" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335909" onclick="return D2.setFocusComment(60335909)" >Python is just more flexible</a>


		 	<span id="comment_score_60335909" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335909); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~fluffernutter">fluffernutter</a>  <span class="uid"><a href="//slashdot.org/~fluffernutter">( 1411889 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335909"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335909">I can be up and running with a fully reactive GUI-based application with Python in a couple days.  C++ would take roughly twice as long, as would any change I want to make to it.  Sure it's not 'really' multiprocessing but it can send several long-running web requests at a time just fine.</div>
	</div>

	<div class="commentSub" id="comment_sub_60335909">

</div>
</div>

<div id="replyto_60335909"></div>

<ul id="group_60335909">
	<li id="hiddens_60335909" class="hide"></li>
</ul>

<ul id="commtree_60335909"><li id="tree_60336485" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60336485" class="commentstatus"></div>
<div id="comment_60336485" class="cw">
	<div id="comment_top_60336485" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60336485" name="comment_link_60336485" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60336485" onclick="return D2.setFocusComment(60336485)" >Which GUI library?</a>


		 	<span id="comment_score_60336485" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60336485); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Latent+Heat">Latent Heat</a>  <span class="uid"><a href="//slashdot.org/~Latent+Heat">( 558884 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60336485"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60336485"><p>
Which GUI library would you use?</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60336485">

</div>
</div>

<div id="replyto_60336485"></div>

<ul id="group_60336485">
	<li id="hiddens_60336485" class="hide"></li>
</ul>

</li></ul></li><li id="tree_60335931" class="comment oneline"><span class="ind"></span>
<div id="comment_status_60335931" class="commentstatus"></div>
<div id="comment_60335931" class="cw">
	<div id="comment_top_60335931" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_60335931" name="comment_link_60335931" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;cid=60335931" onclick="return D2.setFocusComment(60335931)" >Wh... what?</a>


		 	<span id="comment_score_60335931" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 60335931); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~stonecypher">stonecypher</a>  <span class="uid"><a href="//slashdot.org/~stonecypher">( 118140 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_60335931"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_60335931"><p>I have to wonder just how they're measuring this, that matlab and arduino are showing as more common than, say, Javascript, or Cobol</p></div>
	</div>

	<div class="commentSub" id="comment_sub_60335931">

</div>
</div>

<div id="replyto_60335931"></div>

<ul id="group_60335931">
	<li id="hiddens_60335931" class="hide"></li>
</ul>

</li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//developers.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 0;
		D2.currents()['full']     = 14;
		D2.currents()['oneline']  = 86;
		// D2.currents_total(100);

		D2.abbrev_comments({60336067:536,60336003:630,60335857:536,60336419:522,60336313:535,60336447:529,60335501:522,60336355:529,60336239:553,60335145:514,60335473:529,60335937:541,60335847:522,60335817:522,60336723:654});
		D2.noshow_comments([60335609,60335605,60335381,60335023,60336387]);
		D2.pieces_comments([60334853,60335831,60335999,60336513,60336197,60336313,60335261,60335263,60335469,60336205,60336419,60336355,60336529,60335473,60335847,60335899,60335913,60336445,60336209,60335903,60335057,60335117,60335227,60336219,60335647,60335119,60335149,60336223,60336429,60336459,60335477,60335687,60336003,60334887,60334899,60335591,60335885,60334997,60335021,60335181,60335499,60336563,60335005,60336239,60336543,60335027,60336427,60335145,60335241,60335857,60336383,60335513,60335895,60336017,60336615,60336723,60335485,60335501,60335519,60335941,60335817,60335967,60336447,60336039,60336127,60335361,60335951,60336067,60336341,60335765,60335937,60336417,60335975,60336071,60335143,60335375,60336771,60335195,60335491,60335621,60335495,60335541,60335849,60335909,60336485,60335931]);
		D2.init_hiddens([]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(373803);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>504<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/20/06/12/0543254/openzfs-removed-offensive-terminology-from-its-code?sdsrc=popbyskidbtmprev">OpenZFS Removed Offensive Terminology From Its Code</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>413<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/20/06/14/1722223/github-android-python-go-more-software-adopts-race-neutral-terminology?sdsrc=popbyskidbtmprev">GitHub, Android, Python, Go:  More Software Adopts Race-Neutral Terminology</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>390<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/19/07/29/197213/5-programming-languages-that-are-probably-doomed?sdsrc=popbyskidbtmprev">'5 Programming Languages That Are Probably Doomed'</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>341<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/20/04/26/0222228/why-arent-more-developers-using-rust?sdsrc=popbyskidbtmprev">Why Aren't More Developers Using Rust?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>325<span class="hide"> comments</span></span></span><a href="//developers.slashdot.org/story/20/01/13/0554252/how-is-computer-programming-different-today-than-20-years-ago?sdsrc=popbyskidbtmprev">How Is Computer Programming Different Today Than 20 Years Ago?</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//science.slashdot.org/story/20/07/26/170224/slashdot-interviews-an-oxford-vaccine-trial-participant?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/medicine_64.png?refresh=now" width="64" height="64" alt="Medicine"></span>
	    
					<p class="grid_12"><a href="//science.slashdot.org/story/20/07/26/170224/slashdot-interviews-an-oxford-vaccine-trial-participant?sdsrc=nextbtmprev">Slashdot Interviews an Oxford Vaccine Trial Participant</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>73<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//slashdot.org/story/20/07/27/0158259/how-a-chinese-agent-used-linkedin-to-lure-american-targets?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/china_64.png" width="64" height="64" alt="China"></span>
	    
					<p class="grid_12"><a href="//slashdot.org/story/20/07/27/0158259/how-a-chinese-agent-used-linkedin-to-lure-american-targets?sdsrc=prevbtmprev">How a Chinese Agent Used LinkedIn to 'Lure' American Targets</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>58<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->

	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//developers.slashdot.org/comments.pl?sid=16842865&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">100</span> of <span class="totalcommentcnt">134</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>Help!  I'm trapped in a PDP 11/70!</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/" rel="nofollow">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/" rel="nofollow">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/" rel="nofollow">Privacy Statement</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
				<li><a href="#" id="opt-out-link"></a></li>
				<li><button class="btn opt-out" id="opt-out-button" style="display:none">Do Not Sell My Information</button></li>

			</ul>
		</nav>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2020 SlashdotMedia. All Rights Reserved.</span></div>

	<div class="modal-custom overlay-custom" id="ccpa-modal" style="max-width:100%">
		<div class="modal-content">
	    	<span class="close" id="modal-close">&times;</span>
			<div class="modal-header" id="ccpa-modal-content-destination"></div>
		</div>
	</div>

	</footer>
	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
bizx.cmp.ifConsent('', ['all','bombora'], function() {
        /*global _ml:true, window */
        _ml = window._ml || {};
        _ml.eid = '771';

        var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
        mltag.type = 'text/javascript'; mltag.async = true;
        mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
        s.parentNode.insertBefore(mltag, s);
});
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);


if (!window.is_euro_union) {
  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
}
</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && $('#div-gpt-ad-300x250_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			//$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
        if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
        if(topBannerViewed) {
                    //console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
								//console.log('topBannerViewed', topBannerViewed);
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
		  //console.log('ads topBanner displayed');
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
    if($('.adwrap-viewed-railad').length > 0){
						//console.log('ads sidebar displayed');
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
function initPiwikAndNels() {
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();

    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });
    }
    //announcement NEL
    if(document.getElementById('announcementText')){
      $('#announcementText').hide();
      var hlUrl = '/ajax.pl?op=hl_nel';
      if(nelId){
        hlUrl += '&nel_id='+nelId;
      }
      $.ajax({
        url: hlUrl,
        success: function(html){
          if(html.length < 10){
            $('#announcementText').show();
            return;
          }
          $('#announcementText').html(html).show();
        },
        error: function () {
          $('#announcementText').show();
        }
      });
    }
}
bizx.cmp.ifConsent('', ['storage', 'measurement'], initPiwikAndNels);
</script>


<script type="text/javascript">
_linkedin_data_partner_id = "113712";
</script><script type="text/javascript">
if (!window.is_euro_union) {
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
}
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=113712&fmt=gif" />
</noscript>

<!-- Datonics -->
<script type="text/javascript">
if (!window.is_euro_union) {
    bizx.cmp.embedScript("//ads.pro-market.net/ads/scripts/site-143573.js", true);
}
</script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?430">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?424">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>

	    <script>
            var regular_opt_out_link = true;

            if (window.region == 'CA' && window.country_code2 == 'US') {
                regular_opt_out_link = false;

                 document.getElementById('opt-out-button').setAttribute('style', 'display:inline; font-size: 10px; height: 25px; background-color: #004d4e');
            }

            if (window.is_euro_union == '1') {
                regular_opt_out_link = false;
                var elem = '<a href="#" title="Privacy Choices" onclick="bizx.cmp.promptConsent(); return false;">Privacy Choices</a>';
                document.getElementById('opt-out-link').innerHTML = elem;
            }

            if (regular_opt_out_link == true) {
                var elem = '<a href="http://slashdotmedia.com/opt-out-choices" title="Opt Out" rel="nofollow">Opt Out</a>';
                document.getElementById('opt-out-link').innerHTML = elem;
            }
            var modal = document.getElementById('ccpa-modal');
            var btn = document.getElementById('opt-out-button');
            var span = document.getElementById('modal-close');

            btn.onclick = function() {
            	modal.style.display = 'block';
			};

            span.onclick = function() {
            	modal.style.display = 'none';
			};

         </script>

	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

	<script type="text/javascript">
	if (!window.is_euro_union) {
			window._taboola = window._taboola || [];
			_taboola.push({flush: true});
	}
	</script>
        <script>
            if (window.is_euro_union == 0) {
                document.querySelectorAll('body')[0].classList.add('no-cmp');
            }

			function hideJanRainContent() {
				if ($('.janrainContent').length > 0) {
					$('.janrainContent').hide();
				}
			}


			$(document).ready(function() {
				setInterval(hideJanRainContent);
			});
        </script>
	</body>
	</html>


	<!-- footer type=current end -->